Ergebnis 1 bis 29 von 29

Thema: 4.9.x Update Fehler

  1. #1
    Contao-Nutzer Avatar von Dr. Jo
    Registriert seit
    11.08.2009.
    Ort
    Riehen (CH)
    Beiträge
    179

    Standard 4.9.x Update Fehler

    Hallo,

    ich versuche ein Update von einer 4.9.9 auf 4.9.15 durchzuführen, das scheitert allerdings an der folgenden Fehlermeldung:

    Code:
    $ /bin/php74 -q -dmax_execution_time=0 -dmemory_limit=-1 -dallow_url_fopen=1 -ddisable_functions= -ddate.timezone=Europe/Zurich /home/galerieb/public_html/contao-4-9/web/contao-manager.phar.php composer install --prefer-dist --no-dev --no-progress --no-ansi --no-interaction --optimize-autoloader --dry-run
    Installing dependencies from lock file
    Verifying lock file contents can be installed on current platform.
    Your lock file does not contain a compatible set of packages. Please run composer update.
      Problem 1
        - ocramius/proxy-manager is locked to version 2.13.0 and an update of this package was not requested.
        - ocramius/proxy-manager 2.13.0 requires composer-runtime-api ^2.1.0 -> found composer-runtime-api[2.0.0] but it does not match the constraint.
      Problem 2
        - ocramius/proxy-manager 2.13.0 requires composer-runtime-api ^2.1.0 -> found composer-runtime-api[2.0.0] but it does not match the constraint.
        - symfony/proxy-manager-bridge v4.4.18 requires ocramius/proxy-manager ~2.1 -> satisfiable by ocramius/proxy-manager[2.13.0].
        - symfony/proxy-manager-bridge is locked to version v4.4.18 and an update of this package was not requested.

    Auf github gibts ein ähnliches Issue, allerdings für Contao 4.10/11: https://github.com/contao/contao/issues/3070

    Der Eintrag unter conflicts bringt bei mir keine Änderung:

    "conflict": {
    "ocramius/proxy-manager": "2.12.0"
    },
    Ein Composer-Update (per Browser) gibt das gleiche Ergebnis. Irgendwelche Hinweise oder Ideen?

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    27.316
    Partner-ID
    10107

    Standard

    Poste deine composer.json
    » sponsor me via GitHub or PayPal

  3. #3
    Contao-Nutzer Avatar von Dr. Jo
    Registriert seit
    11.08.2009.
    Ort
    Riehen (CH)
    Beiträge
    179

    Standard

    Ja, sorry, hätt ich gleich dran denken können:

    Code:
    {
        "type": "project",
        "require": {
            "bugbuster/contao-cron-bundle": "^1.4",
            "bugbuster/contao-visitors-bundle": "^1.6",
            "christianbarkowsky/extended_checkbox": "^1.2",
            "cliffparnitzky/tiny-mce-image-enhancement": "^1.0",
            "cliffparnitzky/tiny-mce-plugin-loader": "^2.1",
            "codefog/contao-mobile_menu": "^2.7",
            "codefog/contao-social_images": "^3.5",
            "contao-community-alliance/dc-general": "^2.2@dev",
            "contao-community-alliance/dc-general-contao-frontend": "^2.2@dev",
            "contao/calendar-bundle": "4.9.*",
            "contao/comments-bundle": "4.9.*",
            "contao/conflicts": "*@dev",
            "contao/faq-bundle": "4.9.*",
            "contao/listing-bundle": "4.9.*",
            "contao/manager-bundle": "4.9.*",
            "contao/news-bundle": "4.9.*",
            "contao/newsletter-bundle": "4.9.*",
            "craffft/css-style-selector-bundle": "^1.6",
            "dklemmt/contao_dk_masonry": "^1.2",
            "do-while/contao-backupdb-bundle": "^1.4",
            "erdmannfreunde/euf_overlay": "^1.3",
            "fipps/contao-parallax-bundle": "^2.1",
            "fritzmg/contao-lightcase": "^3.0",
            "fritzmg/contao-simple-news-urls": "^3.0",
            "georgpreissl/imagecrop": "^1.6",
            "heimrichhannot/contao-filename-sanitizer-bundle": "^2.2",
            "heimrichhannot/contao-upload_filename_sanitizer": "^1.0",
            "hofff/contao-iconfont": "^2.1",
            "jrgregory/m17-sticky-backend-footer": "^2.0",
            "madeyourday/contao-rocksolid-columns": "^2.0",
            "markocupic/import-from-csv-bundle": "^4.6",
            "menatwork/semantic_html5": "^2.0",
            "metamodels/attribute_alias": "^2.2@dev",
            "metamodels/attribute_checkbox": "^2.2@dev",
            "metamodels/attribute_file": "^2.2@dev",
            "metamodels/attribute_longtext": "^2.2@dev",
            "metamodels/attribute_timestamp": "^2.2@dev",
            "metamodels/attribute_translatedlongtext": "^2.2@dev",
            "metamodels/attribute_translatedtext": "^2.2@dev",
            "metamodels/attribute_url": "^2.2@dev",
            "metamodels/core": "^2.2@dev",
            "metamodels/dropzone_file_upload": "^2.2@dev",
            "metamodels/filter_checkbox": "^2.2@dev",
            "metamodels/filter_register": "^2.2@dev",
            "metamodels/filter_select": "^2.2@dev",
            "metamodels/filter_tags": "^2.2@dev",
            "metamodels/filter_text": "^2.2@dev",
            "netzmacht/contao-font-awesome-inserttag": "^2.2",
            "netzmacht/contao-leaflet-maps": "^3.1",
            "presprog/contao-undo": "^1.0",
            "terminal42/contao-changelanguage": "^3.1",
            "terminal42/contao-easy_themes": "^2.2",
            "terminal42/contao-leads": "^1.4",
            "terminal42/contao-pageimage": "^3.4",
            "terminal42/notification_center": "^1.5",
            "contao-community-alliance/events-contao-bindings": "^4.9@dev",
            "contao-community-alliance/translator": "^2.2@dev"
        },
        "repositories": [
        {
          "type": "composer",
          "url": "https://zugang@domain.tld"
        }
      ],
        "extra": {
            "contao-component-dir": "assets"
        },
        "conflict": {
          "doctrine/dbal": "~2.10.4",
          "doctrine/doctrine-migrations-bundle": "<1.1",
          "doctrine/orm": "<2.4",
          "doctrine/persistence": "1.3.2",
          "ocramius/proxy-manager": "2.12.0"
        },
        "scripts": {
            "post-install-cmd": [
                "Contao\\ManagerBundle\\Composer\\ScriptHandler::initializeApplication"
            ],
            "post-update-cmd": [
                "Contao\\ManagerBundle\\Composer\\ScriptHandler::initializeApplication"
            ]
        }
    }
    "contao-community-alliance/events-contao-bindings": "^4.9@dev",
    "contao-community-alliance/translator": "^2.2@dev"
    sind gemäß Zonky Anweisungen eingefügt, der Rest entspricht soweit der mit 2.2 mitgelieferten default-composer.json ...
    Geändert von zonky (17.06.2021 um 12:32 Uhr)

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    27.316
    Partner-ID
    10107

    Standard

    Du musst eine vollständige Paketaktualisierung durchführen.
    » sponsor me via GitHub or PayPal

  5. #5
    Contao-Urgestein Avatar von zonky
    Registriert seit
    19.03.2010.
    Ort
    Berlin, Rdf
    Beiträge
    7.806
    User beschenken
    Wunschliste

    Standard

    @Dr. Jo: Du solltest die E-Mails lesen, die an alle MM 2.2 EAPler gehen! ;-)

  6. #6
    Contao-Nutzer Avatar von Dr. Jo
    Registriert seit
    11.08.2009.
    Ort
    Riehen (CH)
    Beiträge
    179

    Standard

    @spooky: mach ich ja - bzw. versuche ich ja - alle Pakete aktualisieren, Dry Run - mit obigem Ergebnis
    @zonky: dachte ich eigentlich getan zu haben - deswegen habe ich ja
    "contao-community-alliance/events-contao-bindings": "^4.9@dev",
    "contao-community-alliance/translator": "^2.2@dev",
    eingefügt und auch den Hinweis zu https://github.com/contao/contao/issues/3070 gelesen - sonst war da aber eigentlich nichts Update-Relevantes bei ?!

  7. #7
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    27.316
    Partner-ID
    10107

    Standard

    Zitat Zitat von Dr. Jo Beitrag anzeigen
    @spooky: mach ich ja - bzw. versuche ich ja - alle Pakete aktualisieren
    Laut dieser Meldung:
    Code:
    and an update of this package was not requested
    hast du das nicht gemacht.
    » sponsor me via GitHub or PayPal

  8. #8
    Contao-Urgestein Avatar von zonky
    Registriert seit
    19.03.2010.
    Ort
    Berlin, Rdf
    Beiträge
    7.806
    User beschenken
    Wunschliste

    Standard

    o.k. - ggf. hätte ich das in der E-Mail vom 10.06. ausführlicher schreiben sollen...

    Machst Du Update auf Konsole oder CM? Empfehlung wäre Konsole... ansonsten im CM auf Systemsteuerung und Auswahl "Composer Update"

  9. #9
    Contao-Nutzer Avatar von Dr. Jo
    Registriert seit
    11.08.2009.
    Ort
    Riehen (CH)
    Beiträge
    179

    Standard

    Ggfs. hätte auch ich das deutlicher schreiben sollen - Composer Update (web) habe ich auch probiert, aber ebenfalls mit Fehlermeldung. Console sollte ich aber auch Zugriff haben bzw. beosrgen können ...

  10. #10
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    27.316
    Partner-ID
    10107

    Standard

    Poste die Konsolenausgabe der composer update Operation.
    » sponsor me via GitHub or PayPal

  11. #11
    Contao-Nutzer Avatar von Dr. Jo
    Registriert seit
    11.08.2009.
    Ort
    Riehen (CH)
    Beiträge
    179

    Standard

    Voilà:

    Code:
    $ /bin/php74 -q -dmax_execution_time=0 -dmemory_limit=-1 -dallow_url_fopen=1 -ddisable_functions= -ddate.timezone=Europe/Zurich /home/galerieb/public_html/contao-4-9/web/contao-manager.phar.php composer install --prefer-dist --no-dev --no-progress --no-ansi --no-interaction --optimize-autoloader
    Installing dependencies from lock file
    Verifying lock file contents can be installed on current platform.
    Your lock file does not contain a compatible set of packages. Please run composer update.
      Problem 1
        - ocramius/proxy-manager is locked to version 2.13.0 and an update of this package was not requested.
        - ocramius/proxy-manager 2.13.0 requires composer-runtime-api ^2.1.0 -> found composer-runtime-api[2.0.0] but it does not match the constraint.
      Problem 2
        - ocramius/proxy-manager 2.13.0 requires composer-runtime-api ^2.1.0 -> found composer-runtime-api[2.0.0] but it does not match the constraint.
        - symfony/proxy-manager-bridge v4.4.18 requires ocramius/proxy-manager ~2.1 -> satisfiable by ocramius/proxy-manager[2.13.0].
        - symfony/proxy-manager-bridge is locked to version v4.4.18 and an update of this package was not requested.
    # Process terminated with exit code 2
    # Result: Misuse of shell builtins

  12. #12
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    27.316
    Partner-ID
    10107

    Standard

    Das ist nur der zweite Teil.
    » sponsor me via GitHub or PayPal

  13. #13
    Contao-Nutzer Avatar von Dr. Jo
    Registriert seit
    11.08.2009.
    Ort
    Riehen (CH)
    Beiträge
    179

    Standard

    ouch. ja.

    Code:
    > Resolving dependencies using Composer Cloud v3.2.0
    !!! Current server is sponsored by: Contao Association !!!
    [8.4MiB/0.22s] Loading composer repositories with package information
    [83.8MiB/2.34s] Updating dependencies
    [159.1MiB/41.11s] Lock file operations: 7 installs, 141 updates, 6 removals
    [159.2MiB/41.12s]   - Removing doctrine/doctrine-cache-bundle (1.4.0)
    [159.2MiB/41.12s]   - Removing doctrine/reflection (1.2.2)
    [159.2MiB/41.13s]   - Removing jdorn/sql-formatter (v1.2.17)
    [159.2MiB/41.13s]   - Removing laminas/laminas-eventmanager (3.3.0)
    [159.2MiB/41.13s]   - Removing laminas/laminas-zendframework-bridge (1.1.1)
    [159.2MiB/41.14s]   - Removing scheb/two-factor-bundle (v4.18.4)
    [159.2MiB/41.14s]   - Upgrading beberlei/assert (v3.3.0 => v3.3.1)
    [159.2MiB/41.14s]   - Upgrading bugbuster/contao-botdetection-bundle (1.7.0 => 1.7.1)
    [159.2MiB/41.15s]   - Upgrading bugbuster/contao-cron-bundle (1.5.3 => 1.5.5)
    [159.2MiB/41.15s]   - Upgrading bugbuster/contao-visitors-bundle (1.6.6 => 1.6.10)
    [159.2MiB/41.15s]   - Upgrading cache/adapter-common (1.1.0 => 1.2.0)
    [159.2MiB/41.16s]   - Upgrading cache/array-adapter (1.0.1 => 1.1.0)
    [159.2MiB/41.16s]   - Upgrading cache/doctrine-adapter (1.0.0 => 1.1.0)
    [159.2MiB/41.16s]   - Upgrading cache/hierarchical-cache (1.0.0 => 1.1.0)
    [159.2MiB/41.16s]   - Upgrading cache/tag-interop (1.0.0 => 1.0.1)
    [159.2MiB/41.17s]   - Upgrading codefog/contao-haste (4.24.14 => 4.24.17)
    [159.2MiB/41.17s]   - Upgrading composer/ca-bundle (1.2.9 => 1.2.10)
    [159.2MiB/41.17s]   - Upgrading composer/package-versions-deprecated (1.8.2 => 1.11.99.2)
    [159.2MiB/41.17s]   - Upgrading contao-community-alliance/composer-plugin (3.1.4 => 3.2.1)
    [159.2MiB/41.18s]   - Upgrading contao-community-alliance/contao-polyfill-bundle (1.1.3 => 1.1.6)
    [159.2MiB/41.18s]   - Upgrading contao-community-alliance/dc-general (dev-release/2.2.0 7ade9c1 => dev-release/2.2.0 1e58254)
    [159.2MiB/41.18s]   - Upgrading contao-community-alliance/events-contao-bindings (4.4.5 => dev-release/4.9.0)
    [159.2MiB/41.18s]   - Upgrading contao-community-alliance/translator (2.1.5 => dev-release/2.2.0)
    [159.2MiB/41.19s]   - Upgrading contao-components/dropzone (5.7.2 => 5.9.2)
    [159.2MiB/41.19s]   - Upgrading contao-components/jquery (3.5.1 => 3.6.0)
    [159.2MiB/41.19s]   - Upgrading contao/calendar-bundle (4.9.9 => 4.9.15)
    [159.2MiB/41.20s]   - Upgrading contao/comments-bundle (4.9.9 => 4.9.15)
    [159.2MiB/41.20s]   - Upgrading contao/conflicts (dev-main 5844be3 => dev-main e522208)
    [159.2MiB/41.20s]   - Upgrading contao/core-bundle (4.9.9 => 4.9.15)
    [159.2MiB/41.20s]   - Upgrading contao/faq-bundle (4.9.9 => 4.9.15)
    [159.2MiB/41.21s]   - Upgrading contao/image (1.0.3 => 1.1.0)
    [159.2MiB/41.21s]   - Upgrading contao/installation-bundle (4.9.9 => 4.9.15)
    [159.2MiB/41.21s]   - Upgrading contao/listing-bundle (4.9.9 => 4.9.15)
    [159.2MiB/41.21s]   - Upgrading contao/manager-bundle (4.9.9 => 4.9.15)
    [159.2MiB/41.21s]   - Upgrading contao/news-bundle (4.9.9 => 4.9.15)
    [159.2MiB/41.21s]   - Upgrading contao/newsletter-bundle (4.9.9 => 4.9.15)
    [159.2MiB/41.22s]   - Upgrading doctrine/annotations (1.12.1 => 1.13.1)
    [159.2MiB/41.22s]   - Upgrading doctrine/cache (1.10.2 => 1.11.3)
    [159.2MiB/41.22s]   - Upgrading doctrine/common (2.13.3 => 3.1.2)
    [159.2MiB/41.22s]   - Upgrading doctrine/dbal (2.12.1 => 2.13.1)
    [159.2MiB/41.22s]   - Locking doctrine/deprecations (v0.5.3)
    [159.2MiB/41.23s]   - Upgrading doctrine/doctrine-bundle (1.12.13 => 2.4.2)
    [159.2MiB/41.23s]   - Upgrading doctrine/inflector (1.4.3 => 2.0.3)
    [159.2MiB/41.24s]   - Upgrading doctrine/orm (2.7.5 => 2.9.3)
    [159.2MiB/41.24s]   - Upgrading doctrine/persistence (1.3.8 => 2.2.1)
    [159.2MiB/41.24s]   - Locking doctrine/sql-formatter (1.1.1)
    [159.2MiB/41.25s]   - Upgrading egulias/email-validator (3.1.0 => 3.1.1)
    [159.2MiB/41.25s]   - Upgrading friendsofsymfony/http-cache-bundle (2.10.2 => 2.10.3)
    [159.2MiB/41.25s]   - Upgrading hackzilla/password-generator (1.5.0 => 1.6.0)
    [159.2MiB/41.25s]   - Upgrading heimrichhannot/contao-filename-sanitizer-bundle (2.2.1 => 2.2.2)
    [159.2MiB/41.26s]   - Upgrading heimrichhannot/contao-haste_plus (1.14.0 => 1.14.1)
    [159.2MiB/41.26s]   - Upgrading heimrichhannot/contao-multi-column-editor-bundle (2.10.2 => 2.12.4)
    [159.2MiB/41.26s]   - Upgrading heimrichhannot/contao-request-bundle (1.1.0 => 1.2.1)
    [159.2MiB/41.26s]   - Upgrading heimrichhannot/contao-utils-bundle (2.181.2 => 2.193.1)
    [159.2MiB/41.26s]   - Upgrading jaybizzle/crawler-detect (v1.2.104 => v1.2.106)
    [159.2MiB/41.27s]   - Upgrading knplabs/knp-menu (v3.1.3 => v3.2.0)
    [159.2MiB/41.27s]   - Upgrading laminas/laminas-code (3.5.0 => 4.4.0)
    [159.2MiB/41.27s]   - Locking lcobucci/clock (2.0.0)
    [159.2MiB/41.27s]   - Upgrading lcobucci/jwt (3.4.5 => 4.1.4)
    [159.2MiB/41.27s]   - Upgrading league/csv (9.6.1 => 9.7.1)
    [159.2MiB/41.27s]   - Upgrading madeyourday/contao-rocksolid-columns (v2.0.2 => v2.0.3)
    [159.2MiB/41.27s]   - Upgrading markbaker/complex (2.0.0 => 2.0.3)
    [159.2MiB/41.28s]   - Upgrading markbaker/matrix (2.1.2 => 2.1.3)
    [159.2MiB/41.28s]   - Upgrading markocupic/import-from-csv-bundle (4.6.3 => 4.8.7)
    [159.2MiB/41.28s]   - Upgrading menatwork/contao-multicolumnwizard-bundle (3.4.10 => 3.4.11)
    [159.2MiB/41.28s]   - Upgrading menatwork/semantic_html5 (2.0.2 => 2.1.0)
    [159.2MiB/41.28s]   - Upgrading metamodels/attribute_alias (dev-feature/2.2.0 53bc65f => dev-feature/2.2.0 12b52a7)
    [159.2MiB/41.28s]   - Upgrading metamodels/attribute_checkbox (dev-feature/2.2.0 7c41cb4 => dev-feature/2.2.0 48ad3a3)
    [159.2MiB/41.29s]   - Upgrading metamodels/attribute_file (dev-feature/2.2.0 f0785d3 => dev-feature/2.2.0 696e7fb)
    [159.2MiB/41.29s]   - Upgrading metamodels/attribute_timestamp (dev-feature/2.2.0 3b35709 => dev-feature/2.2.0 928b81d)
    [159.2MiB/41.29s]   - Upgrading metamodels/attribute_translatedtext (dev-feature/2.2.0 74f71ee => dev-feature/2.2.0 c06bf51)
    [159.2MiB/41.29s]   - Upgrading metamodels/attribute_url (dev-feature/2.2.0 6c11112 => dev-feature/2.2.0 e6883f6)
    [159.2MiB/41.29s]   - Upgrading metamodels/core (dev-feature/2.2.0 2b46f08 => dev-feature/2.2.0 228948a)
    [159.2MiB/41.29s]   - Upgrading metamodels/filter_checkbox (dev-feature/2.2.0 9516812 => dev-feature/2.2.0 9c487ab)
    [159.2MiB/41.30s]   - Upgrading metamodels/filter_register (dev-feature/2.2.0 e127ce3 => dev-feature/2.2.0 8c4d973)
    [159.2MiB/41.30s]   - Upgrading metamodels/filter_select (dev-feature/2.2.0 b2df265 => dev-feature/2.2.0 aa2e1bb)
    [159.2MiB/41.30s]   - Upgrading metamodels/filter_tags (dev-feature/2.2.0 76d448b => dev-feature/2.2.0 322564f)
    [159.2MiB/41.30s]   - Upgrading metamodels/filter_text (dev-feature/2.2.0 4eccd99 => dev-feature/2.2.0 a93bc45)
    [159.2MiB/41.30s]   - Upgrading monolog/monolog (1.26.0 => 1.26.1)
    [159.2MiB/41.30s]   - Upgrading nelmio/cors-bundle (2.1.0 => 2.1.1)
    [159.2MiB/41.30s]   - Upgrading nelmio/security-bundle (v2.10.1 => v2.10.3)
    [159.2MiB/41.30s]   - Upgrading netzmacht/contao-toolkit (3.5.0 => 3.6.1)
    [159.2MiB/41.31s]   - Upgrading ocramius/proxy-manager (2.8.1 => 2.13.0)
    [159.2MiB/41.31s]   - Upgrading php-http/discovery (1.13.0 => 1.14.0)
    [159.2MiB/41.31s]   - Upgrading php-http/message (1.11.0 => 1.11.1)
    [159.2MiB/41.31s]   - Upgrading phpoffice/phpspreadsheet (1.16.0 => 1.18.0)
    [159.2MiB/41.31s]   - Upgrading predis/predis (v1.1.6 => v1.1.7)
    [159.2MiB/41.31s]   - Upgrading psr/log (1.1.3 => 1.1.4)
    [159.2MiB/41.31s]   - Locking scheb/2fa-backup-code (v5.10.1)
    [159.2MiB/41.31s]   - Locking scheb/2fa-bundle (v5.10.1)
    [159.2MiB/41.32s]   - Locking scheb/2fa-trusted-device (v5.10.1)
    [159.2MiB/41.32s]   - Upgrading scssphp/scssphp (v1.4.1 => v1.5.2)
    [159.2MiB/41.32s]   - Upgrading symfony/asset (v4.4.20 => v4.4.25)
    [159.2MiB/41.32s]   - Upgrading symfony/cache (v4.4.20 => v4.4.25)
    [159.2MiB/41.32s]   - Upgrading symfony/cache-contracts (v2.2.0 => v2.4.0)
    [159.2MiB/41.32s]   - Upgrading symfony/config (v4.4.20 => v4.4.25)
    [159.2MiB/41.33s]   - Upgrading symfony/console (v4.4.20 => v4.4.25)
    [159.2MiB/41.33s]   - Upgrading symfony/css-selector (v5.2.4 => v5.3.0)
    [159.2MiB/41.33s]   - Upgrading symfony/debug (v4.4.20 => v4.4.25)
    [159.2MiB/41.33s]   - Upgrading symfony/debug-bundle (v4.4.16 => v4.4.20)
    [159.2MiB/41.33s]   - Upgrading symfony/dependency-injection (v4.4.20 => v4.4.25)
    [159.2MiB/41.34s]   - Upgrading symfony/deprecation-contracts (v2.2.0 => v2.4.0)
    [159.2MiB/41.34s]   - Upgrading symfony/doctrine-bridge (v4.4.20 => v4.4.25)
    [159.2MiB/41.34s]   - Upgrading symfony/dom-crawler (v4.4.20 => v4.4.25)
    [159.2MiB/41.34s]   - Upgrading symfony/dotenv (v4.4.16 => v4.4.25)
    [159.2MiB/41.34s]   - Upgrading symfony/error-handler (v4.4.20 => v4.4.25)
    [159.2MiB/41.35s]   - Upgrading symfony/event-dispatcher (v4.4.20 => v4.4.25)
    [159.2MiB/41.35s]   - Upgrading symfony/expression-language (v4.4.20 => v4.4.25)
    [159.2MiB/41.35s]   - Upgrading symfony/filesystem (v4.4.20 => v4.4.25)
    [159.2MiB/41.36s]   - Upgrading symfony/finder (v4.4.20 => v4.4.25)
    [159.2MiB/41.36s]   - Upgrading symfony/framework-bundle (v4.4.20 => v4.4.25)
    [159.2MiB/41.36s]   - Upgrading symfony/http-client (v4.4.20 => v4.4.25)
    [159.2MiB/41.37s]   - Upgrading symfony/http-client-contracts (v2.3.1 => v2.4.0)
    [159.2MiB/41.37s]   - Upgrading symfony/http-foundation (v4.4.20 => v4.4.25)
    [159.2MiB/41.37s]   - Upgrading symfony/http-kernel (v4.4.20 => v4.4.25)
    [159.2MiB/41.37s]   - Upgrading symfony/lock (v4.4.20 => v4.4.25)
    [159.2MiB/41.38s]   - Upgrading symfony/mime (v5.2.5 => v5.3.2)
    [159.2MiB/41.38s]   - Upgrading symfony/monolog-bridge (v4.4.20 => v4.4.25)
    [159.2MiB/41.38s]   - Upgrading symfony/monolog-bundle (v3.6.0 => v3.7.0)
    [159.2MiB/41.38s]   - Upgrading symfony/options-resolver (v5.2.4 => v5.3.0)
    [159.2MiB/41.38s]   - Upgrading symfony/polyfill-ctype (v1.22.1 => v1.23.0)
    [159.2MiB/41.38s]   - Upgrading symfony/polyfill-iconv (v1.22.1 => v1.23.0)
    [159.2MiB/41.39s]   - Upgrading symfony/polyfill-intl-grapheme (v1.22.1 => v1.23.0)
    [159.2MiB/41.39s]   - Upgrading symfony/polyfill-intl-idn (v1.22.1 => v1.23.0)
    [159.2MiB/41.39s]   - Upgrading symfony/polyfill-intl-normalizer (v1.22.1 => v1.23.0)
    [159.2MiB/41.39s]   - Upgrading symfony/polyfill-mbstring (v1.22.1 => v1.23.0)
    [159.2MiB/41.39s]   - Upgrading symfony/polyfill-php72 (v1.22.1 => v1.23.0)
    [159.2MiB/41.39s]   - Upgrading symfony/polyfill-php73 (v1.22.1 => v1.23.0)
    [159.2MiB/41.39s]   - Upgrading symfony/polyfill-php80 (v1.22.1 => v1.23.0)
    [159.2MiB/41.40s]   - Locking symfony/polyfill-php81 (v1.23.0)
    [159.2MiB/41.40s]   - Upgrading symfony/process (v4.4.20 => v4.4.25)
    [159.2MiB/41.40s]   - Upgrading symfony/property-access (v5.2.4 => v5.3.0)
    [159.2MiB/41.40s]   - Upgrading symfony/property-info (v5.2.4 => v5.3.1)
    [159.2MiB/41.40s]   - Upgrading symfony/proxy-manager-bridge (v4.4.16 => v4.4.18)
    [159.2MiB/41.40s]   - Upgrading symfony/routing (v4.4.20 => v4.4.25)
    [159.2MiB/41.41s]   - Upgrading symfony/security (v4.4.20 => v4.4.25)
    [159.2MiB/41.41s]   - Upgrading symfony/security-bundle (v4.4.20 => v4.4.25)
    [159.2MiB/41.41s]   - Upgrading symfony/service-contracts (v2.2.0 => v2.4.0)
    [159.2MiB/41.42s]   - Upgrading symfony/stopwatch (v4.4.20 => v4.4.25)
    [159.2MiB/41.42s]   - Upgrading symfony/string (v5.2.4 => v5.3.2)
    [159.2MiB/41.42s]   - Upgrading symfony/templating (v4.4.20 => v4.4.25)
    [159.2MiB/41.43s]   - Upgrading symfony/translation (v4.4.20 => v4.4.25)
    [159.2MiB/41.43s]   - Upgrading symfony/translation-contracts (v2.3.0 => v2.4.0)
    [159.2MiB/41.43s]   - Upgrading symfony/twig-bridge (v4.4.20 => v4.4.25)
    [159.2MiB/41.44s]   - Upgrading symfony/twig-bundle (v4.4.20 => v4.4.25)
    [159.2MiB/41.44s]   - Upgrading symfony/var-dumper (v4.4.20 => v4.4.25)
    [159.2MiB/41.44s]   - Upgrading symfony/var-exporter (v5.2.4 => v5.3.2)
    [159.2MiB/41.44s]   - Upgrading symfony/web-profiler-bundle (v4.4.16 => v4.4.25)
    [159.2MiB/41.45s]   - Upgrading symfony/yaml (v4.4.20 => v4.4.25)
    [159.2MiB/41.45s]   - Upgrading terminal42/contao-changelanguage (3.1.16 => 3.1.17)
    [159.2MiB/41.45s]   - Upgrading terminal42/escargot (0.6.1 => 1.1.0)
    [159.2MiB/41.45s]   - Upgrading toflar/psr6-symfony-http-cache-store (2.3.1 => 3.0.1)
    [159.2MiB/41.45s]   - Upgrading twig/twig (v2.14.4 => v2.14.6)
    [159.2MiB/41.46s]   - Upgrading webimpress/safe-writer (2.1.0 => 2.2.0)
    [158.2MiB/41.48s] Writing lock file
    [92.1MiB/41.55s] 4 package suggestions were added by new dependencies, use `composer suggest` to see details.
    [93.0MiB/41.56s] <warning>Package league/uri-hostname-parser is abandoned, you should avoid using it. No replacement was suggested.</warning>
    [93.0MiB/41.56s] <warning>Package league/uri-schemes is abandoned, you should avoid using it. No replacement was suggested.</warning>
    [93.0MiB/41.57s] <warning>Package patchwork/utf8 is abandoned, you should avoid using it. Use symfony/polyfill-mbstring or symfony/string instead.</warning>
    [93.0MiB/41.57s] <warning>Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.</warning>
    [93.7MiB/41.57s] Memory usage: 93.68MB (peak: 1554.73MB), time: 41.58s.
    [93.7MiB/41.58s] Finished Composer Cloud resolving.
    # Job ID d856BeBkqkVyu8RJZhx4PhPOCT19iWT6WF32LD6qoSOgoqdi5HAJdC8lgtj0eEOXLut6vCsKGYxnN5iX0k0wW9rIiMGP2jHtu4WmSw3RbYVJZzw0Gy3VczPU completed in 39 seconds
    # Memory usage: 93.68MB (peak: 1554.73MB), time: 41.58s.
    
    $/bin/php74 -q -dmax_execution_time=0 -dmemory_limit=-1 -dallow_url_fopen=1 -ddisable_functions= -ddate.timezone=Europe/Zurich /home/galerieb/public_html/contao-4-9/web/contao-manager.phar.php composer install --prefer-dist --no-dev --no-progress --no-ansi --no-interaction --optimize-autoloader
    Installing dependencies from lock file
    Verifying lock file contents can be installed on current platform.
    Your lock file does not contain a compatible set of packages. Please run composer update.
      Problem 1
        - ocramius/proxy-manager is locked to version 2.13.0 and an update of this package was not requested.
        - ocramius/proxy-manager 2.13.0 requires composer-runtime-api ^2.1.0 -> found composer-runtime-api[2.0.0] but it does not match the constraint.
      Problem 2
        - ocramius/proxy-manager 2.13.0 requires composer-runtime-api ^2.1.0 -> found composer-runtime-api[2.0.0] but it does not match the constraint.
        - symfony/proxy-manager-bridge v4.4.18 requires ocramius/proxy-manager ~2.1 -> satisfiable by ocramius/proxy-manager[2.13.0].
        - symfony/proxy-manager-bridge is locked to version v4.4.18 and an update of this package was not requested.
    # Process terminated with exit code 2
    # Result: Misuse of shell builtins

  14. #14
    Contao-Nutzer
    Registriert seit
    11.06.2021.
    Beiträge
    2

    Standard

    Ich hab' genau dasselbe Problem mit genau diesen Meldungen:

    Code:
    <warning>Package league/uri-hostname-parser is abandoned, you should avoid using it. No replacement was suggested.</warning>
    <warning>Package league/uri-schemes is abandoned, you should avoid using it. No replacement was suggested.</warning>
    <warning>Package patchwork/utf8 is abandoned, you should avoid using it. Use symfony/polyfill-mbstring or symfony/string instead.</warning>
    <warning>Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.</warning>
    Ich hab' schon extrem viel rumprobiert, ich hab' auch schon alle möglichen und unmöglichen Pakete deinstalliert, in der Hoffnung, dass das irgendwas bringt. Dabei hab' ich es (fragt mich nicht wie) geschafft, dass mein Notification Center nicht mehr funktioniert und ich keine E-Mails mehr bekomme, z.B.: wenn sich jemand registriert...

    In diesen Meldungen steht z.B.: dass diese utf8 Erweiterung durch eine andere Erweiterung von symfony ersetzt werden soll. Ich hab' nur absolut keine Ahnung wie man das macht... Ich vermute (bin aber kein Experte), dass diese ganzen ausgelaufenen Systemteile die Updates verhindern und andere Probleme machen. Kann das sein?

    Bin auch schon recht verzweifelt... kann da jemand helfen? (Vielleicht steige ich da auch einfach nur nicht durch...)

  15. #15
    Contao-Urgestein Avatar von zonky
    Registriert seit
    19.03.2010.
    Ort
    Berlin, Rdf
    Beiträge
    7.806
    User beschenken
    Wunschliste

    Standard

    poste mal Deine composer.json

  16. #16
    Contao-Nutzer
    Registriert seit
    11.06.2021.
    Beiträge
    2

    Standard

    {
    "type": "project",
    "require": {
    "bugbuster/contao-be_user_online-bundle": "^2.0",
    "bugbuster/contao-dlstats-bundle": "^1.3",
    "bugbuster/contao-lastlogin-bundle": "^1.5",
    "bugbuster/contao-visitors-bundle": "^1.6",
    "cliffparnitzky/form-checked-text": "^1.0",
    "cliffparnitzky/tiny-mce-advanced-list": "^2.2",
    "cliffparnitzky/tiny-mce-bundle-text-color": "^1.0",
    "cliffparnitzky/tiny-mce-context-menu": "^2.1",
    "cliffparnitzky/tiny-mce-font-awesome": "^2.1",
    "contao-themes-net/nature-theme-bundle": "^1.4",
    "contao/calendar-bundle": "4.9.*",
    "contao/comments-bundle": "4.9.*",
    "contao/conflicts": "*@dev",
    "contao/faq-bundle": "4.9.*",
    "contao/manager-bundle": "4.9.*",
    "contao/news-bundle": "4.9.*",
    "contao/newsletter-bundle": "4.9.*",
    "inspiredminds/contao-maker-bundle": "^0.2.1",
    "numero2/contao-marketing-suite": "^1.0",
    "terminal42/contao-changelanguage": "^3.1",
    "terminal42/notification_center": "^1.5",
    "trilobit-gmbh/contao-tiles-bundle": "^1.0"
    },
    "extra": {
    "contao-component-dir": "assets"
    },
    "scripts": {
    "post-install-cmd": [
    "Contao\\ManagerBundle\\Composer\\ScriptHandler::i nitializeApplication"
    ],
    "post-update-cmd": [
    "Contao\\ManagerBundle\\Composer\\ScriptHandler::i nitializeApplication"
    ]
    }
    }

  17. #17
    Contao-Urgestein Avatar von zonky
    Registriert seit
    19.03.2010.
    Ort
    Berlin, Rdf
    Beiträge
    7.806
    User beschenken
    Wunschliste

    Standard

    @ko2media: wenn Du Code oder Konsolenausgaben postest, bitte das Icon #, <> oder php verwenden ... bei deinem ersten Posting habe ich das schon nachgeholt...

    ... Du bist hier im Bereich MetaModels - das hast Du offensichtlich gar nicht im Einsatz

    Die Warnings kannst Du ignorieren.

    habe die composer.json lokal mal ausgeführt: lief bei mir durch
    Geändert von zonky (18.06.2021 um 08:14 Uhr)

  18. #18
    Contao-Urgestein Avatar von zonky
    Registriert seit
    19.03.2010.
    Ort
    Berlin, Rdf
    Beiträge
    7.806
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Dr. Jo Beitrag anzeigen
    ouch. ja.
    habe Deine composer.json lokal mal ausgeführt - lief durch... die composer.lock kann ich Dir senden

  19. #19
    Contao-Nutzer Avatar von Dr. Jo
    Registriert seit
    11.08.2009.
    Ort
    Riehen (CH)
    Beiträge
    179

    Standard

    ... auch mit der aktualisierten composer.lock das gleiche Problem

  20. #20
    Contao-Nutzer Avatar von Dr. Jo
    Registriert seit
    11.08.2009.
    Ort
    Riehen (CH)
    Beiträge
    179

    Standard

    Scheint nicht direkt MM-related zu sein - mit Zonkys Hilfe sind wir einmal soweit gekommen (einzelne Aktualisierung des ocramius-Pakets und des Managers), bevor der fachliche Strömungsabriss erfolgt ist:

    Code:
    Fatal error: Could not check compatibility between Symfony\Bridge\ProxyManager\LazyProxy\PhpDumper\LazyLoadingValueHolderGenerator::generate(ReflectionClass $originalClass, Zend\Code\Generator\ClassGenerator $classGenerator): void and ProxyManager\ProxyGenerator\LazyLoadingValueHolderGenerator::generate(ReflectionClass $originalClass, Laminas\Code\Generator\ClassGenerator $classGenerator), because class Zend\Code\Generator\ClassGenerator is not available in /home/contao/vendor/symfony/proxy-manager-bridge/LazyProxy/PhpDumper/LazyLoadingValueHolderGenerator.php on line 33
    Script Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication handling the post-install-cmd event terminated with an exception

  21. #21
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    27.316
    Partner-ID
    10107

    Standard

    Welche PHP Version?
    » sponsor me via GitHub or PayPal

  22. #22
    Contao-Urgestein Avatar von zonky
    Registriert seit
    19.03.2010.
    Ort
    Berlin, Rdf
    Beiträge
    7.806
    User beschenken
    Wunschliste

    Standard

    7.4. - die Meldung kommt beim install

  23. #23
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    27.316
    Partner-ID
    10107

    Standard

    @Dr. Jo führe über SSH mit der composer.lock von zonky folgendes aus (im Root der Contao Installation):

    Code:
    wget https://getcomposer.org/download/2.1.3/composer.phar
    /bin/php74 -d memory_limit=-1 composer.phar install -o --prefer-dist --no-dev --dry-run
    Geändert von zonky (25.06.2021 um 07:07 Uhr)
    » sponsor me via GitHub or PayPal

  24. #24
    Contao-Nutzer Avatar von Dr. Jo
    Registriert seit
    11.08.2009.
    Ort
    Riehen (CH)
    Beiträge
    179

    Standard

    Code:
    Installing dependencies from lock file
    Verifying lock file contents can be installed on current platform.
    Nothing to install, update or remove
    Package league/uri-hostname-parser is abandoned, you should avoid using it. No replacement was suggested.
    Package league/uri-schemes is abandoned, you should avoid using it. No replacement was suggested.
    Package patchwork/utf8 is abandoned, you should avoid using it. Use symfony/polyfill-mbstring or symfony/string instead.
    Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.
    97 packages you are using are looking for funding.
    Use the `composer fund` command to find out more!
    Die beschädigte Installation bleibt aber ... und sobald ich bei
    /bin/php74 -dmemory_limit=-1 composer.phar install -o --prefer-dist --no-dev --dry-run
    das --dry-run wegnehme, kommt auf der Konsole:
    Code:
    Installing dependencies from lock file
    Verifying lock file contents can be installed on current platform.
    Nothing to install, update or remove
    Package league/uri-hostname-parser is abandoned, you should avoid using it. No replacement was suggested.
    Package league/uri-schemes is abandoned, you should avoid using it. No replacement was suggested.
    Package patchwork/utf8 is abandoned, you should avoid using it. Use symfony/polyfill-mbstring or symfony/string instead.
    Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.
    Generating optimized autoload files
    Class League\Uri\Schemes\AbstractUri located in ./vendor/league/uri-schemes/src/Schemes/deprecated.php does not comply with psr-4 autoloading standard. Skipping.
    Class League\Uri\Schemes\Data located in ./vendor/league/uri-schemes/src/Schemes/deprecated.php does not comply with psr-4 autoloading standard. Skipping.
    Class League\Uri\Schemes\File located in ./vendor/league/uri-schemes/src/Schemes/deprecated.php does not comply with psr-4 autoloading standard. Skipping.
    Class League\Uri\Schemes\Ftp located in ./vendor/league/uri-schemes/src/Schemes/deprecated.php does not comply with psr-4 autoloading standard. Skipping.
    Class League\Uri\Schemes\Http located in ./vendor/league/uri-schemes/src/Schemes/deprecated.php does not comply with psr-4 autoloading standard. Skipping.
    Class League\Uri\Schemes\Uri located in ./vendor/league/uri-schemes/src/Schemes/deprecated.php does not comply with psr-4 autoloading standard. Skipping.
    Class League\Uri\Schemes\UriException located in ./vendor/league/uri-schemes/src/Schemes/deprecated.php does not comply with psr-4 autoloading standard. Skipping.
    Class League\Uri\Schemes\Ws located in ./vendor/league/uri-schemes/src/Schemes/deprecated.php does not comply with psr-4 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Backend\Automator located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Backend/Automator.php does not comply with psr-0 autoloading st                                 andard. Skipping.
    Class HeimrichHannot\Haste\InsertTags\InsertTags located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/InsertTags/InsertTags.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Security\HttpResponse located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Security/HttpResponse.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Security\CodeGenerator located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Security/CodeGenerator.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Cache\Cache located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Cache/Cache.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Cache\RemoteImageCache located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Cache/RemoteImageCache.php does not comply with psr-0 auto                                 loading standard. Skipping.
    Class HeimrichHannot\Haste\Cache\FileCache located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Cache/FileCache.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Image\Image located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Image/Image.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Pdf\MPdfTemplate located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Pdf/MPdfTemplate.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Pdf\PdfTemplate located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Pdf/PdfTemplate.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Util\PaymentUtil located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/PaymentUtil.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Util\GeoLocation located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/GeoLocation.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Util\Container located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/Container.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Util\Url located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/Url.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Util\Classes located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/Classes.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Util\Files located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/Files.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\DateUtil located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/DateUtil.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Util\Numbers located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/Numbers.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Util\Widget located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/Widget.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Util\Curl located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/Curl.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Util\Validator located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/Validator.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Util\Arrays located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/Arrays.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Util\FormSubmission located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/FormSubmission.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Util\Environment located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/Environment.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Util\Module located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/Module.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Util\Salutations located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/Salutations.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Util\DOMUtil located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/DOMUtil.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Util\StringUtil located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Util/StringUtil.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Dca\General located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Dca/General.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Dca\Event located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Dca/Event.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Dca\Notification located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Dca/Notification.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Dca\Member located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Dca/Member.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Dca\User located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Dca/User.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Dca\DC_HastePlus located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Dca/DC_HastePlus.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Visualization\GoogleChartWrapper located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Visualization/GoogleChartWrapper.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\DC_Table located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Drivers/DC_Table.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Map\GoogleMapOverlay located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Maps/GoogleMapOverlay.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Map\GoogleMapMarker located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Maps/GoogleMapMarker.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Map\GoogleMap located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Maps/GoogleMap.php does not comply with psr-0 autoloading standard.                                  Skipping.
    Class HeimrichHannot\Haste\Model\Model located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Model/Model.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Model\UserModel located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Model/UserModel.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Model\MemberModel located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Model/MemberModel.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Database\QueryHelper located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Database/QueryHelper.php does not comply with psr-0 autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Database\Contao3MysqliHelper located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Database/QueryHelper.php does not comply with psr-0                                  autoloading standard. Skipping.
    Class HeimrichHannot\Haste\Database\Contao3MysqlHelper located in ./vendor/heimrichhannot/contao-haste_plus/library/Haste/Database/QueryHelper.php does not comply with psr-0 a                                 utoloading standard. Skipping.
    composer/package-versions-deprecated: Generating version class...
    composer/package-versions-deprecated: ...done generating version class
    97 packages you are using are looking for funding.
    Use the `composer fund` command to find out more!
    contao/manager-plugin: Generating plugin class...
    contao/manager-plugin: ...done generating plugin class
    > Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication
    
    Fatal error: Could not check compatibility between Symfony\Bridge\ProxyManager\LazyProxy\PhpDumper\LazyLoadingValueHolderGenerator::generate(ReflectionClass $originalClass, Ze                                 nd\Code\Generator\ClassGenerator $classGenerator): void and ProxyManager\ProxyGenerator\LazyLoadingValueHolderGenerator::generate(ReflectionClass $originalClass, Laminas\Code\                                 Generator\ClassGenerator $classGenerator), because class Zend\Code\Generator\ClassGenerator is not available in /contao/vendor/symfony/proxy-manager-bridge/LazyProxy/PhpDumper/LazyLoadingValueHolderGenerator.php on line 33
    Script Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication handling the post-install-cmd event terminated with an exception
    
    
      [RuntimeException]
      An error occurred while executing the "contao:install-web-dir" command:
    
    
    install [--prefer-source] [--prefer-dist] [--prefer-install PREFER-INSTALL] [--dry-run] [--dev] [--no-suggest] [--no-dev] [--no-autoloader] [--no-scripts] [--no-progress] [--no-install] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--apcu-autoloader-prefix APCU-AUTOLOADER-PREFIX] [--ignore-platform-req IGNORE-PLATFORM-REQ] [--ignore-platform-reqs] [--] [<packages>]...

  25. #25
    Contao-Nutzer Avatar von Dr. Jo
    Registriert seit
    11.08.2009.
    Ort
    Riehen (CH)
    Beiträge
    179

    Standard

    Zwischenstand/vorläufige Lösung: Ich habe eine weitere Installation frisch angelegt und dort die gewünschten Pakete in die composer.json eingetragen, dort läuft alles ohne Probleme.
    In der defekten Installation habe ich das vendor-Verzeichnis entfernt und
    php -d memory_limit=-1 composer.phar install -o --prefer-dist --no-dev
    ausgeführt, aber es bleibt dort der Fehler.
    Ist für mich jetzt so erst einmal kein Problem, aber evtl. kommt das ja noch mal vor ...

  26. #26
    Contao-Nutzer
    Registriert seit
    24.05.2013.
    Beiträge
    17

    Standard

    Hatten das Problem bei uns auch - in dem Fall war es eine 1-Click-Installation von Mittwald, welche folgende Zeile in der composer.json festgeschrieben hatte:
    "contao/manager-bundle": "4.11.2",

    Nach der Änderung auf:
    "contao/manager-bundle": "4.11.*",
    lief composer update erfolgreich durch.

    Evtl. hilft das dem ein oder anderen, der auf diese Meldung stößt.

  27. #27
    Contao-Nutzer
    Registriert seit
    30.09.2011.
    Beiträge
    23

    Standard

    Hallo ich Kämpfe leider doch weiter an dem Problem.

    Kurze frage vor ab, da es eh ein neues Projekt wird.

    MYSQL 10.3
    PHP 8
    Contao 4.11.5

    Alle Rocksolid Module
    Metamodels Core + All +Frontend Helper
    LeafMaps + Metamodels

    Ich konnte bei keiner der Module eine Inkompatibilität finde. Aber ich laufe beim Composer immer wieder auf den gleichen Fehler, habe es dann auch mit PHP 7.4 getestet.
    Wie wäre die richtige Reihenfolge der Installation der Pakete ? Oder alles auf einmal ? Ich habe erst Rocksolid dann LeafMap und dann Metamodels versucht.

    Ich teste gerne alles


    Das mit conflict hatte ich auch getestet

  28. #28
    Contao-Urgestein Avatar von zonky
    Registriert seit
    19.03.2010.
    Ort
    Berlin, Rdf
    Beiträge
    7.806
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Speedygonzalez Beitrag anzeigen

    MYSQL 10.3
    PHP 8
    Contao 4.11.5


    Alle Rocksolid Module
    Metamodels Core + All +Frontend Helper
    LeafMaps + Metamodels
    *heul schluchts*

    https://community.contao.org/de/show...en-bitte-lesen!

    https://metamodels.readthedocs.io/de...fur-contao-4-4

  29. #29
    Contao-Urgestein Avatar von zonky
    Registriert seit
    19.03.2010.
    Ort
    Berlin, Rdf
    Beiträge
    7.806
    User beschenken
    Wunschliste

    Standard

    Sofern "contao:install-web-dir" beim "post-install-cmd" mit einer Fehlermeldung beim composer update/install abschmiert und auch mit -vvv nicht mehr Infos zum Übeltäter kommen, kann mit folgender Änderung ggf. mehr Infos erhalten:

    Datei ändern .../vendor/contao/manager-bundle/bin/contao-console

    Code:
    
    $kernel = ContaoKernel::fromInput($projectDir, $input);
    
    // --Start--
    error_reporting(-1);
    set_time_limit(0);
    @ini_set('display_startup_errors', '1');
    @ini_set('display_errors', '1');
    @ini_set('zlib.output_compression', '0');
    // --End--
    
    $application = new ContaoApplication($kernel);
    und die Zeilen zwischen $kernel und $application einfügen.

    Viel Glück bei der Käferjagt!

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •