Ergebnis 1 bis 4 von 4

Thema: 4.13 RC1 - Update conflict

  1. #1
    Contao-Nutzer Avatar von janosch
    Registriert seit
    06.07.2009.
    Ort
    Wien
    Beiträge
    82

    Standard 4.13 RC1 - Update conflict

    Hey Leute,

    ich versuche gerade Contao 4.9 auf den RC von 4.13 zu updaten, jedoch wirft Composer "Conclusion: don't install contao/conflicts 9999999-dev (conflict analysis result)" und ich kann nicht nachvollziehen warum.

    Hat jemand eine Idee bzw. kann vllt. mehr rauslesen?

    Code:
    $ /usr/bin/php74 -q -dmax_execution_time=0 -dmemory_limit=-1 -dallow_url_fopen=1 -ddisable_functions= -ddate.timezone=Europe/Berlin /usr/www/users/xxx/c413_2022/web/contao-manager.phar.php composer require contao/manager-bundle=4.13.* contao/news-bundle=4.13.* contao/calendar-bundle=4.13.* contao/faq-bundle=4.13.* contao/comments-bundle=4.13.* contao/newsletter-bundle=4.13.* contao/listing-bundle=4.13.* --no-update --no-scripts --prefer-stable --sort-packages --no-ansi --no-interaction
    
    Using config.component-dir has been deprecated. Please use extra.contao-component-dir instead.
    /usr/www/users/xxx/c413_2022/composer.json has been updated
    
    # Process terminated with exit code 0
    # Result: OK
    
    
    > Resolving dependencies using Composer Cloud v3.2.0
    !!! Current server is sponsored by: Contao Association !!!
    
    
    [7.4MiB/0.18s] Loading composer repositories with package information
    [71.8MiB/2.37s] Updating dependencies
    [1745.7MiB/12.99s] Your requirements could not be resolved to an installable set of packages.
    [1745.7MiB/12.99s] 
      Problem 1
        - Root composer.json requires contao/manager-bundle 4.13.* -> satisfiable by contao/manager-bundle[4.13.0-RC1].
        - madeyourday/contao-rocksolid-slider is locked to version v2.1.5 and an update of this package was not requested.
        - richardhj/isotope-klarna-checkout is locked to version v2.0.4 and an update of this package was not requested.
        - Conclusion: don't install contao/conflicts 9999999-dev (conflict analysis result)
        - Root composer.json requires contao/conflicts *@dev -> satisfiable by contao/conflicts[dev-main].
    
    [1745.7MiB/12.99s] Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.
    [78.8MiB/15.41s] Memory usage: 78.79MB (peak: 1749.52MB), time: 15.42s.
    [78.8MiB/15.41s] Finished Composer Cloud resolving.
    
    
    # Cloud Job ID C5THggXxphiDaHIAWFMTizpKtq3yx0zNMGUg7mqCiuRaix5cq3YCOs9WjoBTp8ZrBYHIzeOYeK3JOK0f5lrsyhdEfyFUX6Vi65QnHc9N2cVNVMfUeBoafkHzo1qlmgR failed
    Why is 6 afraid of 7? Because 7 8 9.

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    29.578
    Partner-ID
    10107

    Standard

    Du musst eine vollständige Paketaktualisierung durchführen, bzw. alle Pakete zum Update markieren.
    » sponsor me via GitHub or PayPal or Revolut

  3. #3
    Contao-Nutzer Avatar von janosch
    Registriert seit
    06.07.2009.
    Ort
    Wien
    Beiträge
    82

    Standard

    Danke Spooky für die rasche Antwort. Das habe ich bereits versucht (war mal dein Lösungsvorschlag bei einem ähnlichen Problem in einem anderen Thread), führt aber zum selben Output:
    Code:
    composer update trilobit-gmbh/contao-cookiebar-bundle terminal42/notification_center richardhj/isotope-klarna-checkout numero2/contao-marketing-suite mpdf/mpdf madeyourday/contao-rocksolid-slider isotope/isotope_documents isotope/isotope-core inszenium/isotope-export heimrichhannot/contao-email2username-bundle dklemmt/contao_dk_mmenu delahaye/dlh_googlemaps cliffparnitzky/tiny-mce-advanced-list christianbarkowsky/contao-tiny-compress-images chillerlan/php-qrcode contao/manager-bundle contao/news-bundle contao/calendar-bundle contao/faq-bundle contao/comments-bundle contao/newsletter-bundle contao/listing-bundle contao/conflicts
    
    > Resolving dependencies using Composer Cloud v3.2.0
    !!! Current server is sponsored by: Contao Association !!!
    [7.4MiB/0.20s] Loading composer repositories with package information
    [75.4MiB/2.90s] Updating dependencies
    [1801.0MiB/19.03s] Your requirements could not be resolved to an installable set of packages.
    [1801.0MiB/19.04s] 
      Problem 1
        - Root composer.json requires contao/manager-bundle 4.13.* -> satisfiable by contao/manager-bundle[4.13.0-RC1].
        - Root composer.json requires richardhj/isotope-klarna-checkout ^2.0 -> satisfiable by richardhj/isotope-klarna-checkout[v2.0.0, ..., v2.0.4].
        - Conclusion: don't install contao/conflicts 9999999-dev (conflict analysis result)
        - Root composer.json requires contao/conflicts *@dev -> satisfiable by contao/conflicts[dev-main].
    [1801.0MiB/19.04s] <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning>
    [79.4MiB/21.35s] Memory usage: 79.4MB (peak: 1805.55MB), time: 21.36s.
    [79.4MiB/21.35s] Finished Composer Cloud resolving.
    # Cloud Job ID MgnbI9p43SKmwCKGotJtCog35VeKRqAkNOCUQ9EvJxbeZ58uZviHfrhnFuy6XpGGSPVdflVcAw1fQJirTWJqtNHpvvalVmPW9C9v3T6cf0S5WarMzDahTO6PrpyGO failed
    Gibt's eine Möglichkeit herauszufinden, welches Package die Probleme verursacht?
    Why is 6 afraid of 7? Because 7 8 9.

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    29.578
    Partner-ID
    10107

    Standard

    Ja, richardhj/isotope-klarna-checkout benötigt noch doctrine/dbal: ^2.0, Contao 4.13 benötigt aber doctrine/dbal: ^3.0. Da muss richardhj/isotope-klarna-checkout angepasst werden.
    » sponsor me via GitHub or PayPal or Revolut

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •