Ticket sichern für VueJS-Konferenz 2022
Ergebnis 1 bis 10 von 10

Thema: contao-bootstrap/form lässt sich nicht updaten

  1. #1
    Contao-Nutzer
    Registriert seit
    21.01.2014.
    Beiträge
    41

    Frage contao-bootstrap/form lässt sich nicht updaten

    Hallo zusammen,

    habe folgendes Setup:

    Contao 4.13.6
    Php8
    contao-bootstrap/form Version 2.1.1

    Sobald ich contao-bootstrap/form auf eine höhere Version updaten möchte, macht er es nicht.
    Habe schon mal probiert, eine Version zu "erzwingen" durch manuelles Eintragen der höheren Version "^2.1.2" und bekomme dann das:

    Code:
    > Resolving dependencies using Composer Cloud v3.4.4
    !!! Current server is sponsored by: Contao Association !!!
    [6.9MiB/0.17s] Loading composer repositories with package information
    [63.9MiB/6.60s] Updating dependencies
    [79.6MiB/7.09s] Your requirements could not be resolved to an installable set of packages.
    [79.6MiB/7.09s] 
      Problem 1
        - contao-bootstrap/form[2.1.3, ..., 2.1.6] require symfony/config ^3.3 || ^4.0 -> found symfony/config[v3.3.0, ..., v3.4.47, v4.0.0, ..., v4.4.42] but these were not loaded, likely because it conflicts with another require.
        - Root composer.json requires contao-bootstrap/form ^2.1.3 -> satisfiable by contao-bootstrap/form[2.1.3, 2.1.4, 2.1.5, 2.1.6].
    [79.6MiB/7.09s] <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning>
    [37.0MiB/7.11s] Memory usage: 37.04MB (peak: 176.42MB), time: 7.12s.
    [37.0MiB/7.12s] Finished Composer Cloud resolving.
    Problem ist nämlich, dass ich keine Formulare mehr bearbeiten kann wegen einem DCA Fehler:

    Code:
    The "contao_bootstrap.form.listener.form_field_dca" service or alias has been removed or inlined when the container was compiled. You should either make it public, or stop using the container directly and use dependency injection instead.
    Wäre für jede Hilfe und Ideen sehr dankbar!

  2. #2
    Administratorin Avatar von lucina
    Registriert seit
    19.06.2009.
    Ort
    Kiel (DE)
    Beiträge
    7.045
    Partner-ID
    152
    User beschenken
    Wunschliste
    Contao-Projekt unterstützen

    Support Contao

    Standard

    Dazu gibt es bereits ein Ticket. https://github.com/contao-bootstrap/form/issues/51

    Möglicherweise fährst du mit der Version https://packagist.org/packages/conta...rm#dev-develop besser.

    Und ansonsten sehr gerne hier entlang: https://contao-bootstrap.de/contao-4...ibilitaet.html

  3. #3
    Contao-Nutzer
    Registriert seit
    21.01.2014.
    Beiträge
    41

    Standard

    Danke für die Links.

    Spannend ist leider auch, dass eine Deinstallation der Forms Erweiterung leider den DCS Fehler weiterhin behält...
    Weil das war auch schon eine Überlegung. Was könnte man hier dann als Quick Lösung machen?

  4. #4
    Administratorin Avatar von lucina
    Registriert seit
    19.06.2009.
    Ort
    Kiel (DE)
    Beiträge
    7.045
    Partner-ID
    152
    User beschenken
    Wunschliste
    Contao-Projekt unterstützen

    Support Contao

    Standard

    Wie gesagt:
    Code:
    2.5.x-dev as 2.5
    nutzen, das läuft bei mir unter 4.13, allerdings unter PHP 7.4.

  5. #5
    Contao-Nutzer
    Registriert seit
    21.01.2014.
    Beiträge
    41

    Standard

    Arbeite selten mit dev Versionen, ist das wie im Anhang korrekt?
    Angehängte Grafiken Angehängte Grafiken

  6. #6
    Administratorin Avatar von lucina
    Registriert seit
    19.06.2009.
    Ort
    Kiel (DE)
    Beiträge
    7.045
    Partner-ID
    152
    User beschenken
    Wunschliste
    Contao-Projekt unterstützen

    Support Contao

    Standard

    Ja.

  7. #7
    Contao-Nutzer
    Registriert seit
    21.01.2014.
    Beiträge
    41

    Standard

    Invalid version string "^2.5.x-dev" in "^2.5.x-dev as 2.5", the alias source must be an exact version, if it is a branch name you should prefix it with dev-

  8. #8
    Administratorin Avatar von lucina
    Registriert seit
    19.06.2009.
    Ort
    Kiel (DE)
    Beiträge
    7.045
    Partner-ID
    152
    User beschenken
    Wunschliste
    Contao-Projekt unterstützen

    Support Contao

    Standard

    Oh sorry, 2.2.x-dev as 2.2, da war ich in der Zeile verrutscht.

  9. #9
    Contao-Nutzer
    Registriert seit
    21.01.2014.
    Beiträge
    41

    Standard

    Invalid version string "^2.2.x-dev" in "^2.2.x-dev as 2.2", the alias source must be an exact version, if it is a branch name you should prefix it with dev-

  10. #10
    Administratorin Avatar von lucina
    Registriert seit
    19.06.2009.
    Ort
    Kiel (DE)
    Beiträge
    7.045
    Partner-ID
    152
    User beschenken
    Wunschliste
    Contao-Projekt unterstützen

    Support Contao

    Standard

    Und warum stellst Du da noch ein ^ vorweg? Das hatte ich nicht geschrieben.

    Edit: Bitte dazu mal lesen: https://getcomposer.org/doc/articles/versions.md
    Geändert von lucina (20.07.2022 um 09:19 Uhr)

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •