Ergebnis 1 bis 3 von 3

Thema: Abbruch durch nicht gefundene Mailer-Komponente

  1. #1
    Contao-Nutzer
    Registriert seit
    10.10.2013.
    Beiträge
    43

    Standard Abbruch durch nicht gefundene Mailer-Komponente

    Nach einem versuchten Minor-Update innerhalb der 4.9 auf die aktuellste Version mit einem zuvor erforderlichen Update des Contao-Managers auf v1.6.0 will die Installation nicht mehr so richtig.

    Jede Änderung wird final mit einem Fehler im Contao-Manager abgebrochen:
    Code:
    In FrameworkExtension.php line 2070:
                                                                                   
      Mailer support cannot be enabled as the component is not installed. Try run  
      ning "composer require symfony/mailer".
    Folgendes habe ich schon versucht:
    • Reparatur
    • Caches gelöscht
    • Vendor-Pfad gelöscht
    • composer_lock gelöscht
    • Downgrade auf ältere Versionen
    • Contao-Manager nochmals aktualisiert
    • Composer-Abhängigkeiten erneuert

    Die Mail-Verbindung läuft über das Notification Center. Dieses habe ich noch nicht versucht zu deinstallieren, weil ich nicht genau weiß, inwieweit dann erst mal die Datenbank beeinflusst wird und ich alles später zurückbauen muss.

    Front- und Backend bleiben weiß ohne Fehlermeldung.


    Manchmal kommt auch eine zweite Fehlermeldungen:
    Code:
    Script Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication handling the post-install-cmd event terminated with an exception
    In ScriptHandler.php line 97:
                                                                                   
      An error occurred while executing the "contao:install-web-dir" command:      
      In FrameworkExtension.php line 2070:                                         
                                                                                   
                                                                                   
        Mailer support cannot be enabled as the component is not installed. Try r  
      un                                                                           
        ning "composer require symfony/mailer".
    Geändert von 462 (28.09.2022 um 15:05 Uhr)

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    30.696
    Partner-ID
    10107

    Standard

    Hast du in deiner config.yaml eine mailer config? Wenn ja musst du diese entfernen.
    » sponsor me via GitHub or PayPal or Revolut

  3. #3
    Contao-Nutzer
    Registriert seit
    10.10.2013.
    Beiträge
    43

    Standard

    Das war es. Danke.

    Ich hatte für die 4.13 schon was vorbereitet. Bei den Tests im Rahmen der obigen Fehler hatte ich dann nur Teile auskommentiert. Es muss aber alles was zum Mailer gehört in der 4.9er wieder raus (auskommentiert sein).

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •