Ergebnis 1 bis 13 von 13

Thema: Update von 4.12.6 auf 4.13.10 schlägt fehl

  1. #1
    Alter Contao-Hase Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    1.278

    Standard Update von 4.12.6 auf 4.13.10 schlägt fehl

    Hi Leute,

    nachdem mein Server heute Nacht upgegradet wurde, will ich meine Installationen jetzt von 4.12.6 auf 4.13.10 updaten. Bei den meisten läuft es wunderbar durch, aber bei einigen wird folgender Fehler angezeigt:

    Code:
    composer require contao/manager-bundle=4.13.* contao/news-bundle=4.13.* contao/calendar-bundle=4.13.* contao/faq-bundle=4.13.* contao/comments-bundle=4.13.* contao/newsletter-bundle=4.13.* contao/listing-bundle=4.13.*
    $ /usr/bin/php -q -dmax_execution_time=0 -dmemory_limit=-1 -dallow_url_fopen=1 -ddisable_functions= -ddate.timezone=Europe/Berlin /kunden/fotografenmeister.de/rp-hosting/013/13/contao4-Oneo/web/contao-manager.phar.php composer require contao/manager-bundle=4.13.* contao/news-bundle=4.13.* contao/calendar-bundle=4.13.* contao/faq-bundle=4.13.* contao/comments-bundle=4.13.* contao/newsletter-bundle=4.13.* contao/listing-bundle=4.13.* --no-update --no-scripts --prefer-stable --sort-packages --no-ansi --no-interaction
    /kunden/xxx/composer.json has been updated
    # Process terminated with exit code 0
    # Result: OK
    composer update contao/manager-bundle contao/news-bundle contao/calendar-bundle contao/faq-bundle contao/comments-bundle contao/newsletter-bundle contao/listing-bundle contao/conflicts --no-install
    > Resolving dependencies using Composer Cloud v3.5.0
    !!! Current server is sponsored by: terminal42 gmbh !!!
    [7.0MiB/0.24s] Loading composer repositories with package information
    [64.9MiB/8.17s] Updating dependencies
    [101.6MiB/8.77s] Your requirements could not be resolved to an installable set of packages.
    [101.6MiB/8.77s] 
      Problem 1
        - contao/manager-bundle[4.13.0, ..., 4.13.10] require symfony/console ^5.4 -> found symfony/console[v5.4.0, ..., v5.4.12] but these were not loaded, likely because it conflicts with another require.
        - Root composer.json requires contao/manager-bundle 4.13.* -> satisfiable by contao/manager-bundle[4.13.0, ..., 4.13.10].
    [101.6MiB/8.77s] <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning>
    [36.9MiB/8.82s] Memory usage: 36.85MB (peak: 171.96MB), time: 8.83s.
    [36.9MiB/8.82s] Finished Composer Cloud resolving.
    # Cloud Job ID rXd48vNIZAXqMdLlJP5eOyY2qrn8KgEtBxVn30BdzUasdNLPpgtYID5rcvaJHWIb2ndV9n8wvBt failed
    Woran könnte das liegen?

    Grüße
    Jochen
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    30.707
    Partner-ID
    10107

    Standard

    Poste deine composer.json
    » sponsor me via GitHub or PayPal or Revolut

  3. #3
    Alter Contao-Hase Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    1.278

    Standard

    Hi spooky,
    hier die composer.json :

    Code:
    {
        "name": "contao/managed-edition",
        "type": "project",
        "description": "Contao Open Source CMS",
        "license": "LGPL-3.0-or-later",
        "authors": [
            {
                "name": "Leo Feyer",
                "homepage": "https://github.com/leofeyer"
            }
        ],
        "require": {
            "php": "^7.1",
            "bugbuster/contao-visitors-bundle": "^1.3",
            "codefog/contao-cookiebar": "^2.1",
            "contao/calendar-bundle": "4.12.*",
            "contao/comments-bundle": "4.12.*",
            "contao/conflicts": "*@dev",
            "contao/faq-bundle": "4.12.*",
            "contao/listing-bundle": "4.12.*",
            "contao/manager-bundle": "4.12.*",
            "contao/news-bundle": "4.12.*",
            "contao/newsletter-bundle": "4.12.*",
            "madeyourday/contao-rocksolid-columns": "^2.0",
            "madeyourday/contao-rocksolid-custom-elements": "^2.2",
            "madeyourday/contao-rocksolid-frontend-helper": "^2.0",
            "madeyourday/contao-rocksolid-icon-picker": "^2.0",
            "madeyourday/contao-rocksolid-mega-menu": "^2.0",
            "madeyourday/contao-rocksolid-slider": "^2.0",
            "madeyourday/contao-rocksolid-theme-assistant": "^2.0"
        },
        "conflict": {
            "contao-components/installer": "<1.3"
        },
        "require-dev": {
            "sensiolabs/security-checker": "^4.1"
        },
        "extra": {
            "branch-alias": {
                "dev-4.6": "4.6.x-dev"
            },
            "contao-component-dir": "assets",
            "public-dir": "web"
        },
        "autoload": {
            "psr-4": {
                "App\\": "src/"
            }
        },
        "scripts": {
            "post-install-cmd": [
                "@php vendor/bin/contao-setup"
            ],
            "post-update-cmd": [
                "@php vendor/bin/contao-setup"
            ]
        }
    }
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    30.707
    Partner-ID
    10107

    Standard

    Ich denke du wirst eine vollständige Paketaktualisierung machen müssen. Also:

    1. Auf Contao 4.13.* ändern.
    2. Dann in der Systemwartung ein composer update durchführen lassen.
    » sponsor me via GitHub or PayPal or Revolut

  5. #5
    Alter Contao-Hase Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    1.278

    Standard

    Ich habe in der Systemwartung drei Optionen zum Composer:

    - Class-Loader
    - Abhängigkeiten
    - Cache

    was genau meinst Du?
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  6. #6
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    30.707
    Partner-ID
    10107
    » sponsor me via GitHub or PayPal or Revolut

  7. #7
    Alter Contao-Hase Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    1.278

    Standard

    Klappt leider immer noch nicht das composerupdate läuft durch bei der Paketaktualisierung sag die Konsole das hier:


    Code:
    $ /usr/bin/php -q -dmax_execution_time=0 -dmemory_limit=-1 -dallow_url_fopen=1 -ddisable_functions= -ddate.timezone=Europe/Berlin /kunden/fotografenmeister.de/rp-hosting/013/13/contao4-Oneo/web/contao-manager.phar.php composer require contao/manager-bundle=4.13.* contao/news-bundle=4.13.* contao/calendar-bundle=4.13.* contao/faq-bundle=4.13.* contao/comments-bundle=4.13.* contao/newsletter-bundle=4.13.* contao/listing-bundle=4.13.* --no-update --no-scripts --prefer-stable --sort-packages --no-ansi --no-interaction
    
    /kunden/fotografenmeister.de/rp-hosting/013/13/contao4-Oneo/composer.json has been updated
    
    # Process terminated with exit code 0
    # Result: OK
    
    
    > Resolving dependencies using Composer Cloud v3.5.0
    !!! Current server is sponsored by: terminal42 gmbh !!!
    
    
    [6.9MiB/0.18s] Loading composer repositories with package information
    [69.6MiB/7.70s] Updating dependencies
    [130.5MiB/8.28s] Your requirements could not be resolved to an installable set of packages.
    [130.5MiB/8.28s] 
      Problem 1
        - Root composer.json requires sensiolabs/security-checker ^4.1 -> satisfiable by sensiolabs/security-checker[v4.1.0, ..., v4.1.8].
        - contao/news-bundle[4.13.0, ..., 4.13.10] require symfony/yaml ^5.4 -> satisfiable by symfony/yaml[v5.4.0, ..., v5.4.12].
        - Conclusion: don't install symfony/yaml v5.4.12 (conflict analysis result)
        - Root composer.json requires contao/news-bundle 4.13.* -> satisfiable by contao/news-bundle[4.13.0, ..., 4.13.10].
    
    Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.
    [130.5MiB/8.28s] Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.
    [38.6MiB/8.38s] Memory usage: 38.6MB (peak: 177.76MB), time: 8.39s.
    [38.6MiB/8.39s] Finished Composer Cloud resolving.
    
    
    # Cloud Job ID nOg7K2r2LwHhPJHXxuTJcIMIJ7y9FlD6apz1co2qK8S9PBqvY51zOzTP0JPhgEjTMXdJnlm2jTgm2oKNvs2AIzJu7GZRU7dBYbXXmv4Qn failed
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  8. #8
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    30.707
    Partner-ID
    10107

    Standard

    Wie die Meldung schon sagt musst du
    Code:
        "require-dev": {
            "sensiolabs/security-checker": "^4.1"
        },
    entfernen.
    » sponsor me via GitHub or PayPal or Revolut

  9. #9
    Alter Contao-Hase Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    1.278

    Standard

    Da ich die Konsolenmeldung nicht verstehe, kann ich das so nicht rauslesen, sorry!

    Soll ich den Eintrag einfach aus der composer.json löschen?
    Oder muß ich eine Erweiterung entfernen?

    Grüße
    Jochen
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  10. #10
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    30.707
    Partner-ID
    10107

    Standard

    Einfach das erwähnte löschen. Dann wieder eine vollständige Paketaktualisierung durchführen.
    » sponsor me via GitHub or PayPal or Revolut

  11. #11
    Alter Contao-Hase Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    1.278

    Standard

    Woher kann der Eintrag kommen?
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  12. #12
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    30.707
    Partner-ID
    10107

    Standard

    Soweit ich mich erinnere war das in älteren Contao Versionen mal drin.
    » sponsor me via GitHub or PayPal or Revolut

  13. #13
    Alter Contao-Hase Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    1.278

    Standard

    Das hat suuper geklappt, vielen Dank spooky!


    Was kann ich machen, wenn der Composer sich nicht von selbst beendet?


    Grüße
    Jochen
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •