Results 1 to 8 of 8

Thread: Newsletter and InsertTags

  1. #1
    User zlobec's Avatar
    Join Date
    02-14-14.
    Posts
    34

    Default Newsletter and InsertTags

    I'm customising the native newsletter and I have problems with the InsertTags. I'm trying to insert modules and some modules decode ok, but some dont. Especially those from the calendar module.

    I'm using this insertTags like this:

    Code:
    {{insert_content::36|decodeEntries}}
    and
    {{insert_module::13|decodeEntries}}
    On the class side, I'm converting them back with the

    Code:
     $this->replaceInsertTags
    But some work, some dont... strange... Any ideas why?

  2. #2
    User Andreas's Avatar
    Join Date
    07-11-09.
    Location
    Mönchengladbach
    Posts
    485

    Default

    Did you try with the $blnCache parameter?
    PHP Code:
    $this->replaceInsertTags('{{insert_content::36}}'false); 
    ps There is no flag "decodeEntries"
    Web-Development, Freelancer, Burgtech, XHTML, HTML5, CSS, PHP, Javascript, MooTools, MySQL and more
    Amazon wishlist

  3. #3
    User zlobec's Avatar
    Join Date
    02-14-14.
    Posts
    34

    Default

    Yes, i'm replacing the tags with the $blnCache parameter. It only works on the html type modules... eventlist, calendar or other it does not work. Is it possible this is by design for newsletter module only?

    Yeah, thanks for the mistype for decodeEntities I code mostly nights

  4. #4
    User Andreas's Avatar
    Join Date
    07-11-09.
    Location
    Mönchengladbach
    Posts
    485

    Default

    I tested it on Contao 3.4. Put {{insert_content::317}} into the newsletter. The ID is the ID of an event content element, not the ID of the event itself. Sent a test newsletter and it worked, without doing something with $this->replaceInsertTags() in a class.
    Web-Development, Freelancer, Burgtech, XHTML, HTML5, CSS, PHP, Javascript, MooTools, MySQL and more
    Amazon wishlist

  5. #5
    User zlobec's Avatar
    Join Date
    02-14-14.
    Posts
    34

    Default

    I'll try later today.. I'm using the 3.2.14 version.

  6. #6
    User Andreas's Avatar
    Join Date
    07-11-09.
    Location
    Mönchengladbach
    Posts
    485

    Default

    My test in 3.2.14 was also ok.
    Web-Development, Freelancer, Burgtech, XHTML, HTML5, CSS, PHP, Javascript, MooTools, MySQL and more
    Amazon wishlist

  7. #7
    User zlobec's Avatar
    Join Date
    02-14-14.
    Posts
    34

    Default

    Thanks Andreas,

    I had a small bug in my fixes to the newsletter module. Fixed it and now it works.

    Regard.

  8. #8
    User Andreas's Avatar
    Join Date
    07-11-09.
    Location
    Mönchengladbach
    Posts
    485

    Default

    Nice. And please update to 3.2.16 for security reasons.
    Web-Development, Freelancer, Burgtech, XHTML, HTML5, CSS, PHP, Javascript, MooTools, MySQL and more
    Amazon wishlist

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •