Results 1 to 12 of 12

Thread: Composer 503 message when updating package

  1. #1
    User
    Join Date
    08-04-09.
    Posts
    230

    Default Composer 503 message when updating package

    I am trying to install changelanguage in the composer.
    When I try to update the package i get a 503 message.

    I have already updated composer (deleting composer.phar and updating composer)
    Altered composer.json stability to stable (instead of dev)

    Also I have tried to install other modules without luck.

    I standard get a 503 service unavailable message.

    My internet speed is 175 Mbps download, so no problems there.

    What could be the case? And... if I cannot get composer to work, is there another way to install changelanguage?

  2. #2
    Community-Moderator xchs's Avatar
    Join Date
    06-19-09.
    Posts
    1,278

    Default

    Quote Originally Posted by lostrisq View Post
    is there another way to install changelanguage?
    If you have shell access you can require the module via
    Code:
    composer require terminal42/contao-changelanguage
    or
    Code:
    php composer.phar require terminal42/contao-changelanguage
    or
    Code:
    php contao-manager.phar.php composer require terminal42/contao-changelanguage
    Last edited by xchs; 09/05/2017 at 17:08.
    Contao Community Moderator
    → Support options

  3. #3
    User
    Join Date
    08-04-09.
    Posts
    230

    Default

    Thank you for your help.

    Unfortunately I do not have shell access.

    Is this a more common issue, this 503 message upon installing?

  4. #4
    Community-Moderator xchs's Avatar
    Join Date
    06-19-09.
    Posts
    1,278

    Default

    What are the server limits (PHP memory_limit and max_execution_time)? It could well be that the process runs into a timeout.
    Contao Community Moderator
    → Support options

  5. #5
    User Andreas's Avatar
    Join Date
    07-11-09.
    Location
    Mönchengladbach
    Posts
    495

    Default

    Contao 3 or 4? If you are on 4 you can try the install with the Contao Manager and then try it with PHP 7. If your're already on 4 with the manager and change to PHP 7, don't forget to change this line in
    Code:
    _c4_cm/contao-manager/manager.json
    from
    Code:
    "php_cli": "\/usr\/bin\/php56",
    to
    Code:
    "php_cli": "\/usr\/bin\/php70",
    to assume that this is your path to the executable.
    Web-Development, Freelancer, Burgtech, XHTML, HTML5, CSS, PHP, Javascript, MooTools, MySQL and more
    Amazon wishlist

  6. #6
    User
    Join Date
    08-04-09.
    Posts
    230

    Default

    I am running contao 3.5.28

    Max execution is 30 seconds and the limit is 256 mb

  7. #7
    User Spooky's Avatar
    Join Date
    01-03-13.
    Posts
    339

    Default

    You should use the detached mode. See https://github.com/contao-community-...ocess-detached for more information.

  8. #8
    User
    Join Date
    08-04-09.
    Posts
    230

    Default

    Is there someone here who can help me out? I am willing to pay for it, would really like it settled and I can't seem to get it....

  9. #9
    User Spooky's Avatar
    Join Date
    01-03-13.
    Posts
    339

    Default

    Did you read the Wiki entry?

  10. #10
    User
    Join Date
    08-04-09.
    Posts
    230

    Default

    Well yes... And i have been fiddling around with it, but i do not seem to get it.

    I have tried every option under execution mode (in the HTTP request / as sub process of the web server proces / as standalone proces)

    I have altered the PHP path /command to: /usr/bin/env php -d memory_limit=3G -d max_execution_time=9000 and
    also tried: /usr/bin/php5.6

    When i try to add

    Code:
    "platform": {
        "php": "5.6"
    }
    to composer.json i get an error.

    I feel a bit silly now... it is probably real easy.

  11. #11
    New user
    Join Date
    12-01-09.
    Posts
    2

    Default

    Works for me. Thanks a lot Spooky!

  12. #12
    User
    Join Date
    08-04-09.
    Posts
    230

    Default

    Did you encounter the same problem vuk?

    I still do not seem to be able to solve it.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •