Results 1 to 9 of 9

Thread: contao 4... everything from scratch...

  1. #1
    User
    Join Date
    05-02-10.
    Posts
    121

    Unglücklich contao 4... everything from scratch...

    can't add contao/official-demo package ...

    Code:
    $ D:^\myserver^\eds-binaries^\php^\php713vc14x86x190314220302^\php.exe "-q" "D:/myserver/eds-www/web/contao-manager.phar.php" "composer" "require" "contao/official-demo" "--no-suggest" "--no-update" "--no-scripts" "--prefer-stable" "--sort-packages" "--no-ansi" "--no-interaction" 2>&1
    
    Using version ^4.2 for contao/official-demo
    D:/myserver/eds-www\composer.json has been updated
    
    Process terminated with exit code 0
    Result: OK
    $ D:^\myserver^\eds-binaries^\php^\php713vc14x86x190314220302^\php.exe "-q" "D:/myserver/eds-www/web/contao-manager.phar.php" "composer" "update" "contao/official-demo" "--with-dependencies" "--prefer-dist" "--no-dev" "--no-progress" "--no-suggest" "--no-ansi" "--no-interaction" "--optimize-autoloader" 2>&1
    
    Loading composer repositories with package information
    Updating dependencies
    Your requirements could not be resolved to an installable set of packages.
    
    Problem 1
    - Conclusion: don't install contao/official-demo 4.2.2
    - Conclusion: don't install contao/official-demo 4.2.1
    - Conclusion: remove contao-components/contao 7.1.5
    - Installation request for contao/official-demo ^4.2 -> satisfiable by contao/official-demo[4.2.0, 4.2.1, 4.2.2].
    - Conclusion: don't install contao-components/contao 7.1.5
    - contao/official-demo 4.2.0 requires contao/core-bundle ~4.6.3 -> satisfiable by contao/core-bundle[4.6.10, 4.6.11, 4.6.12, 4.6.13, 4.6.14, 4.6.3, 4.6.4, 4.6.5, 4.6.6, 4.6.7, 4.6.8, 4.6.9].
    - contao/core-bundle 4.6.10 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.11 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.12 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.13 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.14 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.3 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.4 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.5 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.6 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.7 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.8 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.9 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - Can only install one of: contao-components/contao[8.0.0, 7.1.5].
    - Can only install one of: contao-components/contao[8.0.1, 7.1.5].
    - Can only install one of: contao-components/contao[8.0.2, 7.1.5].
    - Can only install one of: contao-components/contao[8.0.3, 7.1.5].
    - Installation request for contao-components/contao (locked at 7.1.5) -> satisfiable by contao-components/contao[7.1.5].
    
    Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.
    
    Process terminated with exit code 2
    Result: Misuse of shell builtins
    Code:
    Resolving dependencies using Composer Cloud v2.0.5
    
    [369.9MiB/5.71s] Loading composer repositories with package information
    [370.1MiB/5.80s] Updating dependencies
    [1979.0MiB/45.86s] Your requirements could not be resolved to an installable set of packages.
    [1979.0MiB/45.90s]
    Problem 1
    - Conclusion: don't install contao/official-demo 4.2.2
    - Conclusion: don't install contao/official-demo 4.2.1
    - Installation request for contao/official-demo ^4.2 -> satisfiable by contao/official-demo[4.2.0, 4.2.1, 4.2.2].
    - Conclusion: don't install contao-components/contao 7.1.5
    - contao/official-demo 4.2.0 requires contao/core-bundle ~4.6.3 -> satisfiable by contao/core-bundle[4.6.10, 4.6.11, 4.6.12, 4.6.13, 4.6.14, 4.6.3, 4.6.4, 4.6.5, 4.6.6, 4.6.7, 4.6.8, 4.6.9].
    - contao/core-bundle 4.6.10 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.11 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.12 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.13 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.14 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.3 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.4 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.5 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.6 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.7 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.8 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.6.9 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - Can only install one of: contao-components/contao[8.0.0, 7.1.5].
    - Can only install one of: contao-components/contao[8.0.1, 7.1.5].
    - Can only install one of: contao-components/contao[8.0.2, 7.1.5].
    - Can only install one of: contao-components/contao[8.0.3, 7.1.5].
    - Installation request for contao-components/contao (locked at 7.1.5) -> satisfiable by contao-components/contao[7.1.5].
    
    [1979.0MiB/45.90s] Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.
    [646.7MiB/55.33s] Memory usage: 646.72MB (peak: 2117.09MB), time: 55.34s.
    [646.7MiB/55.34s] Finished Composer Cloud resolving.
    Last edited by Energetik; 03/15/2019 at 08:05.
    sorry for my english

  2. #2
    User Spooky's Avatar
    Join Date
    01-03-13.
    Posts
    331

    Default

    As far as I can see, you need Contao >=4.6.4,<4.7 for the current version of the official demo.

  3. #3
    User
    Join Date
    05-02-10.
    Posts
    121

    Default

    Quote Originally Posted by Spooky View Post
    As far as I can see, you need Contao >=4.6.4,<4.7 for the current version of the official demo.
    now manually need to choose version?

    contao/official-demo 4.0.0 -> install ok
    sorry for my english

  4. #4
    User
    Join Date
    05-02-10.
    Posts
    121

    Default

    contao manager is slow and big monster))

    my notebook hardly maintains (intell i3, 6gb ram)
    sorry for my english

  5. #5
    User Spooky's Avatar
    Join Date
    01-03-13.
    Posts
    331

    Default

    Quote Originally Posted by Energetik View Post
    contao manager is slow and big monster))

    my notebook hardly maintains (intell i3, 6gb ram)
    This seems unrelated to the current thread.

  6. #6
    User Spooky's Avatar
    Join Date
    01-03-13.
    Posts
    331

    Default

    Quote Originally Posted by Energetik View Post
    now manually need to choose version?

    contao/official-demo 4.0.0 -> install ok
    If you are trying to install it into Contao 4.4, then yes, you need to choose "4.0.*" as the version requirement.

  7. #7
    User
    Join Date
    05-02-10.
    Posts
    121

    Default

    ERROR 500 Malformed UTF-8 characters, possibly incorrectly encoded
    when instal other package
    D:\myserver\eds-www\contao-manager\composer-update.out.log:

    Code:
    Loading composer repositories with package information
    Updating dependencies
    
    VirtualAlloc() failed: [0x00000008] Ќедостаточно пам¤ти дл¤ обработки команды.
    
    
    VirtualAlloc() failed: [0x00000008] Ќедостаточно пам¤ти дл¤ обработки команды.
    
    PHP Fatal error:  Out of memory (allocated 884998144) (tried to allocate 117440512 bytes) in phar://D:/myserver/eds-www/web/contao-manager.phar.php/vendor/composer/composer/src/Composer/DependencyResolver/RuleSet.php on line 90
    not utf8 file

    https://github.com/contao/contao-manager/issues/410

    why Out of memory ?

    php memory_limit 1500M now
    sorry for my english

  8. #8
    User Spooky's Avatar
    Join Date
    01-03-13.
    Posts
    331

    Default

    You need to use the Cloud Resolver.

  9. #9
    User
    Join Date
    05-02-10.
    Posts
    121

    Default

    Quote Originally Posted by Spooky View Post
    You need to use the Cloud Resolver.
    thank you for your answers

    contao 3.5 the best of the best!! ))

    contao 4.x for geeks )) high threshold of entry (or high barrier to entry . I do not know how to properly in English)
    Last edited by Energetik; 03/15/2019 at 12:23.
    sorry for my english

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •