Results 1 to 11 of 11

Thread: Contao 4.4 Install Problems via Manager

  1. #1
    New user
    Join Date
    05-05-12.
    Posts
    29

    Default Contao 4.4 Install Problems via Manager

    Hi All,

    I followed the instructions to install Contao 4.4 via Manager and got the following error message:

    "You are using PHP 5.6.40 which is not supported by this Contao Manager. Automatic downgrade to version 1.1 was not successful. "

    Yet, when I looked up the system requirements for Contao 4.4, I found what's needed is PHP 5.6.0+ with GDlib, DOM, Phar and SOAP. Since my server is above the required PHP 5.6.0, why am I getting this error ? This is the closest I've gotten to actually loading up the Contao 4 version and I would sure like to succeed this time around.

    Thanks,

    ally1

  2. #2
    Community-Moderator xchs's Avatar
    Join Date
    06-20-09.
    Posts
    1,229

    Default

    You get this error because the newest version of the Contao Manager needs PHP 7.x. In any case, it would be no harm to switch to PHP 7.2 or 7.3 altogether, especially since PHP 5.6 has already reached its end-of-life.
    Last edited by xchs; 10/28/2019 at 20:12.
    Contao Community Moderator
    → Support options

  3. #3
    New user
    Join Date
    05-05-12.
    Posts
    29

    Default

    Thanks so much ! I was able to upgrade the PHP server version to 7.2 and Contao Manager is now working ! Unfortunately, I am now getting this error message:

    "PHP Web Process
    The PHP setting "allow_url_fopen" is not enabled on the server."

    How do I go about enabling the "allow_url_fopen" on my server ? I don't know where I would find this. Is it via my website's cpanel ?

    Thanks again for the help !

    ally1

  4. #4
    Community-Moderator xchs's Avatar
    Join Date
    06-20-09.
    Posts
    1,229

    Default

    Quote Originally Posted by ally1 View Post
    Is it via my website's cpanel ?
    Probably.

    Otherwise, just ask your hoster.
    Contao Community Moderator
    → Support options

  5. #5
    New user
    Join Date
    05-05-12.
    Posts
    29

    Default

    RE: PHP Version

    I was able to upgrade the PHP version from 5.6 to 7.2 via the cpanel using the MultiPHP Manager tool as well as making sure that "allow_url_fopen" is enabled yet I'm STILL getting following message:

    "PHP Web Process
    The PHP setting "allow_url_fopen" is not enabled on the server."

    I'm so close ! This is the closest I've gotten to actually installing Contao 4 via Contao Manager. Unfortunately, it just won't work. What's the next step ? How can I fix this ?

    Thanks,

    ally1

  6. #6
    Community-Moderator xchs's Avatar
    Join Date
    06-20-09.
    Posts
    1,229

    Default

    Can you confirm this by running phpinfo()?

    Is PHP 7.1 or PHP 7.3 available on your hosting environment? If yes, try to switch the PHP version to one of these versions, too.
    Contao Community Moderator
    → Support options

  7. #7
    New user
    Join Date
    05-05-12.
    Posts
    29

    Default

    Thanks for the quick response !

    PHP 7.2 is the only other version available on my server. Perhaps something else should be enabled beside "allow_url_fopen" ?

  8. #8
    Community-Moderator xchs's Avatar
    Join Date
    06-20-09.
    Posts
    1,229

    Default

    These are the system requirements to run the Contao Manager: https://docs.contao.org/manual/de/in...oraussetzungen

    • PHP extensions Intl and OpenSSL
    • PHP functions proc_open and proc_close
    • PHP setting allow_url_fopen enabled
    Last edited by xchs; 10/29/2019 at 12:22.
    Contao Community Moderator
    → Support options

  9. #9
    New user
    Join Date
    01-08-16.
    Posts
    11

    Default allow_url_fopen On

    The company that I am using for hosting tells me that there is no way I can change allow_url_fopen to "On" because of security issues. Is there a work around?

  10. #10
    Community-Moderator xchs's Avatar
    Join Date
    06-20-09.
    Posts
    1,229

    Default

    You can also install Contao without Contao Manager on the command line:

    Code:
    composer create-project contao/managed-edition target-dir/ 4.8
    Contao Community Moderator
    → Support options

  11. #11
    New user
    Join Date
    01-08-16.
    Posts
    11

    Default Command line

    Quote Originally Posted by xchs View Post
    You can also install Contao without Contao Manager on the command line:

    Code:
    composer create-project contao/managed-edition target-dir/ 4.8
    Sadly the hosting package does not give me command line access. An alternative hosting provider seems to be the only way forward.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •