Results 1 to 10 of 10

Thread: [solved] Install fails with Contao manager 1.2.7 in Contao 4.4.52

  1. #1
    User
    Join Date
    04-01-10.
    Posts
    271

    Default [solved] Install fails with Contao manager 1.2.7 in Contao 4.4.52

    Hello,
    Here is the result. What's wrong ? What can I do ?
    Thanks for help.

    Code:
    $ /usr/local/bin/php -q /home/baje7663/terea.lestock.net/web/contao-manager.phar.php composer require metamodels/core --no-suggest --no-update --no-scripts --prefer-stable --sort-packages --no-ansi --no-interaction  
    Using version ^2.1 for metamodels/core /home/baje7663/terea.lestock.net/composer.json has been updated  
    # Process terminated with exit code 0 
    # Result: OK
    
       > Resolving dependencies using Composer Cloud v2.4.3  [6.4MiB/0.47s] Loading composer repositories with package information [6.8MiB/0.54s] Updating dependencies [3172.1MiB/36.25s] 
    
    Your requirements could not be resolved to an installable set of packages. [3172.1MiB/36.26s]    
    
    Problem 1     
        - Conclusion: don't install metamodels/core 2.1.9     
        - Conclusion: don't install metamodels/core 2.1.8     
        - Conclusion: don't install metamodels/core 2.1.7     
        - Conclusion: don't install metamodels/core 2.1.6     
        - Conclusion: don't install metamodels/core 2.1.5     
        - Conclusion: don't install metamodels/core 2.1.4     
        - Conclusion: don't install metamodels/core 2.1.3     
        - Conclusion: don't install metamodels/core 2.1.2     
        - Conclusion: don't install metamodels/core 2.1.1     
        - Installation request for metamodels/core ^2.1 -> satisfiable by metamodels/core[2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.1.7, 2.1.8, 2.1.9].     
        - Conclusion: don't install menatwork/contao-multicolumnwizard 3.3.16     
        - metamodels/core 2.1.0 requires contao-community-alliance/dc-general ^2.1.0 -> satisfiable by contao-community-alliance/dc-general[2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.1.7].     
        - contao-community-alliance/dc-general 2.1.0 conflicts with menatwork/contao-multicolumnwizard[3.3.16].     
        - contao-community-alliance/dc-general 2.1.1 conflicts with menatwork/contao-multicolumnwizard[3.3.16].     
        - contao-community-alliance/dc-general 2.1.2 conflicts with menatwork/contao-multicolumnwizard[3.3.16].     
        - contao-community-alliance/dc-general 2.1.3 conflicts with menatwork/contao-multicolumnwizard[3.3.16].     
        - contao-community-alliance/dc-general 2.1.4 conflicts with menatwork/contao-multicolumnwizard[3.3.16].     
        - contao-community-alliance/dc-general 2.1.5 conflicts with menatwork/contao-multicolumnwizard[3.3.16].
         - contao-community-alliance/dc-general 2.1.6 conflicts with menatwork/contao-multicolumnwizard[3.3.16].
         - contao-community-alliance/dc-general 2.1.7 conflicts with menatwork/contao-multicolumnwizard[3.3.16].
         - Installation request for menatwork/contao-multicolumnwizard (locked at 3.3.16) -> satisfiable by menatwork/contao-multicolumnwizard[3.3.16].  [3172.1MiB/36.26s] <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning> [529.5MiB/38.74s] 
    Memory usage: 529.51MB (peak: 3172.87MB), time: 38.75s. [529.5MiB/38.75s] Finished Composer Cloud resolving.   # Cloud Job ID xJh3M3WSjBnFLrOjTjIlFhYZCzJ3mGG9HwC4Cw3hV0w78PnSZ8BcU8kqIEzoo0dBSajmnxajflBIVPKsWWjM7nWXyZlTt failed  ---  
    ### The background task has stopped unexpectedly ###
    Last edited by charled; 08/27/2020 at 11:49. Reason: Solved

  2. #2
    User zonky's Avatar
    Join Date
    11-29-11.
    Location
    Berlin
    Posts
    154

    Default

    The problem is your old MCW - it needs to be upgraded to a new version
    either perform update on the console or do the following in the manager:

    1. click the button "Update packages"
    2. select MM packages to install...
    3. button "Apply"
    Last edited by zonky; 08/27/2020 at 08:42.

  3. #3
    User
    Join Date
    04-01-10.
    Posts
    271

    Default

    Hello Zonky,
    I did it but it works no more. Here is the result :
    Code:
    $ /usr/local/bin/php -q /home/baje7663/terea.lestock.net/web/contao-manager.phar.php composer require metamodels/core --no-suggest --no-update --no-scripts --prefer-stable --sort-packages --no-ansi --no-interaction  Using version ^2.1 for metamodels/core /home/baje7663/terea.lestock.net/composer.json has been updated  # Process terminated with exit code 0 # Result: OK   > Resolving dependencies using Composer Cloud v2.4.3  [6.4MiB/0.24s] Loading composer repositories with package information [6.8MiB/0.29s] Updating dependencies [3116.4MiB/36.51s] Your requirements could not be resolved to an installable set of packages. [3116.4MiB/36.51s]    Problem 1     - Conclusion: don't install metamodels/core 2.1.9     - Conclusion: don't install metamodels/core 2.1.8     - Conclusion: don't install metamodels/core 2.1.7     - Conclusion: don't install metamodels/core 2.1.6     - Conclusion: don't install metamodels/core 2.1.5     - Conclusion: don't install metamodels/core 2.1.4     - Conclusion: don't install metamodels/core 2.1.3     - Conclusion: don't install metamodels/core 2.1.2     - Conclusion: don't install metamodels/core 2.1.1     - Installation request for metamodels/core ^2.1 -> satisfiable by metamodels/core[2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.1.7, 2.1.8, 2.1.9].     - Conclusion: don't install menatwork/contao-multicolumnwizard 3.3.16     - metamodels/core 2.1.0 requires contao-community-alliance/dc-general ^2.1.0 -> satisfiable by contao-community-alliance/dc-general[2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.1.7].     - contao-community-alliance/dc-general 2.1.0 conflicts with menatwork/contao-multicolumnwizard[3.3.16].     - contao-community-alliance/dc-general 2.1.1 conflicts with menatwork/contao-multicolumnwizard[3.3.16].     - contao-community-alliance/dc-general 2.1.2 conflicts with menatwork/contao-multicolumnwizard[3.3.16].     - contao-community-alliance/dc-general 2.1.3 conflicts with menatwork/contao-multicolumnwizard[3.3.16].     - contao-community-alliance/dc-general 2.1.4 conflicts with menatwork/contao-multicolumnwizard[3.3.16].     - contao-community-alliance/dc-general 2.1.5 conflicts with menatwork/contao-multicolumnwizard[3.3.16].     - contao-community-alliance/dc-general 2.1.6 conflicts with menatwork/contao-multicolumnwizard[3.3.16].     - contao-community-alliance/dc-general 2.1.7 conflicts with menatwork/contao-multicolumnwizard[3.3.16].     - Installation request for menatwork/contao-multicolumnwizard (locked at 3.3.16) -> satisfiable by menatwork/contao-multicolumnwizard[3.3.16].  [3116.4MiB/36.51s] <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning> [526.1MiB/38.67s] Memory usage: 526.06MB (peak: 3117.22MB), time: 38.68s. [526.1MiB/38.68s] Finished Composer Cloud resolving.   # Cloud Job ID 4SWeNvMacz2RirQPBBrfJKgtcv88XnKK3KPS62E5eOv4AnCvMGks1CHhonkNTUU1UPJIUyNusBYs7H0o7fL1yKAFEm1cbwDyC failed  ---  ### The background task has stopped unexpectedly ###

  4. #4
    User
    Join Date
    04-01-10.
    Posts
    271

    Beitrag Install fails in Contao 4.9.5 too

    I've updated Contao from 4.4 to 4.9. But MM still fails to install. Seems to be the same pb multicolumnwizard to old. How to update it from 3.3.16 to 3.4 (update all bundles doesn't work) ?

    Code:
    $ /usr/local/bin/php -q /home/baje7663/terea.lestock.net/web/contao-manager.phar.php composer require metamodels/core --no-suggest --no-update --no-scripts --prefer-stable --sort-packages --no-ansi --no-interaction
    
    Using version ^2.1 for metamodels/core
    /home/baje7663/terea.lestock.net/composer.json has been updated
    
    # Process terminated with exit code 0
    # Result: OK
    
    
    > Resolving dependencies using Composer Cloud v2.4.3
    
    [7.5MiB/0.21s] Loading composer repositories with package information
    [7.9MiB/0.36s] Updating dependencies
    [2319.7MiB/30.78s] Your requirements could not be resolved to an installable set of packages.
    [2319.7MiB/30.79s] 
      Problem 1
        - Conclusion: don't install metamodels/core 2.1.9
        - Conclusion: don't install metamodels/core 2.1.8
        - Conclusion: don't install metamodels/core 2.1.7
        - Conclusion: don't install metamodels/core 2.1.6
        - Conclusion: don't install metamodels/core 2.1.5
        - Conclusion: don't install metamodels/core 2.1.4
        - Conclusion: don't install metamodels/core 2.1.3
        - Conclusion: don't install metamodels/core 2.1.2
        - Conclusion: don't install metamodels/core 2.1.1
        - Installation request for metamodels/core ^2.1 -> satisfiable by metamodels/core[2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.1.7, 2.1.8, 2.1.9].
        - Conclusion: don't install menatwork/contao-multicolumnwizard 3.3.16
        - metamodels/core 2.1.0 requires contao-community-alliance/dc-general ^2.1.0 -> satisfiable by contao-community-alliance/dc-general[2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.1.7].
        - contao-community-alliance/dc-general 2.1.0 conflicts with menatwork/contao-multicolumnwizard[3.3.16].
        - contao-community-alliance/dc-general 2.1.1 conflicts with menatwork/contao-multicolumnwizard[3.3.16].
        - contao-community-alliance/dc-general 2.1.2 conflicts with menatwork/contao-multicolumnwizard[3.3.16].
        - contao-community-alliance/dc-general 2.1.3 conflicts with menatwork/contao-multicolumnwizard[3.3.16].
        - contao-community-alliance/dc-general 2.1.4 conflicts with menatwork/contao-multicolumnwizard[3.3.16].
        - contao-community-alliance/dc-general 2.1.5 conflicts with menatwork/contao-multicolumnwizard[3.3.16].
        - contao-community-alliance/dc-general 2.1.6 conflicts with menatwork/contao-multicolumnwizard[3.3.16].
        - contao-community-alliance/dc-general 2.1.7 conflicts with menatwork/contao-multicolumnwizard[3.3.16].
        - Installation request for menatwork/contao-multicolumnwizard (locked at 3.3.16) -> satisfiable by menatwork/contao-multicolumnwizard[3.3.16].
    
    [2319.7MiB/30.80s] <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning>
    [465.6MiB/32.40s] Memory usage: 465.61MB (peak: 2320.6MB), time: 32.4s.
    [465.6MiB/32.40s] Finished Composer Cloud resolving.
    
    
    # Cloud Job ID 9SGUNxMerjBoyXm2avugn7Mo7FDbz5t18SiDTZ6EfV8DZhK1Iwd1ITZYoA4Vut0KKxTtAxOpKN2TJwSgjvX4P failed
    
    ---
    
    ### The background task has stopped unexpectedly ###

  5. #5
    User zonky's Avatar
    Join Date
    11-29-11.
    Location
    Berlin
    Posts
    154

    Default

    Quote Originally Posted by charled View Post
    I've updated Contao from 4.4 to 4.9.
    for Contao 4.9 work MM 2.2 - see https://now.metamodel.me/en/supporters/fundraising


    take my manual again or do the one update via console

  6. #6
    User
    Join Date
    04-01-10.
    Posts
    271

    Default

    Here is the answer when I update all packages. How can I update via console (I'm on a shared hosting) ? Or can I manually edit composer.json file ?
    Thanks.


    [CODE]> Resolving dependencies using Composer Cloud v2.4.3

    # Job ID FdPp8nbCzbt72BnI4HItKCASxF4I1XFXOK9uJvxzlQidWdJmDP 9RggbcHw0mZTHeMZJuVyVi completed in 67 seconds
    # Memory usage: 518.69MB (peak: 3102.55MB), time: 65.96s.

    $ /usr/local/bin/php -q /home/baje7663/terea.lestock.net/web/contao-manager.phar.php composer install --prefer-dist --no-dev --no-progress --no-suggest --no-ansi --no-interaction --optimize-autoloader

    ocramius/package-versions: Generating version class...
    ocramius/package-versions: ...done generating version class
    contao/manager-plugin: Generating plugin class...
    contao/manager-plugin: ...done generating plugin class

    // Clearing the cache for the prod environment with debug
    // false

    [OK] Cache for the "prod" environment (debug=false) was successfully cleared.


    // Warming up the cache for the prod environment with debug
    // false

    [OK] Cache for the "prod" environment (debug=false) was successfully warmed.


    Trying to install assets as relative symbolic links.

    --- ---------------------------------- ------------------
    Bundle Method / Error
    --- ---------------------------------- ------------------
    ✔ ContaoCoreBundle relative symlink
    ✔ ContaoFaqBundle relative symlink
    ✔ ContaoNewsBundle relative symlink
    ✔ ContaoNewsletterBundle relative symlink
    ✔ MarkocupicImportFromCsvBundle relative symlink
    ✔ LeafletGeocodeWidgetBundle relative symlink
    ✔ TrilobitCookiebarBundle relative symlink
    ✔ AgoatCustomContentElementsBundle relative symlink
    ✔ ContaoCalendarBundle relative symlink
    ✔ ContaoCommentsBundle relative symlink
    ✔ NetzmachtContaoLeafletBundle relative symlink
    --- ---------------------------------- ------------------

    [OK] All assets were successfully installed.

    Added the system/initialize.php file.
    Symlinked the system/config/tcpdf.php file.

    --- ------------------------------------------- ----------------------------------------------------------------
    Symlink Target / Error
    --- ------------------------------------------- ----------------------------------------------------------------
    ✔ web/files/css files/css
    ✔ web/system/modules/changelanguage/assets system/modules/changelanguage/assets
    ✔ web/system/modules/haste/assets system/modules/haste/assets
    ✔ web/system/modules/multicolumnwizard/html system/modules/multicolumnwizard/html
    ✔ system/themes/flexible vendor/contao/core-bundle/src/Resources/contao/themes/flexible
    ✔ web/assets assets
    ✔ web/system/themes system/themes
    ✔ system/logs var/logs
    --- ------------------------------------------- ----------------------------------------------------------------

    Loading composer repositories with package information
    Installing dependencies from lock file
    Package operations: 0 installs, 2 updates, 0 removals
    - Updating scssphp/scssphp (1.1.1 => 1.2): As there is no 'unzip' command installed zip files are being unpacked using the PHP zip extension.
    This may cause invalid reports of corrupted archives. Besides, any UNIX permissions (e.g. executable) defined in the archives will be lost.
    Installing 'unzip' may remediate them.
    Downloading (100%)
    - Updating netzmacht/contao-toolkit (3.4.2 => 3.4.3): Downloading (100%)
    Package oyejorge/less.php is abandoned, you should avoid using it. No replacement was suggested.
    Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.
    Package sensio/distribution-bundle is abandoned, you should avoid using it. No replacement was suggested.
    Generating optimized autoload files
    30 packages you are using are looking for funding.
    Use the `composer fund` command to find out more!
    > Contao\ManagerBundle\Composer\ScriptHandler::initi alizeApplication

    # Process terminated with exit code 0
    # Result: OK


    ---

    ### Task completed successfully ###/CODE]

  7. #7
    User zonky's Avatar
    Join Date
    11-29-11.
    Location
    Berlin
    Posts
    154

    Default

    Quote Originally Posted by charled View Post
    A: Here is the answer when I update all packages.
    B: How can I update via console (I'm on a shared hosting)
    A: see #2 and follow the 3 points
    B: connect with SSH and work on console, you can make a composer update local and run composer install aon server

    C: deinstall in manager all packages without Contao Bundles - install MetaModels and after then all reinstall other bundles
    Last edited by zonky; 08/27/2020 at 08:57.

  8. #8
    User
    Join Date
    04-01-10.
    Posts
    271

    Hi,

    A - I dit it many times but it didn't work.
    B. I would have to learn how this works… ;-)
    C - Fortunately, this one worked. I could install MM first, then SyncCto (both are a little capricious…) then all others.

    Thanks

  9. #9
    User zonky's Avatar
    Join Date
    11-29-11.
    Location
    Berlin
    Posts
    154

    Default

    the blocking is not caused by MM but by the manager or other extensions that are not updated

  10. #10
    User
    Join Date
    04-01-10.
    Posts
    271

    Default

    That's what I understood.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •