Results 1 to 6 of 6

Thread: Help for beginners

  1. #1
    New user
    Join Date
    02-09-11.
    Posts
    5

    Default Help for beginners

    Greetings from the old user and returnee to the contao system.

    After three days of installing and setting up the server, I was able to make a basic configuration to make everything work properly.
    (Contao Manager 1.4.6 and LTS Contao Version 4.9.20)

    However, I still have problems and if someone is in the mood, give me some advice.

    for example when I try to install Mate theme i get this error:

    - contao-themes-net/mate-theme-bundle[2.17.0, ..., 2.17.1] require contao-themes-net/material-icons-inserttag ^1.0 -> satisfiable by contao-themes-net/material-icons-inserttag[1.0.0, 1.0.1, 1.0.2].
    - contao-themes-net/material-icons-inserttag[1.0.0, ..., 1.0.2] require php ^5.6 || ^7.0 -> your php version (8.0.10.0) does not satisfy that requirement.
    - Root composer.json requires contao-themes-net/mate-theme-bundle ^2.17 -> satisfiable by contao-themes-net/mate-theme-bundle[2.17.0, 2.17.1].

    and when i try to install MetaModels core

    - metamodels/core[1.0.0, ..., 1.0.16] require contao/core ~2.11 -> satisfiable by contao/core[2.11.0, ..., 2.11.17].
    - contao/core[2.11.0, ..., 2.11.17] require contao-community-alliance/composer-plugin ~2.0 -> satisfiable by contao-community-alliance/composer-plugin[2.0.0, ..., 2.4.3].
    - contao-community-alliance/composer-plugin[2.0.0, ..., 2.3.3] require composer-plugin-api 1.0.0 -> found composer-plugin-api[2.1.0] but it does not match the constraint.
    - contao-community-alliance/composer-plugin[2.3.4, ..., 2.4.3] require composer-plugin-api ^1.0 -> found composer-plugin-api[2.1.0] but it does not match the constraint.
    - Root composer.json requires metamodels/core ^1.0 -> satisfiable by metamodels/core[1.0.0, ..., 1.0.16].


    Is there any way to get around all these conditions, and how?

    Thanks

  2. #2
    Community-Moderator xchs's Avatar
    Join Date
    06-20-09.
    Posts
    1,284

    Default

    Hi, try to switch to PHP 7.4.
    Contao Community Moderator
    → Support options

  3. #3
    New user
    Join Date
    02-09-11.
    Posts
    5

    Default

    Thanks for advice.
    I have installed several versions of php on the servers, 5.6, 7.1, 7.3 and 8.0
    I haven't tried with 7.4, but I have with 7.1 and 7.3 ... and do not work...

    I don't believe it will work with 7.4, but I can try though it takes time to compile apache with new php settings

  4. #4
    Community-Moderator xchs's Avatar
    Join Date
    06-20-09.
    Posts
    1,284

    Default

    It should work with PHP 7.3, too. I have mentioned PHP 7.4 because the other versions are now deprecated.

    I haven't tried with 7.4, but I have with 7.1 and 7.3 ... and do not work...
    "Do not work" means what? What was the console output or the error message?
    Contao Community Moderator
    → Support options

  5. #5
    New user
    Join Date
    02-09-11.
    Posts
    5

    Default

    Quote Originally Posted by xchs View Post
    It should work with PHP 7.3, too. I have mentioned PHP 7.4 because the other versions are now deprecated.


    "Do not work" means what? What was the console output or the error message?
    Hi xchs, and thanks for your help. Sorry I didn't describe the problem right away.
    With php version 7.3 the problems disappeared only when I deleted the complete account and re-created it. Anyway, it is possible to run the contao manager and install the themes,
    but when I said it doesn't work ... after the (any) theme is successfully installed I go to Contao install tool >> update database and I expect some values in "Import a template" drop down menu, but it is empty
    when I ftp to server and go to template directory i can see several .sql files in template directory.

    maybe I could import directly via the phpmyadmin application?

  6. #6
    New user
    Join Date
    02-09-11.
    Posts
    5

    Default

    I do manual import and everything works now, thanks.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •