Skocz do zawartości

Witamy na polskim forum Contao
Zarejestruj się teraz, aby skorzystać ze wszystkich funkcji forum. Kiedy się zalogujesz, będziesz mógł tworzyć tematy, pisać posty, rozdawać punkty reputacji, korzystać z prywatnych wiadomości i zarządzać swoim profilem. Jeśli posiadasz już konto, zaloguj się - w przeciwnym wypadku zarejestruj się już teraz!
Zdjęcie

4.4.47 - rozpadły się linki do plików


  • Zaloguj się, aby dodać odpowiedź
5 odpowiedzi w tym temacie

#1
h2o

h2o

    Doświadczony

  • Zarejestrowani
  • PipPipPip
  • 97 postów

Cześć!

Nie wiem co jest grane, ale nie da się wstawić linku do dokumentu. Otwiera się filemanager, przełączam na pliki, wybieram plik i po zapisaniu mam odwołanie do strony głównej. Musze wejść na frontend, znaleźć plik, skopiować url pliku i dopiero wklejam do edytora. Ktoś coś widział, słyszał, jakiś pomysł? PHP7.3


  • 0

#2
Kamil

Kamil

    Contao ambassador

  • Administratorzy
  • 1 538 postów
  • Strona www:zobacz
  • LokalizacjaLidzbark Warminski

Pierwsze słyszę o czymś takim, ale możesz spróbować:

 

1. Sprawdzić logi w /var/logs/prod-xxx.log czy nie ma jakichś błędów.

2. Spróbować innej przeglądarki (może jakieś dane sesji / ciasteczka przeszkadzają).

3. Spróbować w profilu (prawy górny róg backendu) wyczyścić dane sesji.

4. Zsynchronizować pliki w menedżerze plików (opcja na samej górze).


  • 0

Codefog - Contao web development


#3
h2o

h2o

    Doświadczony

  • Zarejestrowani
  • PipPipPip
  • 97 postów

próbowałem wszystkiego. Od po prostu nie tworzy tych linków, dlatego ich nie ma. Do logów zajrzę, jak coś znajdę, to podeślę.


  • 0

#4
h2o

h2o

    Doświadczony

  • Zarejestrowani
  • PipPipPip
  • 97 postów

Tworzy sie coś takiego - 23c28e7a-c499-54c5-b911-c3a4c59f4900 - jak klikam w link na stronie, to skacze do głównej. To samo pod 4.9.1.


  • 0

#5
Kamil

Kamil

    Contao ambassador

  • Administratorzy
  • 1 538 postów
  • Strona www:zobacz
  • LokalizacjaLidzbark Warminski

Jest to wewnętrzne UUID pliku w Contao. W jakim module i dla jakiego konkretnie pola ci się to dzieje?


  • 0

Codefog - Contao web development


#6
h2o

h2o

    Doświadczony

  • Zarejestrowani
  • PipPipPip
  • 97 postów

Dzieje się tak w module NEWS, tworzy UUID ale kliknięcie w link wrzuca na główną. No i teraz ciekawostka, zrobiłem to samo w module ARTICLES. Tak wygląda UUID po wskazaniu pliku jako link

 

{{file::1897ad6d-6a0a-11ea-b13e-e41f136d3830}}, który zamienia się w URL po zapisaniu strony. Zrobiłem ponownie próbę w module NEWS i jest tak: inny załącznik w PDF dodał się prawidłowo, a ten na którym mi zależy - nie chce się podłączyć. Po zapisaniu strony zamiast URLa do dokumentu, jest 'c59ac3a1-c29b-c289-5364-11c48dc2ad7a'. Folder w którym leży plik PDF jest publiczny. Powtórzyłem na koniec próbę w module Articles z tym samym opornym plikiem oraz kilkoma innymi - bez zmian - nie działa.

 

Wcześniej odnosiłem się do 4.4.47 ale to samo mam na 4.9.2 do którego zmigrowałem stronę. Mogę jako hyperlink zalinkować tylko jeden plik z całego katalogu ;-O


  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych użytkowników