Seite 2 von 6 ErsteErste 1234 ... LetzteLetzte
Ergebnis 41 bis 80 von 228

Thema: [con4gis_maps] Offizieller Support-Thread

  1. #41
    Contao-Nutzer Avatar von thomaspahl
    Registriert seit
    06.02.2013.
    Ort
    Fleckeby, S-H
    Beiträge
    40

    Standard Google Maps hakt / Ebene blendet nicht aus

    Hallo Küstenschmiede,

    ich habe im Moment 2 Probleme, deren ich nicht Herr werde. con4gis_maps 1.1.3. in Contao 3.5.6, Neuinstallation (kein Upgrade von CFS-Maps). Nur die default Templates, auch keine CSS Eingriffe. Die Contao-üblichen jqueries sind eingebunden. Das Deaktivieren aller non-std Extensions hilft nicht.

    1. Wenn ich im Starboard Google Maps anklicke, kommen zwar alle POIs, aber nicht die Karte. Auswahl Satellitenkarte geht sofort, DANACH kommt auch die normale Karte (s.a. hier #35). Wenn ich Google Maps als einzige Basiskarte auswähle, komme ich nie an die Karte. Bewegen/Größe ändern der Karte hilft auch nicht. Browser: Firefox + IE11 unter Win7, Firefox unter Linux ebenso.
    Ich benutze CFS-Maps/con4gis schon länger, bei einer anderen Installation, die von CFS-Maps auf con4gis aktualisiert wurde, funktioniert Google Maps problemlos auf Anhieb.

    2. Ich habe einige Lokationen unter einer Ebene zusammengefasst. Das Deaktivieren der Ebene funktioniert aber nicht, weder im Starboard noch wenn ich die Ebene als deaktiviert starte - die zugehörigen Lokationen werden immer angezeigt.

    Bei Bedarf kann ich gerne einen Admin Zugang per PN frei schalten (ist noch Entwickungsversion).

    Ansonsten aber danke für diese tolle Erweiterung (und ihre Pflege)!

    Thomas

  2. #42
    Contao-Nutzer
    Registriert seit
    08.08.2013.
    Beiträge
    77

    Standard

    Mit Handbuch und einer Menge herumprobieren bin ich jetzt schon ziemlich weit gekommen. Derzeit lege ich ein Strukturelement mit "als Karte zeigen" für jeden Reisetagag an. Unter dieses Element kommen die Sehenswürdigkeiten als einzelne Geo-Koordinaten, sowie ein klm mit der Fahrtroute. Das funktioniert soweit blendend.

    Jetzt sind mir nur ein paar Kleinigkeiten aufgefallen:
    • im Starboard erscheint die klm-Ebene unter "Ebenen", die einzelnen Waypoints aber nicht. Nachdem ich bei einzelnen Geo-Koordinaten auch keine Option "Name der Ebene" habe vermute ich mal das ist Absicht?
    • in der Karte erscheint der Layer mit dem klm immer an oberster Stelle, und deckt die Waypoints dadurch teilweise ab - kanz egal wie die Reihung im Backend erfolgt. Ist das irgendwie beinflussbar?
    • Ich versuche als Sahnehäubchen Waypoints und Fließtext zu verbinden. Also per Klick auf einen Marker der Karte soll der Text an die entsprechende Stelle springen, und im Gegenzug beim Klick auf einen entsprechenden Link im Text, die Karte an die gewünschte Stelle zoomen. Punkt 2 ist natürlich außerhalb eures Plugins, da muss ich selbst eine Lösung finden, aber zum Anspringen von Textstellen wäre es eine hilfreiche Kleinigkeit wenn das Backend auch Anchor-Tags ohne Eingabe des kompletten URL unterstützen würde. Derzeit funktioniert das nur über {{env:ath}}{{env::request}}#anchorname.



    lg
    Clavis


    PS: Bei Punkt 1 kann ich mich meinem Vorposter anschließen - die Google-Straßenkarte und Terrain wird auch bei mir nicht geladen, Satellit funktioniert aber sofort. Allerdings kommt die Straßenkarte auch nicht nach dem umschalten.
    Geändert von clavis (30.03.2016 um 07:40 Uhr)

  3. #43
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Hallo Thomas,

    unser Schwerpunkt liegt bei OpenStreetMap Karten. Wir selbst nutzen keine Google Karten. Die Einbindung der Google-Karten über OpenLayers 3 ist leider auch nicht vollständig implementiert. OpenLayers 3 ist Basis von dem neuen con4gis-Maps 3. Was die Deaktivierung der Ebenen betrifft, kannst Du uns gerne mal die Zugangsdaten zur Verfügung stellen (z.B. über die info@). Da können wir bestimmt weiterhelfen.

    Mit besten Grüßen aus der Schmiede
    CoastFace
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  4. #44
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Hallo Clavis,

    wir haben ein paar Unterschiede in den verschiedenen con4gis-Maps Versionen. Wenn der "Name der Ebene" nicht zur Verfügung steht, kannst Du für die Waypoints auch eine Zwischenebene einziehene (Keine Lokation) und den Namen so vergeben. KML ist auch so ein Thema Wir nutzen für Touren GeoJSON. Wir können aber mal versuchen das Reihenfolge Problem bei uns nachzustellen. Bitte schick uns mal ein KML zum Testen. Das mit den Anchor-Tags werden wir bei Gelegenheit mal berücksichtigen.

    Mit besten Grüßen
    CoastFace
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  5. #45
    Contao-Nutzer
    Registriert seit
    08.08.2013.
    Beiträge
    77

    Standard

    Die Idee den Namen über eine leere Ebene einzuziehen ist natürlich pfiffig Habe das gerade probiert und es funktioniert tatsächlich.

    Ad klm: Ja, ich bin auch nur begrenzt begeistert davon, aber in Ermangelung eines GPS-fähigen Geräts auf Reisen, setze ich mich nach dem Urlaub einfach hin, und stelle jede Tagesetappe per Google Routenplaner nach. Das lässt sich danach bequem exportieren - aber leider nur als klm/kmz.
    Inzwischen - nachdem ich Dank des leeren Layers mehrere Ebenen anzeigen kann - hat sich gezeigt, dass offenbar immer die zuletzt aktivierte Ebene zuoberst gerendert wird. Wenn ich also einen Waypoint aus-, und wieder einschalte befindet er sich über dem klm. Aber in der Erstansicht liegt das klm (und damit die Fahrtroute) über allen anderen Ebenen.
    Ich hab zur Anschauung mal eine der klm-Routen hochgeladen.Prades - ille sur Tet.zip

    vielen Dank & lg
    Clavis

    PS: die derzeit aktuelle Version - also 1.1.3 - arbeitet aber mit OpenLayers 2, oder habe ich da etwas gründlich falsch verstanden?
    Geändert von clavis (01.04.2016 um 22:16 Uhr)

  6. #46
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Ja, die Version in der Contao Erweiterungsverwaltung arbeitet mit OpenLayers 2. Die neue Version con4gis-Maps3 ist noch in der Entwicklung (https://github.com/Kuestenschmiede/con4gis_maps3). Wir nutzen diese allerdings schon aktiv in vielen Projekten (z.B. auf mapcil.com) und werden in den nächsten Wochen auch einen ersten Release Candidate in die Erweiterungsverwaltung bringen.
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  7. #47
    Contao-Nutzer
    Registriert seit
    08.08.2013.
    Beiträge
    77

    Standard

    Ah! Das ist jetzt aber erfreulich. Nachdem ich die Karten ohnehin nur in einem Privatprojekt einsetze bin ich bei etwaigen Beta-Krankheiten recht entspannt Ich vermute aber mal die Version 3 erfordert eine Deinstallation der alten Version...

  8. #48
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Auf jeden Fall das Projekt erst einmal wegsichern
    Eine Deinstallation ist nicht erforderlich. Allerdings müssen ein paar Konfigurationsparameter erneut angepasst werden.

    Vorschlag:
    Du installierst das neue con4gis-Core 1.3. Danach entfernst Du con4gis_maps aus Deinem /system/modules Verzeichnis und ersetzt es Durch con4gis_maps3 (GitHub). Erst danach machst Du das Datenbank Update.

    Wichtig:
    con4gis-Maps3 ist noch in der Entwicklung und sollte mit der Contao LTS 3.5.x verwendet werden. Einige Funktionen, wie die Google-Karten, stehen noch nicht wieder zur Verfügung. Dafür lassen sich beispielsweise aber schicke Mapbox-Karten einbinden.
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  9. #49
    Contao-Nutzer
    Registriert seit
    08.08.2013.
    Beiträge
    77

    Standard

    Also ganz grundsätzlich hat das Update wunderbar funktioniert - sogar die Daten wurden sauber übernommen. Aber Karten werden jetzt nicht mehr angezeigt...
    Contao ist 3.5.8, con4gis-Core 1.3.0. Auch funktionieren sämtliche Einstellungen perfekt und werden auch im FE angezeigt, nur die Basiskarte, Lokationen und Ebenen zeigt er nicht an. Ein Versuch alle Daten zu löschen und neu anzulegen, sowie eine Karte ohne Lokationen zu zeigen hat auch keinen Effekt.
    Der Abbruch erfolgt offenbar in der c4g-maps-proxy.js in Zeile 661 wo er in .fail springt (also dort wird natürlich nur die Warnung ausgeworfen, wo der Eigentliche Fehler auftritt konnte ich nicht herausfinden).

    lg
    Clavis

  10. #50
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Bitte mal eine andere Basiskarte konfigurieren und im Profil ggf. neu zuordnen. Der Fehler tritt beim Laden der Basiskarte auf.
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  11. #51
    Contao-Nutzer
    Registriert seit
    08.08.2013.
    Beiträge
    77

    Standard

    Ich habe bereits sämtliche Daten (so viele waren es ja noch nicht) gelöscht und von Grund auf neu angelegt. Das macht keinen Unterschied.
    Interessanterweise ändert sich auch beim Umschalten des Themes in den Profilen (die Steuerelemente sehe ich ja) nichts an deren aussehen.

  12. #52
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Hallo Clavis,

    der neue Theme-Mechanismus ist noch nicht fertig. Auf GitHub in der ReadMe siehst Du die bereits vorhandenen Funktionen. Die Elemente lassen sich in Maps3, im Gegensatz zur Vorgängerversion, aber alle per CSS anpassen.

    Ist Dein Profil im Kartenstrukturelement (Karte) zugeordnet? Hast Du die Basiskarte im Karteninhaltselement (im Artikel) auch neu zugeordnet? Was für eine Basiskarte hast Du angelegt?

    Falls Du weiterhin nichts siehst, werde ich in den nächsten Tagen versuchen das nachzustellen. Oder gibt es eine Möglichkeit auf Deine Installation zu schauen?

    LG
    CoastFace
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  13. #53
    Contao-Nutzer Avatar von harley-rider
    Registriert seit
    08.07.2013.
    Ort
    Bern, CH
    Beiträge
    196

    Standard Diverse Probleme

    Beim Umstellen meiner HP bin ich auf euer Modul gestossen und zuerst begeistert.
    Nur hat sich das etwas gewendet.
    Einen ersten Versuch mit Angabe eine gpx-Datei konnte ich problemlos erstellen und die Karte inkl. Track war mit OSM sichtbar.
    Mittels einer GM Basiskarte wollte ich die Karte mittels GoogleMap anzeigen, es wurde aber nur der Track ohne Karte angezeigt (scheint aber ein bekanntes Problem zu sein)
    Nach Umstellung auf OSM kann ich nur einmal Zoomen, danach geht mit dem Zoom gar nichts mehr.
    Ich habe dann alle Komponenten nochmal gelöscht und mit dem Beispiel aus dem Handbuch eine erste einfacxhe Karte erstellt.
    Nun geht gar nichts mehr...
    Bei der Koordinatensuche wird keine Karte mehr angzeigt sondern 'Bing shaded' obwohl OSM als Defaut definiert ist.
    Karte kann dann aber trotzdem in einen Artikel eingebunden werden aber auch da ist 'nur bing shaded' und wird so nicht agezeigt.

    Ich habe eine lokale XAMPP Installation mit Contao 3.5.9
    Den Browsercache habe ich auch schon geleert aber es scheint dass das interne Standardprofil OSM zerschossen wurde....
    Hat mir jemand einen Tipp was ich weiter machen kann ?
    Geändert von harley-rider (07.04.2016 um 10:57 Uhr)

  14. #54
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Hallo harley-rider,

    welche con4gis-Core und welche con4gis-Maps Version hast Du installiert?

    Beste Grüße
    CoastFace
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  15. #55
    Contao-Nutzer Avatar von harley-rider
    Registriert seit
    08.07.2013.
    Ort
    Bern, CH
    Beiträge
    196

    Standard

    Hallo CoastFace

    Ich habe con4gis-Maps 1.1.3.9004 mit dem darin enthaltenen Core installiert

    Gruss
    HR

  16. #56
    Contao-Nutzer Avatar von eBlick
    Registriert seit
    01.04.2012.
    Ort
    Stuttgart
    Beiträge
    103
    User beschenken
    Wunschliste

    Standard Erste Mühen (V. 1.1.3:9004 aus ExtRep)

    Moin CoastFace,

    nach unserem Agenturtag Treffen habe ich mich mal deiner Karten-Erweiterung angenommen und kämpfe gerade mit den Einstellungen.

    Ich habe eine Karte auf Basis von Events erstellt:
    Basis: Openstreetmap - Deutschlandstil
    Struktur: internes Standardprofil
    Karten und Locationstil keine besonderheiten.
    Dennoch klappt die Zoomfunktion überhaupt nicht.
    Das Icon fürs Zoomen ist nicht vollständig und beim Klicken auf das + kann ich einmal Zoomen und anschließend reagiert die Funktion gar nicht mehr.
    Mit der Maus lässt sich auch gar nicht zoomen obwohl die Einstellung aktiviert ist.
    Hier ein Screenshot.

    Bildschirmfoto 2016-04-09 um 16.50.22.png

    Weiterhin plane ich, Mitglieder ebenfalls in einer Karte darzustellen. Gibt es diese Option bereits? Ich habe sie nicht gefunden.

    Dann möchte ich Events aus mehreren Eventarchiven in einer einzelnen Karte abbilden. Evtl. auch über das Starboard auswählbar. Ist das machbar?

    Vielen Dank
    Thomas
    Geändert von eBlick (09.04.2016 um 17:24 Uhr)

  17. #57
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Moin Thomas,

    schön von Dir zu lesen. Und ärgerlich, dass Du so einen holprigen Start in die con4gis Welt machst. Für mich sieht es so aus, als ob irgendetwas Deine Karte überlagert. Eventuell durch Layout- oder Kartengröße verursacht?

    Die Mitgliederkarte gibt es leider noch nicht. Da die Anfrage aber immer wieder mal kommt, habe ich die Umsetzung jetzt mit in die Planung gebracht.

    Die Termine in der Karte werden über das Strukturelement "Aus anderer Tabelle" integriert. Die "Events" sind da bereits voreingestellt. Aus meiner Sicht spricht nichts gegen mehrere Archive.

    In den letzten Monaten haben wir an der neuen Extension con4gis-Maps3 gearbeitet. In eigenen Projekten setzen wir schon lange nur noch dieses Modul ein. Die con4gis-Maps Version im ER wollen wir schnellstmöglich ablösen. Wenn alles gut geht bringen wir zur Contao Konferenz die con4gis-Maps 3.0rc1 in die Erweiterungsverwaltung. Den Entwicklungsstand findest Du auf GitHub. Termin- und Mitgliedereinträge versuchen wir noch mit reinzubringen.

    Beste Grüße aus Jever
    Matthias
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  18. #58
    Contao-Nutzer
    Registriert seit
    28.06.2016.
    Beiträge
    1

    Standard Seekarten anzeigen oder Seezeichen einblenden

    Moin Support,
    Ich versuche eine Karte für Segler und Motorbootfahrer für unsere Bucht auf unserer Homepage bereitzustellen.
    Wie kann ich Seezeichen, etc. einblenden?
    Wie kann ich Seekarten anzeigen?

    No presure!
    Gerhard

  19. #59
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Moin Gerhard,

    grundsätzlich sind die hier beschriebenen Informationen immer noch gültig:

    http://wiki.openseamap.org/wiki/De:OpenSeaMap_in_Website#Contao


    Du legst über Deine Basiskarte eine benutzerdefinierte Overlaykarte mit dem OpenSeaMap Tileserver für Seezeichen (Seamarks). Näheres findest Du hier:

    http://wiki.openseamap.org/wiki/Open...er#Tile_Server

    Andere Informationen kannst Du auch aus der OpenStreetMap-Datenbank über die Overpass-API abfragen (Kartenstrukturelement).

    Viel Spaß damit
    CoastFace
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  20. #60
    Contao-Nutzer
    Registriert seit
    07.07.2016.
    Ort
    Heusweiler
    Beiträge
    2

    Standard Karte wird nicht angezeigt

    Moin zusammen :-)

    Ich bin Conato-Neuling und habe mich direkt mal an die Anzeige einer Karte mit Eurer genialen Software gemacht. Allerdings komme ich damit nach einigen Stunden herumbastelns nicht weiter.
    Aktueller Stand: Mir werden im Frontend alle Kartensteuerungssymbole angezeigt, ich kann zoomen, Grid einblenden, die Übersichtskarte funktioniert, ich sehe die Deutschland-Karte auch in der Übersicht - allerdings bleibt die große Karte an sich weiß, und im Starboard habe ich zwar den Eintrag "Kartenauswahl", aber dort dreht sich dauerhaft nur ein Pfeil und es werden die drei Karten, die ich eingerichtet habe, nicht angezeigt.

    Was habe ich getan, um so weit zu kommen:
    Basiskarten: Drei Karten (OpenStreetMap, Bing und Mapbox) angelegt, Standardeinstellungen belassen, keine Overlay-Karten
    Lokationsstile: Keine
    Kartenthemen: Keine
    Kartenprofil angelegt, ein gemeinsames für alle drei Karten, mit con4gis Standard-Theme, als Standard definiert (alles, was ich hier einstelle wird auch angezeigt) und alle drei Karten mit Häkchen versehen
    Kartenstruktur: Angelegt, eigenes Kartenprofil, Veröffentlicht, Als Karte verwendet, Kartenstart mit Center und Zoom (funktioniert in Übersichtskarte), Rest Standard
    Theme: Standard-Theme mit Standardeinstellungen erstellt
    Templates: Keins
    Seitenstruktur: Seite angelegt, Knoten "Startseite" angelegt, leeren Artikel eingefügt, Element "Karte (con4gis) eingefügt

    Link zur Testseite auf Wunsch per PM.

    Konfiguration:
    Contao-Check 10.18: Alles grün
    Contao-Version 3.5.14
    con4gis_core 1.3.2
    con4gis_forum 1.4.1
    con4gis_groups 1.1.1
    con4gis_maps3 3.0.1
    con4gis_tracking 2.0.4
    con4gis_tracking_android 1.1.0
    MultiColumnWizard 3.3.3


    Irgendwo ist da ein Gedankenfehler - ein Tipp wäre hilfreich :-)

    Gruß

    Dirk
    Geändert von mobigis (07.07.2016 um 11:21 Uhr)

  21. #61
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Moin Dirk,

    bei MapBox und Bing gibt es keine Standardeinstellungen, da brauchst Du einen API-Key. Am Besten Du schmeißt die beiden Basiskarten erst einmal wieder raus. Falls das nicht weiterhilft, kannst Du mir gerne mal den Link zur Testseite schicken.

    Beste Grüße
    CoastFace
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  22. #62
    Contao-Nutzer
    Registriert seit
    07.07.2016.
    Ort
    Heusweiler
    Beiträge
    2

    Standard

    Hi :-)

    Zitat Zitat von CoastFace Beitrag anzeigen
    bei MapBox und Bing gibt es keine Standardeinstellungen, da brauchst Du einen API-Key.
    Ich habe für beide jeweils gültige API-Keys eingetragen, das sollte funktionieren :-)

    Link kommt per PM.

    Dirk

  23. #63
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Zur Info: das von mobigis beschriebene Problem, wurde durch nicht vorhandene PHP7-Kompatiblität ausgelöst und ist bereits im develop-Stand auf GitHub "gefixt". Eine neue Version in der Erweiterungsverwaltung wird in den nächsten Tagen bereitgestellt.
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  24. #64
    Contao-Nutzer
    Registriert seit
    08.07.2011.
    Ort
    Niedersachsen
    Beiträge
    50

    Standard Als Karte verwenden - falsche Position

    Hallo Zusammen,

    bei Kartenstruktur - als Karte verwenden - habe ich einzelne Koordinate ausgewählt und trage dort Längen- und Breitengrad ein. Die Karte selbst wird auch angezeigt - jedoch nicht an der Position die ich als Koordinate hinterlegt habe. Statt Raum Hannover schmeißt er mich vor die Küste Somalias ....

    Ich kann mir hier keinen Reim drauf machen. Die Koordinaten stimmen aber - habe das jetzt schon zig mal überprüft.

    Hat jemand eine Idee?

    Im Einsatz ist con4gis_maps3 unter Contao 3.5.14

    Edit: da sucht man ne Ewigkeit und dann sieht man endlich den Fehler. Problem gelöst: beim untergeordneten Strukturelement war ein Tippfehler. *narf*
    Geändert von lillena (25.07.2016 um 14:02 Uhr)

  25. #65
    Contao-Nutzer Avatar von wigraf
    Registriert seit
    24.10.2013.
    Ort
    Hamburg
    Beiträge
    15

    Standard Keine Karte auf meiner website

    Hallo, ich weiß nicht ob ich an dieser Stelle statt einer Antwort auch eine Hilfe erbeten kann. Aber ich versuche es.
    Auf meiner Website www.graffenberger.de habe ich unter dem Menupunkt Erweiterungen eine Seite Geografie angelegt.
    Dort möchte ich eine Karte zeigen mit der Adresse vom HSK Schachzentrum, und das gelingt mir absolut nicht.
    Dazu habe ich zunächst con4gis installiert und es steht auch unter Backend-Module der con4gis(Baukasten) zur
    Verfügung. Dann habe ich nach der Anleitung: "3.2.9 Erste Schritte - Der schnellste Weg zur ersten Karte" aus dem
    con4gis_compendium_version_3.o.pdf meine erste Karte erstellt. Diese habe ich auf der Seite Geografie meiner
    Website als Inhalltselement Karte (con4gis) gespeichert.
    Aber leider erscheint auch nach meheren Wiederholungen dieses Procedere nicht nur keine Karte auf der Seite,
    es wird auch noch in der Sidebar der Slider nicht mehr angezeigt.
    Auf der leeren Seite erhalte ich mit dem Firefox Werkzeug "Element untersuchen(Q)" folgende Anzeige:
    result_elementuntersuche(Q).PNG
    Kann mir da irgend jemand helfen und mir Tipps geben was ich falsch mache? Dafür wäre ich sehr dankbar.
    Mit freundlichen Grüßen, Wilhelm Graffenberger (wigraf)

  26. #66
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  27. #67
    Contao-Nutzer
    Registriert seit
    19.07.2009.
    Ort
    Peine
    Beiträge
    90

    Standard Einbindung einer MapBox Karte

    Vielen, vielen Dank für die Entwicklung dieses großartigen Softwaremoduls!

    Ich habe Probleme mit der Einbindung von MapBox Karten. Meine Vorgehensweise:
    (1) Definition des Styles "Light" in MapBox
    (2) Anlegen von Studio Style (Mapbox) und Studio Classic (Mapbox) in Contao/conf4gis maps 3
    (3) Kopien "Access token" aus MapBox und einfügen in "Access Token / API Key" in Contao/conf4gis maps 3
    (4) Kopieren "Style URL" aus MapBox und einfügen in "Style ID / Anwendungsschlüssel" in Contao/conf4gis maps 3

    Leider wird mir weder bei "Studio Style (Mapbox)" noch bei "Studio Classic (Mapbox)" mit den o.g. Daten eine Map in Contao angezeigt.

    Wo könnte meine Fehler liegen?

    Viele Grüße

    Jan
    www.gesamtschullandkarte-niedersachsen.de

  28. #68
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Hallo Jan,

    wir nutzen die Mapbox Karten auch in verschiedenen Projekten und zwar wie folgt:

    Style ID / Anwendungsschlüssel
    kuestenschmiede/fregiuh77egeruguhiugrf345

    Access Token / API Key
    zu.dgjpdoihgfdphjrtpohjdfphgjdpfhjpsdofhkjposthspo fthkjfpsohkjpfog

    Die Werte hier sind frei erfunden. Vom Aufbau her sollten die Eingaben aber so aussehen.

    Beste Grüße
    Matthias
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  29. #69
    Contao-Nutzer
    Registriert seit
    19.07.2009.
    Ort
    Peine
    Beiträge
    90

    Standard

    Vielen Dank. Folgend die Lösung: In MapBox wird folgender Link generiert "mapbox://styles/kontoname/............" Beim Übertragen in con4gis maps müssen die Zeichen vor "kontoname" gelöscht werden, also "kontoname/............" eingegeben werden.

  30. #70
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Mit der nächsten Version taucht dbzgl. ein kleiner Kommentar im Backend auf.
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  31. #71
    Contao-Nutzer
    Registriert seit
    08.07.2011.
    Ort
    Niedersachsen
    Beiträge
    50

    Standard Karte will einfach nicht laufen - 500 Error

    Mit der aktuellen Version des core wie auch der maps bekomm ich die Karte leider nicht zum laufen.

    In der Konsole kommen die Fehler:
    500 Internal Server Error | system/modules/con4gis_core/api/index.php/baseLayerService/2
    500 Internal Server Error | system/modules/con4gis_core/api/index.php/layerService/4

    Karte bleibt leer und kann nicht aufgebaut werden.

    Kann jemand helfen?

  32. #72
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Guten Morgen lillena,

    wir haben gestern abend noch ein Fehler im Core ausgebaut. Versuch bitte die 1.6.1 noch mal neu zu installieren. Falls das nicht das Problem ist: wir haben heute morgen auch noch einen Fehler in Maps3 entdeckt und machen im Laufe des Tages noch neue Versionen.

    Kannst Du mir bitte den entsprechenden Auszug aus Deiner system/logs/error.log schicken (PN oder E-Mail an die Küstenschmiede), dann werden wir das auch noch prüfen. Danke.

    Sonnige Grüße aus Jever
    Matthias
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  33. #73
    Contao-Urgestein Avatar von zonky
    Registriert seit
    19.03.2010.
    Ort
    Berlin, Rdf
    Beiträge
    6.443
    User beschenken
    Wunschliste

    Standard

    ich habe gerde versucht con4gis_maps3 per Composer under Contao 3.5.15 zu installieren...

    Composer ist durchgelaufen aber nun kommt

    Code:
    Fatal error: Class 'FrontendController' not found in /home/hier/undda/composer/vendor/con4gis/con4gis_api_bundle/src/Controller/ApiController.php on line 22
    das zugehörige
    Code:
    use Contao\CoreBundle\Controller\FrontendController;
    ist m.E. für Contao 4x

    Edit: Fehler gefunden: die JSON ist falsch für Feature Release - hier fehlt ein "3."

    shot278.jpg
    Geändert von zonky (25.09.2016 um 15:35 Uhr)

  34. #74
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Danke zonky, wird werden die composer.json mit dem nächsten Release auch für Contao 3 anpassen.
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  35. #75
    Alter Contao-Hase Avatar von xkoy
    Registriert seit
    23.07.2010.
    Ort
    Mount Maunganui, New Zealand
    Beiträge
    1.007

    Standard

    Hi, jetzt habe ich auch mal eine Frage zur "Erweiterung" (Habe euch parallel auch eine Email gesendet, hab aber gerade diesen Thread hier gefunden).

    Ist es möglich (Travel Map) eine Karte zu erstellen um eine Reiseroute zu zeigen? Also von A nach B, mit einer Streckenlinie verbunden, evtl. zwischen drin noch Punkte mit Links (Interne links zum Artikel oder News).

    Am Rande, ich finde keine Google Maps, sind die entfernt wurden?

    Danke euch
    Daniel

  36. #76
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Moin Daniel,

    ja, dass ist möglich. Zum Beispiel mit dem GeoJson-Kartenstrukturelement. Über das Kartenprofil kann auch ein eigener Streckeneditor konfiguriert werden. Alternativ ist auch die Einbindung von KML und GPX möglich.

    Die Technik baut auf dem aktuellen OpenLayers 3 auf. Google-Karten werden zurzeit nicht unterstützt. Es gibt aber zahlreichen Alternativen, um ansprechende Karten darzustellen.

    Beste Grüße
    Matthias
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  37. #77
    Contao-Nutzer
    Registriert seit
    14.01.2013.
    Beiträge
    23

    Standard Einbinden von anderen Contao Tabellen

    Moin,
    augenblicklich implementiere ich die wirklich vielversprechende con4gis_maps 3 in eine zu updatende Webseite. Ziel ist es, die Geodaten verschiedener Anbieter aus einer Metamodels Tabelle auf Karten darzustellen.

    Das automatische Anlegen der Geo Koordinaten aus der jeweiligen Addresse in die Datenbank und die jeweilige Abfrage der Geo Koordinaten aus der mm_XXX Datenbanktabelle funktioniert inzwischen ohne Probleme. Erreicht wurde das unter Verwndung des dlh_geocode Modules.
    Allerdings komme ich bei einem Problem nicht weiter. Wenn ich die Datensätze aus der Datenbank per select weiter filtern möchte, erscheint eine leere Karte und ein nicht ladendes Starboard.

    Das geschieht, sobald ich in der DCA Config die sqlwhere Konstante z.B. bei der mm_xxx Tabelle auf 'published = 1' setze. Auch der Versuch, in der Kartenstruktur der Maps3 bei den Bedingungen eine SQL Bedingung zu hinterlegen, schlägt fehl.

    Vielleicht verstehe ich etwas Grundlegendes falsch, ich wäre aber über einen Lösungsansatz dankbar.

    System:
    PHP 5.6.X
    Contao: 3.5.15
    C4G Maps: 3.4.0

    Mit Grüßen aus Bremen

  38. #78
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Moin hul,

    Du hast DCA config geschrieben. Bin mir nicht sicher, ob Du die beiden Beispielkonfigurationen in der con4gis-Maps3 config.php gesehen hast? Zum Beispiel für den Kalender:

    Code:
    $GLOBALS['con4gis_maps_extension']['sourcetable']['tl_calendar_events'] = array
    (
        'ptable'        => 'tl_calendar',
        'ptable_option' => 'title',
        'geox'          => 'c4g_loc_geox',
        'geoy'          => 'c4g_loc_geoy',
        'label'         => 'c4g_loc_label',
        'locstyle'      => 'c4g_locstyle',
        'tooltip'       => 'title',
        'popup'         => '{{event::[id]}},[startDate:date]',
        /** other example with start- and endDate ->
         * 'popup'         => '{{event::[id]}},(,[startDate:date],-,[endDate:date],)',
         */
        'linkurl'       => '{{event_url::[id]}}',
        'sqlwhere'      => 'published = 1',
        'alias_getparam'=> 'events',
        'title'         => 'title'
    );
    Genauso kannst Du andere Tabellen mit entsprechenden Koordinatenfeldern integrieren und über das Kartenstrukturelement in die Karte einbinden.

    Hilft Dir das weiter?
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  39. #79
    Contao-Nutzer
    Registriert seit
    14.01.2013.
    Beiträge
    23

    Standard Einbinden von anderen Contao Tabellen

    Zitat Zitat von CoastFace Beitrag anzeigen
    Moin hul,

    Du hast DCA config geschrieben. Bin mir nicht sicher, ob Du die beiden Beispielkonfigurationen in der con4gis-Maps3 config.php gesehen hast? Zum Beispiel für den Kalender:

    Code:
    $GLOBALS['con4gis_maps_extension']['sourcetable']['tl_calendar_events'] = array
    (
        'ptable'        => 'tl_calendar',
        'ptable_option' => 'title',
        'geox'          => 'c4g_loc_geox',
        'geoy'          => 'c4g_loc_geoy',
        'label'         => 'c4g_loc_label',
        'locstyle'      => 'c4g_locstyle',
        'tooltip'       => 'title',
        'popup'         => '{{event::[id]}},[startDate:date]',
        /** other example with start- and endDate ->
         * 'popup'         => '{{event::[id]}},(,[startDate:date],-,[endDate:date],)',
         */
        'linkurl'       => '{{event_url::[id]}}',
        'sqlwhere'      => 'published = 1',
        'alias_getparam'=> 'events',
        'title'         => 'title'
    );
    Genauso kannst Du andere Tabellen mit entsprechenden Koordinatenfeldern integrieren und über das Kartenstrukturelement in die Karte einbinden.

    Hilft Dir das weiter?
    Hallo Coastface,
    vielen Dank für die prompte Antwort.
    Ich meine, dass ich die mm_xxx Tabelle richtig eingebunden habe:

    Code:
    $GLOBALS['con4gis_maps_extension']['sourcetable']['mm_supplier'] = array
    (
        'geox'          => 'geox',
        'geoy'          => 'geoy',
        'label'         => '',
    //    'sqlwhere'      => 'published = 1',
        'tooltip'       => 'name'
    );
    Deshalb stehe ich auf dem Schlauch. Sobald die sqlwhere nicht mehr auskommentiert ist, habe ich die leere Karte. Und die eigenen SQL Bedingungen in der dahingehenden Kartenstruktur bewirken ebenfalls nichts.
    Ich habe schon in der LayerContentApi.php um Zeile 246 versucht, das Problem händisch nachzuvollziehen, aber leider ohne Erfolg.

    Nette Grüße

  40. #80
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    142
    Partner-ID
    7247

    Standard

    Hallo hul,

    die Funktion hab' ich selbst lange nicht mehr genutzt: versuch mal die Bedingung so im Kartenstrukturelement einzugeben: mm_xxx.published = 1.

    LG
    Matthias
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

Seite 2 von 6 ErsteErste 1234 ... LetzteLetzte

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •