Das Contao Camp 2020 in Hamburg. LEIDER ABGESAGT!
Ergebnis 1 bis 4 von 4

Thema: calendar-extended-bundle Installation schlägt fehl

  1. #1
    Contao-Nutzer
    Registriert seit
    23.04.2019.
    Beiträge
    14

    Frage calendar-extended-bundle Installation schlägt fehl

    Hi, ich habe versucht die calendar-extended-bundle über den Contao-manager zu installieren, die Installation schlägt jedoch fehl.
    Was ist da los? Hier die Fehlermeldung:
    Code:
    > Resolving dependencies using Composer Cloud v2.0.11
    
    [439.1MiB/5.67s] Loading composer repositories with package information
    [439.4MiB/5.76s] Updating dependencies
    [2155.4MiB/43.19s] Your requirements could not be resolved to an installable set of packages.
    [2155.4MiB/43.19s] 
      Problem 1
        - Installation request for kmielke/calendar-extended-bundle ^1.0.6 -> satisfiable by kmielke/calendar-extended-bundle[1.0.6].
        - Conclusion: don't install menatwork/contao-multicolumnwizard 3.3.16
        - kmielke/calendar-extended-bundle 1.0.6 requires menatwork/contao-multicolumnwizard-bundle ^3.4 -> satisfiable by menatwork/contao-multicolumnwizard-bundle[3.4.0, 3.4.1, 3.4.2].
        - don't install menatwork/contao-multicolumnwizard-bundle 3.4.0|don't install menatwork/contao-multicolumnwizard 3.3.16
        - don't install menatwork/contao-multicolumnwizard-bundle 3.4.1|don't install menatwork/contao-multicolumnwizard 3.3.16
        - don't install menatwork/contao-multicolumnwizard-bundle 3.4.2|don't install menatwork/contao-multicolumnwizard 3.3.16
        - Installation request for menatwork/contao-multicolumnwizard (locked at 3.3.16, required as ^3.3) -> satisfiable by menatwork/contao-multicolumnwizard[3.3.16].
    
    [2155.4MiB/43.19s] <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning>
    [755.3MiB/50.17s] Memory usage: 755.31MB (peak: 3365.68MB), time: 50.18s.
    [755.3MiB/50.18s] Finished Composer Cloud resolving.
    
    
    # Cloud Job ID ekH12gy2JE6Yj0E2GHEHgAjSiDBjZKRliK7zKgkA5ORGnSBaf0SmeNLMjsq5wwg3sGIeCIRdFHAi9Ya1yJWYtTWfzPaZ6zkyrqubHjzWRe55AqPhV3F failed
    
    ---
    
    ### Der Hintergrundprozess wurde unerwartet beendet ###
    Und hier die composer.json:
    Code:
    {
        "type": "project",
        "require": {
            "contao/calendar-bundle": "^4.7",
            "contao/comments-bundle": "^4.7",
            "contao/conflicts": "*@dev",
            "contao/faq-bundle": "^4.7",
            "contao/listing-bundle": "^4.7",
            "contao/manager-bundle": "4.7.*",
            "contao/news-bundle": "^4.7",
            "contao/newsletter-bundle": "^4.7",
            "fipps/contao-rssimport-bundle": "^4.1",
            "hofff/contao-leads-encryption": "^1.0",
            "kmielke/calendar-extended-bundle": "^1.0.6",
            "madeyourday/contao-rocksolid-antispam": "^2.0",
            "madeyourday/contao-rocksolid-columns": "^2.0",
            "madeyourday/contao-rocksolid-custom-elements": "^2.2",
            "madeyourday/contao-rocksolid-frontend-helper": "^2.0",
            "madeyourday/contao-rocksolid-icon-picker": "^2.0",
            "madeyourday/contao-rocksolid-mega-menu": "^2.0",
            "madeyourday/contao-rocksolid-slider": "^2.0",
            "madeyourday/contao-rocksolid-theme-assistant": "^2.0",
            "menatwork/contao-multicolumnwizard": "^3.3",
            "phpoffice/phpspreadsheet": "^1.8",
            "sabre/dav": "^4.0.1",
            "terminal42/contao-leads": "^1.4",
            "terminal42/notification_center": "^1.5"
        },
        "extra": {
            "contao-component-dir": "assets"
        },
        "scripts": {
            "post-install-cmd": [
                "Contao\\ManagerBundle\\Composer\\ScriptHandler::initializeApplication"
            ],
            "post-update-cmd": [
                "Contao\\ManagerBundle\\Composer\\ScriptHandler::initializeApplication"
            ]
        }
    }
    Beste Grüße,
    Alfons

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    23.028
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Du hast in deiner composer.json den MCW drin. Verwendest du den also selbst in diesem Projekt? Wenn ja, ändere die Dependency auf die Bundle Version und führe eine komplette Paket Aktualisierung durch.

  3. #3
    Contao-Nutzer
    Registriert seit
    23.04.2019.
    Beiträge
    14

    Frage

    Zitat Zitat von Spooky Beitrag anzeigen
    Du hast in deiner composer.json den MCW drin. Verwendest du den also selbst in diesem Projekt? Wenn ja, ändere die Dependency auf die Bundle Version und führe eine komplette Paket Aktualisierung durch.
    Ich nehme an, du meinst den multicolumswizard. Das war wohl ein Fehler von mir, ich wollte eigentlich menatwork/contao-multicolumnwizard-bundle installieren, da dieses ja von calendar-extended benötigt wird. Wenn ich aber versuche dieses zu installieren (habe es sowohl einzeln, als auch direkt mit calendar-extended zusammen und über den Composer versucht), erhalte ich aber ähnliche Fehlermeldungen. Die Pakete hatte ich vor der Installation frisch geupdated, man kann im Contao-Manager aber nicht die Pakete aktualisieren, solange dieser versucht, etwas zu installieren ("Pakete aktualisieren" ist ausgegraut).

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    23.028
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von DerAlfons Beitrag anzeigen
    Ich nehme an, du meinst den multicolumswizard. Das war wohl ein Fehler von mir, ich wollte eigentlich menatwork/contao-multicolumnwizard-bundle installieren, da dieses ja von calendar-extended benötigt wird. Wenn ich aber versuche dieses zu installieren (habe es sowohl einzeln, als auch direkt mit calendar-extended zusammen und über den Composer versucht), erhalte ich aber ähnliche Fehlermeldungen.
    Das musst du nicht selbst installieren. Entferne das Paket und führe eine komplette Paketaktualisierung durch.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •