Ergebnis 1 bis 33 von 33

Thema: Contao 4.4.44 - Erweiterung Visitors läßt sich nicht installieren

  1. #1
    Contao-Nutzer
    Registriert seit
    30.09.2012.
    Beiträge
    28

    Standard Contao 4.4.44 - Erweiterung Visitors läßt sich nicht installieren

    Die Erweiterung Visitors läßt sich nicht installieren.
    Composer-Log:
    Code:
    $ /opt/RZphp73/bin/php-cli -q -d max_execution_time=300 /mnt/web201/e2/87/54225387/htdocs/contao4/web/contao-manager.phar.php composer require bugbuster/contao-visitors-bundle --no-suggest --no-update --no-scripts --prefer-stable --sort-packages --no-ansi --no-interaction
    
    Using version ^1.6 for bugbuster/contao-visitors-bundle
    /mnt/web201/e2/87/54225387/htdocs/contao4/composer.json has been updated
    
    # Process terminated with exit code 0
    # Result: OK
    
    
    > Resolving dependencies using Composer Cloud v2.0.11
    
    [456.9MiB/9.99s] Loading composer repositories with package information
    [457.3MiB/10.08s] Updating dependencies
    [2315.1MiB/56.65s] Your requirements could not be resolved to an installable set of packages.
    [2315.1MiB/56.65s] 
      Problem 1
        - Conclusion: don't install bugbuster/contao-visitors-bundle 1.6.1
        - Installation request for bugbuster/contao-visitors-bundle ^1.6 -> satisfiable by bugbuster/contao-visitors-bundle[1.6.0, 1.6.1].
        - Conclusion: don't install contao-components/contao 7.1.5
        - bugbuster/contao-visitors-bundle 1.6.0 requires contao/core-bundle ~4.7 -> satisfiable by contao/core-bundle[4.7.0, 4.7.1, 4.7.2, 4.7.3, 4.7.4, 4.7.5, 4.7.6, 4.7.7, 4.8.0, 4.8.1, 4.8.2, 4.8.3, 4.8.4].
        - contao/core-bundle 4.7.0 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
        - contao/core-bundle 4.7.1 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
        - contao/core-bundle 4.7.2 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
        - contao/core-bundle 4.7.3 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
        - contao/core-bundle 4.7.4 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
        - contao/core-bundle 4.7.5 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
        - contao/core-bundle 4.7.6 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
        - contao/core-bundle 4.7.7 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
        - contao/core-bundle 4.8.0 requires contao-components/contao ^9.0 -> satisfiable by contao-components/contao[9.0.0].
        - contao/core-bundle 4.8.1 requires contao-components/contao ^9.0 -> satisfiable by contao-components/contao[9.0.0].
        - contao/core-bundle 4.8.2 requires contao-components/contao ^9.0 -> satisfiable by contao-components/contao[9.0.0].
        - contao/core-bundle 4.8.3 requires contao-components/contao ^9.0 -> satisfiable by contao-components/contao[9.0.0].
        - contao/core-bundle 4.8.4 requires contao-components/contao ^9.0 -> satisfiable by contao-components/contao[9.0.0].
        - Can only install one of: contao-components/contao[8.0.0, 7.1.5].
        - Can only install one of: contao-components/contao[8.0.1, 7.1.5].
        - Can only install one of: contao-components/contao[8.0.2, 7.1.5].
        - Can only install one of: contao-components/contao[8.0.3, 7.1.5].
        - Can only install one of: contao-components/contao[9.0.0, 7.1.5].
        - Installation request for contao-components/contao (locked at 7.1.5) -> satisfiable by contao-components/contao[7.1.5].
    
    [2315.1MiB/56.66s] <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning>
    [765.0MiB/65.02s] Memory usage: 765.03MB (peak: 3493.72MB), time: 65.02s.
    [765.0MiB/65.03s] Finished Composer Cloud resolving.
    
    
    # Cloud Job ID U2Qg1FTMwlDUoU60cvXFg2rUjRtV9NSdaNag78AAOUWKHhwQcAgxIJrjwdldCun8tHy7jba1GKxgEU2TotidfdBCCAbN failed
    
    ---
    
    ### Der Hintergrundprozess wurde unerwartet beendet ###
    Provider: Strato
    PHP Version: 7.3
    Conato Version: 4.4.44
    Contao Manager: 1.2

    Scheinbar steht die Erweiterung Visitors in Konflikt mit einem Contao-Core-Modul.
    Kann da jemand weiterhelfen?

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    22.293
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Benutze ^1.0 statt ^1.6

  3. #3
    Contao-Nutzer
    Registriert seit
    30.09.2012.
    Beiträge
    28

    Standard Hat leider auch nicht funktioniert.

    Zitat Zitat von Spooky Beitrag anzeigen
    Benutze ^1.0 statt ^1.6
    Code:
    $ /opt/RZphp73/bin/php-cli -q -d max_execution_time=300 /mnt/web201/e2/87/54225387/htdocs/contao4/web/contao-manager.phar.php composer require bugbuster/contao-visitors-bundle=1.0 --no-suggest --no-update --no-scripts --prefer-stable --sort-packages --no-ansi --no-interaction
    
    /mnt/web201/e2/87/54225387/htdocs/contao4/composer.json has been updated
    
    # Process terminated with exit code 0
    # Result: OK
    
    
    > Resolving dependencies using Composer Cloud v2.0.11
    
    # Job ID TldzjFsIVS3GvxhLH8UBdMpMDm6wCtlDbEh5n07nVF01PfAx5ILeQzGejINSUGCFtJak4h8qCkjMxwwAaaea9j5RDR47FieYgLPdzXQlTKMAgAkpkM completed in 80 seconds
    # Memory usage: 761.58MB (peak: 3425.13MB), time: 80.28s.
    
    $ /opt/RZphp73/bin/php-cli -q -d max_execution_time=300 /mnt/web201/e2/87/54225387/htdocs/contao4/web/contao-manager.phar.php composer install --prefer-dist --no-dev --no-progress --no-suggest --no-ansi --no-interaction --optimize-autoloader
    
    contao/manager-plugin: Generating plugin class...
    contao/manager-plugin: ...done generating plugin class
    
     // Clearing the cache for the prod environment with debug                      
     // false                                                                       
    
     [OK] Cache for the "prod" environment (debug=false) was successfully cleared.  
    
    
     // Warming up the cache for the prod environment with debug                    
     // false                                                                       
    
    14:15:38 ERROR     [console] Error thrown while running command "cache:warmup --env=prod". Message: "[Semantical Error] The annotation "@Sensio\Bundle\FrameworkExtraBundle\Configuration\Route" in class BugBuster\VisitorsBundle\Controller\VisitorsController does not exist, or could not be auto-loaded in /mnt/web201/e2/87/54225387/htdocs/contao4/vendor/bugbuster/contao-visitors-bundle/src/Controller (which is being imported from "/mnt/web201/e2/87/54225387/htdocs/contao4/vendor/bugbuster/contao-visitors-bundle/src/ContaoManager/../Resources/config/routing.yml"). Make sure annotations are installed and enabled." ["exception" => Symfony\Component\Config\Exception\FileLoaderLoadException { ...},"command" => "cache:warmup --env=prod","message" => "[Semantical Error] The annotation "@Sensio\Bundle\FrameworkExtraBundle\Configuration\Route" in class BugBuster\VisitorsBundle\Controller\VisitorsController does not exist, or could not be auto-loaded in /mnt/web201/e2/87/54225387/htdocs/contao4/vendor/bugbuster/contao-visitors-bundle/src/Controller (which is being imported from "/mnt/web201/e2/87/54225387/htdocs/contao4/vendor/bugbuster/contao-visitors-bundle/src/ContaoManager/../Resources/config/routing.yml"). Make sure annotations are installed and enabled."]
    
    In FileLoader.php line 168:
                                                                                   
      [Semantical Error] The annotation "@Sensio\Bundle\FrameworkExtraBundle\Conf  
      iguration\Route" in class BugBuster\VisitorsBundle\Controller\VisitorsContr  
      oller does not exist, or could not be auto-loaded in /mnt/web201/e2/87/5422  
      5387/htdocs/contao4/vendor/bugbuster/contao-visitors-bundle/src/Controller   
      (which is being imported from "/mnt/web201/e2/87/54225387/htdocs/contao4/ve  
      ndor/bugbuster/contao-visitors-bundle/src/ContaoManager/../Resources/config  
      /routing.yml"). Make sure annotations are installed and enabled.             
                                                                                   
    
    In AnnotationException.php line 54:
                                                                                   
      [Semantical Error] The annotation "@Sensio\Bundle\FrameworkExtraBundle\Conf  
      iguration\Route" in class BugBuster\VisitorsBundle\Controller\VisitorsContr  
      oller does not exist, or could not be auto-loaded.                           
                                                                                   
    
    cache:warmup [--no-optional-warmers] [-h|--help] [-q|--quiet] [-v|vv|vvv|--verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-e|--env ENV] [--no-debug] [--] <command>
    
    Loading composer repositories with package information
    Installing dependencies from lock file
    Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
    Package operations: 4 installs, 0 updates, 0 removals
      - Installing phpoffice/phpexcel (1.8.2): Downloading (100%)
      - Installing crossjoin/browscap (v1.0.6): Downloading (100%)
      - Installing bugbuster/contao-botdetection-bundle (1.0.1): Downloading (100%)
      - Installing bugbuster/contao-visitors-bundle (1.0.0): Downloading (100%)
    Package phpoffice/phpexcel is abandoned, you should avoid using it. Use phpoffice/phpspreadsheet instead.
    Generating optimized autoload files
    > Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication
    Script Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication handling the post-install-cmd event terminated with an exception
    
    In ScriptHandler.php line 113:
                                                                                   
      An error occurred while executing the "cache:warmup" command: 14:15:38 ERRO  
      R     [console] Error thrown while running command "cache:warmup --env=prod  
      ". Message: "[Semantical Error] The annotation "@Sensio\Bundle\FrameworkExt  
      raBundle\Configuration\Route" in class BugBuster\VisitorsBundle\Controller\  
      VisitorsController does not exist, or could not be auto-loaded in /mnt/web2  
      01/e2/87/54225387/htdocs/contao4/vendor/bugbuster/contao-visitors-bundle/sr  
      c/Controller (which is being imported from "/mnt/web201/e2/87/54225387/htdo  
      cs/contao4/vendor/bugbuster/contao-visitors-bundle/src/ContaoManager/../Res  
      ources/config/routing.yml"). Make sure annotations are installed and enable  
      d." ["exception" => Symfony\Component\Config\Exception\FileLoaderLoadExcept  
      ion { ...},"command" => "cache:warmup --env=prod","message" => "[Semantical E  
      rror] The annotation "@Sensio\Bundle\FrameworkExtraBundle\Configuration\Rou  
      te" in class BugBuster\VisitorsBundle\Controller\VisitorsController does no  
      t exist, or could not be auto-loaded in /mnt/web201/e2/87/54225387/htdocs/c  
      ontao4/vendor/bugbuster/contao-visitors-bundle/src/Controller (which is bei  
      ng imported from "/mnt/web201/e2/87/54225387/htdocs/contao4/vendor/bugbuste  
      r/contao-visitors-bundle/src/ContaoManager/../Resources/config/routing.yml"  
      ). Make sure annotations are installed and enabled."]                        
                                                                                   
      In FileLoader.php line 168:                                                  
                                                                                   
                                                                                   
        [Semantical Error] The annotation "@Sensio\Bundle\FrameworkExtraBundle\Co  
      nf                                                                           
        iguration\Route" in class BugBuster\VisitorsBundle\Controller\VisitorsCon  
      tr                                                                           
        oller does not exist, or could not be auto-loaded in /mnt/web201/e2/87/54  
      22                                                                           
        5387/htdocs/contao4/vendor/bugbuster/contao-visitors-bundle/src/Controlle  
      r                                                                            
        (which is being imported from "/mnt/web201/e2/87/54225387/htdocs/contao4/  
      ve                                                                           
        ndor/bugbuster/contao-visitors-bundle/src/ContaoManager/../Resources/conf  
      ig                                                                           
        /routing.yml"). Make sure annotations are installed and enabled.           
                                                                                   
                                                                                   
                                                                                   
                                                                                   
      In AnnotationException.php line 54:                                          
                                                                                   
                                                                                   
        [Semantical Error] The annotation "@Sensio\Bundle\FrameworkExtraBundle\Co  
      nf                                                                           
        iguration\Route" in class BugBuster\VisitorsBundle\Controller\VisitorsCon  
      tr                                                                           
        oller does not exist, or could not be auto-loaded.                         
                                                                                   
                                                                                   
                                                                                   
                                                                                   
      cache:warmup [--no-optional-warmers] [-h|--help] [-q|--quiet] [-v|vv|vvv|--  
      verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-e|--en  
      v ENV] [--no-debug] [--] <command>                                           
                                                                                   
    
    install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--] [<packages>...]
    
    
    # Process terminated with exit code 1
    # Result: General error
    
    
    ---
    
    ### Der Hintergrundprozess wurde unerwartet beendet ###

  4. #4
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    14.027
    User beschenken
    Wunschliste

    Standard

    //Moderation: Thema in das entsprechende Unterforum der Erweiterung verschoben.
    Contao Community Administrator
    [Unterstützungsmöglichkeiten]

  5. #5
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    22.293
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von compuzius Beitrag anzeigen
    Code:
    $ /opt/RZphp73/bin/php-cli -q -d max_execution_time=300 /mnt/web201/e2/87/54225387/htdocs/contao4/web/contao-manager.phar.php composer require bugbuster/contao-visitors-bundle=1.0 --no-suggest --no-update --no-scripts --prefer-stable --sort-packages --no-ansi --no-interaction
    
    /mnt/web201/e2/87/54225387/htdocs/contao4/composer.json has been updated
    
    # Process terminated with exit code 0
    # Result: OK
    
    
    > Resolving dependencies using Composer Cloud v2.0.11
    
    # Job ID TldzjFsIVS3GvxhLH8UBdMpMDm6wCtlDbEh5n07nVF01PfAx5ILeQzGejINSUGCFtJak4h8qCkjMxwwAaaea9j5RDR47FieYgLPdzXQlTKMAgAkpkM completed in 80 seconds
    # Memory usage: 761.58MB (peak: 3425.13MB), time: 80.28s.
    
    $ /opt/RZphp73/bin/php-cli -q -d max_execution_time=300 /mnt/web201/e2/87/54225387/htdocs/contao4/web/contao-manager.phar.php composer install --prefer-dist --no-dev --no-progress --no-suggest --no-ansi --no-interaction --optimize-autoloader
    
    contao/manager-plugin: Generating plugin class...
    contao/manager-plugin: ...done generating plugin class
    
     // Clearing the cache for the prod environment with debug                      
     // false                                                                       
    
     [OK] Cache for the "prod" environment (debug=false) was successfully cleared.  
    
    
     // Warming up the cache for the prod environment with debug                    
     // false                                                                       
    
    14:15:38 ERROR     [console] Error thrown while running command "cache:warmup --env=prod". Message: "[Semantical Error] The annotation "@Sensio\Bundle\FrameworkExtraBundle\Configuration\Route" in class BugBuster\VisitorsBundle\Controller\VisitorsController does not exist, or could not be auto-loaded in /mnt/web201/e2/87/54225387/htdocs/contao4/vendor/bugbuster/contao-visitors-bundle/src/Controller (which is being imported from "/mnt/web201/e2/87/54225387/htdocs/contao4/vendor/bugbuster/contao-visitors-bundle/src/ContaoManager/../Resources/config/routing.yml"). Make sure annotations are installed and enabled." ["exception" => Symfony\Component\Config\Exception\FileLoaderLoadException { ...},"command" => "cache:warmup --env=prod","message" => "[Semantical Error] The annotation "@Sensio\Bundle\FrameworkExtraBundle\Configuration\Route" in class BugBuster\VisitorsBundle\Controller\VisitorsController does not exist, or could not be auto-loaded in /mnt/web201/e2/87/54225387/htdocs/contao4/vendor/bugbuster/contao-visitors-bundle/src/Controller (which is being imported from "/mnt/web201/e2/87/54225387/htdocs/contao4/vendor/bugbuster/contao-visitors-bundle/src/ContaoManager/../Resources/config/routing.yml"). Make sure annotations are installed and enabled."]
    
    In FileLoader.php line 168:
                                                                                   
      [Semantical Error] The annotation "@Sensio\Bundle\FrameworkExtraBundle\Conf  
      iguration\Route" in class BugBuster\VisitorsBundle\Controller\VisitorsContr  
      oller does not exist, or could not be auto-loaded in /mnt/web201/e2/87/5422  
      5387/htdocs/contao4/vendor/bugbuster/contao-visitors-bundle/src/Controller   
      (which is being imported from "/mnt/web201/e2/87/54225387/htdocs/contao4/ve  
      ndor/bugbuster/contao-visitors-bundle/src/ContaoManager/../Resources/config  
      /routing.yml"). Make sure annotations are installed and enabled.             
                                                                                   
    
    In AnnotationException.php line 54:
                                                                                   
      [Semantical Error] The annotation "@Sensio\Bundle\FrameworkExtraBundle\Conf  
      iguration\Route" in class BugBuster\VisitorsBundle\Controller\VisitorsContr  
      oller does not exist, or could not be auto-loaded.                           
                                                                                   
    
    cache:warmup [--no-optional-warmers] [-h|--help] [-q|--quiet] [-v|vv|vvv|--verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-e|--env ENV] [--no-debug] [--] <command>
    
    Loading composer repositories with package information
    Installing dependencies from lock file
    Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
    Package operations: 4 installs, 0 updates, 0 removals
      - Installing phpoffice/phpexcel (1.8.2): Downloading (100%)
      - Installing crossjoin/browscap (v1.0.6): Downloading (100%)
      - Installing bugbuster/contao-botdetection-bundle (1.0.1): Downloading (100%)
      - Installing bugbuster/contao-visitors-bundle (1.0.0): Downloading (100%)
    Package phpoffice/phpexcel is abandoned, you should avoid using it. Use phpoffice/phpspreadsheet instead.
    Generating optimized autoload files
    > Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication
    Script Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication handling the post-install-cmd event terminated with an exception
    
    In ScriptHandler.php line 113:
                                                                                   
      An error occurred while executing the "cache:warmup" command: 14:15:38 ERRO  
      R     [console] Error thrown while running command "cache:warmup --env=prod  
      ". Message: "[Semantical Error] The annotation "@Sensio\Bundle\FrameworkExt  
      raBundle\Configuration\Route" in class BugBuster\VisitorsBundle\Controller\  
      VisitorsController does not exist, or could not be auto-loaded in /mnt/web2  
      01/e2/87/54225387/htdocs/contao4/vendor/bugbuster/contao-visitors-bundle/sr  
      c/Controller (which is being imported from "/mnt/web201/e2/87/54225387/htdo  
      cs/contao4/vendor/bugbuster/contao-visitors-bundle/src/ContaoManager/../Res  
      ources/config/routing.yml"). Make sure annotations are installed and enable  
      d." ["exception" => Symfony\Component\Config\Exception\FileLoaderLoadExcept  
      ion { ...},"command" => "cache:warmup --env=prod","message" => "[Semantical E  
      rror] The annotation "@Sensio\Bundle\FrameworkExtraBundle\Configuration\Rou  
      te" in class BugBuster\VisitorsBundle\Controller\VisitorsController does no  
      t exist, or could not be auto-loaded in /mnt/web201/e2/87/54225387/htdocs/c  
      ontao4/vendor/bugbuster/contao-visitors-bundle/src/Controller (which is bei  
      ng imported from "/mnt/web201/e2/87/54225387/htdocs/contao4/vendor/bugbuste  
      r/contao-visitors-bundle/src/ContaoManager/../Resources/config/routing.yml"  
      ). Make sure annotations are installed and enabled."]                        
                                                                                   
      In FileLoader.php line 168:                                                  
                                                                                   
                                                                                   
        [Semantical Error] The annotation "@Sensio\Bundle\FrameworkExtraBundle\Co  
      nf                                                                           
        iguration\Route" in class BugBuster\VisitorsBundle\Controller\VisitorsCon  
      tr                                                                           
        oller does not exist, or could not be auto-loaded in /mnt/web201/e2/87/54  
      22                                                                           
        5387/htdocs/contao4/vendor/bugbuster/contao-visitors-bundle/src/Controlle  
      r                                                                            
        (which is being imported from "/mnt/web201/e2/87/54225387/htdocs/contao4/  
      ve                                                                           
        ndor/bugbuster/contao-visitors-bundle/src/ContaoManager/../Resources/conf  
      ig                                                                           
        /routing.yml"). Make sure annotations are installed and enabled.           
                                                                                   
                                                                                   
                                                                                   
                                                                                   
      In AnnotationException.php line 54:                                          
                                                                                   
                                                                                   
        [Semantical Error] The annotation "@Sensio\Bundle\FrameworkExtraBundle\Co  
      nf                                                                           
        iguration\Route" in class BugBuster\VisitorsBundle\Controller\VisitorsCon  
      tr                                                                           
        oller does not exist, or could not be auto-loaded.                         
                                                                                   
                                                                                   
                                                                                   
                                                                                   
      cache:warmup [--no-optional-warmers] [-h|--help] [-q|--quiet] [-v|vv|vvv|--  
      verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-e|--en  
      v ENV] [--no-debug] [--] <command>                                           
                                                                                   
    
    install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--] [<packages>...]
    
    
    # Process terminated with exit code 1
    # Result: General error
    
    
    ---
    
    ### Der Hintergrundprozess wurde unerwartet beendet ###
    Du hast nicht das gemacht, was ich geschrieben habe

  6. #6
    Contao-Nutzer
    Registriert seit
    30.09.2012.
    Beiträge
    28

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Du hast nicht das gemacht, was ich geschrieben habe
    Sorry. Ich hatte das
    Benutze ^1.0 statt ^1.6
    auf die Visitors-Version bezogen.

    Wo muss ich denn das "^1.0" eintragen?

  7. #7
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    14.027
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von compuzius Beitrag anzeigen
    Wo muss ich denn das "^1.0" eintragen?
    Im Feld für den Versionsbereich der Extension "Visitors". Hast Du "1.0" oder "^1.0" eingetragen? Wie schaut Deine composer.json aus?
    Contao Community Administrator
    [Unterstützungsmöglichkeiten]

  8. #8
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    22.293
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Laut Konsolenausgabe hat er 1.0 eingetragen, statt ^1.0

  9. #9
    Contao-Nutzer
    Registriert seit
    30.09.2012.
    Beiträge
    28

    Standard Gelöst

    Zitat Zitat von Spooky Beitrag anzeigen
    Laut Konsolenausgabe hat er 1.0 eingetragen, statt ^1.0
    Ich hatte tatsächlich nur "1.0" eingetragen. Mit "^1.0" hat die Installation jetzt funktioniert.

    Danke für die Hilfe. Es wäre allerdings hilfreich, wenn, wie bei Linux, nur die zur installierten Contao-Version passenden Erweiterungen angezeigt würden.
    Vielleicht kommt da noch was in der Richtung. Der neue Contao-Manager ist ja erst ein paar Tage verfügbar.

  10. #10
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    22.293
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von compuzius Beitrag anzeigen
    Ich hatte tatsächlich nur "1.0" eingetragen. Mit "^1.0" hat die Installation jetzt funktioniert.

    Danke für die Hilfe. Es wäre allerdings hilfreich, wenn, wie bei Linux, nur die zur installierten Contao-Version passenden Erweiterungen angezeigt würden.
    Vielleicht kommt da noch was in der Richtung. Der neue Contao-Manager ist ja erst ein paar Tage verfügbar.
    Das tut er auch grundsätzlich. Nur fügt der composer automatisch als Version Requirement die jeweils neueste Minor Version ein.

  11. #11
    Contao-Nutzer
    Registriert seit
    30.09.2012.
    Beiträge
    28

    Standard

    Das tut er auch grundsätzlich. Nur fügt der composer automatisch als Version Requirement die jeweils neueste Minor Version ein.
    Nun, das meinte ich mit passender Erweiterung. Offensichtlich ist die Version Visitors 1.6.1 nicht mit Contao 4.4.44 kompatibel. Es wäre nett wenn der Installer das berücksichtigen würde. Als normaler Anwender kann ich nicht wissen, ob die Paketabhängikeiten erfüllt sind. Da muss ich mich auf die Paketverwaltung verlassen können.

    Der Vergleich mit der Paketverwaltung von Linux mag vielleicht ein wenig hinken, aber dort kann ich in der Regel nur Pakete installieren, deren Funktionalität in der verwendeten Distribution vorher getestet wurde. Wenn ich als Webdesigner unbedingt mit der neuesten Version von Apache oder PHP arbeiten möchte, dann muss ich ausdrücklich fremde Paketquellen autorisieren - auf eigenes Risiko.

    Ich weiß nicht genau wie der Composer arbeitet, aber es sollte doch möglich sein, bei der Paketverwaltung entsprechend Kompatibilitätsprüfungen einzubauen und nur die zur installierten Contao-Version passenden Pakete zur Installation vorzuschlagen.

  12. #12
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    22.293
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Die "Kompatibilitätsprüfung" wäre eine Abhängigkeitsauflösung. Und das passiert danach.

    Aber grundsätzlich würde ich es auch besser finden, wenn composer (und der Contao Manager) Automatisch ^1.0 (etc.) einträgt, und nicht die neueste, verfügbare Minor Version. Weil die würde ja ohnehin dann automatisch installiert werden.

    Du könntest dazu ja zumindest mal ein Ticket im Contao Manager GitHub Repository anlegen.

  13. #13
    Contao-Nutzer
    Registriert seit
    30.09.2012.
    Beiträge
    28

    Standard Nachtrag zu Visitors mit Contao 4.4.44

    Die Installation von Visitors 1.5.2 hat zwar geklappt, aber danach ist offenbar die Rechteverwaltung zerschossen.
    Der Fehler ist reproduzierbar und tritt sowohl bei Strato als auch auf meiner lokalen Testumgebung auf.

    Wenn ich nach der Installation von Visitors in der Benutzerverwaltung den Zugriff auf die Besucherstatisik für die Gruppe "Autor" erteile, dann sind beim anschließenden Login des zur Gruppe gehörenden Benutzers die Menüpunkte unter "System" nicht mehr sichtbar. Nur die "Wiederherstellung" wird noch angezeigt. Als Administrator sind im Backend alle Menüpunkte erreichbar.

    Anhang 22859
    Anhang 22860

    Nach einer Deinstallation von Visitors ist der Fehler behoben und die freigegebenen Menüpunkte werden unter "System" wieder angezeigt.

    - Es gibt keine Fehlermeldung in den Logfiles.
    - Systemwartung im Backend und im Contao-Manager brachte auch nix.
    - Bei bestehenden älteren Contao-Installationen mit Visitors tritt dieser Fehler - auch nach Aktualisierung - nicht auf.
    - Offenbar tritt der Fehler nur bei einer Neuinstallation mit dem Contao-Manager 1.2 auf.

    Ein möglicher Hinweis könnte das Log des Managers geben.
    Code:
    Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
    Diese Warnung bleibt auch nach einem Update (Aktualisierung) bestehen.

    composer.json:
    Code:
    {
        "type": "project",
        "require": {
            "bugbuster/contao-visitors-bundle": "^1.0",
            "codefog/contao-cookiebar": "^2.2",
            "contao/calendar-bundle": "4.4.*",
            "contao/comments-bundle": "4.4.*",
            "contao/conflicts": "*@dev",
            "contao/faq-bundle": "4.4.*",
            "contao/listing-bundle": "4.4.*",
            "contao/manager-bundle": "4.4.*",
            "contao/news-bundle": "4.4.*",
            "contao/newsletter-bundle": "4.4.*",
            "delahaye/dlh_googlemaps": "^2.4",
            "dklemmt/contao_dk_mmenu": "^3.1",
            "do-while/contao-backupdb-bundle": "^1.4",
            "madeyourday/contao-rocksolid-antispam": "^2.0"
        },
        "extra": {
            "contao-component-dir": "assets"
        },
        "scripts": {
            "post-install-cmd": [
                "Contao\\ManagerBundle\\Composer\\ScriptHandler::initializeApplication"
            ],
            "post-update-cmd": [
                "Contao\\ManagerBundle\\Composer\\ScriptHandler::initializeApplication"
            ]
        }
    }
    composer.lock:
    Code:
    {
        "_readme": [
            "This file locks the dependencies of your project to a known state",
            "Read more about it at https://getcomposer.org/doc/01-basic-usage.md#installing-dependencies",
            "This file is @generated automatically"
        ],
        "content-hash": "27b07f606090867548bbaef2ef766c19",
        "packages": [
            {
                "name": "bugbuster/contao-botdetection-bundle",
                "version": "1.0.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/BugBuster1701/contao-botdetection-bundle.git",
                    "reference": "5534da50ccac06d8e38fdc06c6d93a0824fdcbf9"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/BugBuster1701/contao-botdetection-bundle/zipball/5534da50ccac06d8e38fdc06c6d93a0824fdcbf9",
                    "reference": "5534da50ccac06d8e38fdc06c6d93a0824fdcbf9",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": ">=4.3.8,<5.0",
                    "crossjoin/browscap": "1.0.6",
                    "php": ">=5.6.0"
                },
                "conflict": {
                    "contao/manager-plugin": "<2.0 || >=3.0",
                    "symfony/symfony": "3.2.7"
                },
                "require-dev": {
                    "true/punycode": "^2.0"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao": {
                        "transifex": {
                            "project": "contao-botdetection-bundle",
                            "prefix": "master-",
                            "languages_cto": "src/Resources/contao/languages",
                            "languages_tx": ".tx"
                        },
                        "runonce": [
                            "src/runonce/delete_old_browscap.php"
                        ]
                    },
                    "branch-alias": {
                        "dev-release-1.0-C44LTS": "1.1.x-dev"
                    },
                    "contao-manager-plugin": "BugBuster\\BotdetectionBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "BugBuster\\BotdetectionBundle\\": "src/"
                    },
                    "classmap": [
                        "src/Resources/contao/"
                    ],
                    "exclude-from-classmap": [
                        "src/Resources/contao/cache/",
                        "src/Resources/contao/config/",
                        "src/Resources/contao/dca/",
                        "src/Resources/contao/languages/",
                        "src/Resources/contao/templates/",
                        "src/Resources/contao/test/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Glen Langer",
                        "homepage": "http://contao.ninja",
                        "role": "Developer"
                    }
                ],
                "description": "Contao 4 bundle helper class to detect search engines, bots, spiders, crawlers ...",
                "homepage": "http://contao.ninja",
                "keywords": [
                    "bots",
                    "bundle",
                    "contao",
                    "detection"
                ],
                "time": "2018-10-20T22:29:05+00:00"
            },
            {
                "name": "bugbuster/contao-visitors-bundle",
                "version": "1.5.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/BugBuster1701/contao-visitors-bundle.git",
                    "reference": "7ae8e80df1689761c412442c2de2513d6b9d496a"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/BugBuster1701/contao-visitors-bundle/zipball/7ae8e80df1689761c412442c2de2513d6b9d496a",
                    "reference": "7ae8e80df1689761c412442c2de2513d6b9d496a",
                    "shasum": ""
                },
                "require": {
                    "bugbuster/contao-botdetection-bundle": ">=0.2.1,<2",
                    "composer/semver": "^1.0",
                    "contao/core-bundle": "~4.3",
                    "jean85/pretty-package-versions": "^1.0",
                    "php": "^5.6|^7.0",
                    "phpoffice/phpspreadsheet": "~1.0"
                },
                "conflict": {
                    "contao/manager-plugin": "<2.0 || >=3.0"
                },
                "require-dev": {
                    "contao/manager-plugin": "^2.0"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao": {
                        "transifex": {
                            "project": "contao-visitors-bundle",
                            "prefix": "master-",
                            "languages_cto": "src/Resources/contao/languages",
                            "languages_tx": ".tx"
                        }
                    },
                    "branch-alias": {
                        "dev-develop": "1.5.x-dev"
                    },
                    "contao-manager-plugin": "BugBuster\\VisitorsBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "BugBuster\\VisitorsBundle\\": "src/"
                    },
                    "classmap": [
                        "src/Resources/contao/"
                    ],
                    "exclude-from-classmap": [
                        "src/Resources/contao/config/",
                        "src/Resources/contao/dca/",
                        "src/Resources/contao/languages/",
                        "src/Resources/contao/templates/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Glen Langer",
                        "homepage": "http://contao.ninja",
                        "role": "Developer"
                    }
                ],
                "description": "Contao 4 visitors bundle, allows you to count hits and visits of your website.",
                "homepage": "http://contao.ninja",
                "keywords": [
                    "bundle",
                    "contao",
                    "counter",
                    "hits",
                    "visitors",
                    "visits"
                ],
                "time": "2019-02-10T23:54:32+00:00"
            },
            {
                "name": "clue/stream-filter",
                "version": "v1.4.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/clue/php-stream-filter.git",
                    "reference": "5a58cc30a8bd6a4eb8f856adf61dd3e013f53f71"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/clue/php-stream-filter/zipball/5a58cc30a8bd6a4eb8f856adf61dd3e013f53f71",
                    "reference": "5a58cc30a8bd6a4eb8f856adf61dd3e013f53f71",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3"
                },
                "require-dev": {
                    "phpunit/phpunit": "^5.0 || ^4.8"
                },
                "type": "library",
                "autoload": {
                    "psr-4": {
                        "Clue\\StreamFilter\\": "src/"
                    },
                    "files": [
                        "src/functions_include.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Christian Lück",
                        "email": "christian@lueck.tv"
                    }
                ],
                "description": "A simple and modern approach to stream filtering in PHP",
                "homepage": "https://github.com/clue/php-stream-filter",
                "keywords": [
                    "bucket brigade",
                    "callback",
                    "filter",
                    "php_user_filter",
                    "stream",
                    "stream_filter_append",
                    "stream_filter_register"
                ],
                "time": "2019-04-09T12:31:48+00:00"
            },
            {
                "name": "codefog/contao-cookiebar",
                "version": "2.2.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/codefog/contao-cookiebar.git",
                    "reference": "d87a34d0667c36ea265a6e4bd1e3b7cfc970fa18"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/codefog/contao-cookiebar/zipball/d87a34d0667c36ea265a6e4bd1e3b7cfc970fa18",
                    "reference": "d87a34d0667c36ea265a6e4bd1e3b7cfc970fa18",
                    "shasum": ""
                },
                "require": {
                    "contao-community-alliance/composer-plugin": "~2.4 || ~3.0",
                    "contao/core-bundle": "~3.5 || ~4.4",
                    "php": "^5.4|^7.0"
                },
                "replace": {
                    "contao-legacy/cookiebar": "self.version"
                },
                "require-dev": {
                    "friendsofphp/php-cs-fixer": "^2.10"
                },
                "type": "contao-module",
                "extra": {
                    "contao": {
                        "sources": {
                            "": "system/modules/cookiebar"
                        }
                    }
                },
                "autoload": {
                    "psr-0": {
                        "Codefog\\Cookiebar\\": [
                            "src/"
                        ]
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Codefog",
                        "homepage": "https://codefog.pl"
                    }
                ],
                "description": "cookiebar extension for Contao Open Source CMS",
                "keywords": [
                    "contao",
                    "cookie",
                    "cookiebar",
                    "cookielaw"
                ],
                "time": "2019-10-22T12:47:00+00:00"
            },
            {
                "name": "composer/ca-bundle",
                "version": "1.2.4",
                "source": {
                    "type": "git",
                    "url": "https://github.com/composer/ca-bundle.git",
                    "reference": "10bb96592168a0f8e8f6dcde3532d9fa50b0b527"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/composer/ca-bundle/zipball/10bb96592168a0f8e8f6dcde3532d9fa50b0b527",
                    "reference": "10bb96592168a0f8e8f6dcde3532d9fa50b0b527",
                    "shasum": ""
                },
                "require": {
                    "ext-openssl": "*",
                    "ext-pcre": "*",
                    "php": "^5.3.2 || ^7.0 || ^8.0"
                },
                "require-dev": {
                    "phpunit/phpunit": "^4.8.35 || ^5.7 || 6.5 - 8",
                    "psr/log": "^1.0",
                    "symfony/process": "^2.5 || ^3.0 || ^4.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Composer\\CaBundle\\": "src"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Jordi Boggiano",
                        "email": "j.boggiano@seld.be",
                        "homepage": "http://seld.be"
                    }
                ],
                "description": "Lets you find a path to the system CA bundle, and includes a fallback to the Mozilla CA bundle.",
                "keywords": [
                    "cabundle",
                    "cacert",
                    "certificate",
                    "ssl",
                    "tls"
                ],
                "time": "2019-08-30T08:44:50+00:00"
            },
            {
                "name": "composer/semver",
                "version": "1.5.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/composer/semver.git",
                    "reference": "46d9139568ccb8d9e7cdd4539cab7347568a5e2e"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/composer/semver/zipball/46d9139568ccb8d9e7cdd4539cab7347568a5e2e",
                    "reference": "46d9139568ccb8d9e7cdd4539cab7347568a5e2e",
                    "shasum": ""
                },
                "require": {
                    "php": "^5.3.2 || ^7.0"
                },
                "require-dev": {
                    "phpunit/phpunit": "^4.5 || ^5.0.5",
                    "phpunit/phpunit-mock-objects": "2.3.0 || ^3.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Composer\\Semver\\": "src"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Nils Adermann",
                        "email": "naderman@naderman.de",
                        "homepage": "http://www.naderman.de"
                    },
                    {
                        "name": "Jordi Boggiano",
                        "email": "j.boggiano@seld.be",
                        "homepage": "http://seld.be"
                    },
                    {
                        "name": "Rob Bast",
                        "email": "rob.bast@gmail.com",
                        "homepage": "http://robbast.nl"
                    }
                ],
                "description": "Semver library that offers utilities, version constraint parsing and validation.",
                "keywords": [
                    "semantic",
                    "semver",
                    "validation",
                    "versioning"
                ],
                "time": "2019-03-19T17:25:45+00:00"
            },
            {
                "name": "contao-community-alliance/composer-plugin",
                "version": "3.0.9",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-community-alliance/composer-plugin.git",
                    "reference": "2686fb2299fa4fcde1d3a54ec10cd497661d8536"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-community-alliance/composer-plugin/zipball/2686fb2299fa4fcde1d3a54ec10cd497661d8536",
                    "reference": "2686fb2299fa4fcde1d3a54ec10cd497661d8536",
                    "shasum": ""
                },
                "require": {
                    "composer-plugin-api": "^1.0",
                    "php": "^5.4 || ^7.0",
                    "symfony/finder": "^2.7 || ^3.0 || ^4.0",
                    "symfony/process": "^2.7 || ^3.0 || ^4.0"
                },
                "conflict": {
                    "contao/core": "*",
                    "contao/core-bundle": "<4.1"
                },
                "require-dev": {
                    "composer/composer": "~1.0",
                    "phpcq/all-tasks": "~1.1",
                    "symfony/phpunit-bridge": "^3.0"
                },
                "type": "composer-plugin",
                "extra": {
                    "class": "ContaoCommunityAlliance\\Composer\\Plugin\\Plugin",
                    "branch-alias": {
                        "dev-master": "3.0.x-dev",
                        "dev-develop": "3.1.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "ContaoCommunityAlliance\\Composer\\Plugin\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0+"
                ],
                "description": "Composer plugin that provides installers for contao-module and legacy-contao-module.",
                "homepage": "http://c-c-a.org/",
                "time": "2018-07-22T21:42:30+00:00"
            },
            {
                "name": "contao-components/ace",
                "version": "1.4.4",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/ace.git",
                    "reference": "3286db19f52cee5f85362dedcc438516a4ba2cad"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/ace/zipball/3286db19f52cee5f85362dedcc438516a4ba2cad",
                    "reference": "3286db19f52cee5f85362dedcc438516a4ba2cad",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "BSD-3-Clause"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "ACE code editor integration for Contao Open Source CMS",
                "time": "2019-05-10T15:18:26+00:00"
            },
            {
                "name": "contao-components/chosen",
                "version": "1.2.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/chosen.git",
                    "reference": "637bd469f4230fc63c4cc594478a7515bdd9fa35"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/chosen/zipball/637bd469f4230fc63c4cc594478a7515bdd9fa35",
                    "reference": "637bd469f4230fc63c4cc594478a7515bdd9fa35",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Chosen integration for Contao Open Source CMS",
                "time": "2019-07-12T07:17:07+00:00"
            },
            {
                "name": "contao-components/colorbox",
                "version": "1.6.5",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/colorbox.git",
                    "reference": "8cc986821413921f2bdba85219c13ed86902b1cf"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/colorbox/zipball/8cc986821413921f2bdba85219c13ed86902b1cf",
                    "reference": "8cc986821413921f2bdba85219c13ed86902b1cf",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Colorbox integration for Contao Open Source CMS",
                "time": "2019-07-12T07:20:55+00:00"
            },
            {
                "name": "contao-components/colorpicker",
                "version": "1.5.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/colorpicker.git",
                    "reference": "b9545f1fa3e4f0f4f577caf7fc743c0530157122"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/colorpicker/zipball/b9545f1fa3e4f0f4f577caf7fc743c0530157122",
                    "reference": "b9545f1fa3e4f0f4f577caf7fc743c0530157122",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Color picker integration for Contao Open Source CMS",
                "time": "2019-07-12T07:24:03+00:00"
            },
            {
                "name": "contao-components/compass",
                "version": "0.12.2.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/compass.git",
                    "reference": "57f0d49607922a71b78101728cf03a5bde287a28"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/compass/zipball/57f0d49607922a71b78101728cf03a5bde287a28",
                    "reference": "57f0d49607922a71b78101728cf03a5bde287a28",
                    "shasum": ""
                },
                "type": "library",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Compass integration for Contao Open Source CMS",
                "time": "2016-07-07T11:45:34+00:00"
            },
            {
                "name": "contao-components/contao",
                "version": "7.1.5",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/contao.git",
                    "reference": "13b71489b62b63c5dd72d1e10d821aed551b0558"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/contao/zipball/13b71489b62b63c5dd72d1e10d821aed551b0558",
                    "reference": "13b71489b62b63c5dd72d1e10d821aed551b0558",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Contao Open Source CMS components",
                "time": "2018-02-27T21:13:23+00:00"
            },
            {
                "name": "contao-components/datepicker",
                "version": "2.3.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/datepicker.git",
                    "reference": "6551767a7283383d893989767d3182fb88049ab6"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/datepicker/zipball/6551767a7283383d893989767d3182fb88049ab6",
                    "reference": "6551767a7283383d893989767d3182fb88049ab6",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Date picker integration for Contao Open Source CMS",
                "time": "2019-07-12T07:31:22+00:00"
            },
            {
                "name": "contao-components/dropzone",
                "version": "4.3.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/dropzone.git",
                    "reference": "5d198fb01f58fd79ff1bd7f5b187060393f8c505"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/dropzone/zipball/5d198fb01f58fd79ff1bd7f5b187060393f8c505",
                    "reference": "5d198fb01f58fd79ff1bd7f5b187060393f8c505",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "~1.0"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "DropZone integration for Contao Open Source CMS",
                "time": "2017-01-09T20:15:57+00:00"
            },
            {
                "name": "contao-components/highlight",
                "version": "8.9.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/highlight.git",
                    "reference": "92851aa223c597bfa15ebb170877af92d7243293"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/highlight/zipball/92851aa223c597bfa15ebb170877af92d7243293",
                    "reference": "92851aa223c597bfa15ebb170877af92d7243293",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "~1.0"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Highlight.js integration for Contao Open Source CMS",
                "time": "2015-11-10T13:11:20+00:00"
            },
            {
                "name": "contao-components/html5shiv",
                "version": "3.7.3",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/html5shiv.git",
                    "reference": "15fa06ddc9bc47a09f0c31bb93e26b789c3b43ea"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/html5shiv/zipball/15fa06ddc9bc47a09f0c31bb93e26b789c3b43ea",
                    "reference": "15fa06ddc9bc47a09f0c31bb93e26b789c3b43ea",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "~1.0"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "HTML5 Shiv integration for Contao Open Source CMS",
                "time": "2015-11-10T10:48:13+00:00"
            },
            {
                "name": "contao-components/installer",
                "version": "1.3.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/installer.git",
                    "reference": "0d04932172668f24f3b7af2ff26bf4b7fe0d9de5"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/installer/zipball/0d04932172668f24f3b7af2ff26bf4b7fe0d9de5",
                    "reference": "0d04932172668f24f3b7af2ff26bf4b7fe0d9de5",
                    "shasum": ""
                },
                "require": {
                    "composer-plugin-api": "^1.0",
                    "php": "^5.6 || ^7.0"
                },
                "require-dev": {
                    "composer/composer": "^1.0",
                    "friendsofphp/php-cs-fixer": "^2.12",
                    "php-coveralls/php-coveralls": "^2.1",
                    "phpunit/phpunit": "^5.7.26"
                },
                "type": "composer-plugin",
                "extra": {
                    "class": "Contao\\ComponentsInstaller\\Composer\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\ComponentsInstaller\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Contao components installer",
                "time": "2018-12-21T15:54:01+00:00"
            },
            {
                "name": "contao-components/jquery",
                "version": "1.12.4",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/jquery.git",
                    "reference": "59c19392c1544945f90bb360a1b83abacae87a52"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/jquery/zipball/59c19392c1544945f90bb360a1b83abacae87a52",
                    "reference": "59c19392c1544945f90bb360a1b83abacae87a52",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "~1.0"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "jQuery integration for Contao Open Source CMS",
                "time": "2016-09-06T09:45:28+00:00"
            },
            {
                "name": "contao-components/jquery-ui",
                "version": "1.12.1.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/jquery-ui.git",
                    "reference": "1fabbe27469a6b44130c1ad38bd1aa0a2a3720a1"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/jquery-ui/zipball/1fabbe27469a6b44130c1ad38bd1aa0a2a3720a1",
                    "reference": "1fabbe27469a6b44130c1ad38bd1aa0a2a3720a1",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "jQuery UI integration for Contao Open Source CMS",
                "time": "2017-09-26T08:11:43+00:00"
            },
            {
                "name": "contao-components/mediabox",
                "version": "1.5.5",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/mediabox.git",
                    "reference": "8f56fdbcfe7156e90a7f43e4976e09f61bdb1082"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/mediabox/zipball/8f56fdbcfe7156e90a7f43e4976e09f61bdb1082",
                    "reference": "8f56fdbcfe7156e90a7f43e4976e09f61bdb1082",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Mediabox integration for Contao Open Source CMS",
                "time": "2019-07-12T07:33:27+00:00"
            },
            {
                "name": "contao-components/mediaelement",
                "version": "4.2.10",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/mediaelement.git",
                    "reference": "b3b7b802ccab9f5514400bb4f99eaf24ef6d49e2"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/mediaelement/zipball/b3b7b802ccab9f5514400bb4f99eaf24ef6d49e2",
                    "reference": "b3b7b802ccab9f5514400bb4f99eaf24ef6d49e2",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "MediaElement.js integration for Contao Open Source CMS",
                "time": "2019-03-18T12:06:23+00:00"
            },
            {
                "name": "contao-components/mootools",
                "version": "1.6.0.6",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/mootools.git",
                    "reference": "cd812036f79b2d55dd0feddd7b96c180c1f04bab"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/mootools/zipball/cd812036f79b2d55dd0feddd7b96c180c1f04bab",
                    "reference": "cd812036f79b2d55dd0feddd7b96c180c1f04bab",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "MooTools integration for Contao Open Source CMS",
                "time": "2019-07-12T07:37:02+00:00"
            },
            {
                "name": "contao-components/respimage",
                "version": "1.4.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/respimage.git",
                    "reference": "c8e20216d7e958447b17429d631341dfdd0ebed9"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/respimage/zipball/c8e20216d7e958447b17429d631341dfdd0ebed9",
                    "reference": "c8e20216d7e958447b17429d631341dfdd0ebed9",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "~1.0"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Respimage.js integration for Contao Open Source CMS",
                "time": "2015-11-10T10:49:03+00:00"
            },
            {
                "name": "contao-components/simplemodal",
                "version": "2.1.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/simplemodal.git",
                    "reference": "3f3d4d7005ec3d670c791993ab7bb2c78e7b7849"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/simplemodal/zipball/3f3d4d7005ec3d670c791993ab7bb2c78e7b7849",
                    "reference": "3f3d4d7005ec3d670c791993ab7bb2c78e7b7849",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "SimpleModal integration for Contao Open Source CMS",
                "time": "2019-07-12T07:39:02+00:00"
            },
            {
                "name": "contao-components/swipe",
                "version": "2.2.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/swipe.git",
                    "reference": "1c2acad8b32681ba829d66e99da340666f69b9d9"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/swipe/zipball/1c2acad8b32681ba829d66e99da340666f69b9d9",
                    "reference": "1c2acad8b32681ba829d66e99da340666f69b9d9",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "A JavaScript touch slider with dot menu",
                "time": "2019-09-12T10:53:06+00:00"
            },
            {
                "name": "contao-components/tablesort",
                "version": "3.4.12",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/tablesort.git",
                    "reference": "17e920af665bb89910d094d2df8c5b3014ca239f"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/tablesort/zipball/17e920af665bb89910d094d2df8c5b3014ca239f",
                    "reference": "17e920af665bb89910d094d2df8c5b3014ca239f",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Contao Open Source CMS tablesort",
                "time": "2019-07-12T07:42:48+00:00"
            },
            {
                "name": "contao-components/tablesorter",
                "version": "2.1.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/tablesorter.git",
                    "reference": "98748a7a0ed5410876538d13cb0c78dab46eb6a2"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/tablesorter/zipball/98748a7a0ed5410876538d13cb0c78dab46eb6a2",
                    "reference": "98748a7a0ed5410876538d13cb0c78dab46eb6a2",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "jQuery tablesorter integration for Contao Open Source CMS",
                "time": "2019-07-12T07:45:35+00:00"
            },
            {
                "name": "contao-components/tinymce4",
                "version": "4.6.7.3",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/tinymce4.git",
                    "reference": "a41576ff01899056e1a7ab51cab564669df0094f"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/tinymce4/zipball/a41576ff01899056e1a7ab51cab564669df0094f",
                    "reference": "a41576ff01899056e1a7ab51cab564669df0094f",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-2.1+"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "TinyMCE 4 integration for Contao Open Source CMS",
                "time": "2019-06-12T10:06:04+00:00"
            },
            {
                "name": "contao/calendar-bundle",
                "version": "4.4.44",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/calendar-bundle.git",
                    "reference": "cef60542e70ebfde08c5a285755e0fd606c6bdcd"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/calendar-bundle/zipball/cef60542e70ebfde08c5a285755e0fd606c6bdcd",
                    "reference": "cef60542e70ebfde08c5a285755e0fd606c6bdcd",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "self.version",
                    "php": "^5.6 || ^7.0",
                    "symfony/framework-bundle": "^3.3"
                },
                "conflict": {
                    "contao/core": "*",
                    "contao/manager-plugin": "<2.0 || >=3.0"
                },
                "require-dev": {
                    "contao/manager-plugin": "^2.0",
                    "php-http/guzzle6-adapter": "^1.1",
                    "phpunit/phpunit": "^5.7.26"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\CalendarBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\CalendarBundle\\": "src/"
                    },
                    "classmap": [
                        "src/Resources/contao/"
                    ],
                    "exclude-from-classmap": [
                        "src/Resources/contao/config/",
                        "src/Resources/contao/dca/",
                        "src/Resources/contao/languages/",
                        "src/Resources/contao/templates/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    },
                    {
                        "name": "Contao Community",
                        "homepage": "https://contao.org/contributors"
                    }
                ],
                "description": "Adds calendar functionality to Contao 4",
                "time": "2019-09-30T11:42:29+00:00"
            },
            {
                "name": "contao/comments-bundle",
                "version": "4.4.44",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/comments-bundle.git",
                    "reference": "e4c2bb39fcbbd56b1d5efed468ef2c5722f9a625"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/comments-bundle/zipball/e4c2bb39fcbbd56b1d5efed468ef2c5722f9a625",
                    "reference": "e4c2bb39fcbbd56b1d5efed468ef2c5722f9a625",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "self.version",
                    "php": "^5.6 || ^7.0",
                    "symfony/framework-bundle": "^3.3"
                },
                "conflict": {
                    "contao/core": "*",
                    "contao/manager-plugin": "<2.0 || >=3.0"
                },
                "require-dev": {
                    "contao/manager-plugin": "^2.0",
                    "php-http/guzzle6-adapter": "^1.1"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\CommentsBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\CommentsBundle\\": "src/"
                    },
                    "classmap": [
                        "src/Resources/contao/"
                    ],
                    "exclude-from-classmap": [
                        "src/Resources/contao/config/",
                        "src/Resources/contao/dca/",
                        "src/Resources/contao/languages/",
                        "src/Resources/contao/templates/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    },
                    {
                        "name": "Contao Community",
                        "homepage": "https://contao.org/contributors"
                    }
                ],
                "description": "Adds comments functionality to Contao 4",
                "time": "2019-09-27T20:53:40+00:00"
            },
            {
                "name": "contao/conflicts",
                "version": "dev-master",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/conflicts.git",
                    "reference": "c08b748d2f773bde3a187c22c9a18443e619bd24"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/conflicts/zipball/c08b748d2f773bde3a187c22c9a18443e619bd24",
                    "reference": "c08b748d2f773bde3a187c22c9a18443e619bd24",
                    "shasum": ""
                },
                "conflict": {
                    "doctrine/dbal": "2.9.* <2.9.3",
                    "doctrine/doctrine-migrations-bundle": "<1.1",
                    "doctrine/orm": "<2.4",
                    "knplabs/knp-time-bundle": "1.9.0",
                    "lexik/maintenance-bundle": "2.1.4",
                    "symfony/finder": "3.4.7 || 4.0.7",
                    "symfony/framework-bundle": "4.2.7",
                    "symfony/security": "3.3.17 || 3.4.7 || 3.4.8 || 3.4.11",
                    "symfony/swiftmailer-bundle": "2.6.* <2.6.2",
                    "symfony/twig-bundle": "4.1.0",
                    "twig/twig": "2.7.0"
                },
                "type": "metapackage",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Contao 4 conflicting packages",
                "time": "2019-09-05T14:17:32+00:00"
            },
            {
                "name": "contao/core-bundle",
                "version": "4.4.44",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/core-bundle.git",
                    "reference": "a6db1ef86204e82f6934f90d3c70b8d173e7621c"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/core-bundle/zipball/a6db1ef86204e82f6934f90d3c70b8d173e7621c",
                    "reference": "a6db1ef86204e82f6934f90d3c70b8d173e7621c",
                    "shasum": ""
                },
                "require": {
                    "contao-components/ace": "^1.2",
                    "contao-components/chosen": "^1.1.6",
                    "contao-components/colorbox": "^1.6",
                    "contao-components/colorpicker": "^1.4.0.1",
                    "contao-components/compass": "^0.12",
                    "contao-components/contao": "^7.1.4",
                    "contao-components/datepicker": "^2.2.0.2",
                    "contao-components/dropzone": "^4.1.1",
                    "contao-components/highlight": "^8.9",
                    "contao-components/html5shiv": "^3.7.3",
                    "contao-components/jquery": "^1.11.3",
                    "contao-components/jquery-ui": "^1.11.4",
                    "contao-components/mediabox": "^1.5",
                    "contao-components/mediaelement": "^4.1",
                    "contao-components/mootools": "^1.6.0.1",
                    "contao-components/respimage": "^1.4",
                    "contao-components/simplemodal": "^2.0.3",
                    "contao-components/swipe": "^2.0.3",
                    "contao-components/tablesort": "^3.4.5",
                    "contao-components/tablesorter": "^2.0.5.3",
                    "contao-components/tinymce4": "4.6.*",
                    "contao/image": "^0.3.1",
                    "contao/imagine-svg": "^0.1.2 || ^0.2",
                    "doctrine/dbal": "^2.5",
                    "doctrine/doctrine-bundle": "^1.6",
                    "doctrine/doctrine-cache-bundle": "^1.3",
                    "ext-dom": "*",
                    "ext-gd": "*",
                    "ext-pcre": "*",
                    "imagine/imagine": "^0.6 || ^0.7 || ^1.0",
                    "knplabs/knp-menu-bundle": "^2.1",
                    "knplabs/knp-time-bundle": "^1.5.2",
                    "league/uri": "^4.0",
                    "matthiasmullie/minify": "^1.3",
                    "michelf/php-markdown": "^1.4",
                    "nelmio/cors-bundle": "^1.5.3",
                    "oyejorge/less.php": "^1.7",
                    "patchwork/utf8": "^1.2",
                    "php": "^5.6 || ^7.0",
                    "phpspec/php-diff": "^1.0",
                    "phpunit/php-token-stream": "^1.4 || ^2.0 || ^3.0",
                    "psr/log": "^1.0",
                    "scssphp/scssphp": "^1.0",
                    "simplepie/simplepie": "^1.3",
                    "symfony/console": "^3.3.7",
                    "symfony/filesystem": "^3.3",
                    "symfony/finder": "^3.3",
                    "symfony/framework-bundle": "^3.3",
                    "symfony/http-foundation": "^3.3.5",
                    "symfony/security": "^3.3",
                    "symfony/swiftmailer-bundle": "^2.3",
                    "symfony/yaml": "^3.3",
                    "tecnickcom/tcpdf": "^6.2.22",
                    "terminal42/header-replay-bundle": "^1.2",
                    "true/punycode": "^2.1",
                    "twig/twig": "^1.26",
                    "webmozart/path-util": "^2.0"
                },
                "conflict": {
                    "contao-community-alliance/composer-plugin": "<3.0",
                    "contao/core": "*",
                    "contao/manager-plugin": "<2.0 || >=3.0",
                    "doctrine/dbal": "2.9.* <2.9.3",
                    "doctrine/doctrine-migrations-bundle": "<1.1",
                    "doctrine/orm": "<2.4",
                    "knplabs/knp-time-bundle": "1.9.0",
                    "lexik/maintenance-bundle": "2.1.4",
                    "symfony/finder": "3.4.7",
                    "symfony/security": "3.3.17 || 3.4.7 || 3.4.8 || 3.4.11",
                    "symfony/swiftmailer-bundle": "2.6.* <2.6.2"
                },
                "require-dev": {
                    "composer/composer": "^1.0",
                    "contao/manager-plugin": "^2.2",
                    "doctrine/doctrine-migrations-bundle": "^1.1",
                    "doctrine/orm": "^2.5",
                    "ext-fileinfo": "*",
                    "lexik/maintenance-bundle": "^2.1.3",
                    "monolog/monolog": "^1.22",
                    "php-http/guzzle6-adapter": "^1.1",
                    "phpunit/phpunit": "^5.7.26",
                    "symfony/phpunit-bridge": "^3.3.11"
                },
                "suggest": {
                    "lexik/maintenance-bundle": "To put the application into maintenance mode"
                },
                "type": "symfony-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\CoreBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\CoreBundle\\": "src/"
                    },
                    "classmap": [
                        "src/Resources/contao/"
                    ],
                    "files": [
                        "src/Resources/functions/utf8_bootup.php"
                    ],
                    "exclude-from-classmap": [
                        "src/Resources/contao/config/",
                        "src/Resources/contao/dca/",
                        "src/Resources/contao/helper/functions.php",
                        "src/Resources/contao/languages/",
                        "src/Resources/contao/templates/",
                        "src/Resources/contao/themes/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    },
                    {
                        "name": "Contao Community",
                        "homepage": "https://contao.org/contributors"
                    }
                ],
                "description": "Contao 4 core bundle",
                "time": "2019-10-01T09:39:52+00:00"
            },
            {
                "name": "contao/faq-bundle",
                "version": "4.4.44",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/faq-bundle.git",
                    "reference": "7d9da093df2e0aef779b28f33bfaf718f47e582a"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/faq-bundle/zipball/7d9da093df2e0aef779b28f33bfaf718f47e582a",
                    "reference": "7d9da093df2e0aef779b28f33bfaf718f47e582a",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "self.version",
                    "php": "^5.6 || ^7.0",
                    "symfony/framework-bundle": "^3.3"
                },
                "conflict": {
                    "contao/core": "*",
                    "contao/manager-plugin": "<2.0 || >=3.0"
                },
                "require-dev": {
                    "contao/manager-plugin": "^2.0",
                    "php-http/guzzle6-adapter": "^1.1",
                    "phpunit/phpunit": "^5.7.26"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\FaqBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\FaqBundle\\": "src/"
                    },
                    "classmap": [
                        "src/Resources/contao/"
                    ],
                    "exclude-from-classmap": [
                        "src/Resources/contao/config/",
                        "src/Resources/contao/dca/",
                        "src/Resources/contao/languages/",
                        "src/Resources/contao/templates/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    },
                    {
                        "name": "Contao Community",
                        "homepage": "https://contao.org/contributors"
                    }
                ],
                "description": "Adds FAQ functionality to Contao 4",
                "time": "2019-09-30T11:42:29+00:00"
            },
            {
                "name": "contao/image",
                "version": "0.3.9",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/image.git",
                    "reference": "c5d4aa8fc3226306a3e85cfd05dd0a764f8cab79"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/image/zipball/c5d4aa8fc3226306a3e85cfd05dd0a764f8cab79",
                    "reference": "c5d4aa8fc3226306a3e85cfd05dd0a764f8cab79",
                    "shasum": ""
                },
                "require": {
                    "contao/imagine-svg": "^0.1.4 || ^0.2",
                    "imagine/imagine": "^0.6 || ^0.7 || ^1.0",
                    "php": "^5.6 || ^7.0",
                    "symfony/filesystem": "^2.8 || ^3.0 || ^4.0",
                    "webmozart/path-util": "^2.0"
                },
                "require-dev": {
                    "friendsofphp/php-cs-fixer": "^2.12",
                    "php-coveralls/php-coveralls": "^2.1",
                    "phpunit/phpunit": "^5.7.26"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-develop": "0.4.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\Image\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Martin Auswöger",
                        "homepage": "https://github.com/ausi"
                    }
                ],
                "description": "Contao image library",
                "time": "2019-01-28T20:29:46+00:00"
            },
            {
                "name": "contao/imagine-svg",
                "version": "0.2.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/imagine-svg.git",
                    "reference": "df9603dce9176eff8a66e1d0c8defffb87275ee3"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/imagine-svg/zipball/df9603dce9176eff8a66e1d0c8defffb87275ee3",
                    "reference": "df9603dce9176eff8a66e1d0c8defffb87275ee3",
                    "shasum": ""
                },
                "require": {
                    "ext-dom": "*",
                    "imagine/imagine": "^0.6 || ^0.7 || ^1.0",
                    "php": "^5.6 || ^7.0"
                },
                "require-dev": {
                    "friendsofphp/php-cs-fixer": "^2.12",
                    "php-coveralls/php-coveralls": "^2.1",
                    "phpunit/phpunit": "^5.7.26",
                    "symfony/filesystem": "^2.8 || ^3.0 || ^4.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-develop": "0.2.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\ImagineSvg\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Martin Auswöger",
                        "homepage": "https://github.com/ausi"
                    }
                ],
                "description": "Contao Imagine SVG library",
                "time": "2019-01-27T12:41:51+00:00"
            },
            {
                "name": "contao/installation-bundle",
                "version": "4.4.44",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/installation-bundle.git",
                    "reference": "c65217df408aa146141f94ee5bba7c7d47c3498e"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/installation-bundle/zipball/c65217df408aa146141f94ee5bba7c7d47c3498e",
                    "reference": "c65217df408aa146141f94ee5bba7c7d47c3498e",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "self.version",
                    "php": "^5.6 || ^7.0",
                    "sensio/distribution-bundle": "^5.0",
                    "sensiolabs/ansi-to-html": "^1.1",
                    "symfony/filesystem": "^3.3",
                    "symfony/framework-bundle": "^3.3"
                },
                "conflict": {
                    "contao/core": "*",
                    "contao/manager-plugin": "<2.0 || >=3.0"
                },
                "require-dev": {
                    "contao/manager-plugin": "^2.0",
                    "php-http/guzzle6-adapter": "^1.1",
                    "phpunit/phpunit": "^5.7.26"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\InstallationBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\InstallationBundle\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    },
                    {
                        "name": "Contao Community",
                        "homepage": "https://contao.org/contributors"
                    }
                ],
                "description": "Required to install and update Contao 4",
                "time": "2019-10-01T09:39:52+00:00"
            },
            {
                "name": "contao/listing-bundle",
                "version": "4.4.44",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/listing-bundle.git",
                    "reference": "a0173ef3c7c85b3b498ce84076e0d78596af628c"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/listing-bundle/zipball/a0173ef3c7c85b3b498ce84076e0d78596af628c",
                    "reference": "a0173ef3c7c85b3b498ce84076e0d78596af628c",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "self.version",
                    "php": "^5.6 || ^7.0",
                    "symfony/framework-bundle": "^3.3"
                },
                "conflict": {
                    "contao/core": "*",
                    "contao/manager-plugin": "<2.0 || >=3.0"
                },
                "require-dev": {
                    "contao/manager-plugin": "^2.0",
                    "php-http/guzzle6-adapter": "^1.1"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\ListingBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\ListingBundle\\": "src/"
                    },
                    "classmap": [
                        "src/Resources/contao/"
                    ],
                    "exclude-from-classmap": [
                        "src/Resources/contao/config/",
                        "src/Resources/contao/dca/",
                        "src/Resources/contao/languages/",
                        "src/Resources/contao/templates/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    },
                    {
                        "name": "Contao Community",
                        "homepage": "https://contao.org/contributors"
                    }
                ],
                "description": "Allows to list arbitrary data in the Contao 4 front end",
                "time": "2019-09-27T20:53:40+00:00"
            },
            {
                "name": "contao/manager-bundle",
                "version": "4.4.44",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/manager-bundle.git",
                    "reference": "3c12bd07d38083fb35896f1275d1e2c2e14def1f"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/manager-bundle/zipball/3c12bd07d38083fb35896f1275d1e2c2e14def1f",
                    "reference": "3c12bd07d38083fb35896f1275d1e2c2e14def1f",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "self.version",
                    "contao/installation-bundle": "self.version",
                    "contao/manager-plugin": "^2.1",
                    "doctrine/doctrine-bundle": "^1.6",
                    "friendsofsymfony/http-cache": "^2.0",
                    "lexik/maintenance-bundle": "^2.1.3",
                    "nelmio/security-bundle": "^2.2",
                    "php": "^5.6 || ^7.0",
                    "php-http/guzzle6-adapter": "^1.1",
                    "symfony/monolog-bundle": "^2.8 || ^3.0",
                    "symfony/swiftmailer-bundle": "^2.3",
                    "symfony/symfony": "^3.3.7",
                    "terminal42/header-replay-bundle": "^1.4.2",
                    "toflar/psr6-symfony-http-cache-store": "^2.0"
                },
                "require-dev": {
                    "composer/composer": "^1.0",
                    "phpunit/phpunit": "^5.7.26",
                    "symfony/phpunit-bridge": "^3.3.11"
                },
                "bin": [
                    "bin/contao-console"
                ],
                "type": "symfony-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\ManagerBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\ManagerBundle\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Andreas Schempp",
                        "homepage": "https://github.com/aschempp"
                    }
                ],
                "description": "Contao 4 manager bundle",
                "time": "2019-09-27T20:53:40+00:00"
            },
            {
                "name": "contao/manager-plugin",
                "version": "2.7.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/manager-plugin.git",
                    "reference": "8691b133a0790e4b771ca02a9ce0649aa5600551"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/manager-plugin/zipball/8691b133a0790e4b771ca02a9ce0649aa5600551",
                    "reference": "8691b133a0790e4b771ca02a9ce0649aa5600551",
                    "shasum": ""
                },
                "require": {
                    "composer-plugin-api": "^1.1",
                    "php": "^7.1",
                    "symfony/config": "^3.3 || ^4.0",
                    "symfony/dependency-injection": "^3.3 || ^4.0",
                    "symfony/filesystem": "^3.3 || ^4.0",
                    "symfony/http-kernel": "^3.3 || ^4.0",
                    "symfony/routing": "^3.3 || ^4.0"
                },
                "require-dev": {
                    "composer/composer": "^1.1",
                    "contao/core-bundle": "^4.5",
                    "ext-zip": "*",
                    "friendsofphp/php-cs-fixer": "^2.14",
                    "php-coveralls/php-coveralls": "^2.1",
                    "php-http/guzzle6-adapter": "^1.1",
                    "phpunit/phpunit": "^6.5",
                    "symfony/phpunit-bridge": "^3.4.5"
                },
                "type": "composer-plugin",
                "extra": {
                    "class": [
                        "Contao\\ManagerPlugin\\Composer\\ArtifactsPlugin",
                        "Contao\\ManagerPlugin\\Composer\\ManagerPluginInstaller"
                    ]
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\ManagerPlugin\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Andreas Schempp",
                        "homepage": "https://github.com/aschempp"
                    }
                ],
                "description": "Contao 4 manager plugin",
                "time": "2019-06-07T09:58:11+00:00"
            },
            {
                "name": "contao/news-bundle",
                "version": "4.4.44",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/news-bundle.git",
                    "reference": "19249eea40edc41fa29f30659492c12370dc7bde"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/news-bundle/zipball/19249eea40edc41fa29f30659492c12370dc7bde",
                    "reference": "19249eea40edc41fa29f30659492c12370dc7bde",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "self.version",
                    "php": "^5.6 || ^7.0",
                    "symfony/framework-bundle": "^3.3"
                },
                "conflict": {
                    "contao/core": "*",
                    "contao/manager-plugin": "<2.0 || >=3.0"
                },
                "require-dev": {
                    "contao/manager-plugin": "^2.0",
                    "php-http/guzzle6-adapter": "^1.1",
                    "phpunit/phpunit": "^5.7.26"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\NewsBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\NewsBundle\\": "src/"
                    },
                    "classmap": [
                        "src/Resources/contao/"
                    ],
                    "exclude-from-classmap": [
                        "src/Resources/contao/config/",
                        "src/Resources/contao/dca/",
                        "src/Resources/contao/languages/",
                        "src/Resources/contao/templates/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    },
                    {
                        "name": "Contao Community",
                        "homepage": "https://contao.org/contributors"
                    }
                ],
                "description": "Adds news functionality to Contao 4",
                "time": "2019-09-30T11:42:29+00:00"
            },
            {
                "name": "contao/newsletter-bundle",
                "version": "4.4.44",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/newsletter-bundle.git",
                    "reference": "b1e9ccaa810e60a2e26ede94dc2185e55fc4914e"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/newsletter-bundle/zipball/b1e9ccaa810e60a2e26ede94dc2185e55fc4914e",
                    "reference": "b1e9ccaa810e60a2e26ede94dc2185e55fc4914e",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "self.version",
                    "php": "^5.6 || ^7.0",
                    "symfony/framework-bundle": "^3.3"
                },
                "conflict": {
                    "contao/core": "*",
                    "contao/manager-plugin": "<2.0 || >=3.0"
                },
                "require-dev": {
                    "contao/manager-plugin": "^2.0",
                    "php-http/guzzle6-adapter": "^1.1"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\NewsletterBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\NewsletterBundle\\": "src/"
                    },
                    "classmap": [
                        "src/Resources/contao/"
                    ],
                    "exclude-from-classmap": [
                        "src/Resources/contao/config/",
                        "src/Resources/contao/dca/",
                        "src/Resources/contao/languages/",
                        "src/Resources/contao/templates/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    },
                    {
                        "name": "Contao Community",
                        "homepage": "https://contao.org/contributors"
                    }
                ],
                "description": "Adds newsletter functionality to Contao 4",
                "time": "2019-09-30T11:42:29+00:00"
            },
            {
                "name": "crossjoin/browscap",
                "version": "v1.0.6",
                "source": {
                    "type": "git",
                    "url": "https://github.com/crossjoin/Browscap.git",
                    "reference": "e5fa0314c3190a58c8dc6a9ea0ff19eacdc1e6c0"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/crossjoin/Browscap/zipball/e5fa0314c3190a58c8dc6a9ea0ff19eacdc1e6c0",
                    "reference": "e5fa0314c3190a58c8dc6a9ea0ff19eacdc1e6c0",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.0"
                },
                "suggest": {
                    "php": ">=5.5.0"
                },
                "type": "library",
                "autoload": {
                    "psr-4": {
                        "Crossjoin\\Browscap\\": "src/Crossjoin/Browscap/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Christoph Ziegenberg",
                        "email": "ziegenberg@crossjoin.com",
                        "role": "Developer"
                    }
                ],
                "description": "The standalone PHP Browscap parser Crossjoin\\Browscap detects browser properties as well as device information based on the user agent string of the requesting browsers and search engines, using the data from the Browser Capabilities Project. It's several hundred times faster than the build-in PHP function get_browser(), and faster than other Browscap PHP libraries, with much lower memory consumption. Optionally Crossjoin\\Browscap automatically updates the Browscap data, so you're always up-to-date. It supports PHP 5.3 to PHP 7.0 (PHP 5.5+ recommended).",
                "homepage": "https://github.com/crossjoin/Browscap",
                "keywords": [
                    "Browscap",
                    "browser",
                    "capabilities",
                    "client",
                    "detection",
                    "device",
                    "get_browser",
                    "php",
                    "properties",
                    "user agent"
                ],
                "time": "2016-03-30T14:41:57+00:00"
            },
            {
                "name": "delahaye/dlh_geocode",
                "version": "1.1.4",
                "source": {
                    "type": "git",
                    "url": "https://github.com/delahaye/dlh_geocode.git",
                    "reference": "2af3383a040a2a3893a1f3e3be6ba0de35c7629f"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/delahaye/dlh_geocode/zipball/2af3383a040a2a3893a1f3e3be6ba0de35c7629f",
                    "reference": "2af3383a040a2a3893a1f3e3be6ba0de35c7629f",
                    "shasum": ""
                },
                "require": {
                    "contao-community-alliance/composer-plugin": "~2.4 || ~3.0",
                    "contao/core-bundle": "^3.5 || ~4.2",
                    "php": ">=5.3"
                },
                "replace": {
                    "contao-legacy/dlh_geocode": "*"
                },
                "type": "contao-module",
                "extra": {
                    "contao": {
                        "sources": {
                            "": "system/modules/dlh_geocode"
                        }
                    }
                },
                "autoload": {
                    "classmap": [
                        ""
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Christian de la Haye",
                        "email": "service@delahaye.de",
                        "homepage": "http://www.delahaye.de",
                        "role": "Developer"
                    }
                ],
                "description": "Get geo coordinates from a given address",
                "homepage": "https://github.com/delahaye/dlh_geocode",
                "keywords": [
                    "contao",
                    "geo",
                    "googlemaps"
                ],
                "time": "2018-05-09T09:25:13+00:00"
            },
            {
                "name": "delahaye/dlh_googlemaps",
                "version": "2.4.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/delahaye/dlh_googlemaps.git",
                    "reference": "64445235168d18066e4f430762828dd2aaa3312b"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/delahaye/dlh_googlemaps/zipball/64445235168d18066e4f430762828dd2aaa3312b",
                    "reference": "64445235168d18066e4f430762828dd2aaa3312b",
                    "shasum": ""
                },
                "require": {
                    "contao-community-alliance/composer-plugin": "~2.4 || ~3.0",
                    "contao/core-bundle": "^3.5.1 || ~4.2",
                    "delahaye/dlh_geocode": ">=1.1.2",
                    "php": ">=5.3"
                },
                "replace": {
                    "contao-legacy/dlh_googlemaps": "*"
                },
                "type": "contao-module",
                "extra": {
                    "contao": {
                        "sources": {
                            "": "system/modules/dlh_googlemaps"
                        },
                        "runonce": [
                            "system/modules/dlh_googlemaps/config/runonce.php"
                        ]
                    }
                },
                "autoload": {
                    "classmap": [
                        ""
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Christian de la Haye",
                        "email": "service@delahaye.de",
                        "homepage": "http://www.delahaye.de",
                        "role": "Developer"
                    }
                ],
                "description": "Google maps module for Contao",
                "homepage": "https://github.com/delahaye/dlh_googlemaps",
                "keywords": [
                    "contao",
                    "geo",
                    "googlemaps",
                    "map"
                ],
                "time": "2018-05-09T09:21:33+00:00"
            },
            {
                "name": "dklemmt/contao_dk_mmenu",
                "version": "3.1.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/dklemmt/contao_dk_mmenu.git",
                    "reference": "3f49fc0f88be06abb4055a3879010170ffcc04a1"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/dklemmt/contao_dk_mmenu/zipball/3f49fc0f88be06abb4055a3879010170ffcc04a1",
                    "reference": "3f49fc0f88be06abb4055a3879010170ffcc04a1",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "^4.4",
                    "php": ">=7.1"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao-manager-plugin": "DirkKlemmt\\ContaoMmenuBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "DirkKlemmt\\ContaoMmenuBundle\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Dirk Klemmt",
                        "email": "dirch@quantentunnel.de",
                        "role": "Developer"
                    },
                    {
                        "name": "Fritz Michael Gschwantner",
                        "email": "fmg@inspiredminds.at",
                        "role": "Developer"
                    }
                ],
                "description": "Implementation of mmenu as an extension for the Contao Open Source CMS.",
                "keywords": [
                    "contao",
                    "menu",
                    "mobile",
                    "navigation"
                ],
                "time": "2019-09-17T07:55:55+00:00"
            },
            {
                "name": "do-while/contao-backupdb-bundle",
                "version": "1.4.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/do-while/contao-BackupDB.git",
                    "reference": "4092341b232cecb37b88f36731a7e39e5f6964b2"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/do-while/contao-BackupDB/zipball/4092341b232cecb37b88f36731a7e39e5f6964b2",
                    "reference": "4092341b232cecb37b88f36731a7e39e5f6964b2",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": ">=4.4.0,<5.0",
                    "php": ">=5.6.0",
                    "symfony/routing": "^3.0 || ^4.0"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao-manager-plugin": "Softleister\\BackupDbBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "classmap": [
                        "src/Resources/contao/"
                    ],
                    "exclude-from-classmap": [
                        "src/Resources/contao/cache/",
                        "src/Resources/contao/config/",
                        "src/Resources/contao/dca/",
                        "src/Resources/contao/languages/",
                        "src/Resources/contao/templates/"
                    ],
                    "psr-4": {
                        "Softleister\\BackupDbBundle\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0+"
                ],
                "authors": [
                    {
                        "name": "Hagen Klemp",
                        "homepage": "https://www.softleister.de",
                        "role": "Project leader"
                    }
                ],
                "description": "Backup of the Contao database, automatic backup, creation of website templates for the Install Tool",
                "homepage": "https://www.softleister.de",
                "keywords": [
                    "backup",
                    "contao",
                    "website template",
                    "widget"
                ],
                "time": "2019-05-26T17:25:24+00:00"
            },
            {
                "name": "doctrine/annotations",
                "version": "v1.8.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/annotations.git",
                    "reference": "904dca4eb10715b92569fbcd79e201d5c349b6bc"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/annotations/zipball/904dca4eb10715b92569fbcd79e201d5c349b6bc",
                    "reference": "904dca4eb10715b92569fbcd79e201d5c349b6bc",
                    "shasum": ""
                },
                "require": {
                    "doctrine/lexer": "1.*",
                    "php": "^7.1"
                },
                "require-dev": {
                    "doctrine/cache": "1.*",
                    "phpunit/phpunit": "^7.5"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.7.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Common\\Annotations\\": "lib/Doctrine/Common/Annotations"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    }
                ],
                "description": "Docblock Annotations Parser",
                "homepage": "http://www.doctrine-project.org",
                "keywords": [
                    "annotations",
                    "docblock",
                    "parser"
                ],
                "time": "2019-10-01T18:55:10+00:00"
            },
            {
                "name": "doctrine/cache",
                "version": "v1.8.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/cache.git",
                    "reference": "d768d58baee9a4862ca783840eca1b9add7a7f57"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/cache/zipball/d768d58baee9a4862ca783840eca1b9add7a7f57",
                    "reference": "d768d58baee9a4862ca783840eca1b9add7a7f57",
                    "shasum": ""
                },
                "require": {
                    "php": "~7.1"
                },
                "conflict": {
                    "doctrine/common": ">2.2,<2.4"
                },
                "require-dev": {
                    "alcaeus/mongo-php-adapter": "^1.1",
                    "doctrine/coding-standard": "^4.0",
                    "mongodb/mongodb": "^1.1",
                    "phpunit/phpunit": "^7.0",
                    "predis/predis": "~1.0"
                },
                "suggest": {
                    "alcaeus/mongo-php-adapter": "Required to use legacy MongoDB driver"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.8.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Common\\Cache\\": "lib/Doctrine/Common/Cache"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    }
                ],
                "description": "Caching library offering an object-oriented API for many cache backends",
                "homepage": "https://www.doctrine-project.org",
                "keywords": [
                    "cache",
                    "caching"
                ],
                "time": "2018-08-21T18:01:43+00:00"
            },
            {
                "name": "doctrine/collections",
                "version": "v1.6.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/collections.git",
                    "reference": "c5e0bc17b1620e97c968ac409acbff28b8b850be"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/collections/zipball/c5e0bc17b1620e97c968ac409acbff28b8b850be",
                    "reference": "c5e0bc17b1620e97c968ac409acbff28b8b850be",
                    "shasum": ""
                },
                "require": {
                    "php": "^7.1.3"
                },
                "require-dev": {
                    "doctrine/coding-standard": "^6.0",
                    "phpstan/phpstan-shim": "^0.9.2",
                    "phpunit/phpunit": "^7.0",
                    "vimeo/psalm": "^3.2.2"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.6.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Common\\Collections\\": "lib/Doctrine/Common/Collections"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    }
                ],
                "description": "PHP Doctrine Collections library that adds additional functionality on top of PHP arrays.",
                "homepage": "https://www.doctrine-project.org/projects/collections.html",
                "keywords": [
                    "array",
                    "collections",
                    "iterators",
                    "php"
                ],
                "time": "2019-06-09T13:48:14+00:00"
            },
            {
                "name": "doctrine/common",
                "version": "v2.11.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/common.git",
                    "reference": "b8ca1dcf6b0dc8a2af7a09baac8d0c48345df4ff"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/common/zipball/b8ca1dcf6b0dc8a2af7a09baac8d0c48345df4ff",
                    "reference": "b8ca1dcf6b0dc8a2af7a09baac8d0c48345df4ff",
                    "shasum": ""
                },
                "require": {
                    "doctrine/annotations": "^1.0",
                    "doctrine/cache": "^1.0",
                    "doctrine/collections": "^1.0",
                    "doctrine/event-manager": "^1.0",
                    "doctrine/inflector": "^1.0",
                    "doctrine/lexer": "^1.0",
                    "doctrine/persistence": "^1.1",
                    "doctrine/reflection": "^1.0",
                    "php": "^7.1"
                },
                "require-dev": {
                    "doctrine/coding-standard": "^1.0",
                    "phpstan/phpstan": "^0.11",
                    "phpstan/phpstan-phpunit": "^0.11",
                    "phpunit/phpunit": "^7.0",
                    "squizlabs/php_codesniffer": "^3.0",
                    "symfony/phpunit-bridge": "^4.0.5"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "2.11.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Common\\": "lib/Doctrine/Common"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    },
                    {
                        "name": "Marco Pivetta",
                        "email": "ocramius@gmail.com"
                    }
                ],
                "description": "PHP Doctrine Common project is a library that provides additional functionality that other Doctrine projects depend on such as better reflection support, persistence interfaces, proxies, event system and much more.",
                "homepage": "https://www.doctrine-project.org/projects/common.html",
                "keywords": [
                    "common",
                    "doctrine",
                    "php"
                ],
                "time": "2019-09-10T10:10:14+00:00"
            },
            {
                "name": "doctrine/dbal",
                "version": "v2.8.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/dbal.git",
                    "reference": "a9019c1e3232eacace373a6ba957a85b66a255c1"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/dbal/zipball/a9019c1e3232eacace373a6ba957a85b66a255c1",
                    "reference": "a9019c1e3232eacace373a6ba957a85b66a255c1",
                    "shasum": ""
                },
                "require": {
                    "doctrine/cache": "^1.0",
                    "doctrine/event-manager": "^1.0",
                    "ext-pdo": "*",
                    "php": "^7.1"
                },
                "require-dev": {
                    "doctrine/coding-standard": "^4.0",
                    "jetbrains/phpstorm-stubs": "^2018.1.2",
                    "phpstan/phpstan": "^0.10.1",
                    "phpunit/phpunit": "^7.1.2",
                    "phpunit/phpunit-mock-objects": "!=3.2.4,!=3.2.5",
                    "symfony/console": "^2.0.5|^3.0|^4.0",
                    "symfony/phpunit-bridge": "^3.4.5|^4.0.5"
                },
                "suggest": {
                    "symfony/console": "For helpful console commands such as SQL execution and import of files."
                },
                "bin": [
                    "bin/doctrine-dbal"
                ],
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "2.8.x-dev",
                        "dev-develop": "3.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-0": {
                        "Doctrine\\DBAL\\": "lib/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    }
                ],
                "description": "Database Abstraction Layer",
                "homepage": "http://www.doctrine-project.org",
                "keywords": [
                    "database",
                    "dbal",
                    "persistence",
                    "queryobject"
                ],
                "time": "2018-12-04T06:44:25+00:00"
            },
            {
                "name": "doctrine/doctrine-bundle",
                "version": "1.11.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/DoctrineBundle.git",
                    "reference": "28101e20776d8fa20a00b54947fbae2db0d09103"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/DoctrineBundle/zipball/28101e20776d8fa20a00b54947fbae2db0d09103",
                    "reference": "28101e20776d8fa20a00b54947fbae2db0d09103",
                    "shasum": ""
                },
                "require": {
                    "doctrine/dbal": "^2.5.12",
                    "doctrine/doctrine-cache-bundle": "~1.2",
                    "jdorn/sql-formatter": "^1.2.16",
                    "php": "^7.1",
                    "symfony/config": "^3.4|^4.1",
                    "symfony/console": "^3.4|^4.1",
                    "symfony/dependency-injection": "^3.4|^4.1",
                    "symfony/doctrine-bridge": "^3.4|^4.1",
                    "symfony/framework-bundle": "^3.4|^4.1"
                },
                "conflict": {
                    "doctrine/orm": "<2.6",
                    "twig/twig": "<1.34|>=2.0,<2.4"
                },
                "require-dev": {
                    "doctrine/coding-standard": "^6.0",
                    "doctrine/orm": "^2.6",
                    "php-coveralls/php-coveralls": "^2.1",
                    "phpunit/phpunit": "7.0",
                    "symfony/cache": "^3.4|^4.1",
                    "symfony/phpunit-bridge": "^4.2",
                    "symfony/property-info": "^3.4|^4.1",
                    "symfony/validator": "^3.4|^4.1",
                    "symfony/web-profiler-bundle": "^3.4|^4.1",
                    "symfony/yaml": "^3.4|^4.1",
                    "twig/twig": "^1.34|^2.4"
                },
                "suggest": {
                    "doctrine/orm": "The Doctrine ORM integration is optional in the bundle.",
                    "symfony/web-profiler-bundle": "To use the data collector."
                },
                "type": "symfony-bundle",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.11.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Bundle\\DoctrineBundle\\": ""
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Symfony Community",
                        "homepage": "http://symfony.com/contributors"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Doctrine Project",
                        "homepage": "http://www.doctrine-project.org/"
                    },
                    {
                        "name": "Fabien Potencier",
                        "email": "fabien@symfony.com"
                    }
                ],
                "description": "Symfony DoctrineBundle",
                "homepage": "http://www.doctrine-project.org",
                "keywords": [
                    "database",
                    "dbal",
                    "orm",
                    "persistence"
                ],
                "time": "2019-06-04T07:35:05+00:00"
            },
            {
                "name": "doctrine/doctrine-cache-bundle",
                "version": "1.3.5",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/DoctrineCacheBundle.git",
                    "reference": "5514c90d9fb595e1095e6d66ebb98ce9ef049927"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/DoctrineCacheBundle/zipball/5514c90d9fb595e1095e6d66ebb98ce9ef049927",
                    "reference": "5514c90d9fb595e1095e6d66ebb98ce9ef049927",
                    "shasum": ""
                },
                "require": {
                    "doctrine/cache": "^1.4.2",
                    "doctrine/inflector": "~1.0",
                    "php": ">=5.3.2",
                    "symfony/doctrine-bridge": "~2.7|~3.3|~4.0"
                },
                "require-dev": {
                    "instaclick/coding-standard": "~1.1",
                    "instaclick/object-calisthenics-sniffs": "dev-master",
                    "instaclick/symfony2-coding-standard": "dev-remaster",
                    "phpunit/phpunit": "~4.8.36|~5.6|~6.5|~7.0",
                    "predis/predis": "~0.8",
                    "satooshi/php-coveralls": "^1.0",
                    "squizlabs/php_codesniffer": "~1.5",
                    "symfony/console": "~2.7|~3.3|~4.0",
                    "symfony/finder": "~2.7|~3.3|~4.0",
                    "symfony/framework-bundle": "~2.7|~3.3|~4.0",
                    "symfony/phpunit-bridge": "~2.7|~3.3|~4.0",
                    "symfony/security-acl": "~2.7|~3.3",
                    "symfony/validator": "~2.7|~3.3|~4.0",
                    "symfony/yaml": "~2.7|~3.3|~4.0"
                },
                "suggest": {
                    "symfony/security-acl": "For using this bundle to cache ACLs"
                },
                "type": "symfony-bundle",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.3.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Bundle\\DoctrineCacheBundle\\": ""
                    },
                    "exclude-from-classmap": [
                        "/Tests/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Symfony Community",
                        "homepage": "http://symfony.com/contributors"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Fabio B. Silva",
                        "email": "fabio.bat.silva@gmail.com"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@hotmail.com"
                    },
                    {
                        "name": "Doctrine Project",
                        "homepage": "http://www.doctrine-project.org/"
                    },
                    {
                        "name": "Fabien Potencier",
                        "email": "fabien@symfony.com"
                    }
                ],
                "description": "Symfony Bundle for Doctrine Cache",
                "homepage": "https://www.doctrine-project.org",
                "keywords": [
                    "cache",
                    "caching"
                ],
                "time": "2018-11-09T06:25:35+00:00"
            },
            {
                "name": "doctrine/event-manager",
                "version": "v1.0.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/event-manager.git",
                    "reference": "a520bc093a0170feeb6b14e9d83f3a14452e64b3"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/event-manager/zipball/a520bc093a0170feeb6b14e9d83f3a14452e64b3",
                    "reference": "a520bc093a0170feeb6b14e9d83f3a14452e64b3",
                    "shasum": ""
                },
                "require": {
                    "php": "^7.1"
                },
                "conflict": {
                    "doctrine/common": "<2.9@dev"
                },
                "require-dev": {
                    "doctrine/coding-standard": "^4.0",
                    "phpunit/phpunit": "^7.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Common\\": "lib/Doctrine/Common"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    },
                    {
                        "name": "Marco Pivetta",
                        "email": "ocramius@gmail.com"
                    }
                ],
                "description": "Doctrine Event Manager component",
                "homepage": "https://www.doctrine-project.org/projects/event-manager.html",
                "keywords": [
                    "event",
                    "eventdispatcher",
                    "eventmanager"
                ],
                "time": "2018-06-11T11:59:03+00:00"
            },
            {
                "name": "doctrine/inflector",
                "version": "v1.3.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/inflector.git",
                    "reference": "5527a48b7313d15261292c149e55e26eae771b0a"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/inflector/zipball/5527a48b7313d15261292c149e55e26eae771b0a",
                    "reference": "5527a48b7313d15261292c149e55e26eae771b0a",
                    "shasum": ""
                },
                "require": {
                    "php": "^7.1"
                },
                "require-dev": {
                    "phpunit/phpunit": "^6.2"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.3.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Common\\Inflector\\": "lib/Doctrine/Common/Inflector"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    }
                ],
                "description": "Common String Manipulations with regard to casing and singular/plural rules.",
                "homepage": "http://www.doctrine-project.org",
                "keywords": [
                    "inflection",
                    "pluralize",
                    "singularize",
                    "string"
                ],
                "time": "2018-01-09T20:05:19+00:00"
            },
            {
                "name": "doctrine/lexer",
                "version": "1.1.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/lexer.git",
                    "reference": "e17f069ede36f7534b95adec71910ed1b49c74ea"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/lexer/zipball/e17f069ede36f7534b95adec71910ed1b49c74ea",
                    "reference": "e17f069ede36f7534b95adec71910ed1b49c74ea",
                    "shasum": ""
                },
                "require": {
                    "php": "^7.2"
                },
                "require-dev": {
                    "doctrine/coding-standard": "^6.0",
                    "phpstan/phpstan": "^0.11.8",
                    "phpunit/phpunit": "^8.2"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.1.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Common\\Lexer\\": "lib/Doctrine/Common/Lexer"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    }
                ],
                "description": "PHP Doctrine Lexer parser library that can be used in Top-Down, Recursive Descent Parsers.",
                "homepage": "https://www.doctrine-project.org/projects/lexer.html",
                "keywords": [
                    "annotations",
                    "docblock",
                    "lexer",
                    "parser",
                    "php"
                ],
                "time": "2019-07-30T19:33:28+00:00"
            },
            {
                "name": "doctrine/persistence",
                "version": "1.1.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/persistence.git",
                    "reference": "3da7c9d125591ca83944f477e65ed3d7b4617c48"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/persistence/zipball/3da7c9d125591ca83944f477e65ed3d7b4617c48",
                    "reference": "3da7c9d125591ca83944f477e65ed3d7b4617c48",
                    "shasum": ""
                },
                "require": {
                    "doctrine/annotations": "^1.0",
                    "doctrine/cache": "^1.0",
                    "doctrine/collections": "^1.0",
                    "doctrine/event-manager": "^1.0",
                    "doctrine/reflection": "^1.0",
                    "php": "^7.1"
                },
                "conflict": {
                    "doctrine/common": "<2.10@dev"
                },
                "require-dev": {
                    "doctrine/coding-standard": "^5.0",
                    "phpstan/phpstan": "^0.8",
                    "phpunit/phpunit": "^7.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.1.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Common\\": "lib/Doctrine/Common"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    },
                    {
                        "name": "Marco Pivetta",
                        "email": "ocramius@gmail.com"
                    }
                ],
                "description": "The Doctrine Persistence project is a set of shared interfaces and functionality that the different Doctrine object mappers share.",
                "homepage": "https://doctrine-project.org/projects/persistence.html",
                "keywords": [
                    "mapper",
                    "object",
                    "odm",
                    "orm",
                    "persistence"
                ],
                "time": "2019-04-23T08:28:24+00:00"
            },
            {
                "name": "doctrine/reflection",
                "version": "v1.0.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/reflection.git",
                    "reference": "02538d3f95e88eb397a5f86274deb2c6175c2ab6"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/reflection/zipball/02538d3f95e88eb397a5f86274deb2c6175c2ab6",
                    "reference": "02538d3f95e88eb397a5f86274deb2c6175c2ab6",
                    "shasum": ""
                },
                "require": {
                    "doctrine/annotations": "^1.0",
                    "ext-tokenizer": "*",
                    "php": "^7.1"
                },
                "require-dev": {
                    "doctrine/coding-standard": "^4.0",
                    "doctrine/common": "^2.8",
                    "phpstan/phpstan": "^0.9.2",
                    "phpstan/phpstan-phpunit": "^0.9.4",
                    "phpunit/phpunit": "^7.0",
                    "squizlabs/php_codesniffer": "^3.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Common\\": "lib/Doctrine/Common"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    },
                    {
                        "name": "Marco Pivetta",
                        "email": "ocramius@gmail.com"
                    }
                ],
                "description": "Doctrine Reflection component",
                "homepage": "https://www.doctrine-project.org/projects/reflection.html",
                "keywords": [
                    "reflection"
                ],
                "time": "2018-06-14T14:45:07+00:00"
            },
            {
                "name": "fig/link-util",
                "version": "1.0.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/php-fig/link-util.git",
                    "reference": "1a07821801a148be4add11ab0603e4af55a72fac"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/php-fig/link-util/zipball/1a07821801a148be4add11ab0603e4af55a72fac",
                    "reference": "1a07821801a148be4add11ab0603e4af55a72fac",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.5.0",
                    "psr/link": "~1.0@dev"
                },
                "require-dev": {
                    "phpunit/phpunit": "^5.1",
                    "squizlabs/php_codesniffer": "^2.3.1"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Fig\\Link\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "PHP-FIG",
                        "homepage": "http://www.php-fig.org/"
                    }
                ],
                "description": "Common utility implementations for HTTP links",
                "keywords": [
                    "http",
                    "http-link",
                    "link",
                    "psr",
                    "psr-13",
                    "rest"
                ],
                "time": "2016-10-17T18:31:11+00:00"
            },
            {
                "name": "friendsofsymfony/http-cache",
                "version": "2.7.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/FriendsOfSymfony/FOSHttpCache.git",
                    "reference": "eb1a2c995bcbdb965ad7f0dc2ca5e93885b51ce4"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/FriendsOfSymfony/FOSHttpCache/zipball/eb1a2c995bcbdb965ad7f0dc2ca5e93885b51ce4",
                    "reference": "eb1a2c995bcbdb965ad7f0dc2ca5e93885b51ce4",
                    "shasum": ""
                },
                "require": {
                    "php": "^5.6 || ^7.0.0",
                    "php-http/client-common": "^1.1.0 || ^2.0",
                    "php-http/client-implementation": "^1.0 || ^2.0",
                    "php-http/discovery": "^1.0 || ^2.0",
                    "php-http/message": "^1.0 || ^2.0",
                    "symfony/event-dispatcher": "^3.4 || ^4.0",
                    "symfony/options-resolver": "^3.4 || ^4.0"
                },
                "conflict": {
                    "toflar/psr6-symfony-http-cache-store": "<1.1.2"
                },
                "require-dev": {
                    "mockery/mockery": "~0.9.5",
                    "monolog/monolog": "^1.0",
                    "php-http/guzzle6-adapter": "^1.0 || ^2.0",
                    "php-http/mock-client": "^1.2",
                    "phpunit/phpunit": "^5.7 || ^6.0",
                    "symfony/http-kernel": "^3.4 || ^4.0",
                    "symfony/process": "^3.4 || ^4.0"
                },
                "suggest": {
                    "friendsofsymfony/http-cache-bundle": "For integration with the Symfony framework",
                    "monolog/monolog": "For logging issues while invalidating"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "2.6.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "FOS\\HttpCache\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Liip AG",
                        "homepage": "http://www.liip.ch/"
                    },
                    {
                        "name": "Driebit",
                        "email": "tech@driebit.nl",
                        "homepage": "http://www.driebit.nl"
                    },
                    {
                        "name": "Community contributions",
                        "homepage": "https://github.com/friendsofsymfony/FOSHttpCache/contributors"
                    }
                ],
                "description": "Tools to manage HTTP caching proxies with PHP",
                "homepage": "https://github.com/friendsofsymfony/FOSHttpCache",
                "keywords": [
                    "caching",
                    "http",
                    "invalidation",
                    "nginx",
                    "purge",
                    "varnish"
                ],
                "time": "2019-05-14T12:36:21+00:00"
            },
            {
                "name": "friendsofsymfony/http-cache-bundle",
                "version": "2.7.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/FriendsOfSymfony/FOSHttpCacheBundle.git",
                    "reference": "7b672c17bddd7166768776e2382e12c8e9fe5557"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/FriendsOfSymfony/FOSHttpCacheBundle/zipball/7b672c17bddd7166768776e2382e12c8e9fe5557",
                    "reference": "7b672c17bddd7166768776e2382e12c8e9fe5557",
                    "shasum": ""
                },
                "require": {
                    "friendsofsymfony/http-cache": "^2.5.2",
                    "php": "^7.1",
                    "symfony/framework-bundle": "^3.4.4 || ^4.0",
                    "symfony/http-foundation": "^3.4.4 || ^4.0",
                    "symfony/http-kernel": "^3.4.4 || ^4.0"
                },
                "conflict": {
                    "symfony/monolog-bridge": "<3.4.4",
                    "twig/twig": "<1.12.0"
                },
                "require-dev": {
                    "matthiasnoback/symfony-dependency-injection-test": "^2.3",
                    "mockery/mockery": "^1.0",
                    "monolog/monolog": "*",
                    "php-http/guzzle6-adapter": "^1.0 || ^2.0",
                    "php-http/message": "^1.0",
                    "sebastian/exporter": "^2.0",
                    "sensio/framework-extra-bundle": "^3.0",
                    "symfony/browser-kit": "^3.4.4 || ^4.0",
                    "symfony/console": "^3.4.4 || ^4.0",
                    "symfony/css-selector": "^3.4.4 || ^4.0",
                    "symfony/expression-language": "^3.4.4 || ^4.0",
                    "symfony/finder": "^3.4.4 || ^4.0",
                    "symfony/monolog-bundle": "^3.0",
                    "symfony/phpunit-bridge": "^4.2.4",
                    "symfony/routing": "^3.4.4 || ^4.0",
                    "symfony/security-bundle": "^3.4.4 || ^4.0",
                    "symfony/twig-bundle": "^3.4.4 || ^4.0",
                    "symfony/yaml": "^3.4.4 || ^4.0"
                },
                "suggest": {
                    "sensio/framework-extra-bundle": "For Tagged Cache Invalidation",
                    "symfony/console": "To send invalidation requests from the command line",
                    "symfony/expression-language": "For Tagged Cache Invalidation"
                },
                "type": "symfony-bundle",
                "extra": {
                    "branch-alias": {
                        "dev-master": "2.5.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "FOS\\HttpCacheBundle\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Liip AG",
                        "homepage": "http://www.liip.ch/"
                    },
                    {
                        "name": "Driebit",
                        "email": "tech@driebit.nl",
                        "homepage": "http://www.driebit.nl"
                    },
                    {
                        "name": "Community contributions",
                        "homepage": "https://github.com/friendsofsymfony/FOSHttpCacheBundle/contributors"
                    }
                ],
                "description": "Set path based HTTP cache headers and send invalidation requests to your HTTP cache",
                "homepage": "https://github.com/FriendsOfSymfony/FOSHttpCacheBundle",
                "keywords": [
                    "caching",
                    "esi",
                    "http",
                    "invalidation",
                    "purge",
                    "varnish"
                ],
                "time": "2019-10-16T08:39:03+00:00"
            },
            {
                "name": "guzzlehttp/guzzle",
                "version": "6.3.3",
                "source": {
                    "type": "git",
                    "url": "https://github.com/guzzle/guzzle.git",
                    "reference": "407b0cb880ace85c9b63c5f9551db498cb2d50ba"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/guzzle/guzzle/zipball/407b0cb880ace85c9b63c5f9551db498cb2d50ba",
                    "reference": "407b0cb880ace85c9b63c5f9551db498cb2d50ba",
                    "shasum": ""
                },
                "require": {
                    "guzzlehttp/promises": "^1.0",
                    "guzzlehttp/psr7": "^1.4",
                    "php": ">=5.5"
                },
                "require-dev": {
                    "ext-curl": "*",
                    "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.4 || ^7.0",
                    "psr/log": "^1.0"
                },
                "suggest": {
                    "psr/log": "Required for using the Log middleware"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "6.3-dev"
                    }
                },
                "autoload": {
                    "files": [
                        "src/functions_include.php"
                    ],
                    "psr-4": {
                        "GuzzleHttp\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Michael Dowling",
                        "email": "mtdowling@gmail.com",
                        "homepage": "https://github.com/mtdowling"
                    }
                ],
                "description": "Guzzle is a PHP HTTP client library",
                "homepage": "http://guzzlephp.org/",
                "keywords": [
                    "client",
                    "curl",
                    "framework",
                    "http",
                    "http client",
                    "rest",
                    "web service"
                ],
                "time": "2018-04-22T15:46:56+00:00"
            },
            {
                "name": "guzzlehttp/promises",
                "version": "v1.3.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/guzzle/promises.git",
                    "reference": "a59da6cf61d80060647ff4d3eb2c03a2bc694646"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/guzzle/promises/zipball/a59da6cf61d80060647ff4d3eb2c03a2bc694646",
                    "reference": "a59da6cf61d80060647ff4d3eb2c03a2bc694646",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.5.0"
                },
                "require-dev": {
                    "phpunit/phpunit": "^4.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.4-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "GuzzleHttp\\Promise\\": "src/"
                    },
                    "files": [
                        "src/functions_include.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Michael Dowling",
                        "email": "mtdowling@gmail.com",
                        "homepage": "https://github.com/mtdowling"
                    }
                ],
                "description": "Guzzle promises library",
                "keywords": [
                    "promise"
                ],
                "time": "2016-12-20T10:07:11+00:00"
            },
            {
                "name": "guzzlehttp/psr7",
                "version": "1.6.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/guzzle/psr7.git",
                    "reference": "239400de7a173fe9901b9ac7c06497751f00727a"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/guzzle/psr7/zipball/239400de7a173fe9901b9ac7c06497751f00727a",
                    "reference": "239400de7a173fe9901b9ac7c06497751f00727a",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.4.0",
                    "psr/http-message": "~1.0",
                    "ralouphie/getallheaders": "^2.0.5 || ^3.0.0"
                },
                "provide": {
                    "psr/http-message-implementation": "1.0"
                },
                "require-dev": {
                    "ext-zlib": "*",
                    "phpunit/phpunit": "~4.8.36 || ^5.7.27 || ^6.5.8"
                },
                "suggest": {
                    "zendframework/zend-httphandlerrunner": "Emit PSR-7 responses"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.6-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "GuzzleHttp\\Psr7\\": "src/"
                    },
                    "files": [
                        "src/functions_include.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Michael Dowling",
                        "email": "mtdowling@gmail.com",
                        "homepage": "https://github.com/mtdowling"
                    },
                    {
                        "name": "Tobias Schultze",
                        "homepage": "https://github.com/Tobion"
                    }
                ],
                "description": "PSR-7 message implementation that also provides common utility methods",
                "keywords": [
                    "http",
                    "message",
                    "psr-7",
                    "request",
                    "response",
                    "stream",
                    "uri",
                    "url"
                ],
                "time": "2019-07-01T23:21:34+00:00"
            },
            {
                "name": "imagine/imagine",
                "version": "1.2.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/avalanche123/Imagine.git",
                    "reference": "eec39b2092bc8008a92b8d63824476413dbe7511"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/avalanche123/Imagine/zipball/eec39b2092bc8008a92b8d63824476413dbe7511",
                    "reference": "eec39b2092bc8008a92b8d63824476413dbe7511",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.2"
                },
                "require-dev": {
                    "friendsofphp/php-cs-fixer": "2.2.*",
                    "phpunit/phpunit": "^4.8 || ^5.7 || ^6.5 || ^7.4"
                },
                "suggest": {
                    "ext-gd": "to use the GD implementation",
                    "ext-gmagick": "to use the Gmagick implementation",
                    "ext-imagick": "to use the Imagick implementation"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-develop": "0.7-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Imagine\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Bulat Shakirzyanov",
                        "email": "mallluhuct@gmail.com",
                        "homepage": "http://avalanche123.com"
                    }
                ],
                "description": "Image processing for PHP 5.3",
                "homepage": "http://imagine.readthedocs.org/",
                "keywords": [
                    "drawing",
                    "graphics",
                    "image manipulation",
                    "image processing"
                ],
                "time": "2019-07-09T06:55:48+00:00"
            },
            {
                "name": "jdorn/sql-formatter",
                "version": "v1.2.17",
                "source": {
                    "type": "git",
                    "url": "https://github.com/jdorn/sql-formatter.git",
                    "reference": "64990d96e0959dff8e059dfcdc1af130728d92bc"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/jdorn/sql-formatter/zipball/64990d96e0959dff8e059dfcdc1af130728d92bc",
                    "reference": "64990d96e0959dff8e059dfcdc1af130728d92bc",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.2.4"
                },
                "require-dev": {
                    "phpunit/phpunit": "3.7.*"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.3.x-dev"
                    }
                },
                "autoload": {
                    "classmap": [
                        "lib"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Jeremy Dorn",
                        "email": "jeremy@jeremydorn.com",
                        "homepage": "http://jeremydorn.com/"
                    }
                ],
                "description": "a PHP SQL highlighting library",
                "homepage": "https://github.com/jdorn/sql-formatter/",
                "keywords": [
                    "highlight",
                    "sql"
                ],
                "time": "2014-01-12T16:20:24+00:00"
            },
            {
                "name": "jean85/pretty-package-versions",
                "version": "1.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/Jean85/pretty-package-versions.git",
                    "reference": "75c7effcf3f77501d0e0caa75111aff4daa0dd48"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/Jean85/pretty-package-versions/zipball/75c7effcf3f77501d0e0caa75111aff4daa0dd48",
                    "reference": "75c7effcf3f77501d0e0caa75111aff4daa0dd48",
                    "shasum": ""
                },
                "require": {
                    "ocramius/package-versions": "^1.2.0",
                    "php": "^7.0"
                },
                "require-dev": {
                    "phpunit/phpunit": "^6.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Jean85\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Alessandro Lai",
                        "email": "alessandro.lai85@gmail.com"
                    }
                ],
                "description": "A wrapper for ocramius/package-versions to get pretty versions strings",
                "keywords": [
                    "composer",
                    "package",
                    "release",
                    "versions"
                ],
                "time": "2018-06-13T13:22:40+00:00"
            },
            {
                "name": "jeremykendall/php-domain-parser",
                "version": "3.0.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/jeremykendall/php-domain-parser.git",
                    "reference": "896e7e70f02bd4fd77190052799bc61e4d779672"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/jeremykendall/php-domain-parser/zipball/896e7e70f02bd4fd77190052799bc61e4d779672",
                    "reference": "896e7e70f02bd4fd77190052799bc61e4d779672",
                    "shasum": ""
                },
                "require": {
                    "ext-curl": "*",
                    "ext-intl": "*",
                    "ext-mbstring": "*",
                    "php": ">=5.3.0"
                },
                "require-dev": {
                    "jeremykendall/debug-die": "0.0.1.*",
                    "mikey179/vfsstream": "~1.4",
                    "phpunit/phpunit": "~4.4"
                },
                "bin": [
                    "bin/parse",
                    "bin/update-psl"
                ],
                "type": "library",
                "autoload": {
                    "psr-0": {
                        "Pdp\\": "src/"
                    },
                    "files": [
                        "src/pdp-parse-url.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Jeremy Kendall",
                        "homepage": "http://about.me/jeremykendall",
                        "role": "Developer"
                    },
                    {
                        "name": "Contributors",
                        "homepage": "https://github.com/jeremykendall/php-domain-parser/graphs/contributors"
                    }
                ],
                "description": "Public Suffix List based URL parsing implemented in PHP.",
                "homepage": "https://github.com/jeremykendall/php-domain-parser",
                "keywords": [
                    "Public Suffix List",
                    "domain parsing",
                    "url parsing"
                ],
                "time": "2015-03-30T12:49:45+00:00"
            },
            {
                "name": "knplabs/knp-menu",
                "version": "2.6.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/KnpLabs/KnpMenu.git",
                    "reference": "b6aade272c345b6fbd07fce5929a761cba0909b8"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/KnpLabs/KnpMenu/zipball/b6aade272c345b6fbd07fce5929a761cba0909b8",
                    "reference": "b6aade272c345b6fbd07fce5929a761cba0909b8",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.6.0"
                },
                "conflict": {
                    "twig/twig": "<1.40|>=2,<2.9"
                },
                "require-dev": {
                    "psr/container": "^1.0",
                    "symfony/http-foundation": "~2.4|~3.0|^4.0",
                    "symfony/phpunit-bridge": "~3.3|^4.0",
                    "symfony/routing": "~2.3|~3.0|^4.0",
                    "twig/twig": "^1.40|^2.9"
                },
                "suggest": {
                    "twig/twig": "for the TwigRenderer and the integration with your templates"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "3.0-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Knp\\Menu\\": "src/Knp/Menu"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "KnpLabs",
                        "homepage": "https://knplabs.com"
                    },
                    {
                        "name": "Christophe Coevoet",
                        "email": "stof@notk.org"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://github.com/KnpLabs/KnpMenu/contributors"
                    }
                ],
                "description": "An object oriented menu library",
                "homepage": "https://knplabs.com",
                "keywords": [
                    "menu",
                    "tree"
                ],
                "time": "2019-09-02T10:16:14+00:00"
            },
            {
                "name": "knplabs/knp-menu-bundle",
                "version": "v2.3.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/KnpLabs/KnpMenuBundle.git",
                    "reference": "78b0cebf8e1490f12ba6555511282954de83f627"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/KnpLabs/KnpMenuBundle/zipball/78b0cebf8e1490f12ba6555511282954de83f627",
                    "reference": "78b0cebf8e1490f12ba6555511282954de83f627",
                    "shasum": ""
                },
                "require": {
                    "knplabs/knp-menu": "~2.3",
                    "php": "^7.1",
                    "symfony/framework-bundle": "^3.4 | ^4.0"
                },
                "require-dev": {
                    "symfony/expression-language": "^3.4 | ^4.0",
                    "symfony/phpunit-bridge": "^3.4 | ^4.0",
                    "symfony/templating": "^3.4 | ^4.0"
                },
                "type": "symfony-bundle",
                "extra": {
                    "branch-alias": {
                        "dev-master": "3.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Knp\\Bundle\\MenuBundle\\": "src"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Knplabs",
                        "homepage": "http://knplabs.com"
                    },
                    {
                        "name": "Christophe Coevoet",
                        "email": "stof@notk.org"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://github.com/KnpLabs/KnpMenuBundle/contributors"
                    }
                ],
                "description": "This bundle provides an integration of the KnpMenu library",
                "keywords": [
                    "menu"
                ],
                "time": "2019-09-19T08:51:48+00:00"
            },
            {
                "name": "knplabs/knp-time-bundle",
                "version": "v1.9.1",
                "target-dir": "Knp/Bundle/TimeBundle",
                "source": {
                    "type": "git",
                    "url": "https://github.com/KnpLabs/KnpTimeBundle.git",
                    "reference": "d8464f1f0e0bdeb6fab3dd0d34bc085705e769f0"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/KnpLabs/KnpTimeBundle/zipball/d8464f1f0e0bdeb6fab3dd0d34bc085705e769f0",
                    "reference": "d8464f1f0e0bdeb6fab3dd0d34bc085705e769f0",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.5",
                    "symfony/config": "~2.3|~3.0|~4.0",
                    "symfony/dependency-injection": "~2.3|~3.0|~4.0",
                    "symfony/templating": "~2.3|~3.0|~4.0",
                    "symfony/translation": "~2.3|~3.0|~4.0"
                },
                "require-dev": {
                    "phpunit/phpunit": "^4.8|^5.0"
                },
                "suggest": {
                    "symfony/twig-bundle": "to use the Twig time_diff function"
                },
                "type": "symfony-bundle",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.1.x-dev"
                    }
                },
                "autoload": {
                    "psr-0": {
                        "Knp\\Bundle\\TimeBundle": ""
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "KnpLabs Team",
                        "homepage": "http://knplabs.com"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "http://github.com/KnpLabs/KnpTimeBundle/contributors"
                    }
                ],
                "description": "Knplabs time bundle makes your dates look sensible and descriptive",
                "homepage": "http://github.com/KnpLabs/KnpTimeBundle",
                "keywords": [
                    "bundle",
                    "date",
                    "descriptive time",
                    "knp",
                    "knplabs",
                    "time"
                ],
                "time": "2019-04-19T10:01:52+00:00"
            },
            {
                "name": "league/uri",
                "version": "4.2.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/thephpleague/uri.git",
                    "reference": "a2e73bad7e60c3bc61b649680fb8b46876e342e3"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/thephpleague/uri/zipball/a2e73bad7e60c3bc61b649680fb8b46876e342e3",
                    "reference": "a2e73bad7e60c3bc61b649680fb8b46876e342e3",
                    "shasum": ""
                },
                "require": {
                    "ext-fileinfo": "*",
                    "ext-intl": "*",
                    "ext-mbstring": "*",
                    "jeremykendall/php-domain-parser": "^3.0",
                    "php": ">=5.5.9",
                    "psr/http-message": "^1.0"
                },
                "require-dev": {
                    "friendsofphp/php-cs-fixer": "^1.9",
                    "phpunit/phpunit": "^4.0",
                    "zendframework/zend-diactoros": "^1.3"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "4.2.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "League\\Uri\\": "src"
                    },
                    "files": [
                        "src/functions_include.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Ignace Nyamagana Butera",
                        "email": "nyamsprod@gmail.com",
                        "homepage": "https://nyamsprod.com"
                    }
                ],
                "description": "URI manipulation library",
                "homepage": "http://uri.thephpleague.com",
                "keywords": [
                    "data-uri",
                    "ftp",
                    "http",
                    "https",
                    "parse_url",
                    "psr-7",
                    "rfc3986",
                    "uri",
                    "url",
                    "ws"
                ],
                "time": "2016-12-12T11:36:42+00:00"
            },
            {
                "name": "lexik/maintenance-bundle",
                "version": "v2.1.5",
                "source": {
                    "type": "git",
                    "url": "https://github.com/lexik/LexikMaintenanceBundle.git",
                    "reference": "3a3e916776934a95834235e4a1d71e4595d515f5"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/lexik/LexikMaintenanceBundle/zipball/3a3e916776934a95834235e4a1d71e4595d515f5",
                    "reference": "3a3e916776934a95834235e4a1d71e4595d515f5",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.9",
                    "symfony/framework-bundle": "~2.7|~3.0|^4.0",
                    "symfony/translation": "~2.7|~3.0|^4.0"
                },
                "require-dev": {
                    "phpunit/phpunit": "~4.8|~5.7.11",
                    "symfony/phpunit-bridge": "~2.7|~3.0|^4.0"
                },
                "type": "symfony-bundle",
                "extra": {
                    "branch-alias": {
                        "dev-master": "2.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Lexik\\Bundle\\MaintenanceBundle\\": ""
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Dev Lexik",
                        "email": "dev@lexik.fr"
                    },
                    {
                        "name": "Gilles Gauthier",
                        "email": "g.gauthier@lexik.fr"
                    },
                    {
                        "name": "Djuri Baars",
                        "email": "info@djurict.nl"
                    }
                ],
                "description": "This bundle allows you to place your website in maintenance mode by calling two commands from your console.",
                "homepage": "https://github.com/lexik/LexikMaintenanceBundle",
                "keywords": [
                    "Symfony2",
                    "bundle",
                    "maintenance"
                ],
                "time": "2018-02-14T10:18:33+00:00"
            },
            {
                "name": "madeyourday/contao-rocksolid-antispam",
                "version": "v2.0.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/madeyourday/contao-rocksolid-antispam.git",
                    "reference": "1fbc85e0613d125260afb0fd0b1c9ccd21972f6b"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/madeyourday/contao-rocksolid-antispam/zipball/1fbc85e0613d125260afb0fd0b1c9ccd21972f6b",
                    "reference": "1fbc85e0613d125260afb0fd0b1c9ccd21972f6b",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "^4.3",
                    "php": ">=5.5"
                },
                "conflict": {
                    "contao/core": "*",
                    "contao/manager-plugin": "<2.0 || >=3.0"
                },
                "replace": {
                    "contao-legacy/rocksolid-antispam": "self.version"
                },
                "require-dev": {
                    "contao/manager-plugin": "^2.0"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao-manager-plugin": "MadeYourDay\\RockSolidAntispam\\ContaoManagerPlugin"
                },
                "autoload": {
                    "psr-4": {
                        "MadeYourDay\\RockSolidAntispam\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "RockSolid Themes",
                        "homepage": "https://rocksolidthemes.com/de/contao-themes",
                        "role": "Developer"
                    }
                ],
                "description": "Protect your site effectively from spam without causing your visitors unnecessary difficulties.",
                "homepage": "https://rocksolidthemes.com/de/contao/plugins/honeypot-antispam",
                "keywords": [
                    "contao",
                    "form",
                    "spam"
                ],
                "time": "2017-04-06T13:43:50+00:00"
            },
            {
                "name": "markbaker/complex",
                "version": "1.4.7",
                "source": {
                    "type": "git",
                    "url": "https://github.com/MarkBaker/PHPComplex.git",
                    "reference": "1ea674a8308baf547cbcbd30c5fcd6d301b7c000"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/MarkBaker/PHPComplex/zipball/1ea674a8308baf547cbcbd30c5fcd6d301b7c000",
                    "reference": "1ea674a8308baf547cbcbd30c5fcd6d301b7c000",
                    "shasum": ""
                },
                "require": {
                    "php": "^5.6.0|^7.0.0"
                },
                "require-dev": {
                    "dealerdirect/phpcodesniffer-composer-installer": "^0.4.3",
                    "phpcompatibility/php-compatibility": "^8.0",
                    "phpdocumentor/phpdocumentor": "2.*",
                    "phploc/phploc": "2.*",
                    "phpmd/phpmd": "2.*",
                    "phpunit/phpunit": "^4.8.35|^5.4.0",
                    "sebastian/phpcpd": "2.*",
                    "squizlabs/php_codesniffer": "^3.3.0"
                },
                "type": "library",
                "autoload": {
                    "psr-4": {
                        "Complex\\": "classes/src/"
                    },
                    "files": [
                        "classes/src/functions/abs.php",
                        "classes/src/functions/acos.php",
                        "classes/src/functions/acosh.php",
                        "classes/src/functions/acot.php",
                        "classes/src/functions/acoth.php",
                        "classes/src/functions/acsc.php",
                        "classes/src/functions/acsch.php",
                        "classes/src/functions/argument.php",
                        "classes/src/functions/asec.php",
                        "classes/src/functions/asech.php",
                        "classes/src/functions/asin.php",
                        "classes/src/functions/asinh.php",
                        "classes/src/functions/atan.php",
                        "classes/src/functions/atanh.php",
                        "classes/src/functions/conjugate.php",
                        "classes/src/functions/cos.php",
                        "classes/src/functions/cosh.php",
                        "classes/src/functions/cot.php",
                        "classes/src/functions/coth.php",
                        "classes/src/functions/csc.php",
                        "classes/src/functions/csch.php",
                        "classes/src/functions/exp.php",
                        "classes/src/functions/inverse.php",
                        "classes/src/functions/ln.php",
                        "classes/src/functions/log2.php",
                        "classes/src/functions/log10.php",
                        "classes/src/functions/negative.php",
                        "classes/src/functions/pow.php",
                        "classes/src/functions/rho.php",
                        "classes/src/functions/sec.php",
                        "classes/src/functions/sech.php",
                        "classes/src/functions/sin.php",
                        "classes/src/functions/sinh.php",
                        "classes/src/functions/sqrt.php",
                        "classes/src/functions/tan.php",
                        "classes/src/functions/tanh.php",
                        "classes/src/functions/theta.php",
                        "classes/src/operations/add.php",
                        "classes/src/operations/subtract.php",
                        "classes/src/operations/multiply.php",
                        "classes/src/operations/divideby.php",
                        "classes/src/operations/divideinto.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Mark Baker",
                        "email": "mark@lange.demon.co.uk"
                    }
                ],
                "description": "PHP Class for working with complex numbers",
                "homepage": "https://github.com/MarkBaker/PHPComplex",
                "keywords": [
                    "complex",
                    "mathematics"
                ],
                "time": "2018-10-13T23:28:42+00:00"
            },
            {
                "name": "markbaker/matrix",
                "version": "1.2.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/MarkBaker/PHPMatrix.git",
                    "reference": "5348c5a67e3b75cd209d70103f916a93b1f1ed21"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/MarkBaker/PHPMatrix/zipball/5348c5a67e3b75cd209d70103f916a93b1f1ed21",
                    "reference": "5348c5a67e3b75cd209d70103f916a93b1f1ed21",
                    "shasum": ""
                },
                "require": {
                    "php": "^5.6.0|^7.0.0"
                },
                "require-dev": {
                    "dealerdirect/phpcodesniffer-composer-installer": "dev-master",
                    "phpcompatibility/php-compatibility": "dev-master",
                    "phploc/phploc": "^4",
                    "phpmd/phpmd": "dev-master",
                    "phpunit/phpunit": "^5.7",
                    "sebastian/phpcpd": "^3.0",
                    "squizlabs/php_codesniffer": "^3.0@dev"
                },
                "type": "library",
                "autoload": {
                    "psr-4": {
                        "Matrix\\": "classes/src/"
                    },
                    "files": [
                        "classes/src/functions/adjoint.php",
                        "classes/src/functions/antidiagonal.php",
                        "classes/src/functions/cofactors.php",
                        "classes/src/functions/determinant.php",
                        "classes/src/functions/diagonal.php",
                        "classes/src/functions/identity.php",
                        "classes/src/functions/inverse.php",
                        "classes/src/functions/minors.php",
                        "classes/src/functions/trace.php",
                        "classes/src/functions/transpose.php",
                        "classes/src/operations/add.php",
                        "classes/src/operations/directsum.php",
                        "classes/src/operations/subtract.php",
                        "classes/src/operations/multiply.php",
                        "classes/src/operations/divideby.php",
                        "classes/src/operations/divideinto.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Mark Baker",
                        "email": "mark@lange.demon.co.uk"
                    }
                ],
                "description": "PHP Class for working with matrices",
                "homepage": "https://github.com/MarkBaker/PHPMatrix",
                "keywords": [
                    "mathematics",
                    "matrix",
                    "vector"
                ],
                "time": "2019-10-06T11:29:25+00:00"
            },
            {
                "name": "matthiasmullie/minify",
                "version": "1.3.61",
                "source": {
                    "type": "git",
                    "url": "https://github.com/matthiasmullie/minify.git",
                    "reference": "d5acb8ce5b6acb7d11bafe97cecc533f6e4fd751"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/matthiasmullie/minify/zipball/d5acb8ce5b6acb7d11bafe97cecc533f6e4fd751",
                    "reference": "d5acb8ce5b6acb7d11bafe97cecc533f6e4fd751",
                    "shasum": ""
                },
                "require": {
                    "ext-pcre": "*",
                    "matthiasmullie/path-converter": "~1.1",
                    "php": ">=5.3.0"
                },
                "require-dev": {
                    "friendsofphp/php-cs-fixer": "~2.0",
                    "matthiasmullie/scrapbook": "~1.0",
                    "phpunit/phpunit": "~4.8"
                },
                "suggest": {
                    "psr/cache-implementation": "Cache implementation to use with Minify::cache"
                },
                "bin": [
                    "bin/minifycss",
                    "bin/minifyjs"
                ],
                "type": "library",
                "autoload": {
                    "psr-4": {
                        "MatthiasMullie\\Minify\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Matthias Mullie",
                        "email": "minify@mullie.eu",
                        "homepage": "http://www.mullie.eu",
                        "role": "Developer"
                    }
                ],
                "description": "CSS & JavaScript minifier, in PHP. Removes whitespace, strips comments, combines files (incl. @import statements and small assets in CSS files), and optimizes/shortens a few common programming patterns.",
                "homepage": "http://www.minifier.org",
                "keywords": [
                    "JS",
                    "css",
                    "javascript",
                    "minifier",
                    "minify"
                ],
                "time": "2018-11-26T23:10:39+00:00"
            },
            {
                "name": "matthiasmullie/path-converter",
                "version": "1.1.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/matthiasmullie/path-converter.git",
                    "reference": "5e4b121c8b9f97c80835c1d878b0812ba1d607c9"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/matthiasmullie/path-converter/zipball/5e4b121c8b9f97c80835c1d878b0812ba1d607c9",
                    "reference": "5e4b121c8b9f97c80835c1d878b0812ba1d607c9",
                    "shasum": ""
                },
                "require": {
                    "ext-pcre": "*",
                    "php": ">=5.3.0"
                },
                "require-dev": {
                    "phpunit/phpunit": "~4.8"
                },
                "type": "library",
                "autoload": {
                    "psr-4": {
                        "MatthiasMullie\\PathConverter\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Matthias Mullie",
                        "email": "pathconverter@mullie.eu",
                        "homepage": "http://www.mullie.eu",
                        "role": "Developer"
                    }
                ],
                "description": "Relative path converter",
                "homepage": "http://github.com/matthiasmullie/path-converter",
                "keywords": [
                    "converter",
                    "path",
                    "paths",
                    "relative"
                ],
                "time": "2018-10-25T15:19:41+00:00"
            },
            {
                "name": "michelf/php-markdown",
                "version": "1.8.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/michelf/php-markdown.git",
                    "reference": "01ab082b355bf188d907b9929cd99b2923053495"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/michelf/php-markdown/zipball/01ab082b355bf188d907b9929cd99b2923053495",
                    "reference": "01ab082b355bf188d907b9929cd99b2923053495",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.0"
                },
                "type": "library",
                "autoload": {
                    "psr-4": {
                        "Michelf\\": "Michelf/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "BSD-3-Clause"
                ],
                "authors": [
                    {
                        "name": "Michel Fortin",
                        "email": "michel.fortin@michelf.ca",
                        "homepage": "https://michelf.ca/",
                        "role": "Developer"
                    },
                    {
                        "name": "John Gruber",
                        "homepage": "https://daringfireball.net/"
                    }
                ],
                "description": "PHP Markdown",
                "homepage": "https://michelf.ca/projects/php-markdown/",
                "keywords": [
                    "markdown"
                ],
                "time": "2018-01-15T00:49:33+00:00"
            },
            {
                "name": "monolog/monolog",
                "version": "1.25.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/Seldaek/monolog.git",
                    "reference": "70e65a5470a42cfec1a7da00d30edb6e617e8dcf"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/Seldaek/monolog/zipball/70e65a5470a42cfec1a7da00d30edb6e617e8dcf",
                    "reference": "70e65a5470a42cfec1a7da00d30edb6e617e8dcf",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.0",
                    "psr/log": "~1.0"
                },
                "provide": {
                    "psr/log-implementation": "1.0.0"
                },
                "require-dev": {
                    "aws/aws-sdk-php": "^2.4.9 || ^3.0",
                    "doctrine/couchdb": "~1.0@dev",
                    "graylog2/gelf-php": "~1.0",
                    "jakub-onderka/php-parallel-lint": "0.9",
                    "php-amqplib/php-amqplib": "~2.4",
                    "php-console/php-console": "^3.1.3",
                    "phpunit/phpunit": "~4.5",
                    "phpunit/phpunit-mock-objects": "2.3.0",
                    "ruflin/elastica": ">=0.90 <3.0",
                    "sentry/sentry": "^0.13",
                    "swiftmailer/swiftmailer": "^5.3|^6.0"
                },
                "suggest": {
                    "aws/aws-sdk-php": "Allow sending log messages to AWS services like DynamoDB",
                    "doctrine/couchdb": "Allow sending log messages to a CouchDB server",
                    "ext-amqp": "Allow sending log messages to an AMQP server (1.0+ required)",
                    "ext-mongo": "Allow sending log messages to a MongoDB server",
                    "graylog2/gelf-php": "Allow sending log messages to a GrayLog2 server",
                    "mongodb/mongodb": "Allow sending log messages to a MongoDB server via PHP Driver",
                    "php-amqplib/php-amqplib": "Allow sending log messages to an AMQP server using php-amqplib",
                    "php-console/php-console": "Allow sending log messages to Google Chrome",
                    "rollbar/rollbar": "Allow sending log messages to Rollbar",
                    "ruflin/elastica": "Allow sending log messages to an Elastic Search server",
                    "sentry/sentry": "Allow sending log messages to a Sentry server"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "2.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Monolog\\": "src/Monolog"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Jordi Boggiano",
                        "email": "j.boggiano@seld.be",
                        "homepage": "http://seld.be"
                    }
                ],
                "description": "Sends your logs to files, sockets, inboxes, databases and various web services",
                "homepage": "http://github.com/Seldaek/monolog",
                "keywords": [
                    "log",
                    "logging",
                    "psr-3"
                ],
                "time": "2019-09-06T13:49:17+00:00"
            },
            {
                "name": "nelmio/cors-bundle",
                "version": "1.5.6",
                "source": {
                    "type": "git",
                    "url": "https://github.com/nelmio/NelmioCorsBundle.git",
                    "reference": "10a24c10f242440211ed31075e74f81661c690d9"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/nelmio/NelmioCorsBundle/zipball/10a24c10f242440211ed31075e74f81661c690d9",
                    "reference": "10a24c10f242440211ed31075e74f81661c690d9",
                    "shasum": ""
                },
                "require": {
                    "symfony/framework-bundle": "^2.7 || ^3.0 || ^4.0"
                },
                "require-dev": {
                    "matthiasnoback/symfony-dependency-injection-test": "^1.0 || ^2.0",
                    "mockery/mockery": "^0.9 || ^1.0",
                    "symfony/phpunit-bridge": "^2.7 || ^3.0 || ^4.0"
                },
                "type": "symfony-bundle",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.5.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Nelmio\\CorsBundle\\": ""
                    },
                    "exclude-from-classmap": [
                        "/Tests/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Nelmio",
                        "homepage": "http://nelm.io"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://github.com/nelmio/NelmioCorsBundle/contributors"
                    }
                ],
                "description": "Adds CORS (Cross-Origin Resource Sharing) headers support in your Symfony2 application",
                "keywords": [
                    "api",
                    "cors",
                    "crossdomain"
                ],
                "time": "2019-06-17T08:53:14+00:00"
            },
            {
                "name": "nelmio/security-bundle",
                "version": "2.7.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/nelmio/NelmioSecurityBundle.git",
                    "reference": "ce63c12665440b538dc743dfd9afad3dadf7d12c"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/nelmio/NelmioSecurityBundle/zipball/ce63c12665440b538dc743dfd9afad3dadf7d12c",
                    "reference": "ce63c12665440b538dc743dfd9afad3dadf7d12c",
                    "shasum": ""
                },
                "require": {
                    "paragonie/random_compat": "~1.0|~2.0|9.99.99",
                    "symfony/framework-bundle": "~2.3|~3.0|~4.0",
                    "symfony/security": "~2.3|~3.0|~4.0",
                    "ua-parser/uap-php": "^3.4.4"
                },
                "require-dev": {
                    "doctrine/cache": "^1.0",
                    "psr/cache": "^1.0",
                    "symfony/phpunit-bridge": "^3.4.24|~4.0",
                    "symfony/yaml": "~2.3|~3.0|~4.0",
                    "twig/twig": "^1.24"
                },
                "suggest": {
                    "ua-parser/uap-php": "To allow adapt CSP directives given the user-agent"
                },
                "type": "symfony-bundle",
                "extra": {
                    "branch-alias": {
                        "dev-master": "2.6.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Nelmio\\SecurityBundle\\": ""
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Nelmio",
                        "homepage": "http://nelm.io"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://github.com/nelmio/NelmioSecurityBundle/contributors"
                    }
                ],
                "description": "Extra security-related features for Symfony: signed/encrypted cookies, HTTPS/SSL/HSTS handling, cookie session storage, ...",
                "keywords": [
                    "security"
                ],
                "time": "2019-04-03T13:44:45+00:00"
            },
            {
                "name": "ocramius/package-versions",
                "version": "1.4.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/Ocramius/PackageVersions.git",
                    "reference": "a4d4b60d0e60da2487bd21a2c6ac089f85570dbb"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/Ocramius/PackageVersions/zipball/a4d4b60d0e60da2487bd21a2c6ac089f85570dbb",
                    "reference": "a4d4b60d0e60da2487bd21a2c6ac089f85570dbb",
                    "shasum": ""
                },
                "require": {
                    "composer-plugin-api": "^1.0.0",
                    "php": "^7.1.0"
                },
                "require-dev": {
                    "composer/composer": "^1.6.3",
                    "doctrine/coding-standard": "^5.0.1",
                    "ext-zip": "*",
                    "infection/infection": "^0.7.1",
                    "phpunit/phpunit": "^7.0.0"
                },
                "type": "composer-plugin",
                "extra": {
                    "class": "PackageVersions\\Installer",
                    "branch-alias": {
                        "dev-master": "2.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "PackageVersions\\": "src/PackageVersions"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Marco Pivetta",
                        "email": "ocramius@gmail.com"
                    }
                ],
                "description": "Composer plugin that provides efficient querying for installed package versions (no runtime IO)",
                "time": "2019-02-21T12:16:21+00:00"
            },
            {
                "name": "oyejorge/less.php",
                "version": "v1.7.0.14",
                "source": {
                    "type": "git",
                    "url": "https://github.com/oyejorge/less.php.git",
                    "reference": "42925c5a01a07d67ca7e82dfc8fb31814d557bc9"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/oyejorge/less.php/zipball/42925c5a01a07d67ca7e82dfc8fb31814d557bc9",
                    "reference": "42925c5a01a07d67ca7e82dfc8fb31814d557bc9",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3"
                },
                "require-dev": {
                    "phpunit/phpunit": "~4.8.24"
                },
                "bin": [
                    "bin/lessc"
                ],
                "type": "library",
                "autoload": {
                    "psr-0": {
                        "Less": "lib/"
                    },
                    "classmap": [
                        "lessc.inc.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "Apache-2.0"
                ],
                "authors": [
                    {
                        "name": "Matt Agar",
                        "homepage": "https://github.com/agar"
                    },
                    {
                        "name": "Martin Jantošovi?",
                        "homepage": "https://github.com/Mordred"
                    },
                    {
                        "name": "Josh Schmidt",
                        "homepage": "https://github.com/oyejorge"
                    }
                ],
                "description": "PHP port of the Javascript version of LESS http://lesscss.org (Originally maintained by Josh Schmidt)",
                "homepage": "http://lessphp.gpeasy.com",
                "keywords": [
                    "css",
                    "less",
                    "less.js",
                    "lesscss",
                    "php",
                    "stylesheet"
                ],
                "time": "2017-03-28T22:19:25+00:00"
            },
            {
                "name": "paragonie/random_compat",
                "version": "v9.99.99",
                "source": {
                    "type": "git",
                    "url": "https://github.com/paragonie/random_compat.git",
                    "reference": "84b4dfb120c6f9b4ff7b3685f9b8f1aa365a0c95"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/paragonie/random_compat/zipball/84b4dfb120c6f9b4ff7b3685f9b8f1aa365a0c95",
                    "reference": "84b4dfb120c6f9b4ff7b3685f9b8f1aa365a0c95",
                    "shasum": ""
                },
                "require": {
                    "php": "^7"
                },
                "require-dev": {
                    "phpunit/phpunit": "4.*|5.*",
                    "vimeo/psalm": "^1"
                },
                "suggest": {
                    "ext-libsodium": "Provides a modern crypto API that can be used to generate random bytes."
                },
                "type": "library",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Paragon Initiative Enterprises",
                        "email": "security@paragonie.com",
                        "homepage": "https://paragonie.com"
                    }
                ],
                "description": "PHP 5.x polyfill for random_bytes() and random_int() from PHP 7",
                "keywords": [
                    "csprng",
                    "polyfill",
                    "pseudorandom",
                    "random"
                ],
                "time": "2018-07-02T15:55:56+00:00"
            },
            {
                "name": "patchwork/utf8",
                "version": "v1.3.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/tchwork/utf8.git",
                    "reference": "30ec6451aec7d2536f0af8fe535f70c764f2c47a"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/tchwork/utf8/zipball/30ec6451aec7d2536f0af8fe535f70c764f2c47a",
                    "reference": "30ec6451aec7d2536f0af8fe535f70c764f2c47a",
                    "shasum": ""
                },
                "require": {
                    "lib-pcre": ">=7.3",
                    "php": ">=5.3.0"
                },
                "suggest": {
                    "ext-iconv": "Use iconv for best performance",
                    "ext-intl": "Use Intl for best performance",
                    "ext-mbstring": "Use Mbstring for best performance",
                    "ext-wfio": "Use WFIO for UTF-8 filesystem access on Windows"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.3-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Patchwork\\": "src/Patchwork/"
                    },
                    "classmap": [
                        "src/Normalizer.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "(Apache-2.0 or GPL-2.0)"
                ],
                "authors": [
                    {
                        "name": "Nicolas Grekas",
                        "email": "p@tchwork.com"
                    }
                ],
                "description": "Portable and performant UTF-8, Unicode and Grapheme Clusters for PHP",
                "homepage": "https://github.com/tchwork/utf8",
                "keywords": [
                    "grapheme",
                    "i18n",
                    "unicode",
                    "utf-8",
                    "utf8"
                ],
                "time": "2016-05-18T13:57:10+00:00"
            },
            {
                "name": "php-http/client-common",
                "version": "1.9.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/php-http/client-common.git",
                    "reference": "0e156a12cc3e46f590c73bf57592a2252fc3dc48"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/php-http/client-common/zipball/0e156a12cc3e46f590c73bf57592a2252fc3dc48",
                    "reference": "0e156a12cc3e46f590c73bf57592a2252fc3dc48",
                    "shasum": ""
                },
                "require": {
                    "php": "^5.4 || ^7.0",
                    "php-http/httplug": "^1.1",
                    "php-http/message": "^1.6",
                    "php-http/message-factory": "^1.0",
                    "symfony/options-resolver": "^2.6 || ^3.0 || ^4.0"
                },
                "require-dev": {
                    "guzzlehttp/psr7": "^1.4",
                    "phpspec/phpspec": "^2.5 || ^3.4 || ^4.2"
                },
                "suggest": {
                    "php-http/cache-plugin": "PSR-6 Cache plugin",
                    "php-http/logger-plugin": "PSR-3 Logger plugin",
                    "php-http/stopwatch-plugin": "Symfony Stopwatch plugin"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.9.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Http\\Client\\Common\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Márk Sági-Kazár",
                        "email": "mark.sagikazar@gmail.com"
                    }
                ],
                "description": "Common HTTP Client implementations and tools for HTTPlug",
                "homepage": "http://httplug.io",
                "keywords": [
                    "client",
                    "common",
                    "http",
                    "httplug"
                ],
                "time": "2019-02-02T07:03:15+00:00"
            },
            {
                "name": "php-http/discovery",
                "version": "1.7.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/php-http/discovery.git",
                    "reference": "e822f86a6983790aa17ab13aa7e69631e86806b6"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/php-http/discovery/zipball/e822f86a6983790aa17ab13aa7e69631e86806b6",
                    "reference": "e822f86a6983790aa17ab13aa7e69631e86806b6",
                    "shasum": ""
                },
                "require": {
                    "php": "^7.1"
                },
                "conflict": {
                    "nyholm/psr7": "<1.0"
                },
                "require-dev": {
                    "akeneo/phpspec-skip-example-extension": "^4.0",
                    "php-http/httplug": "^1.0 || ^2.0",
                    "php-http/message-factory": "^1.0",
                    "phpspec/phpspec": "^5.1",
                    "puli/composer-plugin": "1.0.0-beta10"
                },
                "suggest": {
                    "php-http/message": "Allow to use Guzzle, Diactoros or Slim Framework factories",
                    "puli/composer-plugin": "Sets up Puli which is recommended for Discovery to work. Check http://docs.php-http.org/en/latest/discovery.html for more details."
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.7-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Http\\Discovery\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Márk Sági-Kazár",
                        "email": "mark.sagikazar@gmail.com"
                    }
                ],
                "description": "Finds installed HTTPlug implementations and PSR-7 message factories",
                "homepage": "http://php-http.org",
                "keywords": [
                    "adapter",
                    "client",
                    "discovery",
                    "factory",
                    "http",
                    "message",
                    "psr7"
                ],
                "time": "2019-06-30T09:04:27+00:00"
            },
            {
                "name": "php-http/guzzle6-adapter",
                "version": "v1.1.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/php-http/guzzle6-adapter.git",
                    "reference": "a56941f9dc6110409cfcddc91546ee97039277ab"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/php-http/guzzle6-adapter/zipball/a56941f9dc6110409cfcddc91546ee97039277ab",
                    "reference": "a56941f9dc6110409cfcddc91546ee97039277ab",
                    "shasum": ""
                },
                "require": {
                    "guzzlehttp/guzzle": "^6.0",
                    "php": ">=5.5.0",
                    "php-http/httplug": "^1.0"
                },
                "provide": {
                    "php-http/async-client-implementation": "1.0",
                    "php-http/client-implementation": "1.0"
                },
                "require-dev": {
                    "ext-curl": "*",
                    "php-http/adapter-integration-tests": "^0.4"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.2-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Http\\Adapter\\Guzzle6\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Márk Sági-Kazár",
                        "email": "mark.sagikazar@gmail.com"
                    },
                    {
                        "name": "David de Boer",
                        "email": "david@ddeboer.nl"
                    }
                ],
                "description": "Guzzle 6 HTTP Adapter",
                "homepage": "http://httplug.io",
                "keywords": [
                    "Guzzle",
                    "http"
                ],
                "time": "2016-05-10T06:13:32+00:00"
            },
            {
                "name": "php-http/httplug",
                "version": "v1.1.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/php-http/httplug.git",
                    "reference": "1c6381726c18579c4ca2ef1ec1498fdae8bdf018"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/php-http/httplug/zipball/1c6381726c18579c4ca2ef1ec1498fdae8bdf018",
                    "reference": "1c6381726c18579c4ca2ef1ec1498fdae8bdf018",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.4",
                    "php-http/promise": "^1.0",
                    "psr/http-message": "^1.0"
                },
                "require-dev": {
                    "henrikbjorn/phpspec-code-coverage": "^1.0",
                    "phpspec/phpspec": "^2.4"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.1-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Http\\Client\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Eric GELOEN",
                        "email": "geloen.eric@gmail.com"
                    },
                    {
                        "name": "Márk Sági-Kazár",
                        "email": "mark.sagikazar@gmail.com"
                    }
                ],
                "description": "HTTPlug, the HTTP client abstraction for PHP",
                "homepage": "http://httplug.io",
                "keywords": [
                    "client",
                    "http"
                ],
                "time": "2016-08-31T08:30:17+00:00"
            },
            {
                "name": "php-http/message",
                "version": "1.8.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/php-http/message.git",
                    "reference": "ce8f43ac1e294b54aabf5808515c3554a19c1e1c"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/php-http/message/zipball/ce8f43ac1e294b54aabf5808515c3554a19c1e1c",
                    "reference": "ce8f43ac1e294b54aabf5808515c3554a19c1e1c",
                    "shasum": ""
                },
                "require": {
                    "clue/stream-filter": "^1.4",
                    "php": "^7.1",
                    "php-http/message-factory": "^1.0.2",
                    "psr/http-message": "^1.0"
                },
                "provide": {
                    "php-http/message-factory-implementation": "1.0"
                },
                "require-dev": {
                    "akeneo/phpspec-skip-example-extension": "^1.0",
                    "coduo/phpspec-data-provider-extension": "^1.0",
                    "ext-zlib": "*",
                    "guzzlehttp/psr7": "^1.0",
                    "henrikbjorn/phpspec-code-coverage": "^1.0",
                    "phpspec/phpspec": "^2.4",
                    "slim/slim": "^3.0",
                    "zendframework/zend-diactoros": "^1.0"
                },
                "suggest": {
                    "ext-zlib": "Used with compressor/decompressor streams",
                    "guzzlehttp/psr7": "Used with Guzzle PSR-7 Factories",
                    "slim/slim": "Used with Slim Framework PSR-7 implementation",
                    "zendframework/zend-diactoros": "Used with Diactoros Factories"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.8-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Http\\Message\\": "src/"
                    },
                    "files": [
                        "src/filters.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Márk Sági-Kazár",
                        "email": "mark.sagikazar@gmail.com"
                    }
                ],
                "description": "HTTP Message related tools",
                "homepage": "http://php-http.org",
                "keywords": [
                    "http",
                    "message",
                    "psr-7"
                ],
                "time": "2019-08-05T06:55:08+00:00"
            },
            {
                "name": "php-http/message-factory",
                "version": "v1.0.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/php-http/message-factory.git",
                    "reference": "a478cb11f66a6ac48d8954216cfed9aa06a501a1"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/php-http/message-factory/zipball/a478cb11f66a6ac48d8954216cfed9aa06a501a1",
                    "reference": "a478cb11f66a6ac48d8954216cfed9aa06a501a1",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.4",
                    "psr/http-message": "^1.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.0-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Http\\Message\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Márk Sági-Kazár",
                        "email": "mark.sagikazar@gmail.com"
                    }
                ],
                "description": "Factory interfaces for PSR-7 HTTP Message",
                "homepage": "http://php-http.org",
                "keywords": [
                    "factory",
                    "http",
                    "message",
                    "stream",
                    "uri"
                ],
                "time": "2015-12-19T14:08:53+00:00"
            },
            {
                "name": "php-http/promise",
                "version": "v1.0.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/php-http/promise.git",
                    "reference": "dc494cdc9d7160b9a09bd5573272195242ce7980"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/php-http/promise/zipball/dc494cdc9d7160b9a09bd5573272195242ce7980",
                    "reference": "dc494cdc9d7160b9a09bd5573272195242ce7980",
                    "shasum": ""
                },
                "require-dev": {
                    "henrikbjorn/phpspec-code-coverage": "^1.0",
                    "phpspec/phpspec": "^2.4"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.1-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Http\\Promise\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Márk Sági-Kazár",
                        "email": "mark.sagikazar@gmail.com"
                    },
                    {
                        "name": "Joel Wurtz",
                        "email": "joel.wurtz@gmail.com"
                    }
                ],
                "description": "Promise used for asynchronous HTTP requests",
                "homepage": "http://httplug.io",
                "keywords": [
                    "promise"
                ],
                "time": "2016-01-26T13:27:02+00:00"
            },
            {
                "name": "phpoffice/phpspreadsheet",
                "version": "1.9.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/PHPOffice/PhpSpreadsheet.git",
                    "reference": "8dea03eaf60a349b6097e4bcad11f894668280df"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/PHPOffice/PhpSpreadsheet/zipball/8dea03eaf60a349b6097e4bcad11f894668280df",
                    "reference": "8dea03eaf60a349b6097e4bcad11f894668280df",
                    "shasum": ""
                },
                "require": {
                    "ext-ctype": "*",
                    "ext-dom": "*",
                    "ext-fileinfo": "*",
                    "ext-gd": "*",
                    "ext-iconv": "*",
                    "ext-libxml": "*",
                    "ext-mbstring": "*",
                    "ext-simplexml": "*",
                    "ext-xml": "*",
                    "ext-xmlreader": "*",
                    "ext-xmlwriter": "*",
                    "ext-zip": "*",
                    "ext-zlib": "*",
                    "markbaker/complex": "^1.4",
                    "markbaker/matrix": "^1.1",
                    "php": "^7.1",
                    "psr/simple-cache": "^1.0"
                },
                "require-dev": {
                    "dompdf/dompdf": "^0.8.0",
                    "friendsofphp/php-cs-fixer": "@stable",
                    "jpgraph/jpgraph": "^4.0",
                    "mpdf/mpdf": "^7.0.0",
                    "phpcompatibility/php-compatibility": "^8.0",
                    "phpunit/phpunit": "^7.5",
                    "squizlabs/php_codesniffer": "^3.3",
                    "tecnickcom/tcpdf": "^6.2"
                },
                "suggest": {
                    "dompdf/dompdf": "Option for rendering PDF with PDF Writer",
                    "jpgraph/jpgraph": "Option for rendering charts, or including charts with PDF or HTML Writers",
                    "mpdf/mpdf": "Option for rendering PDF with PDF Writer",
                    "tecnickcom/tcpdf": "Option for rendering PDF with PDF Writer"
                },
                "type": "library",
                "autoload": {
                    "psr-4": {
                        "PhpOffice\\PhpSpreadsheet\\": "src/PhpSpreadsheet"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-2.1-or-later"
                ],
                "authors": [
                    {
                        "name": "Maarten Balliauw",
                        "homepage": "https://blog.maartenballiauw.be"
                    },
                    {
                        "name": "Mark Baker",
                        "homepage": "https://markbakeruk.net"
                    },
                    {
                        "name": "Franck Lefevre",
                        "homepage": "https://rootslabs.net"
                    },
                    {
                        "name": "Erik Tilt"
                    },
                    {
                        "name": "Adrien Crivelli"
                    }
                ],
                "description": "PHPSpreadsheet - Read, Create and Write Spreadsheet documents in PHP - Spreadsheet engine",
                "homepage": "https://github.com/PHPOffice/PhpSpreadsheet",
                "keywords": [
                    "OpenXML",
                    "excel",
                    "gnumeric",
                    "ods",
                    "php",
                    "spreadsheet",
                    "xls",
                    "xlsx"
                ],
                "time": "2019-08-17T22:24:35+00:00"
            },
            {
                "name": "phpspec/php-diff",
                "version": "v1.1.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/phpspec/php-diff.git",
                    "reference": "0464787bfa7cd13576c5a1e318709768798bec6a"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/phpspec/php-diff/zipball/0464787bfa7cd13576c5a1e318709768798bec6a",
                    "reference": "0464787bfa7cd13576c5a1e318709768798bec6a",
                    "shasum": ""
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-0": {
                        "Diff": "lib/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "BSD-3-Clause"
                ],
                "authors": [
                    {
                        "name": "Chris Boulton",
                        "homepage": "http://github.com/chrisboulton"
                    }
                ],
                "description": "A comprehensive library for generating differences between two hashable objects (strings or arrays).",
                "time": "2016-04-07T12:29:16+00:00"
            },
            {
                "name": "phpunit/php-token-stream",
                "version": "3.1.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/sebastianbergmann/php-token-stream.git",
                    "reference": "995192df77f63a59e47f025390d2d1fdf8f425ff"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/sebastianbergmann/php-token-stream/zipball/995192df77f63a59e47f025390d2d1fdf8f425ff",
                    "reference": "995192df77f63a59e47f025390d2d1fdf8f425ff",
                    "shasum": ""
                },
                "require": {
                    "ext-tokenizer": "*",
                    "php": "^7.1"
                },
                "require-dev": {
                    "phpunit/phpunit": "^7.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "3.1-dev"
                    }
                },
                "autoload": {
                    "classmap": [
                        "src/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "BSD-3-Clause"
                ],
                "authors": [
                    {
                        "name": "Sebastian Bergmann",
                        "email": "sebastian@phpunit.de"
                    }
                ],
                "description": "Wrapper around PHP's tokenizer extension.",
                "homepage": "https://github.com/sebastianbergmann/php-token-stream/",
                "keywords": [
                    "tokenizer"
                ],
                "time": "2019-09-17T06:23:10+00:00"
            },
            {
                "name": "psr/cache",
                "version": "1.0.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/php-fig/cache.git",
                    "reference": "d11b50ad223250cf17b86e38383413f5a6764bf8"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/php-fig/cache/zipball/d11b50ad223250cf17b86e38383413f5a6764bf8",
                    "reference": "d11b50ad223250cf17b86e38383413f5a6764bf8",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Psr\\Cache\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "PHP-FIG",
                        "homepage": "http://www.php-fig.org/"
                    }
                ],
                "description": "Common interface for caching libraries",
                "keywords": [
                    "cache",
                    "psr",
                    "psr-6"
                ],
                "time": "2016-08-06T20:24:11+00:00"
            },
            {
                "name": "psr/container",
                "version": "1.0.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/php-fig/container.git",
                    "reference": "b7ce3b176482dbbc1245ebf52b181af44c2cf55f"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/php-fig/container/zipball/b7ce3b176482dbbc1245ebf52b181af44c2cf55f",
                    "reference": "b7ce3b176482dbbc1245ebf52b181af44c2cf55f",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Psr\\Container\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "PHP-FIG",
                        "homepage": "http://www.php-fig.org/"
                    }
                ],
                "description": "Common Container Interface (PHP FIG PSR-11)",
                "homepage": "https://github.com/php-fig/container",
                "keywords": [
                    "PSR-11",
                    "container",
                    "container-interface",
                    "container-interop",
                    "psr"
                ],
                "time": "2017-02-14T16:28:37+00:00"
            },
            {
                "name": "psr/http-message",
                "version": "1.0.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/php-fig/http-message.git",
                    "reference": "f6561bf28d520154e4b0ec72be95418abe6d9363"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/php-fig/http-message/zipball/f6561bf28d520154e4b0ec72be95418abe6d9363",
                    "reference": "f6561bf28d520154e4b0ec72be95418abe6d9363",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Psr\\Http\\Message\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "PHP-FIG",
                        "homepage": "http://www.php-fig.org/"
                    }
                ],
                "description": "Common interface for HTTP messages",
                "homepage": "https://github.com/php-fig/http-message",
                "keywords": [
                    "http",
                    "http-message",
                    "psr",
                    "psr-7",
                    "request",
                    "response"
                ],
                "time": "2016-08-06T14:39:51+00:00"
            },
            {
                "name": "psr/link",
                "version": "1.0.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/php-fig/link.git",
                    "reference": "eea8e8662d5cd3ae4517c9b864493f59fca95562"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/php-fig/link/zipball/eea8e8662d5cd3ae4517c9b864493f59fca95562",
                    "reference": "eea8e8662d5cd3ae4517c9b864493f59fca95562",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Psr\\Link\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "PHP-FIG",
                        "homepage": "http://www.php-fig.org/"
                    }
                ],
                "description": "Common interfaces for HTTP links",
                "keywords": [
                    "http",
                    "http-link",
                    "link",
                    "psr",
                    "psr-13",
                    "rest"
                ],
                "time": "2016-10-28T16:06:13+00:00"
            },
            {
                "name": "psr/log",
                "version": "1.1.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/php-fig/log.git",
                    "reference": "6c001f1daafa3a3ac1d8ff69ee4db8e799a654dd"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/php-fig/log/zipball/6c001f1daafa3a3ac1d8ff69ee4db8e799a654dd",
                    "reference": "6c001f1daafa3a3ac1d8ff69ee4db8e799a654dd",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Psr\\Log\\": "Psr/Log/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "PHP-FIG",
                        "homepage": "http://www.php-fig.org/"
                    }
                ],
                "description": "Common interface for logging libraries",
                "homepage": "https://github.com/php-fig/log",
                "keywords": [
                    "log",
                    "psr",
                    "psr-3"
                ],
                "time": "2018-11-20T15:27:04+00:00"
            },
            {
                "name": "psr/simple-cache",
                "version": "1.0.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/php-fig/simple-cache.git",
                    "reference": "408d5eafb83c57f6365a3ca330ff23aa4a5fa39b"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/php-fig/simple-cache/zipball/408d5eafb83c57f6365a3ca330ff23aa4a5fa39b",
                    "reference": "408d5eafb83c57f6365a3ca330ff23aa4a5fa39b",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Psr\\SimpleCache\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "PHP-FIG",
                        "homepage": "http://www.php-fig.org/"
                    }
                ],
                "description": "Common interfaces for simple caching",
                "keywords": [
                    "cache",
                    "caching",
                    "psr",
                    "psr-16",
                    "simple-cache"
                ],
                "time": "2017-10-23T01:57:42+00:00"
            },
            {
                "name": "ralouphie/getallheaders",
                "version": "3.0.3",
                "source": {
                    "type": "git",
                    "url": "https://github.com/ralouphie/getallheaders.git",
                    "reference": "120b605dfeb996808c31b6477290a714d356e822"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/ralouphie/getallheaders/zipball/120b605dfeb996808c31b6477290a714d356e822",
                    "reference": "120b605dfeb996808c31b6477290a714d356e822",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.6"
                },
                "require-dev": {
                    "php-coveralls/php-coveralls": "^2.1",
                    "phpunit/phpunit": "^5 || ^6.5"
                },
                "type": "library",
                "autoload": {
                    "files": [
                        "src/getallheaders.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Ralph Khattar",
                        "email": "ralph.khattar@gmail.com"
                    }
                ],
                "description": "A polyfill for getallheaders.",
                "time": "2019-03-08T08:55:37+00:00"
            },
            {
                "name": "scssphp/scssphp",
                "version": "1.0.5",
                "source": {
                    "type": "git",
                    "url": "https://github.com/scssphp/scssphp.git",
                    "reference": "98e10149058102817b493c5a147fa582cb62d46e"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/scssphp/scssphp/zipball/98e10149058102817b493c5a147fa582cb62d46e",
                    "reference": "98e10149058102817b493c5a147fa582cb62d46e",
                    "shasum": ""
                },
                "require": {
                    "ext-ctype": "*",
                    "ext-json": "*",
                    "php": ">=5.6.0"
                },
                "require-dev": {
                    "phpunit/phpunit": "^5.7 || ^6.5 || ^7.5 || ^8.3",
                    "squizlabs/php_codesniffer": "~2.5",
                    "twbs/bootstrap": "~4.3",
                    "zurb/foundation": "~6.5"
                },
                "bin": [
                    "bin/pscss"
                ],
                "type": "library",
                "autoload": {
                    "psr-4": {
                        "ScssPhp\\ScssPhp\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Anthon Pang",
                        "email": "apang@softwaredevelopment.ca",
                        "homepage": "https://github.com/robocoder"
                    },
                    {
                        "name": "Cédric Morin",
                        "email": "cedric@yterium.com",
                        "homepage": "https://github.com/Cerdic"
                    }
                ],
                "description": "scssphp is a compiler for SCSS written in PHP.",
                "homepage": "http://scssphp.github.io/scssphp/",
                "keywords": [
                    "css",
                    "less",
                    "sass",
                    "scss",
                    "stylesheet"
                ],
                "time": "2019-10-03T17:09:15+00:00"
            },
            {
                "name": "sensio/distribution-bundle",
                "version": "v5.0.25",
                "source": {
                    "type": "git",
                    "url": "https://github.com/sensiolabs/SensioDistributionBundle.git",
                    "reference": "80a38234bde8321fb92aa0b8c27978a272bb4baf"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/sensiolabs/SensioDistributionBundle/zipball/80a38234bde8321fb92aa0b8c27978a272bb4baf",
                    "reference": "80a38234bde8321fb92aa0b8c27978a272bb4baf",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.9",
                    "sensiolabs/security-checker": "~5.0|~6.0",
                    "symfony/class-loader": "~2.3|~3.0",
                    "symfony/config": "~2.3|~3.0",
                    "symfony/dependency-injection": "~2.3|~3.0",
                    "symfony/filesystem": "~2.3|~3.0",
                    "symfony/http-kernel": "~2.3|~3.0",
                    "symfony/process": "~2.3|~3.0"
                },
                "type": "symfony-bundle",
                "extra": {
                    "branch-alias": {
                        "dev-master": "5.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Sensio\\Bundle\\DistributionBundle\\": ""
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Fabien Potencier",
                        "email": "fabien@symfony.com"
                    }
                ],
                "description": "Base bundle for Symfony Distributions",
                "keywords": [
                    "configuration",
                    "distribution"
                ],
                "time": "2019-06-18T15:43:58+00:00"
            },
            {
                "name": "sensiolabs/ansi-to-html",
                "version": "v1.1.3",
                "source": {
                    "type": "git",
                    "url": "https://github.com/sensiolabs/ansi-to-html.git",
                    "reference": "8b5d787dca714bd98dd770c078d76528320a8286"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/sensiolabs/ansi-to-html/zipball/8b5d787dca714bd98dd770c078d76528320a8286",
                    "reference": "8b5d787dca714bd98dd770c078d76528320a8286",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.0"
                },
                "suggest": {
                    "twig/twig": "Provides nice templating features"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.1-dev"
                    }
                },
                "autoload": {
                    "psr-0": {
                        "SensioLabs\\AnsiConverter": "."
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Fabien Potencier",
                        "email": "fabien@symfony.com"
                    }
                ],
                "description": "A library to convert a text with ANSI codes to HTML",
                "time": "2017-05-02T00:53:29+00:00"
            },
            {
                "name": "sensiolabs/security-checker",
                "version": "v6.0.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/sensiolabs/security-checker.git",
                    "reference": "ce8d0552dcb8d3677ab9adb6d19a5837949bfec4"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/sensiolabs/security-checker/zipball/ce8d0552dcb8d3677ab9adb6d19a5837949bfec4",
                    "reference": "ce8d0552dcb8d3677ab9adb6d19a5837949bfec4",
                    "shasum": ""
                },
                "require": {
                    "php": ">=7.1.3",
                    "symfony/console": "^2.8|^3.4|^4.2",
                    "symfony/http-client": "^4.3",
                    "symfony/mime": "^4.3",
                    "symfony/polyfill-ctype": "^1.11"
                },
                "bin": [
                    "security-checker"
                ],
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "6.0-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "SensioLabs\\Security\\": "SensioLabs/Security"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Fabien Potencier",
                        "email": "fabien.potencier@gmail.com"
                    }
                ],
                "description": "A security checker for your composer.lock",
                "time": "2019-06-08T06:46:26+00:00"
            },
            {
                "name": "simplepie/simplepie",
                "version": "1.5.3",
                "source": {
                    "type": "git",
                    "url": "https://github.com/simplepie/simplepie.git",
                    "reference": "173663382a9346acd53df60c7ffb20689c9cf1f6"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/simplepie/simplepie/zipball/173663382a9346acd53df60c7ffb20689c9cf1f6",
                    "reference": "173663382a9346acd53df60c7ffb20689c9cf1f6",
                    "shasum": ""
                },
                "require": {
                    "ext-pcre": "*",
                    "ext-xml": "*",
                    "ext-xmlreader": "*",
                    "php": ">=5.6.0"
                },
                "require-dev": {
                    "phpunit/phpunit": "~5.4.3 || ~6.5"
                },
                "suggest": {
                    "ext-curl": "",
                    "ext-iconv": "",
                    "ext-intl": "",
                    "ext-mbstring": "",
                    "mf2/mf2": "Microformat module that allows for parsing HTML for microformats"
                },
                "type": "library",
                "autoload": {
                    "psr-0": {
                        "SimplePie": "library"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "BSD-3-Clause"
                ],
                "authors": [
                    {
                        "name": "Ryan Parman",
                        "homepage": "http://ryanparman.com/",
                        "role": "Creator, alumnus developer"
                    },
                    {
                        "name": "Geoffrey Sneddon",
                        "homepage": "http://gsnedders.com/",
                        "role": "Alumnus developer"
                    },
                    {
                        "name": "Ryan McCue",
                        "email": "me@ryanmccue.info",
                        "homepage": "http://ryanmccue.info/",
                        "role": "Developer"
                    }
                ],
                "description": "A simple Atom/RSS parsing library for PHP",
                "homepage": "http://simplepie.org/",
                "keywords": [
                    "atom",
                    "feeds",
                    "rss"
                ],
                "time": "2019-09-22T23:21:30+00:00"
            },
            {
                "name": "swiftmailer/swiftmailer",
                "version": "v5.4.12",
                "source": {
                    "type": "git",
                    "url": "https://github.com/swiftmailer/swiftmailer.git",
                    "reference": "181b89f18a90f8925ef805f950d47a7190e9b950"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/swiftmailer/swiftmailer/zipball/181b89f18a90f8925ef805f950d47a7190e9b950",
                    "reference": "181b89f18a90f8925ef805f950d47a7190e9b950",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.3"
                },
                "require-dev": {
                    "mockery/mockery": "~0.9.1",
                    "symfony/phpunit-bridge": "~3.2"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "5.4-dev"
                    }
                },
                "autoload": {
                    "files": [
                        "lib/swift_required.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Chris Corbyn"
                    },
                    {
                        "name": "Fabien Potencier",
                        "email": "fabien@symfony.com"
                    }
                ],
                "description": "Swiftmailer, free feature-rich PHP mailer",
                "homepage": "https://swiftmailer.symfony.com",
                "keywords": [
                    "email",
                    "mail",
                    "mailer"
                ],
                "time": "2018-07-31T09:26:32+00:00"
            },
            {
                "name": "symfony/http-client",
                "version": "v4.3.5",
                "source": {
                    "type": "git",
                    "url": "https://github.com/symfony/http-client.git",
                    "reference": "69d438274718121e1166e7f65c290f891a4c8ddb"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/symfony/http-client/zipball/69d438274718121e1166e7f65c290f891a4c8ddb",
                    "reference": "69d438274718121e1166e7f65c290f891a4c8ddb",
                    "shasum": ""
                },
                "require": {
                    "php": "^7.1.3",
                    "psr/log": "^1.0",
                    "symfony/http-client-contracts": "^1.1.7",
                    "symfony/polyfill-php73": "^1.11"
                },
                "provide": {
                    "psr/http-client-implementation": "1.0",
                    "symfony/http-client-implementation": "1.1"
                },
                "require-dev": {
                    "nyholm/psr7": "^1.0",
                    "psr/http-client": "^1.0",
                    "symfony/http-kernel": "^4.3",
                    "symfony/process": "^4.2"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "4.3-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Symfony\\Component\\HttpClient\\": ""
                    },
                    "exclude-from-classmap": [
                        "/Tests/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Nicolas Grekas",
                        "email": "p@tchwork.com"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://symfony.com/contributors"
                    }
                ],
                "description": "Symfony HttpClient component",
                "homepage": "https://symfony.com",
                "time": "2019-10-07T10:52:41+00:00"
            },
            {
                "name": "symfony/http-client-contracts",
                "version": "v1.1.7",
                "source": {
                    "type": "git",
                    "url": "https://github.com/symfony/http-client-contracts.git",
                    "reference": "353b2a3e907e5c34cf8f74827a4b21eb745aab1d"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/symfony/http-client-contracts/zipball/353b2a3e907e5c34cf8f74827a4b21eb745aab1d",
                    "reference": "353b2a3e907e5c34cf8f74827a4b21eb745aab1d",
                    "shasum": ""
                },
                "require": {
                    "php": "^7.1.3"
                },
                "suggest": {
                    "symfony/http-client-implementation": ""
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.1-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Symfony\\Contracts\\HttpClient\\": ""
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Nicolas Grekas",
                        "email": "p@tchwork.com"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://symfony.com/contributors"
                    }
                ],
                "description": "Generic abstractions related to HTTP clients",
                "homepage": "https://symfony.com",
                "keywords": [
                    "abstractions",
                    "contracts",
                    "decoupling",
                    "interfaces",
                    "interoperability",
                    "standards"
                ],
                "time": "2019-09-26T22:09:58+00:00"
            },
            {
                "name": "symfony/mime",
                "version": "v4.3.5",
                "source": {
                    "type": "git",
                    "url": "https://github.com/symfony/mime.git",
                    "reference": "32f71570547b91879fdbd9cf50317d556ae86916"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/symfony/mime/zipball/32f71570547b91879fdbd9cf50317d556ae86916",
                    "reference": "32f71570547b91879fdbd9cf50317d556ae86916",
                    "shasum": ""
                },
                "require": {
                    "php": "^7.1.3",
                    "symfony/polyfill-intl-idn": "^1.10",
                    "symfony/polyfill-mbstring": "^1.0"
                },
                "require-dev": {
                    "egulias/email-validator": "^2.1.10",
                    "symfony/dependency-injection": "~3.4|^4.1"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "4.3-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Symfony\\Component\\Mime\\": ""
                    },
                    "exclude-from-classmap": [
                        "/Tests/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Fabien Potencier",
                        "email": "fabien@symfony.com"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://symfony.com/contributors"
                    }
                ],
                "description": "A library to manipulate MIME messages",
                "homepage": "https://symfony.com",
                "keywords": [
                    "mime",
                    "mime-type"
                ],
                "time": "2019-09-19T17:00:15+00:00"
            },
            {
                "name": "symfony/monolog-bundle",
                "version": "v3.4.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/symfony/monolog-bundle.git",
                    "reference": "7fbecb371c1c614642c93c6b2cbcdf723ae8809d"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/symfony/monolog-bundle/zipball/7fbecb371c1c614642c93c6b2cbcdf723ae8809d",
                    "reference": "7fbecb371c1c614642c93c6b2cbcdf723ae8809d",
                    "shasum": ""
                },
                "require": {
                    "monolog/monolog": "~1.22",
                    "php": ">=5.6",
                    "symfony/config": "~3.4|~4.0",
                    "symfony/dependency-injection": "~3.4.10|^4.0.10",
                    "symfony/http-kernel": "~3.4|~4.0",
                    "symfony/monolog-bridge": "~3.4|~4.0"
                },
                "require-dev": {
                    "symfony/console": "~3.4|~4.0",
                    "symfony/phpunit-bridge": "^3.4.19|^4.0",
                    "symfony/yaml": "~3.4|~4.0"
                },
                "type": "symfony-bundle",
                "extra": {
                    "branch-alias": {
                        "dev-master": "3.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Symfony\\Bundle\\MonologBundle\\": ""
                    },
                    "exclude-from-classmap": [
                        "/Tests/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Symfony Community",
                        "homepage": "http://symfony.com/contributors"
                    },
                    {
                        "name": "Fabien Potencier",
                        "email": "fabien@symfony.com"
                    }
                ],
                "description": "Symfony MonologBundle",
                "homepage": "http://symfony.com",
                "keywords": [
                    "log",
                    "logging"
                ],
                "time": "2019-06-20T12:18:19+00:00"
            },
            {
                "name": "symfony/polyfill-apcu",
                "version": "v1.12.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/symfony/polyfill-apcu.git",
                    "reference": "71ce80635d5dcd67772b4dda00b86068595f64d5"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/symfony/polyfill-apcu/zipball/71ce80635d5dcd67772b4dda00b86068595f64d5",
                    "reference": "71ce80635d5dcd67772b4dda00b86068595f64d5",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.3"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.12-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Symfony\\Polyfill\\Apcu\\": ""
                    },
                    "files": [
                        "bootstrap.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Nicolas Grekas",
                        "email": "p@tchwork.com"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://symfony.com/contributors"
                    }
                ],
                "description": "Symfony polyfill backporting apcu_* functions to lower PHP versions",
                "homepage": "https://symfony.com",
                "keywords": [
                    "apcu",
                    "compatibility",
                    "polyfill",
                    "portable",
                    "shim"
                ],
                "time": "2019-08-06T08:03:45+00:00"
            },
            {
                "name": "symfony/polyfill-ctype",
                "version": "v1.12.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/symfony/polyfill-ctype.git",
                    "reference": "550ebaac289296ce228a706d0867afc34687e3f4"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/550ebaac289296ce228a706d0867afc34687e3f4",
                    "reference": "550ebaac289296ce228a706d0867afc34687e3f4",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.3"
                },
                "suggest": {
                    "ext-ctype": "For best performance"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.12-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Symfony\\Polyfill\\Ctype\\": ""
                    },
                    "files": [
                        "bootstrap.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Gert de Pagter",
                        "email": "BackEndTea@gmail.com"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://symfony.com/contributors"
                    }
                ],
                "description": "Symfony polyfill for ctype functions",
                "homepage": "https://symfony.com",
                "keywords": [
                    "compatibility",
                    "ctype",
                    "polyfill",
                    "portable"
                ],
                "time": "2019-08-06T08:03:45+00:00"
            },
            {
                "name": "symfony/polyfill-intl-icu",
                "version": "v1.12.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/symfony/polyfill-intl-icu.git",
                    "reference": "66810b9d6eb4af54d543867909d65ab9af654d7e"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/symfony/polyfill-intl-icu/zipball/66810b9d6eb4af54d543867909d65ab9af654d7e",
                    "reference": "66810b9d6eb4af54d543867909d65ab9af654d7e",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.3",
                    "symfony/intl": "~2.3|~3.0|~4.0|~5.0"
                },
                "suggest": {
                    "ext-intl": "For best performance"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.12-dev"
                    }
                },
                "autoload": {
                    "files": [
                        "bootstrap.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Nicolas Grekas",
                        "email": "p@tchwork.com"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://symfony.com/contributors"
                    }
                ],
                "description": "Symfony polyfill for intl's ICU-related data and classes",
                "homepage": "https://symfony.com",
                "keywords": [
                    "compatibility",
                    "icu",
                    "intl",
                    "polyfill",
                    "portable",
                    "shim"
                ],
                "time": "2019-08-06T08:03:45+00:00"
            },
            {
                "name": "symfony/polyfill-intl-idn",
                "version": "v1.12.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/symfony/polyfill-intl-idn.git",
                    "reference": "6af626ae6fa37d396dc90a399c0ff08e5cfc45b2"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/symfony/polyfill-intl-idn/zipball/6af626ae6fa37d396dc90a399c0ff08e5cfc45b2",
                    "reference": "6af626ae6fa37d396dc90a399c0ff08e5cfc45b2",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.3",
                    "symfony/polyfill-mbstring": "^1.3",
                    "symfony/polyfill-php72": "^1.9"
                },
                "suggest": {
                    "ext-intl": "For best performance"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.12-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Symfony\\Polyfill\\Intl\\Idn\\": ""
                    },
                    "files": [
                        "bootstrap.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Laurent Bassin",
                        "email": "laurent@bassin.info"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://symfony.com/contributors"
                    }
                ],
                "description": "Symfony polyfill for intl's idn_to_ascii and idn_to_utf8 functions",
                "homepage": "https://symfony.com",
                "keywords": [
                    "compatibility",
                    "idn",
                    "intl",
                    "polyfill",
                    "portable",
                    "shim"
                ],
                "time": "2019-08-06T08:03:45+00:00"
            },
            {
                "name": "symfony/polyfill-mbstring",
                "version": "v1.12.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/symfony/polyfill-mbstring.git",
                    "reference": "b42a2f66e8f1b15ccf25652c3424265923eb4f17"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/b42a2f66e8f1b15ccf25652c3424265923eb4f17",
                    "reference": "b42a2f66e8f1b15ccf25652c3424265923eb4f17",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.3"
                },
                "suggest": {
                    "ext-mbstring": "For best performance"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.12-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Symfony\\Polyfill\\Mbstring\\": ""
                    },
                    "files": [
                        "bootstrap.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Nicolas Grekas",
                        "email": "p@tchwork.com"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://symfony.com/contributors"
                    }
                ],
                "description": "Symfony polyfill for the Mbstring extension",
                "homepage": "https://symfony.com",
                "keywords": [
                    "compatibility",
                    "mbstring",
                    "polyfill",
                    "portable",
                    "shim"
                ],
                "time": "2019-08-06T08:03:45+00:00"
            },
            {
                "name": "symfony/polyfill-php56",
                "version": "v1.12.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/symfony/polyfill-php56.git",
                    "reference": "0e3b212e96a51338639d8ce175c046d7729c3403"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/symfony/polyfill-php56/zipball/0e3b212e96a51338639d8ce175c046d7729c3403",
                    "reference": "0e3b212e96a51338639d8ce175c046d7729c3403",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.3",
                    "symfony/polyfill-util": "~1.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.12-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Symfony\\Polyfill\\Php56\\": ""
                    },
                    "files": [
                        "bootstrap.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Nicolas Grekas",
                        "email": "p@tchwork.com"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://symfony.com/contributors"
                    }
                ],
                "description": "Symfony polyfill backporting some PHP 5.6+ features to lower PHP versions",
                "homepage": "https://symfony.com",
                "keywords": [
                    "compatibility",
                    "polyfill",
                    "portable",
                    "shim"
                ],
                "time": "2019-08-06T08:03:45+00:00"
            },
            {
                "name": "symfony/polyfill-php70",
                "version": "v1.12.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/symfony/polyfill-php70.git",
                    "reference": "54b4c428a0054e254223797d2713c31e08610831"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/symfony/polyfill-php70/zipball/54b4c428a0054e254223797d2713c31e08610831",
                    "reference": "54b4c428a0054e254223797d2713c31e08610831",
                    "shasum": ""
                },
                "require": {
                    "paragonie/random_compat": "~1.0|~2.0|~9.99",
                    "php": ">=5.3.3"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.12-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Symfony\\Polyfill\\Php70\\": ""
                    },
                    "files": [
                        "bootstrap.php"
                    ],
                    "classmap": [
                        "Resources/stubs"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Nicolas Grekas",
                        "email": "p@tchwork.com"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://symfony.com/contributors"
                    }
                ],
                "description": "Symfony polyfill backporting some PHP 7.0+ features to lower PHP versions",
                "homepage": "https://symfony.com",
                "keywords": [
                    "compatibility",
                    "polyfill",
                    "portable",
                    "shim"
                ],
                "time": "2019-08-06T08:03:45+00:00"
            },
            {
                "name": "symfony/polyfill-php72",
                "version": "v1.12.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/symfony/polyfill-php72.git",
                    "reference": "04ce3335667451138df4307d6a9b61565560199e"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/symfony/polyfill-php72/zipball/04ce3335667451138df4307d6a9b61565560199e",
                    "reference": "04ce3335667451138df4307d6a9b61565560199e",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.3"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.12-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Symfony\\Polyfill\\Php72\\": ""
                    },
                    "files": [
                        "bootstrap.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Nicolas Grekas",
                        "email": "p@tchwork.com"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://symfony.com/contributors"
                    }
                ],
                "description": "Symfony polyfill backporting some PHP 7.2+ features to lower PHP versions",
                "homepage": "https://symfony.com",
                "keywords": [
                    "compatibility",
                    "polyfill",
                    "portable",
                    "shim"
                ],
                "time": "2019-08-06T08:03:45+00:00"
            },
            {
                "name": "symfony/polyfill-php73",
                "version": "v1.12.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/symfony/polyfill-php73.git",
                    "reference": "2ceb49eaccb9352bff54d22570276bb75ba4a188"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/symfony/polyfill-php73/zipball/2ceb49eaccb9352bff54d22570276bb75ba4a188",
                    "reference": "2ceb49eaccb9352bff54d22570276bb75ba4a188",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.3"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.12-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Symfony\\Polyfill\\Php73\\": ""
                    },
                    "files": [
                        "bootstrap.php"
                    ],
                    "classmap": [
                        "Resources/stubs"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Nicolas Grekas",
                        "email": "p@tchwork.com"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://symfony.com/contributors"
                    }
                ],
                "description": "Symfony polyfill backporting some PHP 7.3+ features to lower PHP versions",
                "homepage": "https://symfony.com",
                "keywords": [
                    "compatibility",
                    "polyfill",
                    "portable",
                    "shim"
                ],
                "time": "2019-08-06T08:03:45+00:00"
            },
            {
                "name": "symfony/polyfill-util",
                "version": "v1.12.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/symfony/polyfill-util.git",
                    "reference": "4317de1386717b4c22caed7725350a8887ab205c"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/symfony/polyfill-util/zipball/4317de1386717b4c22caed7725350a8887ab205c",
                    "reference": "4317de1386717b4c22caed7725350a8887ab205c",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.3"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.12-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Symfony\\Polyfill\\Util\\": ""
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Nicolas Grekas",
                        "email": "p@tchwork.com"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://symfony.com/contributors"
                    }
                ],
                "description": "Symfony utilities for portability of PHP codes",
                "homepage": "https://symfony.com",
                "keywords": [
                    "compat",
                    "compatibility",
                    "polyfill",
                    "shim"
                ],
                "time": "2019-08-06T08:03:45+00:00"
            },
            {
                "name": "symfony/swiftmailer-bundle",
                "version": "v2.6.7",
                "source": {
                    "type": "git",
                    "url": "https://github.com/symfony/swiftmailer-bundle.git",
                    "reference": "c4808f5169efc05567be983909d00f00521c53ec"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/symfony/swiftmailer-bundle/zipball/c4808f5169efc05567be983909d00f00521c53ec",
                    "reference": "c4808f5169efc05567be983909d00f00521c53ec",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.2",
                    "swiftmailer/swiftmailer": "~4.2|~5.0",
                    "symfony/config": "~2.7|~3.0",
                    "symfony/dependency-injection": "~2.7|~3.0",
                    "symfony/http-kernel": "~2.7|~3.0"
                },
                "require-dev": {
                    "symfony/console": "~2.7|~3.0",
                    "symfony/framework-bundle": "~2.7|~3.0",
                    "symfony/phpunit-bridge": "~3.3@dev",
                    "symfony/yaml": "~2.7|~3.0"
                },
                "suggest": {
                    "psr/log": "Allows logging"
                },
                "type": "symfony-bundle",
                "extra": {
                    "branch-alias": {
                        "dev-master": "2.6-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Symfony\\Bundle\\SwiftmailerBundle\\": ""
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Symfony Community",
                        "homepage": "http://symfony.com/contributors"
                    },
                    {
                        "name": "Fabien Potencier",
                        "email": "fabien@symfony.com"
                    }
                ],
                "description": "Symfony SwiftmailerBundle",
                "homepage": "http://symfony.com",
                "time": "2017-10-19T01:06:41+00:00"
            },
            {
                "name": "symfony/symfony",
                "version": "v3.4.32",
                "source": {
                    "type": "git",
                    "url": "https://github.com/symfony/symfony.git",
                    "reference": "2815d1fa34d417b8b87450667f166edbefff3177"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/symfony/symfony/zipball/2815d1fa34d417b8b87450667f166edbefff3177",
                    "reference": "2815d1fa34d417b8b87450667f166edbefff3177",
                    "shasum": ""
                },
                "require": {
                    "doctrine/common": "~2.4",
                    "ext-xml": "*",
                    "fig/link-util": "^1.0",
                    "php": "^5.5.9|>=7.0.8",
                    "psr/cache": "~1.0",
                    "psr/container": "^1.0",
                    "psr/link": "^1.0",
                    "psr/log": "~1.0",
                    "psr/simple-cache": "^1.0",
                    "symfony/polyfill-apcu": "~1.1",
                    "symfony/polyfill-ctype": "~1.8",
                    "symfony/polyfill-intl-icu": "~1.0",
                    "symfony/polyfill-mbstring": "~1.0",
                    "symfony/polyfill-php56": "~1.0",
                    "symfony/polyfill-php70": "~1.6",
                    "twig/twig": "^1.41|^2.10"
                },
                "conflict": {
                    "phpdocumentor/reflection-docblock": "<3.0||>=3.2.0,<3.2.2",
                    "phpdocumentor/type-resolver": "<0.3.0",
                    "phpunit/phpunit": "<4.8.35|<5.4.3,>=5.0"
                },
                "provide": {
                    "psr/cache-implementation": "1.0",
                    "psr/container-implementation": "1.0",
                    "psr/log-implementation": "1.0",
                    "psr/simple-cache-implementation": "1.0"
                },
                "replace": {
                    "symfony/asset": "self.version",
                    "symfony/browser-kit": "self.version",
                    "symfony/cache": "self.version",
                    "symfony/class-loader": "self.version",
                    "symfony/config": "self.version",
                    "symfony/console": "self.version",
                    "symfony/css-selector": "self.version",
                    "symfony/debug": "self.version",
                    "symfony/debug-bundle": "self.version",
                    "symfony/dependency-injection": "self.version",
                    "symfony/doctrine-bridge": "self.version",
                    "symfony/dom-crawler": "self.version",
                    "symfony/dotenv": "self.version",
                    "symfony/event-dispatcher": "self.version",
                    "symfony/expression-language": "self.version",
                    "symfony/filesystem": "self.version",
                    "symfony/finder": "self.version",
                    "symfony/form": "self.version",
                    "symfony/framework-bundle": "self.version",
                    "symfony/http-foundation": "self.version",
                    "symfony/http-kernel": "self.version",
                    "symfony/inflector": "self.version",
                    "symfony/intl": "self.version",
                    "symfony/ldap": "self.version",
                    "symfony/lock": "self.version",
                    "symfony/monolog-bridge": "self.version",
                    "symfony/options-resolver": "self.version",
                    "symfony/process": "self.version",
                    "symfony/property-access": "self.version",
                    "symfony/property-info": "self.version",
                    "symfony/proxy-manager-bridge": "self.version",
                    "symfony/routing": "self.version",
                    "symfony/security": "self.version",
                    "symfony/security-bundle": "self.version",
                    "symfony/security-core": "self.version",
                    "symfony/security-csrf": "self.version",
                    "symfony/security-guard": "self.version",
                    "symfony/security-http": "self.version",
                    "symfony/serializer": "self.version",
                    "symfony/stopwatch": "self.version",
                    "symfony/templating": "self.version",
                    "symfony/translation": "self.version",
                    "symfony/twig-bridge": "self.version",
                    "symfony/twig-bundle": "self.version",
                    "symfony/validator": "self.version",
                    "symfony/var-dumper": "self.version",
                    "symfony/web-link": "self.version",
                    "symfony/web-profiler-bundle": "self.version",
                    "symfony/web-server-bundle": "self.version",
                    "symfony/workflow": "self.version",
                    "symfony/yaml": "self.version"
                },
                "require-dev": {
                    "cache/integration-tests": "dev-master",
                    "doctrine/annotations": "~1.0",
                    "doctrine/cache": "~1.6",
                    "doctrine/data-fixtures": "1.0.*",
                    "doctrine/dbal": "~2.4",
                    "doctrine/doctrine-bundle": "~1.4",
                    "doctrine/orm": "~2.4,>=2.4.5",
                    "egulias/email-validator": "~1.2,>=1.2.8|~2.0",
                    "monolog/monolog": "~1.11",
                    "ocramius/proxy-manager": "~0.4|~1.0|~2.0",
                    "phpdocumentor/reflection-docblock": "^3.0|^4.0",
                    "predis/predis": "~1.0",
                    "symfony/phpunit-bridge": "^3.4.31|^4.3.4|~5.0",
                    "symfony/security-acl": "~2.8|~3.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "3.4-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Symfony\\Bridge\\Doctrine\\": "src/Symfony/Bridge/Doctrine/",
                        "Symfony\\Bridge\\Monolog\\": "src/Symfony/Bridge/Monolog/",
                        "Symfony\\Bridge\\ProxyManager\\": "src/Symfony/Bridge/ProxyManager/",
                        "Symfony\\Bridge\\Twig\\": "src/Symfony/Bridge/Twig/",
                        "Symfony\\Bundle\\": "src/Symfony/Bundle/",
                        "Symfony\\Component\\": "src/Symfony/Component/"
                    },
                    "classmap": [
                        "src/Symfony/Component/Intl/Resources/stubs"
                    ],
                    "exclude-from-classmap": [
                        "**/Tests/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Fabien Potencier",
                        "email": "fabien@symfony.com"
                    },
                    {
                        "name": "Symfony Community",
                        "homepage": "https://symfony.com/contributors"
                    }
                ],
                "description": "The Symfony PHP framework",
                "homepage": "https://symfony.com",
                "keywords": [
                    "framework"
                ],
                "time": "2019-10-07T14:42:16+00:00"
            },
            {
                "name": "tecnickcom/tcpdf",
                "version": "6.3.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/tecnickcom/TCPDF.git",
                    "reference": "9fde7bb9b404b945e7ea88fb7eccd23d9a4e324b"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/tecnickcom/TCPDF/zipball/9fde7bb9b404b945e7ea88fb7eccd23d9a4e324b",
                    "reference": "9fde7bb9b404b945e7ea88fb7eccd23d9a4e324b",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.0"
                },
                "type": "library",
                "autoload": {
                    "classmap": [
                        "config",
                        "include",
                        "tcpdf.php",
                        "tcpdf_parser.php",
                        "tcpdf_import.php",
                        "tcpdf_barcodes_1d.php",
                        "tcpdf_barcodes_2d.php",
                        "include/tcpdf_colors.php",
                        "include/tcpdf_filters.php",
                        "include/tcpdf_font_data.php",
                        "include/tcpdf_fonts.php",
                        "include/tcpdf_images.php",
                        "include/tcpdf_static.php",
                        "include/barcodes/datamatrix.php",
                        "include/barcodes/pdf417.php",
                        "include/barcodes/qrcode.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0"
                ],
                "authors": [
                    {
                        "name": "Nicola Asuni",
                        "email": "info@tecnick.com",
                        "role": "lead"
                    }
                ],
                "description": "TCPDF is a PHP class for generating PDF documents and barcodes.",
                "homepage": "http://www.tcpdf.org/",
                "keywords": [
                    "PDFD32000-2008",
                    "TCPDF",
                    "barcodes",
                    "datamatrix",
                    "pdf",
                    "pdf417",
                    "qrcode"
                ],
                "time": "2019-09-20T09:35:01+00:00"
            },
            {
                "name": "terminal42/header-replay-bundle",
                "version": "1.5.3",
                "source": {
                    "type": "git",
                    "url": "https://github.com/terminal42/header-replay-bundle.git",
                    "reference": "f92e6bf942a8f63e2db9a90ad9a4782fe40036f6"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/terminal42/header-replay-bundle/zipball/f92e6bf942a8f63e2db9a90ad9a4782fe40036f6",
                    "reference": "f92e6bf942a8f63e2db9a90ad9a4782fe40036f6",
                    "shasum": ""
                },
                "require": {
                    "friendsofsymfony/http-cache": "^2.1",
                    "friendsofsymfony/http-cache-bundle": "^2.1",
                    "php": "^5.6 | ^7.0",
                    "symfony/options-resolver": "^3.3 | ^4.0"
                },
                "require-dev": {
                    "friendsofphp/php-cs-fixer": "^2.1",
                    "leofeyer/optimize-native-functions-fixer": "^1.1",
                    "php-coveralls/php-coveralls": "^2.1",
                    "php-http/guzzle6-adapter": "^1.1",
                    "phpunit/phpunit": "^5.7"
                },
                "type": "symfony-bundle",
                "autoload": {
                    "psr-4": {
                        "Terminal42\\HeaderReplay\\": "src"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Yanick Witschi",
                        "email": "yanick.witschi@terminal42.ch"
                    }
                ],
                "description": "Send preflight requests for user context headers and replay them for reverse proxy support.",
                "time": "2018-10-18T12:10:53+00:00"
            },
            {
                "name": "toflar/psr6-symfony-http-cache-store",
                "version": "2.1.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/Toflar/psr6-symfony-http-cache-store.git",
                    "reference": "d9c3ca57ca5153b88aed45b49080c0fe5a5fa7c6"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/Toflar/psr6-symfony-http-cache-store/zipball/d9c3ca57ca5153b88aed45b49080c0fe5a5fa7c6",
                    "reference": "d9c3ca57ca5153b88aed45b49080c0fe5a5fa7c6",
                    "shasum": ""
                },
                "require": {
                    "php": "^5.6|^7.0",
                    "symfony/cache": "^3.4|^4.0",
                    "symfony/http-foundation": "^3.0|^4.0",
                    "symfony/http-kernel": "^3.0|^4.0",
                    "symfony/lock": "^3.4|^4.0",
                    "symfony/options-resolver": "^3.0|^4.0"
                },
                "require-dev": {
                    "friendsofphp/php-cs-fixer": "^2.12",
                    "php-coveralls/php-coveralls": "^2.1",
                    "phpunit/phpunit": "^5.7.27"
                },
                "type": "library",
                "autoload": {
                    "psr-4": {
                        "Toflar\\Psr6HttpCacheStore\\": "src"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Yanick Witschi",
                        "email": "yanick.witschi@terminal42.ch"
                    }
                ],
                "description": "An alternative store implementation for Symfony's HttpCache reverse proxy that supports auto-pruning of expired entries and cache invalidation by tags.",
                "time": "2019-09-04T14:55:00+00:00"
            },
            {
                "name": "true/punycode",
                "version": "v2.1.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/true/php-punycode.git",
                    "reference": "a4d0c11a36dd7f4e7cd7096076cab6d3378a071e"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/true/php-punycode/zipball/a4d0c11a36dd7f4e7cd7096076cab6d3378a071e",
                    "reference": "a4d0c11a36dd7f4e7cd7096076cab6d3378a071e",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.0",
                    "symfony/polyfill-mbstring": "^1.3"
                },
                "require-dev": {
                    "phpunit/phpunit": "~4.7",
                    "squizlabs/php_codesniffer": "~2.0"
                },
                "type": "library",
                "autoload": {
                    "psr-4": {
                        "TrueBV\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Renan Gonçalves",
                        "email": "renan.saddam@gmail.com"
                    }
                ],
                "description": "A Bootstring encoding of Unicode for Internationalized Domain Names in Applications (IDNA)",
                "homepage": "https://github.com/true/php-punycode",
                "keywords": [
                    "idna",
                    "punycode"
                ],
                "time": "2016-11-16T10:37:54+00:00"
            },
            {
                "name": "twig/twig",
                "version": "v1.42.3",
                "source": {
                    "type": "git",
                    "url": "https://github.com/twigphp/Twig.git",
                    "reference": "201baee843e0ffe8b0b956f336dd42b2a92fae4e"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/twigphp/Twig/zipball/201baee843e0ffe8b0b956f336dd42b2a92fae4e",
                    "reference": "201baee843e0ffe8b0b956f336dd42b2a92fae4e",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.5.0",
                    "symfony/polyfill-ctype": "^1.8"
                },
                "require-dev": {
                    "psr/container": "^1.0",
                    "symfony/debug": "^3.4|^4.2",
                    "symfony/phpunit-bridge": "^4.4@dev|^5.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.42-dev"
                    }
                },
                "autoload": {
                    "psr-0": {
                        "Twig_": "lib/"
                    },
                    "psr-4": {
                        "Twig\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "BSD-3-Clause"
                ],
                "authors": [
                    {
                        "name": "Fabien Potencier",
                        "email": "fabien@symfony.com",
                        "homepage": "http://fabien.potencier.org",
                        "role": "Lead Developer"
                    },
                    {
                        "name": "Twig Team",
                        "homepage": "https://twig.symfony.com/contributors",
                        "role": "Contributors"
                    },
                    {
                        "name": "Armin Ronacher",
                        "email": "armin.ronacher@active-4.com",
                        "role": "Project Founder"
                    }
                ],
                "description": "Twig, the flexible, fast, and secure template language for PHP",
                "homepage": "https://twig.symfony.com",
                "keywords": [
                    "templating"
                ],
                "time": "2019-08-24T12:51:03+00:00"
            },
            {
                "name": "ua-parser/uap-php",
                "version": "v3.9.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/ua-parser/uap-php.git",
                    "reference": "2b7130ce5030a880e9d6c4d8463fd181dfd94711"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/ua-parser/uap-php/zipball/2b7130ce5030a880e9d6c4d8463fd181dfd94711",
                    "reference": "2b7130ce5030a880e9d6c4d8463fd181dfd94711",
                    "shasum": ""
                },
                "require": {
                    "composer/ca-bundle": "^1.1",
                    "php": ">=5.3.0"
                },
                "require-dev": {
                    "phpunit/phpunit": "<8",
                    "symfony/console": "^2.0 || ^3.0 || ^4.0",
                    "symfony/filesystem": "^2.0 || ^3.0 || ^4.0",
                    "symfony/finder": "^2.0 || ^3.0 || ^4.0",
                    "symfony/yaml": "^2.0 || ^3.0 || ^4.0"
                },
                "suggest": {
                    "symfony/console": "Required for CLI usage - ^2.0 || ^3.0 || ^4.0",
                    "symfony/filesystem": "Required for CLI usage - 2.0 || ^3.0 || ^4.0",
                    "symfony/finder": "Required for CLI usage - ^2.0 || ^3.0 || ^4.0",
                    "symfony/yaml": "Required for CLI usage - ^4.0 || ^5.0"
                },
                "bin": [
                    "bin/uaparser"
                ],
                "type": "library",
                "autoload": {
                    "psr-4": {
                        "UAParser\\": "src"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Lars Strojny",
                        "email": "lars@strojny.net"
                    },
                    {
                        "name": "Dave Olsen",
                        "email": "dmolsen@gmail.com"
                    }
                ],
                "description": "A multi-language port of Browserscope's user agent parser.",
                "time": "2019-07-15T14:27:12+00:00"
            },
            {
                "name": "webmozart/assert",
                "version": "1.5.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/webmozart/assert.git",
                    "reference": "88e6d84706d09a236046d686bbea96f07b3a34f4"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/webmozart/assert/zipball/88e6d84706d09a236046d686bbea96f07b3a34f4",
                    "reference": "88e6d84706d09a236046d686bbea96f07b3a34f4",
                    "shasum": ""
                },
                "require": {
                    "php": "^5.3.3 || ^7.0",
                    "symfony/polyfill-ctype": "^1.8"
                },
                "require-dev": {
                    "phpunit/phpunit": "^4.8.36 || ^7.5.13"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.3-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Webmozart\\Assert\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Bernhard Schussek",
                        "email": "bschussek@gmail.com"
                    }
                ],
                "description": "Assertions to validate method input/output with nice error messages.",
                "keywords": [
                    "assert",
                    "check",
                    "validate"
                ],
                "time": "2019-08-24T08:43:50+00:00"
            },
            {
                "name": "webmozart/path-util",
                "version": "2.3.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/webmozart/path-util.git",
                    "reference": "d939f7edc24c9a1bb9c0dee5cb05d8e859490725"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/webmozart/path-util/zipball/d939f7edc24c9a1bb9c0dee5cb05d8e859490725",
                    "reference": "d939f7edc24c9a1bb9c0dee5cb05d8e859490725",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.3",
                    "webmozart/assert": "~1.0"
                },
                "require-dev": {
                    "phpunit/phpunit": "^4.6",
                    "sebastian/version": "^1.0.1"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "2.3-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Webmozart\\PathUtil\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Bernhard Schussek",
                        "email": "bschussek@gmail.com"
                    }
                ],
                "description": "A robust cross-platform utility for normalizing, comparing and modifying file paths.",
                "time": "2015-12-17T08:42:14+00:00"
            }
        ],
        "packages-dev": [],
        "aliases": [],
        "minimum-stability": "stable",
        "stability-flags": {
            "contao/conflicts": 20
        },
        "prefer-stable": false,
        "prefer-lowest": false,
        "platform": [],
        "platform-dev": [],
        "platform-overrides": {
            "php": "7.2.23.0",
            "php-64bit": "7.2.23.0",
            "php-ipv6": "7.2.23.0",
            "ext-date": "7.2.23.0",
            "ext-libxml": "7.2.23.0",
            "ext-openssl": "7.2.23.0",
            "ext-pcre": "7.2.23.0",
            "ext-zlib": "7.2.23.0",
            "ext-filter": "7.2.23.0",
            "ext-hash": "1.0.0.0",
            "ext-pcntl": "7.2.23.0",
            "ext-reflection": "7.2.23.0",
            "ext-spl": "7.2.23.0",
            "ext-sodium": "7.2.23.0",
            "ext-session": "7.2.23.0",
            "ext-cgi-fcgi": "0.0.0.0",
            "ext-soap": "7.2.23.0",
            "ext-mysqlnd": "0.0.0.0",
            "ext-pdo": "7.2.23.0",
            "ext-xml": "7.2.23.0",
            "ext-calendar": "7.2.23.0",
            "ext-ctype": "7.2.23.0",
            "ext-curl": "7.2.23.0",
            "ext-dom": "20031129",
            "ext-mbstring": "7.2.23.0",
            "ext-fileinfo": "1.0.5.0",
            "ext-ftp": "7.2.23.0",
            "ext-gd": "7.2.23.0",
            "ext-gettext": "7.2.23.0",
            "ext-iconv": "7.2.23.0",
            "ext-imagick": "3.4.4.0",
            "ext-intl": "1.1.0.0",
            "ext-json": "1.6.0.0",
            "ext-exif": "7.2.23.0",
            "ext-mysqli": "7.2.23.0",
            "ext-pdo_mysql": "7.2.23.0",
            "ext-phar": "2.0.2.0",
            "ext-posix": "7.2.23.0",
            "ext-readline": "7.2.23.0",
            "ext-recode": "7.2.23.0",
            "ext-shmop": "7.2.23.0",
            "ext-simplexml": "7.2.23.0",
            "ext-sockets": "7.2.23.0",
            "ext-sysvmsg": "7.2.23.0",
            "ext-sysvsem": "7.2.23.0",
            "ext-sysvshm": "7.2.23.0",
            "ext-tidy": "7.2.23.0",
            "ext-tokenizer": "7.2.23.0",
            "ext-wddx": "7.2.23.0",
            "ext-xmlreader": "7.2.23.0",
            "ext-xmlrpc": "7.2.23.0",
            "ext-xmlwriter": "7.2.23.0",
            "ext-xsl": "7.2.23.0",
            "ext-zip": "1.15.4.0",
            "ext-zend-opcache": "7.2.23.0",
            "lib-libxml": "2.9.9.0",
            "lib-openssl": "1.1.1.3",
            "lib-pcre": "8.43.0.0",
            "lib-curl": "7.47.0.0",
            "lib-iconv": "2.23.0.0",
            "lib-imagick": "6.8.9.9",
            "lib-icu": "64.1.0.0",
            "lib-xsl": "1.1.28.0"
        }
    }
    Ich finde da zur Zeit keine Lösung und habe Visitors wierder deinstalliert.

  14. #14
    Wandelndes Contao-Lexikon Avatar von BugBuster
    Registriert seit
    15.06.2009.
    Ort
    Berlin
    Beiträge
    10.103
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von compuzius Beitrag anzeigen
    - Bei bestehenden älteren Contao-Installationen mit Visitors tritt dieser Fehler - auch nach Aktualisierung - nicht auf.
    - Offenbar tritt der Fehler nur bei einer Neuinstallation mit dem Contao-Manager 1.2 auf.

    Ein möglicher Hinweis könnte das Log des Managers geben.
    Code:
    Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
    Diese Warnung bleibt auch nach einem Update (Aktualisierung) bestehen.

    Ich finde da zur Zeit keine Lösung und habe Visitors wierder deinstalliert.
    Da würde ich dann auf Kommandozeile versuchen den Grund für die Fehlermeldung zu finden, denn solange die lock Datei nicht "up to date" ist, solange ist die Installation nicht korrekt gelaufen.
    Da wird es schwer festzustellen, was genau nun das Problem ist, denn das ist nicht nachstellbar.
    Grüße, BugBuster
    "view source" is your guide.
    Danke an alle Amazon Wunschlisten Erfüller

  15. #15
    Contao-Nutzer
    Registriert seit
    30.09.2012.
    Beiträge
    28

    Standard Die Warnmeldung bleibt

    Naja - bei Strato habe ich keinen Konsolenzugang, aber auf meiner lokalen Testumgebung habe ich das mal getestet.
    Im "web" Verzeichnis "composer require contao/manager-bundle:4.4.*" und "composer update" aufgerufen.
    Konsolenausgabe:
    Code:
    werner@TOSHIBA /var/www/html/werner/public_html/harhoff/web $ composer require contao/manager-bundle:4.4.*
    ./composer.json has been updated
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Package operations: 111 installs, 0 updates, 0 removals
      - Installing contao-components/installer (1.3.1): Loading from cache
      - Installing symfony/polyfill-ctype (v1.12.0): Loading from cache
      - Installing symfony/polyfill-mbstring (v1.12.0): Loading from cache
      - Installing twig/twig (v1.42.3): Loading from cache
      - Installing paragonie/random_compat (v9.99.99): Loading from cache
      - Installing symfony/polyfill-php70 (v1.12.0): Loading from cache
      - Installing symfony/polyfill-util (v1.12.0): Loading from cache
      - Installing symfony/polyfill-php56 (v1.12.0): Loading from cache
      - Installing symfony/symfony (v3.4.32): Loading from cache
      - Installing symfony/polyfill-intl-icu (v1.12.0): Loading from cache
      - Installing symfony/polyfill-apcu (v1.12.0): Loading from cache
      - Installing psr/simple-cache (1.0.1): Loading from cache
      - Installing psr/log (1.1.0): Loading from cache
      - Installing psr/link (1.0.0): Loading from cache
      - Installing psr/container (1.0.0): Loading from cache
      - Installing psr/cache (1.0.1): Loading from cache
      - Installing fig/link-util (1.0.0): Loading from cache
      - Installing doctrine/lexer (1.1.0): Loading from cache
      - Installing doctrine/annotations (v1.8.0): Loading from cache
      - Installing doctrine/reflection (v1.0.0): Loading from cache
      - Installing doctrine/event-manager (v1.0.0): Loading from cache
      - Installing doctrine/collections (v1.6.2): Loading from cache
      - Installing doctrine/cache (v1.8.0): Loading from cache
      - Installing doctrine/persistence (1.1.1): Loading from cache
      - Installing doctrine/inflector (v1.3.0): Loading from cache
      - Installing doctrine/common (v2.11.0): Loading from cache
      - Installing symfony/polyfill-php73 (v1.12.0): Loading from cache
      - Installing symfony/polyfill-php72 (v1.12.0): Loading from cache
      - Installing symfony/polyfill-intl-idn (v1.12.0): Loading from cache
      - Installing symfony/mime (v4.3.5): Loading from cache
      - Installing toflar/psr6-symfony-http-cache-store (2.1.1): Loading from cache
      - Installing psr/http-message (1.0.1): Loading from cache
      - Installing php-http/message-factory (v1.0.2): Loading from cache
      - Installing clue/stream-filter (v1.4.1): Loading from cache
      - Installing php-http/message (1.8.0): Loading from cache
      - Installing php-http/discovery (1.7.0): Loading from cache
      - Installing php-http/promise (v1.0.0): Loading from cache
      - Installing php-http/httplug (v1.1.0): Loading from cache
      - Installing ralouphie/getallheaders (3.0.3): Loading from cache
      - Installing guzzlehttp/psr7 (1.6.1): Loading from cache
      - Installing guzzlehttp/promises (v1.3.1): Loading from cache
      - Installing guzzlehttp/guzzle (6.3.3): Loading from cache
      - Installing php-http/guzzle6-adapter (v1.1.1): Loading from cache
      - Installing php-http/client-common (1.9.1): Loading from cache
      - Installing friendsofsymfony/http-cache (2.7.0): Loading from cache
      - Installing friendsofsymfony/http-cache-bundle (2.7.2): Loading from cache
      - Installing terminal42/header-replay-bundle (1.5.3): Loading from cache
      - Installing swiftmailer/swiftmailer (v5.4.12): Loading from cache
      - Installing symfony/swiftmailer-bundle (v2.6.7): Loading from cache
      - Installing monolog/monolog (1.25.1): Loading from cache
      - Installing symfony/monolog-bundle (v3.4.0): Loading from cache
      - Installing composer/ca-bundle (1.2.4): Loading from cache
      - Installing ua-parser/uap-php (v3.9.1): Loading from cache
      - Installing nelmio/security-bundle (2.7.0): Loading from cache
      - Installing lexik/maintenance-bundle (v2.1.5): Loading from cache
      - Installing jdorn/sql-formatter (v1.2.17): Loading from cache
      - Installing doctrine/doctrine-cache-bundle (1.3.5): Loading from cache
      - Installing doctrine/dbal (v2.8.1): Loading from cache
      - Installing doctrine/doctrine-bundle (1.11.2): Loading from cache
      - Installing contao/manager-plugin (2.7.1): Loading from cache
      - Installing sensiolabs/ansi-to-html (v1.1.3): Loading from cache
      - Installing symfony/http-client-contracts (v1.1.7): Loading from cache
      - Installing symfony/http-client (v4.3.5): Loading from cache
      - Installing sensiolabs/security-checker (v6.0.2): Loading from cache
      - Installing sensio/distribution-bundle (v5.0.25): Loading from cache
      - Installing webmozart/assert (1.5.0): Loading from cache
      - Installing webmozart/path-util (2.3.0): Loading from cache
      - Installing true/punycode (v2.1.1): Loading from cache
      - Installing tecnickcom/tcpdf (6.3.2): Loading from cache
      - Installing simplepie/simplepie (1.5.3): Loading from cache
      - Installing scssphp/scssphp (1.0.5): Loading from cache
      - Installing phpunit/php-token-stream (3.1.1): Loading from cache
      - Installing phpspec/php-diff (v1.1.0): Loading from cache
      - Installing patchwork/utf8 (v1.3.1): Loading from cache
      - Installing oyejorge/less.php (v1.7.0.14): Loading from cache
      - Installing nelmio/cors-bundle (1.5.6): Loading from cache
      - Installing michelf/php-markdown (1.8.0): Loading from cache
      - Installing matthiasmullie/path-converter (1.1.2): Loading from cache
      - Installing matthiasmullie/minify (1.3.61): Loading from cache
      - Installing jeremykendall/php-domain-parser (3.0.0): Loading from cache
      - Installing league/uri (4.2.2): Loading from cache
      - Installing knplabs/knp-time-bundle (v1.9.1): Loading from cache
      - Installing knplabs/knp-menu (2.6.0): Loading from cache
      - Installing knplabs/knp-menu-bundle (v2.3.0): Loading from cache
      - Installing imagine/imagine (1.2.2): Loading from cache
      - Installing contao/imagine-svg (0.2.2): Loading from cache
      - Installing contao/image (0.3.9): Loading from cache
      - Installing contao-components/compass (0.12.2.1): Loading from cache
      - Installing contao/core-bundle (4.4.44): Loading from cache
      - Installing contao/installation-bundle (4.4.44): Loading from cache
      - Installing contao/manager-bundle (4.4.44): Loading from cache
    paragonie/random_compat suggests installing ext-libsodium (Provides a modern crypto API that can be used to generate random bytes.)
    doctrine/cache suggests installing alcaeus/mongo-php-adapter (Required to use legacy MongoDB driver)
    php-http/message suggests installing zendframework/zend-diactoros (Used with Diactoros Factories)
    php-http/message suggests installing slim/slim (Used with Slim Framework PSR-7 implementation)
    php-http/discovery suggests installing puli/composer-plugin (Sets up Puli which is recommended for Discovery to work. Check http://docs.php-http.org/en/latest/discovery.html for more details.)
    guzzlehttp/psr7 suggests installing zendframework/zend-httphandlerrunner (Emit PSR-7 responses)
    php-http/client-common suggests installing php-http/logger-plugin (PSR-3 Logger plugin)
    php-http/client-common suggests installing php-http/cache-plugin (PSR-6 Cache plugin)
    php-http/client-common suggests installing php-http/stopwatch-plugin (Symfony Stopwatch plugin)
    friendsofsymfony/http-cache-bundle suggests installing sensio/framework-extra-bundle (For Tagged Cache Invalidation)
    monolog/monolog suggests installing graylog2/gelf-php (Allow sending log messages to a GrayLog2 server)
    monolog/monolog suggests installing sentry/sentry (Allow sending log messages to a Sentry server)
    monolog/monolog suggests installing doctrine/couchdb (Allow sending log messages to a CouchDB server)
    monolog/monolog suggests installing ruflin/elastica (Allow sending log messages to an Elastic Search server)
    monolog/monolog suggests installing php-amqplib/php-amqplib (Allow sending log messages to an AMQP server using php-amqplib)
    monolog/monolog suggests installing ext-amqp (Allow sending log messages to an AMQP server (1.0+ required))
    monolog/monolog suggests installing ext-mongo (Allow sending log messages to a MongoDB server)
    monolog/monolog suggests installing mongodb/mongodb (Allow sending log messages to a MongoDB server via PHP Driver)
    monolog/monolog suggests installing aws/aws-sdk-php (Allow sending log messages to AWS services like DynamoDB)
    monolog/monolog suggests installing rollbar/rollbar (Allow sending log messages to Rollbar)
    monolog/monolog suggests installing php-console/php-console (Allow sending log messages to Google Chrome)
    doctrine/doctrine-cache-bundle suggests installing symfony/security-acl (For using this bundle to cache ACLs)
    doctrine/doctrine-bundle suggests installing doctrine/orm (The Doctrine ORM integration is optional in the bundle.)
    simplepie/simplepie suggests installing mf2/mf2 (Microformat module that allows for parsing HTML for microformats)
    patchwork/utf8 suggests installing ext-wfio (Use WFIO for UTF-8 filesystem access on Windows)
    imagine/imagine suggests installing ext-gmagick (to use the Gmagick implementation)
    Generating autoload files
    contao/manager-plugin: Generating plugin class...
    contao/manager-plugin: ...done generating plugin class
    werner@TOSHIBA /var/www/html/werner/public_html/harhoff/web $ composer update
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Package operations: 0 installs, 1 update, 0 removals
      - Updating guzzlehttp/guzzle (6.3.3 => 6.4.0): Downloading (100%)         
    Writing lock file
    Generating autoload files
    contao/manager-plugin: Generating plugin class...
    contao/manager-plugin: ...done generating plugin class
    Soweit ich das beurteilen kann wurden da nur die Contao-Core Elemente neu installiert.
    Der Fehler mit den fehlenden Menüeinträgen unter "System" für den Benutzer blieb bestehen.

    Daraufhin habe ich mal eine Neuinstallation von Contao 4.4 gemacht und anschließend "Pakete aktualisieren" aufgerufen.
    Siehe da - die Warnmeldung war wieder da.
    Code:
    Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
    Wohlgemerkt: Nur das nackte Contao mit anschließender Aktualisierung.
    Da scheint wohl irgendwas mit der Aktualisierung nicht zu klappen oder meine Testumgebung ist nicht kompatibel.

    Die Warnmeldung sollte reproduzierbar sein, es liegt wohl nicht (nur) an der Erweiterung "Visitors".

  16. #16
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    14.027
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von compuzius Beitrag anzeigen
    bei Strato habe ich keinen Konsolenzugang
    FYI: Normalerweise hast Du bei Strato auch einen Shell-Zugang.
    Contao Community Administrator
    [Unterstützungsmöglichkeiten]

  17. #17
    Contao-Nutzer
    Registriert seit
    30.09.2012.
    Beiträge
    28

    Standard

    Zitat Zitat von xchs Beitrag anzeigen
    FYI: Normalerweise hast Du bei Strato auch einen Shell-Zugang.
    Stimmt. Im Backend von Strato (STRATO PowerWeb Starter) konnte ich dazu nix finden, aber mit der Anleitung unter:
    https://www.strato.de/faq/hosting/so...ssh_verbindung
    hat es dann geklappt.

    Leider bisher ohne Erfolg.

    Code:
    composer require contao/manager-bundle:4.4.*
    composer: No match.
    Code:
    php contao-manager.phar.php self-update
    
    In UpdateCommand.php line 52:
                                                                     
      This build of Contao Manager cannot be automatically updated.  
                                                                     
    
    self-update
    
    X-Powered-By: PHP/7.3.10
    Content-type: text/html
    Gibt es irgendwo eine Anleitung zu der Kommandozeilen-Version des Managers?
    Habe bisher nur Infos zum Webversion gefunden.

  18. #18
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    14.027
    User beschenken
    Wunschliste

    Standard

    Versuche es so:
    Code:
    /opt/RZphp73/bin/php-cli web/contao-manager.phar.php composer update
    Ausgeführt wird das Kommando im Contao Hauptverzeichnis.
    Contao Community Administrator
    [Unterstützungsmöglichkeiten]

  19. #19
    Wandelndes Contao-Lexikon Avatar von BugBuster
    Registriert seit
    15.06.2009.
    Ort
    Berlin
    Beiträge
    10.103
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von compuzius Beitrag anzeigen
    Wenn ich nach der Installation von Visitors in der Benutzerverwaltung den Zugriff auf die Besucherstatisik für die Gruppe "Autor" erteile, dann sind beim anschließenden Login des zur Gruppe gehörenden Benutzers die Menüpunkte unter "System" nicht mehr sichtbar. Nur die "Wiederherstellung" wird noch angezeigt. Als Administrator sind im Backend alle Menüpunkte erreichbar.
    Witzigerweise ist das bei mir in der Contao Demo ebenso. Aber das liegt daran, das für die Benutzergruppe (bei mir Editors) fast alle Menüpunkte innerhalb System deaktiviert sind. Das trifft dann auch Visitors.
    Ich gehe mal davon aus, das ist bei dir ebenso, da Autoren/Editoren normalerweise nichts in den System Menü zu suchen haben.

    Aus meiner Sicht also alles normal.
    Grüße, BugBuster
    "view source" is your guide.
    Danke an alle Amazon Wunschlisten Erfüller

  20. #20
    Contao-Nutzer
    Registriert seit
    30.09.2012.
    Beiträge
    28

    Standard

    Zitat Zitat von xchs Beitrag anzeigen
    Versuche es so:
    Code:
    /opt/RZphp73/bin/php-cli web/contao-manager.phar.php composer update
    Ausgeführt wird das Kommando im Contao Hauptverzeichnis.
    Mit dem Zusatz "-d memory_limit=-1" lief das Script durch.
    Konsolenausgabe:

    Code:
    /opt/RZphp73/bin/php-cli -d memory_limit=-1 web/contao-manager.phar.php composer update
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Nothing to install or update
    Writing lock file
    Generating autoload files
    ocramius/package-versions: Generating version class...
    ocramius/package-versions: ...done generating version class
    contao/manager-plugin: Generating plugin class...
    contao/manager-plugin: ...done generating plugin class
    > Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication
    
     // Clearing the cache for the prod environment with debug                      
     // false                                                                       
    
                                                                                    
     [OK] Cache for the "prod" environment (debug=false) was successfully cleared.  
                                                                                    
    
    
     // Warming up the cache for the prod environment with debug                    
     // false                                                                       
    
                                                                                    
     [OK] Cache for the "prod" environment (debug=false) was successfully warmed.   
                                                                                    
    
    
     Trying to install assets as relative symbolic links.
    
     --- ----------------------------- ------------------ 
          Bundle                        Method / Error    
     --- ----------------------------- ------------------ 
      ?   ContaoCoreBundle              relative symlink  
      ?   ContaoFaqBundle               relative symlink  
      ?   ContaoNewsBundle              relative symlink  
      ?   ContaoNewsletterBundle        relative symlink  
      ?   ContaoMmenuBundle             relative symlink  
      ?   SoftleisterBackupDbBundle     relative symlink  
      ?   BugBusterBotdetectionBundle   relative symlink  
      ?   BugBusterVisitorsBundle       relative symlink  
      ?   ContaoCalendarBundle          relative symlink  
      ?   ContaoCommentsBundle          relative symlink  
     --- ----------------------------- ------------------ 
    
                                                                                    
     [OK] All assets were successfully installed.                                   
                                                                                    
    
    Added the system/initialize.php file.
    Symlinked the system/config/tcpdf.php file.
    
     --- ------------------------------------------ ----------------------------------------------------------------
    Soweit ich das beurteilen kann gab es keine Fehlermeldungen.
    Die Zeitstempel bei "composer.json" und "composer.lock" wurden aktualisiert.

    Sobald ich jedoch im Backend das Modul einbaue und für die Benutzergruppe den Zugriff auf die "Besucherstatistik" freigebe verschwinden im Backend für den Benutzer wieder die Menüpunkte unter "System".
    Nach einer Deinstallation von Vistors 1.5.2 sind die Menüpukte unter "System" für den Benutzer wieder sichtbar.

    Ich habe schon einige Contao-Installationen gemacht, aber ein so mysteriöser Fehler ist mir noch nicht vorgekommen.

  21. #21
    Contao-Nutzer
    Registriert seit
    30.09.2012.
    Beiträge
    28

    Standard

    Zitat Zitat von BugBuster Beitrag anzeigen
    Witzigerweise ist das bei mir in der Contao Demo ebenso. Aber das liegt daran, das für die Benutzergruppe (bei mir Editors) fast alle Menüpunkte innerhalb System deaktiviert sind. Das trifft dann auch Visitors.
    Ich gehe mal davon aus, das ist bei dir ebenso, da Autoren/Editoren normalerweise nichts in den System Menü zu suchen haben.

    Aus meiner Sicht also alles normal.
    Nun - zumindest die Dateiverwaltung sollte auch für Benutzer zugänglich sein.

  22. #22
    Wandelndes Contao-Lexikon Avatar von BugBuster
    Registriert seit
    15.06.2009.
    Ort
    Berlin
    Beiträge
    10.103
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von compuzius Beitrag anzeigen
    Nun - zumindest die Dateiverwaltung sollte auch für Benutzer zugänglich sein.
    Ist sie das in der entsprechenden Benutzergruppe?
    Grüße, BugBuster
    "view source" is your guide.
    Danke an alle Amazon Wunschlisten Erfüller

  23. #23
    Contao-Nutzer
    Registriert seit
    30.09.2012.
    Beiträge
    28

    Standard

    Zitat Zitat von BugBuster Beitrag anzeigen
    Ist sie das in der entsprechenden Benutzergruppe?
    Nein - unter "System" ist nur der Menüpunkt "Wiederherstellen" sichtbar.

  24. #24
    Wandelndes Contao-Lexikon Avatar von BugBuster
    Registriert seit
    15.06.2009.
    Ort
    Berlin
    Beiträge
    10.103
    User beschenken
    Wunschliste

    Standard

    Nee ich meinte, ob das freigegeben ist, nicht ob sichtbar.
    Beispiel bei mir:
    Benutzergruppen_›_Gruppe_ID_1_bearbeiten_-_Contao_Open_Source_CMS_-_2019-10-24_01.06.27.jpg
    Grüße, BugBuster
    "view source" is your guide.
    Danke an alle Amazon Wunschlisten Erfüller

  25. #25
    Contao-Nutzer
    Registriert seit
    30.09.2012.
    Beiträge
    28

    Standard

    Hier die Freigaben und das Ergebnis als Benutzer:
    Rechte.png
    Backend.png

  26. #26
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    22.293
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von compuzius Beitrag anzeigen
    Hier die Freigaben und das Ergebnis als Benutzer:
    Rechte.png
    Backend.png
    Poste einen Screenshot der gesamten Benutzergruppenkonfiguration.

  27. #27
    Contao-Nutzer
    Registriert seit
    30.09.2012.
    Beiträge
    28

    Standard

    Einen Screenshot? Das ist ne lange Liste - 7 Screenshots.

    Rechte_1.png
    Rechte_2.png
    Rechte_3.png
    Rechte_4.png
    Rechte_5.png
    Rechte_6.png
    Rechte_7.png

  28. #28
    Wandelndes Contao-Lexikon Avatar von BugBuster
    Registriert seit
    15.06.2009.
    Ort
    Berlin
    Beiträge
    10.103
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von compuzius Beitrag anzeigen
    Naja - bei Strato habe ich keinen Konsolenzugang, aber auf meiner lokalen Testumgebung habe ich das mal getestet.
    Im "web" Verzeichnis "composer require contao/manager-bundle:4.4.*" und "composer update" aufgerufen.
    Dein "web" Verzeichnis, ist das das web innerhalb der Contao Installation oder ist das das Installationsverzeichnis von Contao? (dann müsstest du in Prinzip ein web/web/ haben)
    Wenn ersteres, das war falsch.
    Grüße, BugBuster
    "view source" is your guide.
    Danke an alle Amazon Wunschlisten Erfüller

  29. #29
    Contao-Nutzer
    Registriert seit
    30.09.2012.
    Beiträge
    28

    Standard

    Zitat Zitat von BugBuster Beitrag anzeigen
    Dein "web" Verzeichnis, ist das das web innerhalb der Contao Installation oder ist das das Installationsverzeichnis von Contao? (dann müsstest du in Prinzip ein web/web/ haben)
    Wenn ersteres, das war falsch.
    Das passt schon. Contao ist im Verzeichnis "contao4" installiert und dort gibt es einen Unterordner "web", auf den die Domain angemeldet ist.
    Nix mit web/web.

  30. #30
    Contao-Nutzer
    Registriert seit
    30.09.2012.
    Beiträge
    28

    Standard

    Ich habe den Installationsprozeß von "visitors" noch mal wiederholt, um herauszufinden wann es zu den Unregelmäßigkeiten kommt.

    Installiert:
    Contao Open Source CMS 4.4.44
    Contao Cookiebar 2.2.0
    Google Maps 2.4.1
    mmenu - Mobile Navigation für Contao 3.1.0
    Datenbanksicherung 1.4.0
    RockSolid AntiSpam 2.0.0

    Neu:
    Besucher Statistiken 1.5.2

    Meldung des Managers bei Installation von "visitors"
    Code:
    > Resolving dependencies using Composer Cloud v2.0.11
    
    # Job ID ht43aggKyuJ3DoOkqa9Cin7lHnqnwBSXEe8HMsQEpLgHicq5HRx6GWYS3YACmoT0mt0Lm13yZtTDU818687cLoZAIXYxbsTBcb completed in 77 seconds
    # Memory usage: 766.68MB (peak: 3940.77MB), time: 84.54s.
    
    $ /usr/bin/php7.2 -q /var/www/html/werner/public_html/harhoff/web/contao-manager.phar.php composer install --prefer-dist --no-dev --no-progress --no-suggest --no-ansi --no-interaction --optimize-autoloader
    
    contao/manager-plugin: Generating plugin class...
    contao/manager-plugin: ...done generating plugin class
    ocramius/package-versions:  Generating version class...
    ocramius/package-versions: ...done generating version class
    
     // Clearing the cache for the prod environment with debug                      
     // false                                                                       
    
     [OK] Cache for the "prod" environment (debug=false) was successfully cleared.  
    
    
     // Warming up the cache for the prod environment with debug                    
     // false                                                                       
    
     [OK] Cache for the "prod" environment (debug=false) was successfully warmed.   
    
    
     Trying to install assets as relative symbolic links.
    
     --- ----------------------------- ------------------ 
          Bundle                        Method / Error    
     --- ----------------------------- ------------------ 
      ?   ContaoCoreBundle              relative symlink  
      ?   ContaoFaqBundle               relative symlink  
      ?   ContaoNewsBundle              relative symlink  
      ?   ContaoNewsletterBundle        relative symlink  
      ?   ContaoMmenuBundle             relative symlink  
      ?   SoftleisterBackupDbBundle     relative symlink  
      ?   BugBusterBotdetectionBundle   relative symlink  
      ?   BugBusterVisitorsBundle       relative symlink  
      ?   ContaoCalendarBundle          relative symlink  
      ?   ContaoCommentsBundle          relative symlink  
     --- ----------------------------- ------------------ 
    
     [OK] All assets were successfully installed.                                   
    
    Added the system/initialize.php file.
    Symlinked the system/config/tcpdf.php file.
    
     --- ------------------------------------------ ---------------------------------------------------------------- 
          Symlink                                    Target / Error                                                  
     --- ------------------------------------------ ---------------------------------------------------------------- 
      !   web/files/logopaedie/praxisrundgang        Skipped because files/logopaedie will be symlinked.             
      !   web/files/logopaedie/unser_team            Skipped because files/logopaedie will be symlinked.             
      !   web/files/logopaedie/sonstige_bilder       Skipped because files/logopaedie will be symlinked.             
      ?   web/files/logopaedie                       files/logopaedie                                                
      ?   web/files/layout                           files/layout                                                    
      ?   web/system/modules/cookiebar/assets        system/modules/cookiebar/assets                                 
      ?   web/system/modules/dlh_googlemaps/assets   system/modules/dlh_googlemaps/assets                            
      ?   system/themes/flexible                     vendor/contao/core-bundle/src/Resources/contao/themes/flexible  
      ?   web/assets                                 assets                                                          
      ?   web/system/themes                          system/themes                                                   
      ?   system/logs                                var/logs                                                        
     --- ------------------------------------------ ---------------------------------------------------------------- 
    
    Loading composer repositories with package information
    Installing dependencies from lock file
    Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
    Package operations: 9 installs, 0 updates, 0 removals
    As there is no 'unzip' command installed zip files are being unpacked using the PHP zip extension.
    This may cause invalid reports of corrupted archives. Besides, any UNIX permissions (e.g. executable) defined in the archives will be lost.
    Installing 'unzip' may remediate them.
      - Installing ocramius/package-versions (1.4.0): Downloading (100%)
      - Installing markbaker/matrix (1.2.0): Downloading (100%)
      - Installing markbaker/complex (1.4.7): Downloading (100%)
      - Installing phpoffice/phpspreadsheet (1.9.0): Downloading (100%)
      - Installing jean85/pretty-package-versions (1.2): Downloading (100%)
      - Installing composer/semver (1.5.0): Downloading (100%)
      - Installing crossjoin/browscap (v1.0.6): Downloading (100%)
      - Installing bugbuster/contao-botdetection-bundle (1.0.1): Downloading (100%)
      - Installing bugbuster/contao-visitors-bundle (1.5.2): Downloading (100%)
    Generating optimized autoload files
    > Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication
    
    # Process terminated with exit code 0
    # Result: OK
    
    
    ---
    
    ### Prozess erfolgreich abgeschlossen ###
    Install-Tool:
    Code:
    Tabellen anlegen
    	Alle auswählen
    	
    
    CREATE TABLE tl_visitors (
      id INT UNSIGNED AUTO_INCREMENT NOT NULL, 
      pid INT UNSIGNED DEFAULT 0 NOT NULL, 
      sorting INT UNSIGNED DEFAULT 0 NOT NULL, 
      tstamp INT UNSIGNED DEFAULT 0 NOT NULL, 
      visitors_name VARCHAR(64) DEFAULT '' NOT NULL, 
      visitors_startdate VARCHAR(10) DEFAULT '' NOT NULL, 
      visitors_visit_start INT UNSIGNED DEFAULT 0 NOT NULL, 
      visitors_hit_start INT UNSIGNED DEFAULT 0 NOT NULL, 
      visitors_average CHAR(1) DEFAULT '' NOT NULL, 
      visitors_block_time INT UNSIGNED DEFAULT 1800 NOT NULL, 
      visitors_thousands_separator CHAR(1) DEFAULT '' NOT NULL, 
      visitors_statistic_days INT UNSIGNED DEFAULT 14 NOT NULL, 
      published CHAR(1) DEFAULT '' NOT NULL, 
      visitors_expert_debug_tag CHAR(1) DEFAULT '' NOT NULL, 
      visitors_expert_debug_checks CHAR(1) DEFAULT '' NOT NULL, 
      visitors_expert_debug_referrer CHAR(1) DEFAULT '' NOT NULL, 
      visitors_expert_debug_searchengine CHAR(1) DEFAULT '' NOT NULL, 
      visitors_expert_debug_screenresolutioncount CHAR(1) DEFAULT '' NOT NULL, 
      INDEX pid (pid), 
      PRIMARY KEY(id)
    ) DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci ENGINE = MyISAM
    
    	
    
    CREATE TABLE tl_visitors_blocker (
      id INT UNSIGNED AUTO_INCREMENT NOT NULL, 
      vid INT UNSIGNED DEFAULT 0 NOT NULL, 
      visitors_tstamp DATETIME DEFAULT NULL, 
      visitors_ip VARCHAR(40) DEFAULT '0.0.0.0' NOT NULL, 
      visitors_type CHAR(1) DEFAULT 'v' NOT NULL, 
      INDEX vid (vid), 
      PRIMARY KEY(id)
    ) DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci ENGINE = MyISAM
    
    	
    
    CREATE TABLE tl_visitors_browser (
      id INT UNSIGNED AUTO_INCREMENT NOT NULL, 
      vid INT UNSIGNED DEFAULT 0 NOT NULL, 
      visitors_browser VARCHAR(60) DEFAULT 'Unknown' NOT NULL, 
      visitors_os VARCHAR(60) DEFAULT 'Unknown' NOT NULL, 
      visitors_lang VARCHAR(10) DEFAULT 'Unknown' NOT NULL, 
      visitors_counter INT UNSIGNED DEFAULT 0 NOT NULL, 
      INDEX vid (vid), 
      PRIMARY KEY(id)
    ) DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci ENGINE = MyISAM
    
    	
    
    CREATE TABLE tl_visitors_category (
      id INT UNSIGNED AUTO_INCREMENT NOT NULL, 
      tstamp INT UNSIGNED DEFAULT 0 NOT NULL, 
      title VARCHAR(60) DEFAULT '' NOT NULL, 
      visitors_stat_protected CHAR(1) DEFAULT '' NOT NULL, 
      visitors_stat_groups VARCHAR(255) DEFAULT '' NOT NULL, 
      visitors_statreset_protected CHAR(1) DEFAULT '' NOT NULL, 
      visitors_statreset_groups VARCHAR(255) DEFAULT '' NOT NULL, 
      PRIMARY KEY(id)
    ) DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci ENGINE = MyISAM
    
    	
    
    CREATE TABLE tl_visitors_counter (
      id INT UNSIGNED AUTO_INCREMENT NOT NULL, 
      vid INT UNSIGNED DEFAULT 0 NOT NULL, 
      visitors_date DATE DEFAULT '1999-01-01' NOT NULL, 
      visitors_visit INT UNSIGNED DEFAULT 0 NOT NULL, 
      visitors_hit INT UNSIGNED DEFAULT 0 NOT NULL, 
      UNIQUE INDEX vid_visitors_date (vid, visitors_date), 
      PRIMARY KEY(id)
    ) DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci ENGINE = MyISAM
    
    	
    
    CREATE TABLE tl_visitors_pages (
      id INT UNSIGNED AUTO_INCREMENT NOT NULL, 
      vid INT UNSIGNED DEFAULT 0 NOT NULL, 
      visitors_page_date DATE DEFAULT '1999-01-01' NOT NULL, 
      visitors_page_id INT UNSIGNED DEFAULT 0 NOT NULL, 
      visitors_page_pid INT UNSIGNED DEFAULT 0 NOT NULL, 
      visitors_page_type TINYINT(1) DEFAULT '0' NOT NULL, 
      visitors_page_visit INT UNSIGNED DEFAULT 0 NOT NULL, 
      visitors_page_hit INT UNSIGNED DEFAULT 0 NOT NULL, 
      visitors_page_lang VARCHAR(5) DEFAULT '' NOT NULL, 
      UNIQUE INDEX vid_visitors_page_date_visitors_page_id_visitors_page_type (
        vid, visitors_page_date, visitors_page_id, 
        visitors_page_type
      ), 
      PRIMARY KEY(id)
    ) DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci ENGINE = MyISAM
    
    	
    
    CREATE TABLE tl_visitors_referrer (
      id INT UNSIGNED AUTO_INCREMENT NOT NULL, 
      vid INT UNSIGNED DEFAULT 0 NOT NULL, 
      tstamp INT UNSIGNED DEFAULT 0 NOT NULL, 
      visitors_referrer_dns VARCHAR(255) DEFAULT '-' NOT NULL, 
      visitors_referrer_full TEXT DEFAULT NULL, 
      INDEX vid (vid), 
      PRIMARY KEY(id)
    ) DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci ENGINE = MyISAM
    
    	
    
    CREATE TABLE tl_visitors_screen_counter (
      id INT UNSIGNED AUTO_INCREMENT NOT NULL, 
      vid INT UNSIGNED DEFAULT 0 NOT NULL, 
      v_date DATE DEFAULT '1999-01-01' NOT NULL, 
      v_s_w INT UNSIGNED DEFAULT 0 NOT NULL, 
      v_s_h INT UNSIGNED DEFAULT 0 NOT NULL, 
      v_s_iw INT UNSIGNED DEFAULT 0 NOT NULL, 
      v_s_ih INT UNSIGNED DEFAULT 0 NOT NULL, 
      v_screen_counter INT UNSIGNED DEFAULT 0 NOT NULL, 
      UNIQUE INDEX vid_v_date_v_s_w_v_s_h_v_s_iw_v_s_ih (
        vid, v_date, v_s_w, v_s_h, v_s_iw, v_s_ih
      ), 
      PRIMARY KEY(id)
    ) DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci ENGINE = MyISAM
    
    	
    
    CREATE TABLE tl_visitors_searchengines (
      id INT UNSIGNED AUTO_INCREMENT NOT NULL, 
      vid INT UNSIGNED DEFAULT 0 NOT NULL, 
      tstamp INT UNSIGNED DEFAULT 0 NOT NULL, 
      visitors_searchengine VARCHAR(60) DEFAULT 'Unknown' NOT NULL, 
      visitors_keywords VARCHAR(255) DEFAULT 'Unknown' NOT NULL, 
      INDEX vid (vid), 
      PRIMARY KEY(id)
    ) DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci ENGINE = MyISAM
    
    Spalten anlegen
    	Alle auswählen
    	
    
    ALTER TABLE tl_module ADD visitors_useragent VARCHAR(64) DEFAULT '' NOT NULL
    
    	
    
    ALTER TABLE tl_module ADD visitors_template VARCHAR(32) DEFAULT '' NOT NULL
    
    	
    
    ALTER TABLE tl_module ADD visitors_categories VARCHAR(255) DEFAULT '' NOT NULL
    Direkt nach der Installation von "visitors" habe ich die vergebenen Benutzerrecht geprüft.
    Dort war das Häkchen bei der Freigabe von "Backup Datenbank" verschwunden.
    Benutzergruppen_Rechte.png

    Bei der Anmeldung als Benutzer konnte ich trotzdem auf "System - Dateiverwaltung" und "System - Backup Datenbank" zugreifen.
    Benutzer_Backend.png

    Irgendein Prozeß scheint bei der Installation von "visitors" die Rechte für die Benutzergruppen durcheinander zu bringen.

  31. #31
    Wandelndes Contao-Lexikon Avatar von BugBuster
    Registriert seit
    15.06.2009.
    Ort
    Berlin
    Beiträge
    10.103
    User beschenken
    Wunschliste

    Standard

    Da sieht mir ganz nach einem Contao Bug aus.
    So konnte ich es teilweise nachvollziehen:
    https://community.contao.org/de/show...er-Erweiterung
    Grüße, BugBuster
    "view source" is your guide.
    Danke an alle Amazon Wunschlisten Erfüller

  32. #32
    Wandelndes Contao-Lexikon Avatar von BugBuster
    Registriert seit
    15.06.2009.
    Ort
    Berlin
    Beiträge
    10.103
    User beschenken
    Wunschliste

    Standard

    Jo, Bug:
    https://github.com/contao/contao/issues/826
    Bugfix, noch nicht implementiert:
    https://github.com/contao/contao/pull/834

    Nachtrag: in Contao 4.4.45 / 4.8.5 behoben.

    Hab den Bugfix mal manuell installiert und Cache gelöscht. Danach waren erstmal alle Berechtigungen unter System weg. Setze ich die neu funktioniert danach aber die Installation/Deinstallation wieder bzw. die Rechte bleiben korrekt gesetzt.
    Sieht bei Details der Gruppe, da nun als Key nicht mehr die Zahlen sondern die Namen auftauchen.
    Code:
    Backend-Module: 	article, calendar, news, page, files, maintenance, visitorstat, bannerstat
    Geändert von BugBuster (16.11.2019 um 15:31 Uhr)
    Grüße, BugBuster
    "view source" is your guide.
    Danke an alle Amazon Wunschlisten Erfüller

  33. #33
    Contao-Nutzer
    Registriert seit
    30.09.2012.
    Beiträge
    28

    Standard

    Ich habe die Änderungen unter
    https://github.com/contao/contao/pul...59557758b84ba1
    auf meiner lokalen Testumgebungen mal nachvollzogen.
    Danach konnte ich die Rechte für die Benutzergruppen neu vergeben und die Freigaben als Benutzer im Backend unter "System" auch wieder sehen.

    Vielen Dank für die Hilfe und die geduldige Suche nach den möglichen Ursachen.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •