Ergebnis 1 bis 7 von 7

Thema: Fehler bei Contao Update: The metamodels.contao_input service or alias has been

  1. #1
    Contao-Nutzer
    Registriert seit
    28.03.2019.
    Beiträge
    39

    Standard Fehler bei Contao Update: The metamodels.contao_input service or alias has been

    Ich wollte ein Update von Contao 4.4 auf Contao 4.8 machen. Dabei kam es im Contao Manager zu diesem Fehler, der sich scheinbar auf MM bezieht:

    Ausschnitt:

    Code:
    In Container.php line 263:
                                                                                   
      The "metamodels.contao_input" service or alias has been removed or inlined   
      when the container was compiled. You should either make it public, or stop   
      using the container directly and use dependency injection instead.
    Ganzer Meldung:

    Code:
    Konsolentask beendet!
    
    Der Hintergrund-Prozess wurde unerwartet beendet. Bitte prüfen Sie die Konsolenausgabe.
    $ /usr/local/bin/php_cli -q /html/FOO/web/contao-manager.phar.php composer require contao/manager-bundle=4.8.* contao/news-bundle=4.8.* contao/calendar-bundle=4.8.* contao/faq-bundle=4.8.* contao/comments-bundle=4.8.* contao/newsletter-bundle=4.8.* contao/listing-bundle=4.8.* --no-suggest --no-update --no-scripts --prefer-stable --sort-packages --no-ansi --no-interaction
    
    /html/FOO/composer.json has been updated
    
    # Process terminated with exit code 0
    # Result: OK
    
    
    > Resolving dependencies using Composer Cloud v2.1.1
    
    # Job ID XXX completed in 43 seconds
    # Memory usage: 409.1MB (peak: 1905.74MB), time: 43.03s.
    
    $ /usr/local/bin/php_cli -q /html/FOO/web/contao-manager.phar.php composer install --prefer-dist --no-dev --no-progress --no-suggest --no-ansi --no-interaction --optimize-autoloader
    
    ocramius/package-versions: Generating version class...
    ocramius/package-versions: ...done generating version class
    contao/manager-plugin: Generating plugin class...
    contao/manager-plugin: ...done generating plugin class
    
     [WARNING] Some commands could not be registered:                               
    
    In Container.php line 263:
                                                                                   
      The "metamodels.contao_input" service or alias has been removed or inlined   
      when the container was compiled. You should either make it public, or stop   
      using the container directly and use dependency injection instead.           
                                                                                   
    
    
     [WARNING] Some commands could not be registered:                               
    
    In Container.php line 263:
                                                                                   
      The "metamodels.contao_input" service or alias has been removed or inlined   
      when the container was compiled. You should either make it public, or stop   
      using the container directly and use dependency injection instead.           
                                                                                   
    
    Added the web/index.php file.
    Added the web/app.php file.
    Added the web/preview.php file.
    Deleted the web/app_dev.php file.
    
     [WARNING] Some commands could not be registered:                               
    
    In Container.php line 263:
                                                                                   
      The "metamodels.contao_input" service or alias has been removed or inlined   
      when the container was compiled. You should either make it public, or stop   
      using the container directly and use dependency injection instead.           
                                                                                   
    
    
     [WARNING] Some commands could not be registered:                               
    
    In Container.php line 263:
                                                                                   
      The "metamodels.contao_input" service or alias has been removed or inlined   
      when the container was compiled. You should either make it public, or stop   
      using the container directly and use dependency injection instead.           
                                                                                   
    
    
     // Clearing the cache for the prod environment with debug                      
     // false                                                                       
    
     [OK] Cache for the "prod" environment (debug=false) was successfully cleared.  
    
    
     [WARNING] Some commands could not be registered:                               
    
    In Container.php line 263:
                                                                                   
      The "metamodels.contao_input" service or alias has been removed or inlined   
      when the container was compiled. You should either make it public, or stop   
      using the container directly and use dependency injection instead.           
                                                                                   
    
    
     [WARNING] Some commands could not be registered:                               
    
    In Container.php line 263:
                                                                                   
      The "metamodels.contao_input" service or alias has been removed or inlined   
      when the container was compiled. You should either make it public, or stop   
      using the container directly and use dependency injection instead.           
                                                                                   
    
    
     // Warming up the cache for the prod environment with debug                    
     // false                                                                       
    
    16:10:35 ERROR     [console] Error thrown while running command "cache:warmup --env=prod". Message: "The "metamodels.contao_input" service or alias has been removed or inlined when the container was compiled. You should either make it public, or stop using the container directly and use dependency injection instead." ["exception" => Symfony\Component\DependencyInjection\Exception\ServiceNotFoundException { …},"command" => "cache:warmup --env=prod","message" => "The "metamodels.contao_input" service or alias has been removed or inlined when the container was compiled. You should either make it public, or stop using the container directly and use dependency injection instead."]
    
    In Container.php line 263:
                                                                                   
      The "metamodels.contao_input" service or alias has been removed or inlined   
      when the container was compiled. You should either make it public, or stop   
      using the container directly and use dependency injection instead.           
                                                                                   
    
    cache:warmup [--no-optional-warmers] [-h|--help] [-q|--quiet] [-v|vv|vvv|--verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-e|--env ENV] [--] <command>
    
    Loading composer repositories with package information
    Installing dependencies from lock file
    Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
    Package operations: 58 installs, 23 updates, 19 removals
      - Removing tecnickcom/tcpdf (6.3.2)
      - Removing symfony/polyfill-util (v1.13.1)
      - Removing symfony/polyfill-php70 (v1.13.1)
      - Removing symfony/polyfill-php56 (v1.13.1)
      - Removing symfony/polyfill-apcu (v1.13.1)
      - Removing symfony/http-client-contracts (v2.0.1)
      - Removing symfony/http-client (v5.0.1)
      - Removing sensiolabs/security-checker (v6.0.3)
      - Removing psr/link (1.0.0)
      - Removing jeremykendall/php-domain-parser (3.0.0)
      - Removing fig/link-util (1.0.0)
      - Removing contao-components/respimage (1.4.2)
      - Removing contao-components/mediaelement (4.2.14)
      - Removing contao-components/html5shiv (3.7.3)
      - Removing contao-components/compass (0.12.2.1)
      - Removing symfony/polyfill-intl-icu (v1.13.1)
      - Removing symfony/symfony (v3.4.36)
      - Removing sensio/distribution-bundle (v5.0.25)
      - Removing terminal42/header-replay-bundle (1.5.3)
      - Updating composer/ca-bundle (1.2.4 => 1.2.5): As there is no 'unzip' command installed zip files are being unpacked using the PHP zip extension.
    This may cause invalid reports of corrupted archives. Besides, any UNIX permissions (e.g. executable) defined in the archives will be lost.
    Installing 'unzip' may remediate them.
    Loading from cache
      - Updating contao-components/contao (7.1.5 => 9.0.0): Loading from cache
      - Updating contao-components/dropzone (4.3.0 => 5.5.0): Loading from cache
      - Updating contao-components/highlight (8.9.1 => 9.16.1): Loading from cache
      - Updating contao-components/jquery (1.12.4 => 3.4.1): Loading from cache
      - Updating contao-components/tablesort (3.4.12 => 4.0.1): Loading from cache
      - Updating contao-components/tinymce4 (4.6.7.3 => 4.9.6): Loading from cache
      - Installing symfony/yaml (v4.3.9): Loading from cache
      - Downgrading symfony/mime (v5.0.1 => v4.4.1): Loading from cache
      - Installing symfony/http-foundation (v4.3.9): Loading from cache
      - Installing symfony/event-dispatcher-contracts (v1.1.7): Loading from cache
      - Installing symfony/event-dispatcher (v4.3.9): Loading from cache
      - Installing symfony/debug (v4.4.1): Loading from cache
      - Installing symfony/http-kernel (v4.3.9): Loading from cache
      - Downgrading symfony/service-contracts (v2.0.1 => v1.1.8): Loading from cache
      - Installing symfony/dependency-injection (v4.3.9): Loading from cache
      - Installing symfony/filesystem (v4.3.9): Loading from cache
      - Installing symfony/config (v4.3.9): Loading from cache
      - Installing symfony/options-resolver (v5.0.1): Loading from cache
      - Updating twig/twig (v1.42.4 => v2.12.2): Loading from cache
      - Installing terminal42/service-annotation-bundle (1.0.0): Loading from cache
      - Installing symfony/var-dumper (v4.3.9): Loading from cache
      - Installing symfony/translation-contracts (v1.1.7): Loading from cache
      - Installing symfony/twig-bridge (v4.4.1): Loading from cache
      - Installing symfony/twig-bundle (v4.3.9): Loading from cache
      - Installing symfony/translation (v4.3.9): Loading from cache
      - Installing symfony/polyfill-iconv (v1.13.1): Loading from cache
      - Installing egulias/email-validator (2.1.11): Loading from cache
      - Updating swiftmailer/swiftmailer (v5.4.12 => v6.2.3): Loading from cache
      - Updating symfony/swiftmailer-bundle (v2.6.7 => v3.4.0): Loading from cache
      - Installing symfony/inflector (v5.0.1): Loading from cache
      - Installing symfony/property-access (v4.4.1): Loading from cache
      - Installing symfony/security (v4.3.9): Loading from cache
      - Installing symfony/security-bundle (v4.3.9): Loading from cache
      - Installing symfony/routing (v4.3.9): Loading from cache
      - Installing symfony/process (v4.3.9): Loading from cache
      - Installing symfony/lock (v4.3.9): Loading from cache
      - Installing symfony/finder (v4.3.9): Loading from cache
      - Installing symfony/var-exporter (v4.4.1): Loading from cache
      - Installing symfony/cache-contracts (v1.1.7): Loading from cache
      - Installing symfony/cache (v4.3.9): Loading from cache
      - Installing symfony/framework-bundle (v4.3.9): Loading from cache
      - Installing symfony/expression-language (v4.3.9): Loading from cache
      - Installing symfony/console (v4.3.9): Loading from cache
      - Installing symfony/asset (v4.3.9): Loading from cache
      - Installing symfony-cmf/routing (2.1.1): Loading from cache
      - Installing symfony-cmf/routing-bundle (2.1.1): Loading from cache
      - Installing paragonie/constant_time_encoding (v2.3.0): Loading from cache
      - Installing beberlei/assert (v3.2.6): Loading from cache
      - Installing spomky-labs/otphp (v9.1.4): Loading from cache
      - Installing lcobucci/jwt (3.3.1): Loading from cache
      - Installing scheb/two-factor-bundle (v4.11.0): Loading from cache
      - Installing league/uri-parser (1.4.1): Loading from cache
      - Installing league/uri-interfaces (1.1.1): Loading from cache
      - Installing league/uri-schemes (1.2.1): Loading from cache
      - Installing league/uri-hostname-parser (1.1.1): Loading from cache
      - Installing league/uri-components (1.8.2): Loading from cache
      - Installing league/uri-manipulations (1.5.0): Loading from cache
      - Removing league/uri (4.2.2)
      - Installing league/uri (5.3.0)
      - Installing symfony/templating (v5.0.1): Loading from cache
      - Installing doctrine/instantiator (1.3.0): Loading from cache
      - Installing doctrine/orm (v2.7.0): Loading from cache
      - Installing symfony/doctrine-bridge (v4.3.9): Loading from cache
      - Updating contao/image (0.3.9 => 1.0.1): Loading from cache
      - Installing dasprid/enum (1.0.0): Loading from cache
      - Installing bacon/bacon-qr-code (2.0.0): Loading from cache
      - Installing ausi/slug-generator (v1.1.0): Loading from cache
      - Updating contao/core-bundle (4.4.45 => 4.8.5): Loading from cache
      - Updating contao/calendar-bundle (4.4.45 => 4.8.5): Loading from cache
      - Updating contao/comments-bundle (4.4.45 => 4.8.5): Loading from cache
      - Updating contao/faq-bundle (4.4.45 => 4.8.5): Loading from cache
      - Updating contao/listing-bundle (4.4.45 => 4.8.5): Loading from cache
      - Installing symfony/web-profiler-bundle (v4.3.9): Loading from cache
      - Installing symfony/proxy-manager-bridge (v4.3.9): Loading from cache
      - Installing symfony/monolog-bridge (v4.3.9): Loading from cache
      - Installing symfony/dotenv (v4.3.9): Loading from cache
      - Installing symfony/debug-bundle (v4.3.9): Loading from cache
      - Updating contao/installation-bundle (4.4.45 => 4.8.5): Loading from cache
      - Updating contao/manager-bundle (4.4.45 => 4.8.5): Loading from cache
      - Updating contao/news-bundle (4.4.45 => 4.8.5): Loading from cache
      - Updating contao/newsletter-bundle (4.4.45 => 4.8.5): Loading from cache
    Generating optimized autoload files
    > Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication
    Script Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication handling the post-install-cmd event terminated with an exception
    
    In ScriptHandler.php line 88:
                                                                                   
      An error occurred while executing the "cache:warmup" command:                
       [WARNING] Some commands could not be registered:                            
                                                                                   
                                                                                   
      In Container.php line 263:                                                   
                                                                                   
                                                                                   
        The "metamodels.contao_input" service or alias has been removed or inline  
      d                                                                            
        when the container was compiled. You should either make it public, or sto  
      p                                                                            
        using the container directly and use dependency injection instead.         
                                                                                   
                                                                                   
                                                                                   
                                                                                   
                                                                                   
       [WARNING] Some commands could not be registered:                            
                                                                                   
                                                                                   
      In Container.php line 263:                                                   
                                                                                   
                                                                                   
        The "metamodels.contao_input" service or alias has been removed or inline  
      d                                                                            
        when the container was compiled. You should either make it public, or sto  
      p                                                                            
        using the container directly and use dependency injection instead.         
                                                                                   
                                                                                   
                                                                                   
                                                                                   
      16:10:35 ERROR     [console] Error thrown while running command "cache:warm  
      up --env=prod". Message: "The "metamodels.contao_input" service or alias ha  
      s been removed or inlined when the container was compiled. You should eithe  
      r make it public, or stop using the container directly and use dependency i  
      njection instead." ["exception" => Symfony\Component\DependencyInjection\Ex  
      ception\ServiceNotFoundException { …},"command" => "cache:warmup --env=prod  
      ","message" => "The "metamodels.contao_input" service or alias has been rem  
      oved or inlined when the container was compiled. You should either make it   
      public, or stop using the container directly and use dependency injection i  
      nstead."]                                                                    
                                                                                   
      In Container.php line 263:                                                   
                                                                                   
                                                                                   
        The "metamodels.contao_input" service or alias has been removed or inline  
      d                                                                            
        when the container was compiled. You should either make it public, or sto  
      p                                                                            
        using the container directly and use dependency injection instead.         
                                                                                   
                                                                                   
                                                                                   
                                                                                   
      cache:warmup [--no-optional-warmers] [-h|--help] [-q|--quiet] [-v|vv|vvv|--  
      verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-e|--en  
      v ENV] [--] <command>                                                        
                                                                                   
    
    install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--] [<packages>...]
    
    
    # Process terminated with exit code 1
    # Result: General error
    
    
    ---
    
    ### Der Hintergrundprozess wurde unerwartet beendet ###
    Ich versteh nicht, was ich tun kann um das zu beheben.

  2. #2
    Contao-Urgestein Avatar von zonky
    Registriert seit
    19.03.2010.
    Ort
    Berlin, Rdf
    Beiträge
    6.443
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von maxine Beitrag anzeigen
    Ich wollte ein Update von Contao 4.4 auf Contao 4.8 machen. Dabei kam es im Contao Manager zu diesem Fehler, der sich scheinbar auf MM bezieht:

    Ich versteh nicht, was ich tun kann um das zu beheben.
    Installationsvorausetzungen lesen: https://metamodels.readthedocs.io/de...ion-von-mm-2-1

  3. #3
    Contao-Nutzer
    Registriert seit
    28.03.2019.
    Beiträge
    39

    Standard

    Du willst mir sagen, dass MM nicht unter Contao 4.8 läuft?

  4. #4
    Contao-Urgestein Avatar von zonky
    Registriert seit
    19.03.2010.
    Ort
    Berlin, Rdf
    Beiträge
    6.443
    User beschenken
    Wunschliste

    Standard

    Höhere Versionen von Contao und/oder PHP sind möglich, werden aber nicht ofiziell supportet.
    dachte, das kann man daraus ableiten...

    je nach Paketen kann das laufen... muss aber nicht - Version 2.2 mit Kompatibilität ist in Arbeit... siehe News!

  5. #5
    Contao-Nutzer
    Registriert seit
    28.03.2019.
    Beiträge
    39

    Standard

    Du meinst das hier "Bei MM wird an einer neuen Version MM 2.2 gearbeitet, die eine vollständige Kompatibilität mit Contao 4.9 haben soll. Zudem kommen neue Features hinzu, die das Arbeiten mit MM erleichtern und erweitern soll. Für die Refinanzierung wird es wieder ein kostenpflichtiges "early-adopter-Programm" geben - dazu in den nächsten News mehr..."?

    Wenn ich das richtig verstehe, wird mein Problem wegen 4.8 dadurch auch gelöst, wenn es die Version MM 2.2 gibt.
    Wann es diese Version geben wird (bzw. die Möglichkeit per kostenpflichtigem early-adopter darauf zuzugreifen), steht aber noch in den Sternen?

  6. #6
    Contao-Urgestein Avatar von zonky
    Registriert seit
    19.03.2010.
    Ort
    Berlin, Rdf
    Beiträge
    6.443
    User beschenken
    Wunschliste

    Standard

    ich gehe davon aus, dass wenn die 4.9 da ist, Du dann ein Update fährst... ;-)

    Planung ist, möglichst zeitnah mit der 4.9 die MM 2.2 raus zu bringen

  7. #7
    Contao-Urgestein Avatar von zonky
    Registriert seit
    19.03.2010.
    Ort
    Berlin, Rdf
    Beiträge
    6.443
    User beschenken
    Wunschliste

    Standard

    @maxine - bitte mir mal deine composer.json zusenden, bei der der Fehler aufgetreten ist - entweder hier oder per E-Mail (die hat Nina)

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 2 (Registrierte Benutzer: 0, Gäste: 2)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •