Ergebnis 1 bis 13 von 13

Thema: Nach Update von 4.9.11 auf 4.9.13 Probleme mit Datenbank?

  1. #1
    Contao-Nutzer
    Registriert seit
    24.06.2013.
    Beiträge
    20

    Standard Nach Update von 4.9.11 auf 4.9.13 Probleme mit Datenbank?

    Hallo,

    nach einem Update via Contao-Manager von der Version 4.9.11 auf 4.9.13 läuft bei mir weder das Frontend noch kann ich mich ins Backend einloggen (Anmeldung fehlgeschlagen trotz korrektem Usernamen und Passwort).

    Im Logfile steht folgende Fehlermeldung:

    Code:
    [2021-03-30 14:45:49] request.CRITICAL: Uncaught PHP Exception InvalidArgumentException: "$statement must be a Statement object or an array" at /homepages/xxx/vendor/contao/core-bundle/src/Resources/contao/library/Contao/Database/Result.php line 93 {"exception":"[object] (InvalidArgumentException(code: 0): $statement must be a Statement object or an array at /homepages/xxx/vendor/contao/core-bundle/src/Resources/contao/library/Contao/Database/Result.php:93)"} []
    Habe mir den Quellcode von Result.php schonmal angeschaut. Hier wird der Fehler ausgegeben:

    PHP-Code:
    public function __construct($statement$strQuery)
        {
            if (
    $statement instanceof DoctrineStatement)
            {
                
    $this->resResult $statement;
            }
            elseif (\
    is_array($statement) && \count(array_filter(array_map('is_array'$statement))) === \count($statement))
            {
                
    $this->resultSet array_values($statement);
                
    $this->rowCount = \count($this->resultSet);
            }
            else
            {
                throw new \
    InvalidArgumentException('$statement must be a Statement object or an array');
            }

            
    $this->strQuery $strQuery;
        } 
    Mir ist aber nicht klar, warum das plötzlich nicht mehr läuft?!

    parameters.yml mit korrekten DB-Credentials ist vorhanden, Datenbank läuft ... soweit alles in Ordnung.

    Aber sowohl der Fehler im Frontend als auch das unmögliche Einloggen ins BE spricht für mich für einen Fehler in der Kommunikation mit der DB?

    Ein Downgrade auf 4.9.11 per CM hat leider nichts gebracht. :-(

    Vorher lief es einwandfrei.

    Bitte um kurzen Supporthinweis, was ich hier tun kann bzw. woher der Fehler kommen könnte?

    Herzlichen Dank vorab und viele Grüße,
    Boris

  2. #2
    Contao-Nutzer Avatar von JMMB
    Registriert seit
    08.03.2012.
    Beiträge
    236
    User beschenken
    Wunschliste

    Standard

    Den Fehler kann ich bestätigen. Laufe gerade in die gleiche Fehlermeldung.

  3. #3
    Contao-Nutzer Avatar von JamesdK
    Registriert seit
    02.12.2009.
    Ort
    Leverkusen
    Beiträge
    147
    Partner-ID
    8753

    Standard

    Ich kann das Problem auch bei drei Seiten bestätigen, die dazu bei drei verschiedenen Hostern liegen.
    Jeweils Update von 4.9.12 auf 4.9.13 via Contao-Manager, PHP 7.4.
    Fehlermeldung im /var/log genauso wie bei bopsoid.

  4. #4
    Contao-Nutzer Avatar von Philipp96
    Registriert seit
    06.07.2017.
    Ort
    Meißen
    Beiträge
    46

    Standard

    Bei mir ist der Fehler auch gerade aufgetreten, beim Update einer Erweiterung. Mit Contao 4.9.

  5. #5
    Contao-Nutzer
    Registriert seit
    07.01.2010.
    Ort
    Buchs ZH (Schweiz)
    Beiträge
    47

    Standard

    Kann den Fehler auch bestätigen. Bestehende Contao 4.9.12 Installation, zuerst Update auf Contao Manger 1.4.2. dann Update des Cores auf 4.9.13 -> kein Zugang ins Backend, Frontend nicht mehr erreichbar. Installtool und Contao-Manager funktionieren einwandfrei.

    Hinweis, bei der Installation ist nur der reine Core installiert. Keine weiteren Pakete.

  6. #6
    Contao-Nutzer Avatar von Philipp96
    Registriert seit
    06.07.2017.
    Ort
    Meißen
    Beiträge
    46

    Standard

    Der Fehler hat etwas mit der neuen Doctrine-Version zu tun. Wenn man die Version auf die 2.12.1 fixiert, sollte es wieder laufen.

    https://pdir.de/news/fehlermeldung-i...y.html#loesung

  7. #7
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    26.757
    Partner-ID
    10107

    Standard

    https://github.com/contao/contao/issues/2928

    - - - Aktualisiert - - -

    Es wurde nun ein zusätzlicher conflict Eintrag in contao/conflicts hinzugefügt: https://github.com/contao/conflicts/pull/24

    Das Problem sollte also nicht mehr auftreten, wenn man ein Composer Update durchführt.
    » sponsor me via GitHub or PayPal

  8. #8
    Contao-Nutzer Avatar von JMMB
    Registriert seit
    08.03.2012.
    Beiträge
    236
    User beschenken
    Wunschliste

    Standard

    Funktioniert. Danke.

  9. #9
    Contao-Urgestein Avatar von tab
    Registriert seit
    22.10.2013.
    Beiträge
    8.961
    User beschenken
    Wunschliste

    Standard

    Es tritt aber nicht immer auf, oder? Ich habe letztens einige Websites auf 4.9.13 gebracht und habe da keine Probleme. Ich lasse die erst mal so, oder ist die Empfehlung trotzdem ein Composer Update durchzuführen?

  10. #10
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    26.757
    Partner-ID
    10107

    Standard

    Zitat Zitat von tab Beitrag anzeigen
    Ich habe letztens einige Websites auf 4.9.13 gebracht und habe da keine Probleme.
    doctrine/dbal 2.13.0 wurde am 2021-03-28 um 18:10 (UTC) veröffentlicht. Wenn du die Updates davor durchgeführt hast, konnte es kein Problem geben.


    Zitat Zitat von tab Beitrag anzeigen
    Ich lasse die erst mal so, oder ist die Empfehlung trotzdem ein Composer Update durchzuführen?
    Da jetzt ein conflict in contao/conflicts hinzugefügt wurde, besteht (vorerst) keine Gefahr mehr in dieses Problem zu laufen, wenn du Pakete aktualisieren lässt.
    » sponsor me via GitHub or PayPal

  11. #11
    Contao-Nutzer Avatar von JamesdK
    Registriert seit
    02.12.2009.
    Ort
    Leverkusen
    Beiträge
    147
    Partner-ID
    8753

    Standard

    Auch von mir die Bestätigung, dass die Reparatur via Composer Update funktioniert hat.
    Danke für die schnelle Reaktion der Entwickler!

  12. #12
    Contao-Urgestein Avatar von tab
    Registriert seit
    22.10.2013.
    Beiträge
    8.961
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    doctrine/dbal 2.13.0 wurde am 2021-03-28 um 18:10 (UTC) veröffentlicht. Wenn du die Updates davor durchgeführt hast, konnte es kein Problem geben.
    Ja, das erklärt es, ich habe die Updates davor gemacht.
    Geändert von Spooky (31.03.2021 um 14:14 Uhr)

  13. #13
    Contao-Fan Avatar von Fehrmann
    Registriert seit
    04.07.2009.
    Ort
    Wismar
    Beiträge
    446

    Standard

    Hi,

    wir hatten heute in unserem wöchentlichen Updateprozess ebenfalls das Vergnügen mit dieser Fehlermeldung. Bei uns betraf es ausschließlich Systeme, welche vorher von Contao 3 auf 4 aktualisiert wurden.

    Es fehlte schlicht das
    Code:
    "contao/conflicts": "*@dev"
    in der composer.json (unter "require").

    Vielleicht hilft es ja wem.

    Viele Grüße
    René
    aiDESIGNER - www.ai-designer.de, ehemals als Freelancer www.omos.de

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •