Ergebnis 1 bis 4 von 4

Thema: Installationsabbruch bei Neuinstallation...

  1. #1
    Contao-Nutzer
    Registriert seit
    28.08.2009.
    Beiträge
    126

    Standard Installationsabbruch bei Neuinstallation...

    Contao 4.11.2
    PHP 7.3.2

    Hallo zusammen,

    nach einer Neuinstallation und dem Einspielen eines fertigen Themes habe ich versucht, die "Datenbanksicherung" zu installieren. Leider bricht die Routine mit einer Fehlermeldung ab. Keine Ahnung, was ich machen soll. Hat jemand von euch eine Idee was gemeint ist: "Your requirements could not be resolved to an installable set of packages"

    Vielen Dank für eure Hilfe !
    Roland

    Code:
    $ /usr/bin/php -q -dmax_execution_time=0 -dmemory_limit=-1 -dallow_url_fopen=1 -ddisable_functions= -ddate.timezone=Europe/Berlin /html/contao411/web/contao-manager.phar.php composer require do-while/contao-backupdb-bundle --no-update --no-scripts --prefer-stable --sort-packages --no-ansi --no-interaction
    
    Using version ^1.4 for do-while/contao-backupdb-bundle
    /html/contao411/composer.json has been updated
    
    # Process terminated with exit code 0
    # Result: OK
    
    
    > Resolving dependencies using Composer Cloud v3.1.1
    !!! Current server is sponsored by: Contao Association !!!
    
    
    [6.7MiB/0.17s] Loading composer repositories with package information
    [55.0MiB/1.55s] Updating dependencies
    [1089.9MiB/12.55s] Your requirements could not be resolved to an installable set of packages.
    [1089.9MiB/12.55s] 
      Problem 1
        - Root composer.json requires contao/conflicts *@dev -> satisfiable by contao/conflicts[dev-main].
        - Conclusion: don't install symfony/http-kernel v5.2.6 (conflict analysis result)
        - Conclusion: don't install symfony/framework-bundle v5.2.7 (conflict analysis result)
        - Conclusion: don't install symfony/routing v5.2.4 (conflict analysis result)
        - Conclusion: don't install symfony/routing[v5.2.6] | install do-while/contao-backupdb-bundle[1.4.2] (conflict analysis result)
        - Conclusion: don't install do-while/contao-backupdb-bundle 1.4.2 (conflict analysis result)
        - Conclusion: don't install symfony/http-kernel v5.2.7 (conflict analysis result)
        - Conclusion: don't install symfony/routing v5.2.7 (conflict analysis result)
        - contao/manager-bundle 4.11.2 requires symfony/web-profiler-bundle 4.4.* || 5.2.* -> satisfiable by symfony/web-profiler-bundle[v5.2.7].
        - contao/calendar-bundle 4.11.2 requires contao/core-bundle 4.11.2 -> satisfiable by contao/core-bundle[4.11.2].
        - contao/calendar-bundle is locked to version 4.11.2 and an update of this package was not requested.
        - Conclusion: don't install symfony/routing v5.2.2 (conflict analysis result)
        - Conclusion: don't install symfony/http-kernel v5.2.2 (conflict analysis result)
        - Conclusion: don't install symfony/framework-bundle v5.2.4 (conflict analysis result)
        - Conclusion: don't install symfony/http-kernel v5.2.3 (conflict analysis result)
        - Conclusion: don't install symfony/http-kernel v5.2.4 (conflict analysis result)
        - Conclusion: don't install symfony/framework-bundle v5.2.5 (conflict analysis result)
        - Conclusion: don't install symfony/routing v5.2.3 (conflict analysis result)
        - Conclusion: don't install symfony/http-kernel v5.2.5 (conflict analysis result)
        - Conclusion: don't install symfony/framework-bundle v5.2.6 (conflict analysis result)
        - contao/manager-bundle is locked to version 4.11.2 and an update of this package was not requested.
        - contao/core-bundle 4.11.2 requires symfony/framework-bundle 4.4.* || 5.2.* -> satisfiable by symfony/framework-bundle[v4.4.0, ..., v4.4.22, v5.2.0, ..., v5.2.7].
        - symfony/framework-bundle[v4.4.0, ..., v4.4.22] require symfony/http-kernel ^4.4 -> satisfiable by symfony/http-kernel[v4.4.0, ..., v4.4.22].
        - You can only install one version of a package, so only one of these can be installed: symfony/http-kernel[v2.1.0, ..., v2.8.52, v3.0.0, ..., v3.4.47, v4.0.0, ..., v4.4.22, v5.0.0, ..., v5.2.7].
        - symfony/web-profiler-bundle v5.2.7 requires symfony/http-kernel ^5.2 -> satisfiable by symfony/http-kernel[v5.2.0, ..., v5.2.7].
        - symfony/framework-bundle[v5.2.1, ..., v5.2.3] require symfony/http-kernel ^5.2.1 -> satisfiable by symfony/http-kernel[v5.2.1, ..., v5.2.7].
        - Conclusion: don't install symfony/http-kernel v5.2.1 (conflict analysis result)
        - Conclusion: don't install do-while/contao-backupdb-bundle[1.4.1] | install one of symfony/routing[v5.2.6], symfony/framework-bundle[v4.4.0, ..., v4.4.22] (conflict analysis result)
        - do-while/contao-backupdb-bundle 1.4.0 requires symfony/routing ^3.0 || ^4.0 -> satisfiable by symfony/routing[v3.0.0, ..., v3.4.47, v4.0.0, ..., v4.4.22].
        - You can only install one version of a package, so only one of these can be installed: symfony/routing[v2.2.0, ..., v2.8.52, v3.0.0, ..., v3.4.47, v4.0.0, ..., v4.4.22, v5.0.0, ..., v5.2.7].
        - symfony/framework-bundle v5.2.0 requires symfony/routing ^5.2 -> satisfiable by symfony/routing[v5.2.0, ..., v5.2.7].
        - Conclusion: don't install one of symfony/routing[v5.2.1], do-while/contao-backupdb-bundle[1.4.0] (conflict analysis result)
        - Root composer.json requires do-while/contao-backupdb-bundle ^1.4 -> satisfiable by do-while/contao-backupdb-bundle[1.4.0, 1.4.1, 1.4.2].
    
    [1089.9MiB/12.55s] Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.
    [44.2MiB/13.76s] Memory usage: 44.24MB (peak: 1091.24MB), time: 13.77s.
    [44.2MiB/13.76s] Finished Composer Cloud resolving.
    
    
    # Cloud Job ID Ju5T3CkpdYLCPXc89x0vMqOOSGhqtKssWCFVhPANf291XGOraXJjWYeLVCnsut1nVsox280DNbPUwsCnW9vinIhUKHLT8gsuSeBwuXP6hTYP0Fhg8wz92eC failed
    Geändert von RoGer (08.05.2021 um 18:02 Uhr)

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    27.097
    Partner-ID
    10107

    Standard

    Du musst folgendes machen, da die Instalaltion dieser Extension ein Downgrade von Symfony erfordert:

    1. Alle Pakete zum Update markieren.
    2. Die Änderungen nicht anwenden.
    3. Das neue Paket hinzufügen.
    4. Die Änderungen jetzt anwenden.
    » sponsor me via GitHub or PayPal

  3. #3
    Contao-Nutzer
    Registriert seit
    28.08.2009.
    Beiträge
    126

    Standard

    Vielen Dank! Hat funktioniert!

    Das werde ich wohl ebenso bei weiteren Ext. machen müssen, die noch nicht auf dem aktuellen Stand sind !?

    Roland

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    27.097
    Partner-ID
    10107

    Standard

    Nein, zumindest nicht mehr wegen der Symfony Version, da diese ja bei dir jetzt entsprechend downgegraded ist.

    Diese Vorgangsweise ist immer dann nötig, wenn die Installation eines neuen Pakets auch eine Versionsänderung eines bereits installierten Pakets benötigt (egal ob es eine direkte oder indirekte Abhängigkeit ist).
    » sponsor me via GitHub or PayPal

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •