Ergebnis 1 bis 21 von 21

Thema: Installation von Contao nicht möglich

  1. #1
    Contao-Fan Avatar von aadursun
    Registriert seit
    25.09.2011.
    Beiträge
    541

    Standard Installation von Contao nicht möglich

    Hallo,

    versuche unter Plesk, PHP 8.0, im Ordner "web" wohin auch das root Verzeichnis zeigt: httpdocs/web

    Leider wird im Contao Manager die Struktur nicht erkannt und dieser will eine neue Struktur wie folgt anlegen:


    /var/www/html/domain.de/httpdocs/web

    /var/www/html/domain.de/httpdocs/domain.de/web

    siehe

    sNZvddx.png


    Aber warum, die Struktur ist doch da? Ist das ein Bug?

    VG
    VG
    aadursun

  2. #2
    Contao-Urgestein Avatar von tab
    Registriert seit
    22.10.2013.
    Beiträge
    9.289
    Contao-Projekt unterstützen

    Support Contao

    Standard

    Ist das Verzeichnis httpdocs vor der Installation leer (enthält nur das Unterverzeichnis web)? Und ist im web-Verzeichnis nur die contao-manager.phar.php und sonst nichts (auch versteckte Dateien prüfen). Ansonsten installiert der Contao-Manager nicht, um zu vermeiden dass potenziell wichtige Daten überschrieben werden bzw reagiert so wie von dir beschrieben, also mit Änderung des Installationsverzeichnisses.

  3. #3
    Contao-Fan Avatar von aadursun
    Registriert seit
    25.09.2011.
    Beiträge
    541

    Standard

    Hallo tab,

    1. der httpdocs Ordner ist nicht leer, das sind noch "_backup, _old & weitere Ordner; ist das ein Problem? Backup will ich auch nicht löschen!!

    2. Im web-Verzeichnis befindet sich nur die contao-manager.phar.php

    3. habe auch direkt aus dem httpdocs versucht zu installieren, da klappt es gar nicht es kommt zu einer Fehlermeldung im Manager.
    VG
    aadursun

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    28.167
    Partner-ID
    10107

    Standard

    Zitat Zitat von aadursun Beitrag anzeigen
    1. der httpdocs Ordner ist nicht leer, das sind noch "_backup, _old & weitere Ordner; ist das ein Problem? Backup will ich auch nicht löschen!!
    Das Installationsverzeichnis muss komplett leer sein.
    » sponsor me via GitHub or PayPal

  5. #5
    Contao-Fan Avatar von aadursun
    Registriert seit
    25.09.2011.
    Beiträge
    541

    Standard

    Aber es wird doch in httpdocs/web installiert und nicht in httpdocs!!

    Ist das fix, dass der httpdocs Ordner leer sein muss, was ich ganz bescheuert finde!! Soll ich jetzt alle Backups löschen um nur Contao zu installieren.
    Irgendetwas haben die Entwickler nicht zu Ende gedacht, das darf doch nicht so sein !!!

    VG
    VG
    aadursun

  6. #6
    Contao-Fan Avatar von mdoll
    Registriert seit
    25.06.2009.
    Ort
    Wietze
    Beiträge
    263

    Standard

    Moin,

    auch wenn Dein root-Verzeichnis auf web zeigt, Contao wird in der Ebene darüber installiert, und die muss vorher halt leer sein.
    Spricht denn was dagegen, einen weiteren Ordner hinzuzufügen?

    httpdocs/meinecontaoinstallation/web

    Hat auch den Vorteil, dass man ggf mehrere Contao-Installationen haben kann.

    httpdocs/meinecontaoinstallation-2/web
    httpdocs/meinecontaoinstallation-3/web

    Und Du kannst Deine _backup, _old etc behalten.

    Gruß
    Mathias
    “Ah," said Mr Pin. "Right. I remember. You are concerned citizens." He knew about concerned citizens. Wherever they were, they all spoke the same private language, where 'traditional values' meant 'hang someone'.”
    ― Terry Pratchett, The Truth

  7. #7
    Contao-Urgestein Avatar von zonky
    Registriert seit
    19.03.2010.
    Ort
    Berlin, Rdf
    Beiträge
    8.097
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von mdoll Beitrag anzeigen
    httpdocs/meinecontaoinstallation/web

    Hat auch den Vorteil, dass man ggf mehrere Contao-Installationen haben kann.

    httpdocs/meinecontaoinstallation-2/web
    httpdocs/meinecontaoinstallation-3/web
    Das ist auch meine (dringende) Empfehlung - spätestens, wenn man zu Live noch eine Dev erstellen möchte oder für einen größeren Relaunch eine Parallelinstallation benötigt, fällt einem die fehlende Struktur auf die Füße...

  8. #8
    Contao-Fan Avatar von aadursun
    Registriert seit
    25.09.2011.
    Beiträge
    541

    Standard

    Super Idee mit den Verzeichnissen... es geht weiter bis zu dem Punkt

    --

    > @php vendor/bin/contao-setup
    In AbstractMySQLDriver.php line 128:

    An exception occurred in driver: SQLSTATE[HY000] [1698] Access denied for u
    ser 'root'@'localhost'

    In Exception.php line 18:

    SQLSTATE[HY000] [1698] Access denied for user 'root'@'localhost'

    In PDOConnection.php line 40:

    SQLSTATE[HY000] [1698] Access denied for user 'root'@'localhost'

    Script @php vendor/bin/contao-setup handling the post-install-cmd event returned with error code 1
    # Process terminated with exit code 1
    # Result: General error


    DB-Instanz ist MariaDB
    VG
    aadursun

  9. #9
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    28.167
    Partner-ID
    10107

    Standard

    Zitat Zitat von aadursun Beitrag anzeigen
    Aber es wird doch in httpdocs/web installiert und nicht in httpdocs!!
    Nein, es wird in httpdocs/ installiert. web/ ist nur der DocumentRoot.
    » sponsor me via GitHub or PayPal

  10. #10
    Contao-Fan Avatar von Birden
    Registriert seit
    15.01.2011.
    Beiträge
    637

    Standard

    @aadursun ... noch was, die Domain oder Subdomain, muß in der Ordner /web verweisen. Das heißt, wenn man die Domain über den Browser aufruft, wird der Inhalt von /web aufgerufen.

    Die Ordnerstruktur wie bereits erklärt httpdocs/meinecontaoinstallation/web

  11. #11
    Contao-Nutzer
    Registriert seit
    21.03.2011.
    Beiträge
    13

    Standard Installation von Contao 4.12 mit contao manager 4.1.8 schlägt fehl

    PHP 7.4
    Mit dem Contao Manager Ver 4.1.8 konnte ich heute eine Contao 4.9 Installation durchführen, Contao 4.12 Installationen auf verschiedenen Hostern schlugen fehl.

    Hier die Fehlermeldung einer IONOS Installation:

    Code:
    $ /usr/bin/php7.4-cli -q -dmax_execution_time=0 -dmemory_limit=-1 -dallow_url_fopen=1 -ddisable_functions= -ddate.timezone=Europe/Berlin /homepages/4/d370253878/htdocs/webpages/contao412/web/contao-manager.phar.php composer install --prefer-dist --no-dev --no-progress --no-ansi --no-interaction --optimize-autoloader
    Installing dependencies from lock file
    Verifying lock file contents can be installed on current platform.
    Package operations: 175 installs, 0 updates, 0 removals
      - Downloading contao-components/installer (1.4.1)
      - Downloading composer/package-versions-deprecated (1.11.99.4)
      - Downloading symfony/polyfill-ctype (v1.23.0)
      - Downloading symfony/deprecation-contracts (v2.4.0)
      - Downloading symfony/polyfill-php80 (v1.23.1)
      - Downloading symfony/polyfill-php73 (v1.23.0)
      - Downloading symfony/polyfill-mbstring (v1.23.1)
      - Downloading symfony/http-foundation (v5.3.7)
      - Downloading symfony/http-client-contracts (v2.4.0)
      - Downloading psr/event-dispatcher (1.0.0)
      - Downloading symfony/event-dispatcher-contracts (v2.4.0)
      - Downloading symfony/event-dispatcher (v5.3.7)
      - Downloading symfony/var-dumper (v5.3.8)
      - Downloading psr/log (1.1.4)
      - Downloading symfony/error-handler (v5.3.7)
      - Downloading symfony/http-kernel (v5.3.9)
      - Downloading psr/container (1.1.1)
      - Downloading symfony/service-contracts (v2.4.0)
      - Downloading symfony/dependency-injection (v5.3.8)
      - Downloading symfony/polyfill-php81 (v1.23.0)
      - Downloading symfony/filesystem (v5.3.4)
      - Downloading symfony/config (v5.3.4)
      - Downloading symfony/routing (v5.3.7)
      - Downloading contao/manager-plugin (2.11.0)
      - Downloading ausi/slug-generator (v1.1.1)
      - Downloading dasprid/enum (1.0.3)
      - Downloading bacon/bacon-qr-code (2.0.4)
      - Downloading contao-components/ace (1.4.12)
      - Downloading contao-components/chosen (1.2.4)
      - Downloading contao-components/colorbox (1.6.6)
      - Downloading contao-components/colorpicker (1.5.1)
      - Downloading contao-components/contao (9.2.0)
      - Downloading contao-components/datepicker (2.3.2)
      - Downloading contao-components/dropzone (5.9.3)
      - Downloading contao-components/jquery (3.6.0)
      - Downloading contao-components/jquery-ui (1.12.1.1)
      - Downloading contao-components/mediabox (1.5.5)
      - Downloading contao-components/mootools (1.6.0.6)
      - Downloading contao-components/simplemodal (2.1.1)
      - Downloading contao-components/swipe (2.2.0)
      - Downloading contao-components/tablesort (4.0.1)
      - Downloading contao-components/tablesorter (2.31.3)
      - Downloading contao-components/tinymce4 (5.10.0)
      - Downloading symfony/yaml (v5.3.6)
      - Downloading patchwork/utf8 (v1.3.3)
      - Downloading symfony/options-resolver (v5.3.7)
      - Downloading psr/http-message (1.0.1)
      - Downloading php-http/message-factory (v1.0.2)
      - Downloading clue/stream-filter (v1.5.0)
      - Downloading php-http/message (1.12.0)
      - Downloading php-http/discovery (1.14.1)
      - Downloading symfony/http-client (v5.3.8)
      - Downloading psr/http-factory (1.0.1)
      - Downloading psr/http-client (1.0.1)
      - Downloading php-http/promise (1.1.0)
      - Downloading php-http/httplug (2.2.0)
      - Downloading php-http/client-common (2.4.0)
      - Downloading friendsofsymfony/http-cache (2.11.0)
      - Downloading wikimedia/less.php (1.8.2)
      - Downloading webmozart/assert (1.10.0)
      - Downloading webmozart/path-util (2.3.0)
      - Downloading webignition/disallowed-character-terminated-string (2.0)
      - Downloading webignition/robots-txt-file (3.0)
      - Downloading composer/ca-bundle (1.2.11)
      - Downloading ua-parser/uap-php (v3.9.14)
      - Downloading twig/twig (v3.3.3)
      - Downloading true/punycode (v2.1.1)
      - Downloading psr/cache (1.0.1)
      - Downloading doctrine/lexer (1.2.1)
      - Downloading doctrine/annotations (1.13.2)
      - Downloading terminal42/service-annotation-bundle (1.1.3)
      - Downloading symfony/dom-crawler (v5.3.7)
      - Downloading nyholm/psr7 (1.4.1)
      - Downloading terminal42/escargot (1.2.0)
      - Downloading symfony/translation-contracts (v2.4.0)
      - Downloading symfony/twig-bridge (v5.3.7)
      - Downloading symfony/twig-bundle (v5.3.4)
      - Downloading symfony/translation (v5.3.9)
      - Downloading symfony/password-hasher (v5.3.8)
      - Downloading symfony/security-core (v5.3.8)
      - Downloading symfony/polyfill-intl-normalizer (v1.23.0)
      - Downloading symfony/polyfill-intl-grapheme (v1.23.1)
      - Downloading symfony/string (v5.3.7)
      - Downloading symfony/property-info (v5.3.8)
      - Downloading symfony/property-access (v5.3.8)
      - Downloading symfony/security-http (v5.3.8)
      - Downloading symfony/security-guard (v5.3.7)
      - Downloading symfony/security-csrf (v5.3.4)
      - Downloading symfony/security-bundle (v5.3.8)
      - Downloading symfony/process (v5.3.7)
      - Downloading monolog/monolog (2.3.5)
      - Downloading symfony/monolog-bridge (v5.3.7)
      - Downloading symfony/polyfill-php72 (v1.23.0)
      - Downloading symfony/polyfill-intl-idn (v1.23.0)
      - Downloading symfony/mime (v5.3.8)
      - Downloading egulias/email-validator (3.1.2)
      - Downloading symfony/mailer (v5.3.9)
      - Downloading symfony/lock (v5.3.4)
      - Downloading symfony/intl (v5.3.8)
      - Downloading symfony/finder (v5.3.7)
      - Downloading symfony/var-exporter (v5.3.8)
      - Downloading symfony/cache-contracts (v2.4.0)
      - Downloading symfony/cache (v5.3.8)
      - Downloading symfony/framework-bundle (v5.3.8)
      - Downloading symfony/expression-language (v5.3.7)
      - Downloading symfony/console (v5.3.7)
      - Downloading symfony/asset (v5.3.4)
      - Downloading symfony-cmf/routing (2.3.3)
      - Downloading symfony-cmf/routing-bundle (2.5.1)
      - Downloading thecodingmachine/safe (v1.3.3)
      - Downloading paragonie/constant_time_encoding (v2.4.0)
      - Downloading beberlei/assert (v3.3.1)
      - Downloading spomky-labs/otphp (v10.0.1)
      - Downloading spatie/schema-org (3.7.0)
      - Downloading simplepie/simplepie (1.5.6)
      - Downloading scssphp/scssphp (v1.8.1)
      - Downloading scrivo/highlight.php (v9.18.1.7)
      - Downloading scheb/2fa-bundle (v5.12.1)
      - Downloading lcobucci/clock (2.0.0)
      - Downloading lcobucci/jwt (4.1.5)
      - Downloading scheb/2fa-trusted-device (v5.12.1)
      - Downloading scheb/2fa-backup-code (v5.12.1)
      - Downloading paragonie/random_compat (v9.99.100)
      - Downloading ramsey/uuid (3.9.6)
      - Downloading phpspec/php-diff (v1.1.3)
      - Downloading nikic/php-parser (v4.13.0)
      - Downloading nelmio/cors-bundle (2.1.1)
      - Downloading matthiasmullie/path-converter (1.1.3)
      - Downloading matthiasmullie/minify (1.3.66)
      - Downloading league/commonmark (1.6.6)
      - Downloading knplabs/knp-time-bundle (v1.16.1)
      - Downloading knplabs/knp-menu (v3.2.0)
      - Downloading knplabs/knp-menu-bundle (v3.1.0)
      - Downloading imagine/imagine (1.2.4)
      - Downloading friendsofsymfony/http-cache-bundle (2.11.1)
      - Downloading dragonmantank/cron-expression (v2.3.1)
      - Downloading doctrine/event-manager (1.1.1)
      - Downloading doctrine/deprecations (v0.5.3)
      - Downloading doctrine/collections (1.6.8)
      - Downloading doctrine/cache (2.1.1)
      - Downloading doctrine/persistence (2.2.2)
      - Downloading doctrine/instantiator (1.4.0)
      - Downloading doctrine/inflector (2.0.3)
      - Downloading doctrine/dbal (2.13.4)
      - Downloading doctrine/common (3.1.2)
      - Downloading doctrine/orm (2.10.1)
      - Downloading symfony/doctrine-bridge (v5.3.8)
      - Downloading doctrine/sql-formatter (1.1.1)
      - Downloading doctrine/doctrine-bundle (2.4.3)
      - Downloading contao/polyfill-symfony (1.0.0)
      - Downloading contao/imagine-svg (1.0.3)
      - Downloading contao/image (1.1.1)
      - Downloading contao/core-bundle (4.12.2)
      - Downloading contao/calendar-bundle (4.12.2)
      - Downloading contao/comments-bundle (4.12.2)
      - Downloading contao/faq-bundle (4.12.2)
      - Downloading contao/listing-bundle (4.12.2)
      - Downloading twig/extra-bundle (v3.3.3)
      - Downloading toflar/psr6-symfony-http-cache-store (3.0.1)
      - Downloading symfony/web-profiler-bundle (v5.3.8)
      - Downloading symfony/stopwatch (v5.3.4)
      - Downloading laminas/laminas-code (4.4.3)
      - Downloading friendsofphp/proxy-manager-lts (v1.0.5)
      - Downloading symfony/proxy-manager-bridge (v5.3.4)
      - Downloading symfony/monolog-bundle (v3.7.0)
      - Downloading symfony/dotenv (v5.3.8)
      - Downloading symfony/debug-bundle (v5.3.4)
      - Downloading symfony/debug (v4.4.31)
      - Downloading nelmio/security-bundle (v2.10.3)
      - Downloading contao/maintenance-bundle-deprecated (v2.1.9)
      - Downloading contao/installation-bundle (4.12.2)
      - Downloading contao/manager-bundle (4.12.2)
      - Downloading contao/news-bundle (4.12.2)
      - Downloading contao/newsletter-bundle (4.12.2)
      - Installing contao-components/installer (1.4.1): Extracting archive
      - Installing composer/package-versions-deprecated (1.11.99.4): Extracting archive
      - Installing symfony/polyfill-ctype (v1.23.0): Extracting archive
      - Installing symfony/deprecation-contracts (v2.4.0): Extracting archive
      - Installing symfony/polyfill-php80 (v1.23.1): Extracting archive
      - Installing symfony/polyfill-php73 (v1.23.0): Extracting archive
      - Installing symfony/polyfill-mbstring (v1.23.1): Extracting archive
      - Installing symfony/http-foundation (v5.3.7): Extracting archive
      - Installing symfony/http-client-contracts (v2.4.0): Extracting archive
      - Installing psr/event-dispatcher (1.0.0): Extracting archive
      - Installing symfony/event-dispatcher-contracts (v2.4.0): Extracting archive
      - Installing symfony/event-dispatcher (v5.3.7): Extracting archive
      - Installing symfony/var-dumper (v5.3.8): Extracting archive
      - Installing psr/log (1.1.4): Extracting archive
      - Installing symfony/error-handler (v5.3.7): Extracting archive
      - Installing symfony/http-kernel (v5.3.9): Extracting archive
      - Installing psr/container (1.1.1): Extracting archive
      - Installing symfony/service-contracts (v2.4.0): Extracting archive
      - Installing symfony/dependency-injection (v5.3.8): Extracting archive
      - Installing symfony/polyfill-php81 (v1.23.0): Extracting archive
      - Installing symfony/filesystem (v5.3.4): Extracting archive
      - Installing symfony/config (v5.3.4): Extracting archive
      - Installing symfony/routing (v5.3.7): Extracting archive
      - Installing contao/manager-plugin (2.11.0): Extracting archive
      - Installing ausi/slug-generator (v1.1.1): Extracting archive
      - Installing dasprid/enum (1.0.3): Extracting archive
      - Installing bacon/bacon-qr-code (2.0.4): Extracting archive
      - Installing contao-components/ace (1.4.12): Extracting archive
      - Installing contao-components/chosen (1.2.4): Extracting archive
      - Installing contao-components/colorbox (1.6.6): Extracting archive
      - Installing contao-components/colorpicker (1.5.1): Extracting archive
      - Installing contao-components/contao (9.2.0): Extracting archive
      - Installing contao-components/datepicker (2.3.2): Extracting archive
      - Installing contao-components/dropzone (5.9.3): Extracting archive
      - Installing contao-components/jquery (3.6.0): Extracting archive
      - Installing contao-components/jquery-ui (1.12.1.1): Extracting archive
      - Installing contao-components/mediabox (1.5.5): Extracting archive
      - Installing contao-components/mootools (1.6.0.6): Extracting archive
      - Installing contao-components/simplemodal (2.1.1): Extracting archive
      - Installing contao-components/swipe (2.2.0): Extracting archive
      - Installing contao-components/tablesort (4.0.1): Extracting archive
      - Installing contao-components/tablesorter (2.31.3): Extracting archive
      - Installing contao-components/tinymce4 (5.10.0): Extracting archive
      - Installing symfony/yaml (v5.3.6): Extracting archive
      - Installing patchwork/utf8 (v1.3.3): Extracting archive
      - Installing symfony/options-resolver (v5.3.7): Extracting archive
      - Installing psr/http-message (1.0.1): Extracting archive
      - Installing php-http/message-factory (v1.0.2): Extracting archive
      - Installing clue/stream-filter (v1.5.0): Extracting archive
      - Installing php-http/message (1.12.0): Extracting archive
      - Installing php-http/discovery (1.14.1): Extracting archive
      - Installing symfony/http-client (v5.3.8): Extracting archive
      - Installing psr/http-factory (1.0.1): Extracting archive
      - Installing psr/http-client (1.0.1): Extracting archive
      - Installing php-http/promise (1.1.0): Extracting archive
      - Installing php-http/httplug (2.2.0): Extracting archive
      - Installing php-http/client-common (2.4.0): Extracting archive
      - Installing friendsofsymfony/http-cache (2.11.0): Extracting archive
      - Installing wikimedia/less.php (1.8.2): Extracting archive
      - Installing webmozart/assert (1.10.0): Extracting archive
      - Installing webmozart/path-util (2.3.0): Extracting archive
      - Installing webignition/disallowed-character-terminated-string (2.0): Extracting archive
      - Installing webignition/robots-txt-file (3.0): Extracting archive
      - Installing composer/ca-bundle (1.2.11): Extracting archive
      - Installing ua-parser/uap-php (v3.9.14): Extracting archive
      - Installing twig/twig (v3.3.3): Extracting archive
      - Installing true/punycode (v2.1.1): Extracting archive
      - Installing psr/cache (1.0.1): Extracting archive
      - Installing doctrine/lexer (1.2.1): Extracting archive
      - Installing doctrine/annotations (1.13.2): Extracting archive
      - Installing terminal42/service-annotation-bundle (1.1.3): Extracting archive
      - Installing symfony/dom-crawler (v5.3.7): Extracting archive
      - Installing nyholm/psr7 (1.4.1): Extracting archive
      - Installing terminal42/escargot (1.2.0): Extracting archive
      - Installing symfony/translation-contracts (v2.4.0): Extracting archive
      - Installing symfony/twig-bridge (v5.3.7): Extracting archive
      - Installing symfony/twig-bundle (v5.3.4): Extracting archive
      - Installing symfony/translation (v5.3.9): Extracting archive
      - Installing symfony/password-hasher (v5.3.8): Extracting archive
      - Installing symfony/security-core (v5.3.8): Extracting archive
      - Installing symfony/polyfill-intl-normalizer (v1.23.0): Extracting archive
      - Installing symfony/polyfill-intl-grapheme (v1.23.1): Extracting archive
      - Installing symfony/string (v5.3.7): Extracting archive
      - Installing symfony/property-info (v5.3.8): Extracting archive
      - Installing symfony/property-access (v5.3.8): Extracting archive
      - Installing symfony/security-http (v5.3.8): Extracting archive
      - Installing symfony/security-guard (v5.3.7): Extracting archive
      - Installing symfony/security-csrf (v5.3.4): Extracting archive
      - Installing symfony/security-bundle (v5.3.8): Extracting archive
      - Installing symfony/process (v5.3.7): Extracting archive
      - Installing monolog/monolog (2.3.5): Extracting archive
      - Installing symfony/monolog-bridge (v5.3.7): Extracting archive
      - Installing symfony/polyfill-php72 (v1.23.0): Extracting archive
      - Installing symfony/polyfill-intl-idn (v1.23.0): Extracting archive
      - Installing symfony/mime (v5.3.8): Extracting archive
      - Installing egulias/email-validator (3.1.2): Extracting archive
      - Installing symfony/mailer (v5.3.9): Extracting archive
      - Installing symfony/lock (v5.3.4): Extracting archive
      - Installing symfony/intl (v5.3.8): Extracting archive
      - Installing symfony/finder (v5.3.7): Extracting archive
      - Installing symfony/var-exporter (v5.3.8): Extracting archive
      - Installing symfony/cache-contracts (v2.4.0): Extracting archive
      - Installing symfony/cache (v5.3.8): Extracting archive
      - Installing symfony/framework-bundle (v5.3.8): Extracting archive
      - Installing symfony/expression-language (v5.3.7): Extracting archive
      - Installing symfony/console (v5.3.7): Extracting archive
      - Installing symfony/asset (v5.3.4): Extracting archive
      - Installing symfony-cmf/routing (2.3.3): Extracting archive
      - Installing symfony-cmf/routing-bundle (2.5.1): Extracting archive
      - Installing thecodingmachine/safe (v1.3.3): Extracting archive
      - Installing paragonie/constant_time_encoding (v2.4.0): Extracting archive
      - Installing beberlei/assert (v3.3.1): Extracting archive
      - Installing spomky-labs/otphp (v10.0.1): Extracting archive
      - Installing spatie/schema-org (3.7.0): Extracting archive
      - Installing simplepie/simplepie (1.5.6): Extracting archive
      - Installing scssphp/scssphp (v1.8.1): Extracting archive
      - Installing scrivo/highlight.php (v9.18.1.7): Extracting archive
      - Installing scheb/2fa-bundle (v5.12.1): Extracting archive
      - Installing lcobucci/clock (2.0.0): Extracting archive
      - Installing lcobucci/jwt (4.1.5): Extracting archive
      - Installing scheb/2fa-trusted-device (v5.12.1): Extracting archive
      - Installing scheb/2fa-backup-code (v5.12.1): Extracting archive
      - Installing paragonie/random_compat (v9.99.100): Extracting archive
      - Installing ramsey/uuid (3.9.6): Extracting archive
      - Installing phpspec/php-diff (v1.1.3): Extracting archive
      - Installing nikic/php-parser (v4.13.0): Extracting archive
      - Installing nelmio/cors-bundle (2.1.1): Extracting archive
      - Installing matthiasmullie/path-converter (1.1.3): Extracting archive
      - Installing matthiasmullie/minify (1.3.66): Extracting archive
      - Installing league/commonmark (1.6.6): Extracting archive
      - Installing knplabs/knp-time-bundle (v1.16.1): Extracting archive
      - Installing knplabs/knp-menu (v3.2.0): Extracting archive
      - Installing knplabs/knp-menu-bundle (v3.1.0): Extracting archive
      - Installing imagine/imagine (1.2.4): Extracting archive
      - Installing friendsofsymfony/http-cache-bundle (2.11.1): Extracting archive
      - Installing dragonmantank/cron-expression (v2.3.1): Extracting archive
      - Installing doctrine/event-manager (1.1.1): Extracting archive
      - Installing doctrine/deprecations (v0.5.3): Extracting archive
      - Installing doctrine/collections (1.6.8): Extracting archive
      - Installing doctrine/cache (2.1.1): Extracting archive
      - Installing doctrine/persistence (2.2.2): Extracting archive
      - Installing doctrine/instantiator (1.4.0): Extracting archive
      - Installing doctrine/inflector (2.0.3): Extracting archive
      - Installing doctrine/dbal (2.13.4): Extracting archive
      - Installing doctrine/common (3.1.2): Extracting archive
      - Installing doctrine/orm (2.10.1): Extracting archive
      - Installing symfony/doctrine-bridge (v5.3.8): Extracting archive
      - Installing doctrine/sql-formatter (1.1.1): Extracting archive
      - Installing doctrine/doctrine-bundle (2.4.3): Extracting archive
      - Installing contao/polyfill-symfony (1.0.0): Extracting archive
      - Installing contao/imagine-svg (1.0.3): Extracting archive
      - Installing contao/image (1.1.1): Extracting archive
      - Installing contao/core-bundle (4.12.2): Extracting archive
      - Installing contao/calendar-bundle (4.12.2): Extracting archive
      - Installing contao/comments-bundle (4.12.2): Extracting archive
      - Installing contao/conflicts (dev-main b52fb0f)
      - Installing contao/faq-bundle (4.12.2): Extracting archive
      - Installing contao/listing-bundle (4.12.2): Extracting archive
      - Installing twig/extra-bundle (v3.3.3): Extracting archive
      - Installing toflar/psr6-symfony-http-cache-store (3.0.1): Extracting archive
      - Installing symfony/web-profiler-bundle (v5.3.8): Extracting archive
      - Installing symfony/stopwatch (v5.3.4): Extracting archive
      - Installing laminas/laminas-code (4.4.3): Extracting archive
      - Installing friendsofphp/proxy-manager-lts (v1.0.5): Extracting archive
      - Installing symfony/proxy-manager-bridge (v5.3.4): Extracting archive
      - Installing symfony/monolog-bundle (v3.7.0): Extracting archive
      - Installing symfony/dotenv (v5.3.8): Extracting archive
      - Installing symfony/debug-bundle (v5.3.4): Extracting archive
      - Installing symfony/debug (v4.4.31): Extracting archive
      - Installing nelmio/security-bundle (v2.10.3): Extracting archive
      - Installing contao/maintenance-bundle-deprecated (v2.1.9): Extracting archive
      - Installing contao/installation-bundle (4.12.2): Extracting archive
      - Installing contao/manager-bundle (4.12.2): Extracting archive
      - Installing contao/news-bundle (4.12.2): Extracting archive
      - Installing contao/newsletter-bundle (4.12.2): Extracting archive
    Package patchwork/utf8 is abandoned, you should avoid using it. Use symfony/polyfill-mbstring or symfony/string instead.
    Generating optimized autoload files
    composer/package-versions-deprecated: Generating version class...
    composer/package-versions-deprecated: ...done generating version class
    contao/manager-plugin: Generating plugin class...
    contao/manager-plugin: ...done generating plugin class
    90 packages you are using are looking for funding.
    Use the `composer fund` command to find out more!
    > @php vendor/bin/contao-setup
    In AbstractMySQLDriver.php line 112:
                                                                                   
      An exception occurred in driver: SQLSTATE[HY000] [2002] No such file or dir  
      ectory                                                                       
                                                                                   
    In Exception.php line 18:
                                                        
      SQLSTATE[HY000] [2002] No such file or directory  
                                                        
    In PDOConnection.php line 40:
                                                        
      SQLSTATE[HY000] [2002] No such file or directory  
                                                        
    Script @php vendor/bin/contao-setup handling the post-install-cmd event returned with error code 1
    # Process terminated with exit code 1
    # Result: General error
    Geändert von xchs (13.10.2021 um 00:33 Uhr) Grund: Code-Tags

  12. #12
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    28.167
    Partner-ID
    10107
    » sponsor me via GitHub or PayPal

  13. #13
    Contao-Fan Avatar von aadursun
    Registriert seit
    25.09.2011.
    Beiträge
    541

    Standard

    Ich starte den 5. Versuch Contao 4.12 zu installieren. Jetzt unter PHP 7.4.

    Leider ohne Erfolg.

    Jetzt versuche ich 4.9 zu installieren. Das klappt ohne Probleme.
    VG
    aadursun

  14. #14
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    28.167
    Partner-ID
    10107

    Standard

    Bei Contao 4.12 gibt es wie gesagt aktuell einen Fehler, der die Installation erschwert.
    » sponsor me via GitHub or PayPal

  15. #15
    Contao-Urgestein Avatar von tab
    Registriert seit
    22.10.2013.
    Beiträge
    9.289
    Contao-Projekt unterstützen

    Support Contao

    Standard

    Ja, 4.9 hat ja auch nicht den im Issue beschriebenen Bug.

  16. #16
    Contao-Fan Avatar von OneChance
    Registriert seit
    23.06.2009.
    Ort
    Korneuburg
    Beiträge
    534
    User beschenken
    Wunschliste

    Standard Wegen dem Bug in 4.12

    Ich habe es jetzt auch mit der 4.9 versucht aber hier geht auch nicht unter MAMP Pro 6.6.

    Sorry Leute aber wie kann ich das ding zum laufen bringen ohne den Composer zu verwenden?

    Bin nicht Composer kompatibel! ggg

    Aber jetzt mal Spass beiseite kann man schon sagen wann 4.12.3 rauskommt?

    Mfg Patrick
    There's only ONE Chance for the first Impression.

  17. #17
    Contao-Nutzer
    Registriert seit
    06.10.2011.
    Ort
    Wien
    Beiträge
    69

    Standard

    Hallo. Der Fehler dürfte noch bestehen, ich konnte eine 4.12 heute 23.11. bei Hostingwerk nicht installieren.

    Das Ticket https://github.com/contao/contao/pull/3560 ist auch noch offen.

    Hat jemand dazu mehr Informationen?

    Danke und liebe Grüße!

  18. #18
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    28.167
    Partner-ID
    10107

    Standard

    Zitat Zitat von Creasign Beitrag anzeigen
    Hallo. Der Fehler dürfte noch bestehen, ich konnte eine 4.12 heute 23.11. bei Hostingwerk nicht installieren.
    Was genau war das Problem?



    Zitat Zitat von Creasign Beitrag anzeigen
    Das Ticket https://github.com/contao/contao/pull/3560 ist auch noch offen.

    Hat jemand dazu mehr Informationen?

    Danke und liebe Grüße!
    Der von dir referenzierte Pull Request wurde gemerged und in Contao 4.12.3 veröffentlicht.
    » sponsor me via GitHub or PayPal

  19. #19
    Contao-Nutzer
    Registriert seit
    06.10.2011.
    Ort
    Wien
    Beiträge
    69

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Was genau war das Problem?
    Die Installation bricht mit "SQLSTATE[HY000] [1698] Access denied for user 'root'@'localhost'" (wie in einem Beitrag weiter oben beschrieben) ab. 4.9 konnte ich ohne Probleme installieren. Es hat mich verwundert, dass dieses Problem anscheinend schon seit 1 Monat besteht. Ich wollte auch ausschließen, dass ich etwas falsch gemacht habe. LG

  20. #20
    Contao-Urgestein Avatar von tab
    Registriert seit
    22.10.2013.
    Beiträge
    9.289
    Contao-Projekt unterstützen

    Support Contao

    Standard

    Das konnte ich gerade eben nachvollziehen bei Hostingwerk.
    Eingestellt ist PHP 7.4
    Nginx-Profil: Contao 4
    Pagespeed-Modul: Aus
    SSL-Zertifikat: An
    HTTPS-Umleitung: An

    Code:
    $ /usr/bin/php7.4 -q -dmax_execution_time=0 -dmemory_limit=-1 -dallow_url_fopen=1 -ddisable_functions= -ddate.timezone=Europe/Berlin /srv/www/tbantel/public/c412.bantel.cyou/web/contao-manager.phar.php composer install --prefer-dist --no-dev --no-progress --no-ansi --no-interaction --optimize-autoloader
    
    Installing dependencies from lock file
    Verifying lock file contents can be installed on current platform.
    Package operations: 175 installs, 0 updates, 0 removals
    As there is no 'unzip' nor '7z' command installed zip files are being unpacked using the PHP zip extension.
    This may cause invalid reports of corrupted archives. Besides, any UNIX permissions (e.g. executable) defined in the archives will be lost.
    Installing 'unzip' or '7z' may remediate them.
      - Downloading contao-components/installer (1.4.1)
      - Downloading composer/package-versions-deprecated (1.11.99.4)
      - Downloading symfony/polyfill-ctype (v1.23.0)
      - Downloading symfony/deprecation-contracts (v2.5.0)
      - Downloading symfony/polyfill-php80 (v1.23.1)
      - Downloading symfony/polyfill-php73 (v1.23.0)
      - Downloading symfony/polyfill-mbstring (v1.23.1)
      - Downloading symfony/http-foundation (v5.3.11)
      - Downloading symfony/http-client-contracts (v2.5.0)
      - Downloading psr/event-dispatcher (1.0.0)
      - Downloading symfony/event-dispatcher-contracts (v2.5.0)
      - Downloading symfony/event-dispatcher (v5.3.11)
      - Downloading symfony/var-dumper (v5.3.11)
      - Downloading psr/log (1.1.4)
      - Downloading symfony/error-handler (v5.3.11)
      - Downloading symfony/http-kernel (v5.3.11)
      - Downloading psr/container (1.1.2)
      - Downloading symfony/service-contracts (v2.5.0)
      - Downloading symfony/dependency-injection (v5.3.11)
      - Downloading symfony/polyfill-php81 (v1.23.0)
      - Downloading symfony/filesystem (v5.3.4)
      - Downloading symfony/config (v5.3.11)
      - Downloading symfony/routing (v5.3.11)
      - Downloading contao/manager-plugin (2.11.0)
      - Downloading ausi/slug-generator (v1.1.1)
      - Downloading dasprid/enum (1.0.3)
      - Downloading bacon/bacon-qr-code (2.0.4)
      - Downloading contao-components/ace (1.4.13)
      - Downloading contao-components/chosen (1.2.4)
      - Downloading contao-components/colorbox (1.6.6)
      - Downloading contao-components/colorpicker (1.5.1)
      - Downloading contao-components/contao (9.2.0)
      - Downloading contao-components/datepicker (2.3.2)
      - Downloading contao-components/dropzone (5.9.3)
      - Downloading contao-components/jquery (3.6.0)
      - Downloading contao-components/jquery-ui (1.12.1.1)
      - Downloading contao-components/mediabox (1.5.5)
      - Downloading contao-components/mootools (1.6.0.6)
      - Downloading contao-components/simplemodal (2.1.1)
      - Downloading contao-components/swipe (2.2.0)
      - Downloading contao-components/tablesort (4.0.1)
      - Downloading contao-components/tablesorter (2.31.3)
      - Downloading contao-components/tinymce4 (5.10.2)
      - Downloading symfony/yaml (v5.3.11)
      - Downloading patchwork/utf8 (v1.3.3)
      - Downloading symfony/options-resolver (v5.3.7)
      - Downloading psr/http-message (1.0.1)
      - Downloading php-http/message-factory (v1.0.2)
      - Downloading clue/stream-filter (v1.5.0)
      - Downloading php-http/message (1.12.0)
      - Downloading php-http/discovery (1.14.1)
      - Downloading symfony/http-client (v5.3.11)
      - Downloading psr/http-factory (1.0.1)
      - Downloading psr/http-client (1.0.1)
      - Downloading php-http/promise (1.1.0)
      - Downloading php-http/httplug (2.2.0)
      - Downloading php-http/client-common (2.4.0)
      - Downloading friendsofsymfony/http-cache (2.11.0)
      - Downloading wikimedia/less.php (1.8.2)
      - Downloading webmozart/assert (1.10.0)
      - Downloading webmozart/path-util (2.3.0)
      - Downloading webignition/disallowed-character-terminated-string (2.0)
      - Downloading webignition/robots-txt-file (3.0)
      - Downloading composer/ca-bundle (1.3.1)
      - Downloading ua-parser/uap-php (v3.9.14)
      - Downloading twig/twig (v3.3.3)
      - Downloading true/punycode (v2.1.1)
      - Downloading psr/cache (1.0.1)
      - Downloading doctrine/lexer (1.2.1)
      - Downloading doctrine/annotations (1.13.2)
      - Downloading terminal42/service-annotation-bundle (1.1.3)
      - Downloading symfony/dom-crawler (v5.3.7)
      - Downloading nyholm/psr7 (1.4.1)
      - Downloading terminal42/escargot (1.3.0)
      - Downloading symfony/translation-contracts (v2.5.0)
      - Downloading symfony/twig-bridge (v5.3.11)
      - Downloading symfony/twig-bundle (v5.3.10)
      - Downloading symfony/translation (v5.3.11)
      - Downloading symfony/password-hasher (v5.3.8)
      - Downloading symfony/security-core (v5.3.11)
      - Downloading symfony/polyfill-intl-normalizer (v1.23.0)
      - Downloading symfony/polyfill-intl-grapheme (v1.23.1)
      - Downloading symfony/string (v5.3.10)
      - Downloading symfony/property-info (v5.3.8)
      - Downloading symfony/property-access (v5.3.8)
      - Downloading symfony/security-http (v5.3.11)
      - Downloading symfony/security-guard (v5.3.7)
      - Downloading symfony/security-csrf (v5.3.4)
      - Downloading symfony/security-bundle (v5.3.11)
      - Downloading symfony/process (v5.3.11)
      - Downloading monolog/monolog (2.3.5)
      - Downloading symfony/monolog-bridge (v5.3.7)
      - Downloading symfony/polyfill-php72 (v1.23.0)
      - Downloading symfony/polyfill-intl-idn (v1.23.0)
      - Downloading symfony/mime (v5.3.11)
      - Downloading egulias/email-validator (3.1.2)
      - Downloading symfony/mailer (v5.3.9)
      - Downloading symfony/lock (v5.3.10)
      - Downloading symfony/intl (v5.3.11)
      - Downloading symfony/finder (v5.3.7)
      - Downloading symfony/var-exporter (v5.3.11)
      - Downloading symfony/cache-contracts (v2.5.0)
      - Downloading symfony/cache (v5.3.11)
      - Downloading symfony/framework-bundle (v5.3.11)
      - Downloading symfony/expression-language (v5.3.11)
      - Downloading symfony/console (v5.3.11)
      - Downloading symfony/asset (v5.3.11)
      - Downloading symfony-cmf/routing (2.3.4)
      - Downloading symfony-cmf/routing-bundle (2.5.1)
      - Downloading thecodingmachine/safe (v1.3.3)
      - Downloading paragonie/constant_time_encoding (v2.4.0)
      - Downloading beberlei/assert (v3.3.1)
      - Downloading spomky-labs/otphp (v10.0.1)
      - Downloading spatie/schema-org (3.8.0)
      - Downloading simplepie/simplepie (1.5.6)
      - Downloading scssphp/scssphp (v1.8.1)
      - Downloading scrivo/highlight.php (v9.18.1.8)
      - Downloading scheb/2fa-bundle (v5.13.0)
      - Downloading lcobucci/clock (2.0.0)
      - Downloading lcobucci/jwt (4.1.5)
      - Downloading scheb/2fa-trusted-device (v5.13.0)
      - Downloading scheb/2fa-backup-code (v5.13.0)
      - Downloading paragonie/random_compat (v9.99.100)
      - Downloading ramsey/uuid (3.9.6)
      - Downloading phpspec/php-diff (v1.1.3)
      - Downloading nikic/php-parser (v4.13.1)
      - Downloading nelmio/cors-bundle (2.1.1)
      - Downloading matthiasmullie/path-converter (1.1.3)
      - Downloading matthiasmullie/minify (1.3.66)
      - Downloading league/commonmark (1.6.6)
      - Downloading knplabs/knp-time-bundle (1.17.0)
      - Downloading knplabs/knp-menu (v3.3.0)
      - Downloading knplabs/knp-menu-bundle (v3.2.0)
      - Downloading imagine/imagine (1.2.4)
      - Downloading friendsofsymfony/http-cache-bundle (2.11.2)
      - Downloading dragonmantank/cron-expression (v2.3.1)
      - Downloading doctrine/event-manager (1.1.1)
      - Downloading doctrine/deprecations (v0.5.3)
      - Downloading doctrine/collections (1.6.8)
      - Downloading doctrine/cache (2.1.1)
      - Downloading doctrine/persistence (2.2.3)
      - Downloading doctrine/instantiator (1.4.0)
      - Downloading doctrine/inflector (2.0.4)
      - Downloading doctrine/dbal (2.13.5)
      - Downloading doctrine/common (3.2.0)
      - Downloading doctrine/orm (2.10.2)
      - Downloading symfony/doctrine-bridge (v5.3.11)
      - Downloading doctrine/sql-formatter (1.1.2)
      - Downloading doctrine/doctrine-bundle (2.5.0)
      - Downloading contao/polyfill-symfony (1.0.0)
      - Downloading contao/imagine-svg (1.0.3)
      - Downloading contao/image (1.1.1)
      - Downloading contao/core-bundle (4.12.3)
      - Downloading contao/calendar-bundle (4.12.3)
      - Downloading contao/comments-bundle (4.12.3)
      - Downloading contao/faq-bundle (4.12.3)
      - Downloading contao/listing-bundle (4.12.3)
      - Downloading twig/extra-bundle (v3.3.3)
      - Downloading toflar/psr6-symfony-http-cache-store (3.0.1)
      - Downloading symfony/web-profiler-bundle (v5.3.8)
      - Downloading symfony/stopwatch (v5.3.4)
      - Downloading laminas/laminas-code (4.4.3)
      - Downloading friendsofphp/proxy-manager-lts (v1.0.5)
      - Downloading symfony/proxy-manager-bridge (v5.3.11)
      - Downloading symfony/monolog-bundle (v3.7.1)
      - Downloading symfony/dotenv (v5.3.10)
      - Downloading symfony/debug-bundle (v5.3.4)
      - Downloading symfony/debug (v4.4.31)
      - Downloading nelmio/security-bundle (v2.10.3)
      - Downloading contao/maintenance-bundle-deprecated (v2.1.9)
      - Downloading contao/installation-bundle (4.12.3)
      - Downloading contao/manager-bundle (4.12.3)
      - Downloading contao/news-bundle (4.12.3)
      - Downloading contao/newsletter-bundle (4.12.3)
      - Installing contao-components/installer (1.4.1): Extracting archive
      - Installing composer/package-versions-deprecated (1.11.99.4): Extracting archive
      - Installing symfony/polyfill-ctype (v1.23.0): Extracting archive
      - Installing symfony/deprecation-contracts (v2.5.0): Extracting archive
      - Installing symfony/polyfill-php80 (v1.23.1): Extracting archive
      - Installing symfony/polyfill-php73 (v1.23.0): Extracting archive
      - Installing symfony/polyfill-mbstring (v1.23.1): Extracting archive
      - Installing symfony/http-foundation (v5.3.11): Extracting archive
      - Installing symfony/http-client-contracts (v2.5.0): Extracting archive
      - Installing psr/event-dispatcher (1.0.0): Extracting archive
      - Installing symfony/event-dispatcher-contracts (v2.5.0): Extracting archive
      - Installing symfony/event-dispatcher (v5.3.11): Extracting archive
      - Installing symfony/var-dumper (v5.3.11): Extracting archive
      - Installing psr/log (1.1.4): Extracting archive
      - Installing symfony/error-handler (v5.3.11): Extracting archive
      - Installing symfony/http-kernel (v5.3.11): Extracting archive
      - Installing psr/container (1.1.2): Extracting archive
      - Installing symfony/service-contracts (v2.5.0): Extracting archive
      - Installing symfony/dependency-injection (v5.3.11): Extracting archive
      - Installing symfony/polyfill-php81 (v1.23.0): Extracting archive
      - Installing symfony/filesystem (v5.3.4): Extracting archive
      - Installing symfony/config (v5.3.11): Extracting archive
      - Installing symfony/routing (v5.3.11): Extracting archive
      - Installing contao/manager-plugin (2.11.0): Extracting archive
      - Installing ausi/slug-generator (v1.1.1): Extracting archive
      - Installing dasprid/enum (1.0.3): Extracting archive
      - Installing bacon/bacon-qr-code (2.0.4): Extracting archive
      - Installing contao-components/ace (1.4.13): Extracting archive
      - Installing contao-components/chosen (1.2.4): Extracting archive
      - Installing contao-components/colorbox (1.6.6): Extracting archive
      - Installing contao-components/colorpicker (1.5.1): Extracting archive
      - Installing contao-components/contao (9.2.0): Extracting archive
      - Installing contao-components/datepicker (2.3.2): Extracting archive
      - Installing contao-components/dropzone (5.9.3): Extracting archive
      - Installing contao-components/jquery (3.6.0): Extracting archive
      - Installing contao-components/jquery-ui (1.12.1.1): Extracting archive
      - Installing contao-components/mediabox (1.5.5): Extracting archive
      - Installing contao-components/mootools (1.6.0.6): Extracting archive
      - Installing contao-components/simplemodal (2.1.1): Extracting archive
      - Installing contao-components/swipe (2.2.0): Extracting archive
      - Installing contao-components/tablesort (4.0.1): Extracting archive
      - Installing contao-components/tablesorter (2.31.3): Extracting archive
      - Installing contao-components/tinymce4 (5.10.2): Extracting archive
      - Installing symfony/yaml (v5.3.11): Extracting archive
      - Installing patchwork/utf8 (v1.3.3): Extracting archive
      - Installing symfony/options-resolver (v5.3.7): Extracting archive
      - Installing psr/http-message (1.0.1): Extracting archive
      - Installing php-http/message-factory (v1.0.2): Extracting archive
      - Installing clue/stream-filter (v1.5.0): Extracting archive
      - Installing php-http/message (1.12.0): Extracting archive
      - Installing php-http/discovery (1.14.1): Extracting archive
      - Installing symfony/http-client (v5.3.11): Extracting archive
      - Installing psr/http-factory (1.0.1): Extracting archive
      - Installing psr/http-client (1.0.1): Extracting archive
      - Installing php-http/promise (1.1.0): Extracting archive
      - Installing php-http/httplug (2.2.0): Extracting archive
      - Installing php-http/client-common (2.4.0): Extracting archive
      - Installing friendsofsymfony/http-cache (2.11.0): Extracting archive
      - Installing wikimedia/less.php (1.8.2): Extracting archive
      - Installing webmozart/assert (1.10.0): Extracting archive
      - Installing webmozart/path-util (2.3.0): Extracting archive
      - Installing webignition/disallowed-character-terminated-string (2.0): Extracting archive
      - Installing webignition/robots-txt-file (3.0): Extracting archive
      - Installing composer/ca-bundle (1.3.1): Extracting archive
      - Installing ua-parser/uap-php (v3.9.14): Extracting archive
      - Installing twig/twig (v3.3.3): Extracting archive
      - Installing true/punycode (v2.1.1): Extracting archive
      - Installing psr/cache (1.0.1): Extracting archive
      - Installing doctrine/lexer (1.2.1): Extracting archive
      - Installing doctrine/annotations (1.13.2): Extracting archive
      - Installing terminal42/service-annotation-bundle (1.1.3): Extracting archive
      - Installing symfony/dom-crawler (v5.3.7): Extracting archive
      - Installing nyholm/psr7 (1.4.1): Extracting archive
      - Installing terminal42/escargot (1.3.0): Extracting archive
      - Installing symfony/translation-contracts (v2.5.0): Extracting archive
      - Installing symfony/twig-bridge (v5.3.11): Extracting archive
      - Installing symfony/twig-bundle (v5.3.10): Extracting archive
      - Installing symfony/translation (v5.3.11): Extracting archive
      - Installing symfony/password-hasher (v5.3.8): Extracting archive
      - Installing symfony/security-core (v5.3.11): Extracting archive
      - Installing symfony/polyfill-intl-normalizer (v1.23.0): Extracting archive
      - Installing symfony/polyfill-intl-grapheme (v1.23.1): Extracting archive
      - Installing symfony/string (v5.3.10): Extracting archive
      - Installing symfony/property-info (v5.3.8): Extracting archive
      - Installing symfony/property-access (v5.3.8): Extracting archive
      - Installing symfony/security-http (v5.3.11): Extracting archive
      - Installing symfony/security-guard (v5.3.7): Extracting archive
      - Installing symfony/security-csrf (v5.3.4): Extracting archive
      - Installing symfony/security-bundle (v5.3.11): Extracting archive
      - Installing symfony/process (v5.3.11): Extracting archive
      - Installing monolog/monolog (2.3.5): Extracting archive
      - Installing symfony/monolog-bridge (v5.3.7): Extracting archive
      - Installing symfony/polyfill-php72 (v1.23.0): Extracting archive
      - Installing symfony/polyfill-intl-idn (v1.23.0): Extracting archive
      - Installing symfony/mime (v5.3.11): Extracting archive
      - Installing egulias/email-validator (3.1.2): Extracting archive
      - Installing symfony/mailer (v5.3.9): Extracting archive
      - Installing symfony/lock (v5.3.10): Extracting archive
      - Installing symfony/intl (v5.3.11): Extracting archive
      - Installing symfony/finder (v5.3.7): Extracting archive
      - Installing symfony/var-exporter (v5.3.11): Extracting archive
      - Installing symfony/cache-contracts (v2.5.0): Extracting archive
      - Installing symfony/cache (v5.3.11): Extracting archive
      - Installing symfony/framework-bundle (v5.3.11): Extracting archive
      - Installing symfony/expression-language (v5.3.11): Extracting archive
      - Installing symfony/console (v5.3.11): Extracting archive
      - Installing symfony/asset (v5.3.11): Extracting archive
      - Installing symfony-cmf/routing (2.3.4): Extracting archive
      - Installing symfony-cmf/routing-bundle (2.5.1): Extracting archive
      - Installing thecodingmachine/safe (v1.3.3): Extracting archive
      - Installing paragonie/constant_time_encoding (v2.4.0): Extracting archive
      - Installing beberlei/assert (v3.3.1): Extracting archive
      - Installing spomky-labs/otphp (v10.0.1): Extracting archive
      - Installing spatie/schema-org (3.8.0): Extracting archive
      - Installing simplepie/simplepie (1.5.6): Extracting archive
      - Installing scssphp/scssphp (v1.8.1): Extracting archive
      - Installing scrivo/highlight.php (v9.18.1.8): Extracting archive
      - Installing scheb/2fa-bundle (v5.13.0): Extracting archive
      - Installing lcobucci/clock (2.0.0): Extracting archive
      - Installing lcobucci/jwt (4.1.5): Extracting archive
      - Installing scheb/2fa-trusted-device (v5.13.0): Extracting archive
      - Installing scheb/2fa-backup-code (v5.13.0): Extracting archive
      - Installing paragonie/random_compat (v9.99.100): Extracting archive
      - Installing ramsey/uuid (3.9.6): Extracting archive
      - Installing phpspec/php-diff (v1.1.3): Extracting archive
      - Installing nikic/php-parser (v4.13.1): Extracting archive
      - Installing nelmio/cors-bundle (2.1.1): Extracting archive
      - Installing matthiasmullie/path-converter (1.1.3): Extracting archive
      - Installing matthiasmullie/minify (1.3.66): Extracting archive
      - Installing league/commonmark (1.6.6): Extracting archive
      - Installing knplabs/knp-time-bundle (1.17.0): Extracting archive
      - Installing knplabs/knp-menu (v3.3.0): Extracting archive
      - Installing knplabs/knp-menu-bundle (v3.2.0): Extracting archive
      - Installing imagine/imagine (1.2.4): Extracting archive
      - Installing friendsofsymfony/http-cache-bundle (2.11.2): Extracting archive
      - Installing dragonmantank/cron-expression (v2.3.1): Extracting archive
      - Installing doctrine/event-manager (1.1.1): Extracting archive
      - Installing doctrine/deprecations (v0.5.3): Extracting archive
      - Installing doctrine/collections (1.6.8): Extracting archive
      - Installing doctrine/cache (2.1.1): Extracting archive
      - Installing doctrine/persistence (2.2.3): Extracting archive
      - Installing doctrine/instantiator (1.4.0): Extracting archive
      - Installing doctrine/inflector (2.0.4): Extracting archive
      - Installing doctrine/dbal (2.13.5): Extracting archive
      - Installing doctrine/common (3.2.0): Extracting archive
      - Installing doctrine/orm (2.10.2): Extracting archive
      - Installing symfony/doctrine-bridge (v5.3.11): Extracting archive
      - Installing doctrine/sql-formatter (1.1.2): Extracting archive
      - Installing doctrine/doctrine-bundle (2.5.0): Extracting archive
      - Installing contao/polyfill-symfony (1.0.0): Extracting archive
      - Installing contao/imagine-svg (1.0.3): Extracting archive
      - Installing contao/image (1.1.1): Extracting archive
      - Installing contao/core-bundle (4.12.3): Extracting archive
      - Installing contao/calendar-bundle (4.12.3): Extracting archive
      - Installing contao/comments-bundle (4.12.3): Extracting archive
      - Installing contao/conflicts (dev-main b52fb0f)
      - Installing contao/faq-bundle (4.12.3): Extracting archive
      - Installing contao/listing-bundle (4.12.3): Extracting archive
      - Installing twig/extra-bundle (v3.3.3): Extracting archive
      - Installing toflar/psr6-symfony-http-cache-store (3.0.1): Extracting archive
      - Installing symfony/web-profiler-bundle (v5.3.8): Extracting archive
      - Installing symfony/stopwatch (v5.3.4): Extracting archive
      - Installing laminas/laminas-code (4.4.3): Extracting archive
      - Installing friendsofphp/proxy-manager-lts (v1.0.5): Extracting archive
      - Installing symfony/proxy-manager-bridge (v5.3.11): Extracting archive
      - Installing symfony/monolog-bundle (v3.7.1): Extracting archive
      - Installing symfony/dotenv (v5.3.10): Extracting archive
      - Installing symfony/debug-bundle (v5.3.4): Extracting archive
      - Installing symfony/debug (v4.4.31): Extracting archive
      - Installing nelmio/security-bundle (v2.10.3): Extracting archive
      - Installing contao/maintenance-bundle-deprecated (v2.1.9): Extracting archive
      - Installing contao/installation-bundle (4.12.3): Extracting archive
      - Installing contao/manager-bundle (4.12.3): Extracting archive
      - Installing contao/news-bundle (4.12.3): Extracting archive
      - Installing contao/newsletter-bundle (4.12.3): Extracting archive
    Package patchwork/utf8 is abandoned, you should avoid using it. Use symfony/polyfill-mbstring or symfony/string instead.
    Package webmozart/path-util is abandoned, you should avoid using it. Use symfony/filesystem instead.
    Generating optimized autoload files
    composer/package-versions-deprecated: Generating version class...
    composer/package-versions-deprecated: ...done generating version class
    contao/manager-plugin: Generating plugin class...
    contao/manager-plugin: ...done generating plugin class
    90 packages you are using are looking for funding.
    Use the `composer fund` command to find out more!
    > @php vendor/bin/contao-setup
    
    In AbstractMySQLDriver.php line 128:
                                                                                   
      An exception occurred in driver: SQLSTATE[HY000] [1698] Access denied for u  
      ser 'root'@'localhost'                                                       
                                                                                   
    
    In Exception.php line 18:
                                                                        
      SQLSTATE[HY000] [1698] Access denied for user 'root'@'localhost'  
                                                                        
    
    In PDOConnection.php line 40:
                                                                        
      SQLSTATE[HY000] [1698] Access denied for user 'root'@'localhost'  
                                                                        
    
    Script @php vendor/bin/contao-setup handling the post-install-cmd event returned with error code 1
    
    # Process terminated with exit code 1
    # Result: General error

  21. #21
    Contao-Urgestein Avatar von tab
    Registriert seit
    22.10.2013.
    Beiträge
    9.289
    Contao-Projekt unterstützen

    Support Contao

    Standard

    Selbes Spiel auf meinem vServer mit PHP 7.4.25 und MariaDB 10.5.12
    Dagegen funktioniert es bei Webgo (CMS Power SSD) mit PHP 7.4 und MySQL 8 problemlos.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •