Ergebnis 1 bis 12 von 12

Thema: Update/Installation von Packages

  1. #1
    Contao-Fan
    Registriert seit
    27.11.2009.
    Ort
    Bremen
    Beiträge
    304
    Partner-ID
    8258

    Standard Update/Installation von Packages

    Ich habe Probleme mit dem Contao Manager in einer Installation. Beim Versuch die Cookiebar zu aktualisieren, erhalte ich folgende Meldung:
    Code:
    $ /usr/bin/php8.0-cli -q -dmax_execution_time=0 -dmemory_limit=-1 -dallow_url_fopen=1 -ddisable_functions= -ddate.timezone=Europe/Berlin /homepages/13/xxx/htdocs/contao2022/web/contao-manager.phar.php composer require do-while/contao-backupdb-bundle --no-update --no-scripts --prefer-stable --sort-packages --no-ansi --no-interaction
    
    Using version ^1.4 for do-while/contao-backupdb-bundle
    /homepages/13/xxx/htdocs/contao2022/composer.json has been updated
    
    # Process terminated with exit code 0
    # Result: OK
    
    
    > Resolving dependencies using Composer Cloud v3.2.0
    !!! Current server is sponsored by: Contao Association !!!
    
    
    [7.0MiB/0.20s] Loading composer repositories with package information
    [62.5MiB/1.90s] Updating dependencies
    [1570.6MiB/13.26s] Your requirements could not be resolved to an installable set of packages.
    [1570.6MiB/13.26s] 
      Problem 1
        - contao/manager-bundle is locked to version 4.12.5 and an update of this package was not requested.
        - Conclusion: don't install symfony/routing v5.3.4 (conflict analysis result)
        - Conclusion: don't install symfony/routing v5.3.7 (conflict analysis result)
        - Conclusion: don't install symfony/routing v6.0.1 (conflict analysis result)
        - Conclusion: don't install symfony/framework-bundle v6.0.2 (conflict analysis result)
        - Conclusion: don't install symfony/routing v5.3.11 (conflict analysis result)
        - Conclusion: don't install symfony/routing v5.4.0 (conflict analysis result)
        - contao/manager-bundle 4.12.5 requires symfony/web-profiler-bundle ^4.4 || ^5.2 -> satisfiable by symfony/web-profiler-bundle[v5.4.0].
        - Root composer.json requires do-while/contao-backupdb-bundle ^1.4 -> satisfiable by do-while/contao-backupdb-bundle[1.4.0, 1.4.1, 1.4.2].
        - symfony/framework-bundle[v6.0.0, ..., v6.0.1] require symfony/routing ^5.4|^6.0 -> satisfiable by symfony/routing[v5.4.0, v6.0.0, v6.0.1].
        - Conclusion: don't install symfony/routing v6.0.0 (conflict analysis result)
        - symfony/web-profiler-bundle v5.4.0 requires symfony/framework-bundle ^5.3|^6.0 -> satisfiable by symfony/framework-bundle[v5.3.0, ..., v5.4.2, v6.0.0, v6.0.1, v6.0.2].
        - symfony/framework-bundle[v5.3.0, ..., v5.3.13] require symfony/routing ^5.3 -> satisfiable by symfony/routing[v5.3.0, ..., v5.4.0].
        - symfony/framework-bundle[v5.4.0, ..., v5.4.2] require symfony/routing ^5.3|^6.0 -> satisfiable by symfony/routing[v5.3.0, ..., v5.4.0, v6.0.0, v6.0.1].
        - Conclusion: don't install symfony/routing v5.3.0 (conflict analysis result)
    
    [1570.6MiB/13.26s] Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.
    [77.5MiB/14.86s] Memory usage: 77.5MB (peak: 1573.19MB), time: 14.87s.
    [77.5MiB/14.86s] Finished Composer Cloud resolving.
    
    
    # Cloud Job ID dCYx4cGvhNEnxx5jkzqCdyYSmZgrk31f7QiIX8p4WpzeHEKXuQ2Po0yB8WQHi6FG7k2HlkydkRIs8gx failed
    Und auch die Installation von [Datenbanksicherung] läuft nicht durch:
    Code:
    $ /usr/bin/php8.0-cli -q -dmax_execution_time=0 -dmemory_limit=-1 -dallow_url_fopen=1 -ddisable_functions= -ddate.timezone=Europe/Berlin /homepages/13/xxx/htdocs/contao2022/web/contao-manager.phar.php composer require do-while/contao-backupdb-bundle --no-update --no-scripts --prefer-stable --sort-packages --no-ansi --no-interaction
    
    Using version ^1.4 for do-while/contao-backupdb-bundle
    /homepages/13/xxx/htdocs/contao2022/composer.json has been updated
    
    # Process terminated with exit code 0
    # Result: OK
    
    
    > Resolving dependencies using Composer Cloud v3.2.0
    !!! Current server is sponsored by: Contao Association !!!
    
    
    [7.0MiB/0.22s] Loading composer repositories with package information
    [62.3MiB/2.06s] Updating dependencies
    [1555.1MiB/12.39s] Your requirements could not be resolved to an installable set of packages.
    [1555.1MiB/12.39s] 
      Problem 1
        - contao/manager-bundle is locked to version 4.12.5 and an update of this package was not requested.
        - Conclusion: don't install symfony/routing v5.3.4 (conflict analysis result)
        - Conclusion: don't install symfony/routing v5.3.7 (conflict analysis result)
        - Conclusion: don't install symfony/routing v6.0.1 (conflict analysis result)
        - Conclusion: don't install symfony/framework-bundle v6.0.2 (conflict analysis result)
        - Conclusion: don't install symfony/routing v5.3.11 (conflict analysis result)
        - Conclusion: don't install symfony/routing v5.4.0 (conflict analysis result)
        - contao/manager-bundle 4.12.5 requires symfony/web-profiler-bundle ^4.4 || ^5.2 -> satisfiable by symfony/web-profiler-bundle[v5.4.0].
        - Root composer.json requires do-while/contao-backupdb-bundle ^1.4 -> satisfiable by do-while/contao-backupdb-bundle[1.4.0, 1.4.1, 1.4.2].
        - symfony/framework-bundle[v6.0.0, ..., v6.0.1] require symfony/routing ^5.4|^6.0 -> satisfiable by symfony/routing[v5.4.0, v6.0.0, v6.0.1].
        - Conclusion: don't install symfony/routing v6.0.0 (conflict analysis result)
        - symfony/web-profiler-bundle v5.4.0 requires symfony/framework-bundle ^5.3|^6.0 -> satisfiable by symfony/framework-bundle[v5.3.0, ..., v5.4.2, v6.0.0, v6.0.1, v6.0.2].
        - symfony/framework-bundle[v5.3.0, ..., v5.3.13] require symfony/routing ^5.3 -> satisfiable by symfony/routing[v5.3.0, ..., v5.4.0].
        - symfony/framework-bundle[v5.4.0, ..., v5.4.2] require symfony/routing ^5.3|^6.0 -> satisfiable by symfony/routing[v5.3.0, ..., v5.4.0, v6.0.0, v6.0.1].
        - Conclusion: don't install symfony/routing v5.3.0 (conflict analysis result)
    
    [1555.1MiB/12.39s] Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.
    [77.5MiB/13.99s] Memory usage: 77.48MB (peak: 1557.37MB), time: 14s.
    [77.5MiB/13.99s] Finished Composer Cloud resolving.
    
    
    # Cloud Job ID fr16jKI4vcrgYbdJ2trtPJFFV0t3yYuouGNnZvBIUaIeBF0deqHjLUJqUSMawoV8d6lTEfYEWVbSyKXkZqviSRLGn4Siq9nkRt1 failed
    Da ist an irgendeiner Stelle der Wurm drin, aber ich finde ihn nicht ...

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    29.544
    Partner-ID
    10107

    Standard

    Laut der Ausgabe versuchst du do-while/contao-backupdb-bundle zu installieren? Dafür musst du eine vollständige Paketaktualisierung durchführen, also alle Pakete zum Update markieren, da diese Erweiterung noch nicht Symfony 5 freigeschalten hat.
    » sponsor me via GitHub or PayPal or Revolut

  3. #3
    Contao-Fan
    Registriert seit
    27.11.2009.
    Ort
    Bremen
    Beiträge
    304
    Partner-ID
    8258

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Laut der Ausgabe versuchst du do-while/contao-backupdb-bundle zu installieren? Dafür musst du eine vollständige Paketaktualisierung durchführen, also alle Pakete zum Update markieren, da diese Erweiterung noch nicht Symfony 5 freigeschalten hat.
    Die Pakete sind alle auf dem aktuellsten Stand und wenn ich sie trotzdem noch einmal aktualisiere und anschließend versuche backupdb zu installieren, erhalten ich wieder diese Meldung:
    Code:
    $ /usr/bin/php8.0-cli -q -dmax_execution_time=0 -dmemory_limit=-1 -dallow_url_fopen=1 -ddisable_functions= -ddate.timezone=Europe/Berlin /homepages/13/xxx/htdocs/contao2022/web/contao-manager.phar.php composer require do-while/contao-backupdb-bundle --no-update --no-scripts --prefer-stable --sort-packages --no-ansi --no-interaction
    
    Using version ^1.4 for do-while/contao-backupdb-bundle
    /homepages/13/xxx/htdocs/contao2022/composer.json has been updated
    
    # Process terminated with exit code 0
    # Result: OK
    
    
    > Resolving dependencies using Composer Cloud v3.2.0
    !!! Current server is sponsored by: Contao Association !!!
    
    
    [7.0MiB/0.17s] Loading composer repositories with package information
    [62.3MiB/2.23s] Updating dependencies
    [1555.6MiB/12.61s] Your requirements could not be resolved to an installable set of packages.
    [1555.6MiB/12.61s] 
      Problem 1
        - contao/manager-bundle is locked to version 4.12.5 and an update of this package was not requested.
        - Conclusion: don't install symfony/framework-bundle v6.0.0 (conflict analysis result)
        - Conclusion: don't install symfony/routing v5.3.4 (conflict analysis result)
        - Conclusion: don't install symfony/routing v5.3.7 (conflict analysis result)
        - Conclusion: don't install symfony/routing v6.0.1 (conflict analysis result)
        - Conclusion: don't install symfony/framework-bundle v6.0.1 (conflict analysis result)
        - Conclusion: don't install symfony/framework-bundle v6.0.2 (conflict analysis result)
        - Conclusion: don't install symfony/routing v5.3.11 (conflict analysis result)
        - Conclusion: don't install symfony/routing v5.4.0 (conflict analysis result)
        - contao/manager-bundle 4.12.5 requires symfony/web-profiler-bundle ^4.4 || ^5.2 -> satisfiable by symfony/web-profiler-bundle[v5.4.2].
        - Root composer.json requires do-while/contao-backupdb-bundle ^1.4 -> satisfiable by do-while/contao-backupdb-bundle[1.4.0, 1.4.1, 1.4.2].
        - Conclusion: don't install symfony/routing v6.0.0 (conflict analysis result)
        - symfony/web-profiler-bundle v5.4.2 requires symfony/framework-bundle ^5.3|^6.0 -> satisfiable by symfony/framework-bundle[v5.3.0, ..., v5.4.2, v6.0.0, v6.0.1, v6.0.2].
        - symfony/framework-bundle[v5.3.0, ..., v5.3.13] require symfony/routing ^5.3 -> satisfiable by symfony/routing[v5.3.0, ..., v5.4.0].
        - symfony/framework-bundle[v5.4.0, ..., v5.4.2] require symfony/routing ^5.3|^6.0 -> satisfiable by symfony/routing[v5.3.0, ..., v5.4.0, v6.0.0, v6.0.1].
        - Conclusion: don't install symfony/routing v5.3.0 (conflict analysis result)
    
    [1555.6MiB/12.62s] Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.
    [77.5MiB/14.37s] Memory usage: 77.48MB (peak: 1557.84MB), time: 14.37s.
    [77.5MiB/14.37s] Finished Composer Cloud resolving.
    
    
    # Cloud Job ID MMruSP0uyFogENDAXNYpKuZZDLem1Ok3nskfk5xJPcxq6vUyijnCP3O5T0MCTqIFcVOjtaDJ3xihdReEaF197gcnUQyYEzkN60 failed
    Egal, ich installiere jetzt einfach eine andere Backup-Erweiterung ...

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    29.544
    Partner-ID
    10107

    Standard

    Nein, du musst wie gesagt alle Pakete zum Update markieren, wenn du diese Erweiterung installieren willst.
    » sponsor me via GitHub or PayPal or Revolut

  5. #5
    Contao-Fan
    Registriert seit
    27.11.2009.
    Ort
    Bremen
    Beiträge
    304
    Partner-ID
    8258

    Standard

    Jetzt habe ich es kapiert! Alles in einem Rutsch, also BackupDB installieren und alle Pakete aktualisieren - so hat es geklappt :-)

    Danke Spooky!

  6. #6
    Contao-Fan
    Registriert seit
    27.11.2009.
    Ort
    Bremen
    Beiträge
    304
    Partner-ID
    8258

    Standard

    Aaargh, zu früh gefreut: wenn ich BackupDB im Backend ausführen möchte, meldet das System
    Code:
    Non-static method Softleister\BackupDB\BackupDbRun::run() cannot be called statically

  7. #7
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    29.544
    Partner-ID
    10107

    Standard

    Nutze den Debug-Modus und poste den Stack Trace.
    » sponsor me via GitHub or PayPal or Revolut

  8. #8
    Contao-Urgestein Avatar von do_while
    Registriert seit
    15.06.2009.
    Ort
    Berlin | Deutschland
    Beiträge
    3.526
    Partner-ID
    1081
    User beschenken
    Wunschliste
    Contao-Projekt unterstützen

    Support Contao

    Standard

    Zitat Zitat von Lufine Beitrag anzeigen
    Aaargh, zu früh gefreut: wenn ich BackupDB im Backend ausführen möchte, meldet das System
    Code:
    Non-static method Softleister\BackupDB\BackupDbRun::run() cannot be called statically
    Verwendest Du PHP8?
    Dafür ist die Version 1.4 nicht geeignet.
    Wenn Du die Autobackup-Funktion nicht verwendest, sondern nur manuell ausgelöste Backups, dann kannst Du den dev-master verwenden.

  9. #9
    Contao-Fan
    Registriert seit
    27.11.2009.
    Ort
    Bremen
    Beiträge
    304
    Partner-ID
    8258

    Standard

    Code:
    ErrorException:
    Warning: Undefined array key "MOD"
    
      at vendor/alnv/catalog-manager/library/alnv/I18nCatalogTranslator.php:105
      at CatalogManager\I18nCatalogTranslator->get('nav', 'content', array('title' => 'Inhalte'))
         (vendor/alnv/catalog-manager/library/alnv/CatalogManagerInitializer.php:93)
      at CatalogManager\CatalogManagerInitializer->setNavigation()
         (vendor/alnv/catalog-manager/library/alnv/CatalogManagerInitializer.php:31)
      at CatalogManager\CatalogManagerInitializer->initialize()
         (vendor/contao/core-bundle/src/Framework/ContaoFramework.php:412)
      at Contao\CoreBundle\Framework\ContaoFramework->triggerInitializeSystemHook()
         (vendor/contao/core-bundle/src/Framework/ContaoFramework.php:310)
      at Contao\CoreBundle\Framework\ContaoFramework->initializeFramework()
         (vendor/contao/core-bundle/src/Framework/ContaoFramework.php:158)
      at Contao\CoreBundle\Framework\ContaoFramework->initialize()
         (vendor/contao/core-bundle/src/HttpKernel/ModelArgumentResolver.php:50)
      at Contao\CoreBundle\HttpKernel\ModelArgumentResolver->supports(object(Request), object(ArgumentMetadata))
         (vendor/symfony/http-kernel/Controller/ArgumentResolver/TraceableValueResolver.php:43)
      at Symfony\Component\HttpKernel\Controller\ArgumentResolver\TraceableValueResolver->supports(object(Request), object(ArgumentMetadata))
         (vendor/symfony/http-kernel/Controller/ArgumentResolver.php:52)
      at Symfony\Component\HttpKernel\Controller\ArgumentResolver->getArguments(object(Request), array(object(BackendController), 'loginAction'))
         (vendor/symfony/http-kernel/Controller/TraceableArgumentResolver.php:38)
      at Symfony\Component\HttpKernel\Controller\TraceableArgumentResolver->getArguments(object(Request), array(object(BackendController), 'loginAction'))
         (vendor/symfony/http-kernel/HttpKernel.php:150)
      at Symfony\Component\HttpKernel\HttpKernel->handleRaw(object(Request), 1)
         (vendor/symfony/http-kernel/HttpKernel.php:80)
      at Symfony\Component\HttpKernel\HttpKernel->handle(object(Request), 1, true)
         (vendor/symfony/http-kernel/Kernel.php:201)
      at Symfony\Component\HttpKernel\Kernel->handle(object(Request))
         (web/index.php:31)

  10. #10
    Contao-Fan
    Registriert seit
    27.11.2009.
    Ort
    Bremen
    Beiträge
    304
    Partner-ID
    8258

    Standard

    Zitat Zitat von do_while Beitrag anzeigen
    Verwendest Du PHP8?
    Dafür ist die Version 1.4 nicht geeignet.
    Wenn Du die Autobackup-Funktion nicht verwendest, sondern nur manuell ausgelöste Backups, dann kannst Du den dev-master verwenden.
    Ja, PHP 8 ist im Einsatz ... Wie schade! Wird es in naher Zukunft ein Update für die Erweiterung geben? Ich hab' Sie immer so gerne eingesetzt, weil damit auch die Kund:innen gut klarkommen :-)

    Dann werde ich erstmal den DEV-Master installieren ...
    Geändert von Lufine (26.01.2022 um 08:36 Uhr)

  11. #11
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    29.544
    Partner-ID
    10107

    Standard

    alnv/catalog-manager scheint auch noch nicht zu 100% PHP 8 kompatibel zu sein.
    » sponsor me via GitHub or PayPal or Revolut

  12. #12
    Contao-Fan
    Registriert seit
    27.11.2009.
    Ort
    Bremen
    Beiträge
    304
    Partner-ID
    8258

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    alnv/catalog-manager scheint auch noch nicht zu 100% PHP 8 kompatibel zu sein.
    Ja, hab' mich auch schon gewundert, dass der in den Logs immer wieder auftaucht ... Ich hab' ihn in diesem Projekt noch nicht richtig im Einsatz, daher hat es mich bislang noch nicht so gestört ...

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •