Ergebnis 1 bis 3 von 3

Thema: Systemwartung, Suchindex aktualisieren: 0%, der Crawler arbeitet gerade.... ewig

  1. #1
    Contao-Nutzer
    Registriert seit
    23.01.2014.
    Beiträge
    53

    Standard Systemwartung, Suchindex aktualisieren: 0%, der Crawler arbeitet gerade.... ewig

    Systemwartung
    Crawler
    0%
    0 / 0
    Den Suchindex aktualisieren
    Der Crawler arbeitet gerade. Bitte warten Sie bis er fertig ist, um die Ergebnisse zu sehen.


    Vorher hatte ich in der Systemwartung alles bis auf die System-Log-Einträge bereinigt.

    Jemand im Forum wollte derweil einkaufen gehen, bei mir tut sich aber nach über einer halben Stunde (bei allein einem der vielen Versuche) nicht mal 1%. Niente.
    Im Log erscheint mit Zeitstempel vom Aufruf Folgendes und nur Folgendes, also keine weiteren Zeilen mit der Zeit.

    [2022-08-11 00:53:12] request.INFO: Matched route "contao_backend". {"route":"contao_backend","route_parameters":{"_ro ute":"contao_backend","_scope":"backend","_token_c heck":true,"_controller":"Contao\\CoreBundle\\Cont roller\\BackendController::mainAction"},"request_u ri":"https://www.example.org/contao?act=crawl&crawl_subscriber_names%5B0%5D=sea rch-index&do=maintenance&jobId=6f9b4dce-foo&ref=l56bar","method":"POST"} []
    [2022-08-11 00:53:12] request.CRITICAL: Uncaught PHP Exception Symfony\Component\HttpClient\Exception\TransportEx ception: "No error" at /pfad/contao-4-9/vendor/symfony/http-client/Response/CurlResponse.php line 284 {"exception":"[object] (Symfony\\Component\\HttpClient\\Exception\\Transp ortException(code: 0): No error at /pfad/contao-4-9/vendor/symfony/http-client/Response/CurlResponse.php:284, Symfony\\Component\\HttpClient\\Exception\\Transpo rtException(code: 0): No error at /pfad/contao-4-9/vendor/symfony/http-client/Response/CurlResponse.php:284, Symfony\\Component\\HttpClient\\Exception\\Transpo rtException(code: 0): No error at /pfad/contao-4-9/vendor/symfony/http-client/Response/CurlResponse.php:284)"} []

    Eigentlich hätte ich gedacht, dass "No error" ein Zeichen für keine Probleme sei ... Ist das so wie neuerdings, dass die Leute aufschrecken, wenn man sagt, das Testergebnis sei positiv?

    ------
    Contao 4.9, migriert aus 3.5
    ------

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    30.342
    Partner-ID
    10107

    Standard

    Führe mal auf der Konsole
    Code:
    vendor/bin/contao-console contao:crawl --subscribers=search-index --enable-debug-csv
    aus und poste im Fehlerfall ggf. die Konsolenausgabe oder prüfe das Debug CSV.
    » sponsor me via GitHub or PayPal or Revolut

  3. #3
    Contao-Nutzer
    Registriert seit
    23.01.2014.
    Beiträge
    53

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Führe mal auf der Konsole
    Code:
    vendor/bin/contao-console contao:crawl --subscribers=search-index --enable-debug-csv
    aus und poste im Fehlerfall ggf. die Konsolenausgabe oder prüfe das Debug CSV.
    Damit hat es geklappt! In 3 Minuten - hab die Zeit gestoppt.

    Contao Crawler
    ==============
    Done!
    6292/6292 [============================] 100%
    // Finished crawling! Find the details for each subscriber below:

    search-index
    ------------
    [OK] Indexed 330 URI(s) successfully. 0 failed.
    [WARNING] 3274 URI(s) were skipped.


    Wo müsste ich ggf. das Debug-CSV suchen? Als Extradatei in var/logs? (In var/logs gab es weder bei prod noch bei dev Einträge, aber es gab ja auch keine Fehler.)

    Zur Meldung hätte ich nun auch Fragen, aber nicht dringend, also eventuell ein ander Mal, falls mir die Antworten nicht vorher über den Weg laufen.
    Jetzt bin ich erstmal froh, dass es läuft, und rühr es auch nicht an. Die Suche selbst habe ich natürlich getestet und die funktioniert. :-)
    Besten Dank!

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •