Ergebnis 1 bis 18 von 18

Thema: Seiten mit Subdomain mail.

  1. #1
    Contao-Nutzer
    Registriert seit
    14.10.2010.
    Beiträge
    129

    Standard Seiten mit Subdomain mail.

    Contao 4.13 Installationen,
    Admin-Tool: cPanel
    Hallo, ich muss vorausschicken, dass meine Kenntnisse bezüglich DNS-Einträge und Umleitungen sich in Grenzen halten.
    Zum Problem: bei einigen meiner Contao 4 Installationen ist mir aufgefallen, dass die Seiten auch über die Subdomain „mail.“ zu erreichen ist, also https://mail.domain.se
    Auch Suchmaschinen liefern dann teilweise Ergebnisse mit dieser subdomain.
    In den DNS-Einstellungen habe ich folgende Zeile gefunden:
    mail.domain.se. 3600 A 185.XX.XX.XXX (IP)
    Auf Anfrage beim Hoster (misshosting.se /Schweden) wurde mir mitgeteilt, dass es vermutlich an diesen Umleitungseinträgen liegen kann:
    ALL ^/$ /index.php/ 302 permanent
    ALL ^/$ /app.php/ 302 permanent
    Bei manchen Projekten sind beide Zeilen vorhanden, bei anderen nur die index.php-betreffende.
    Kann mir jemand helfen, wie ich das Problem mit dem vorangestellten „mail.“ lösen kann, so dass die Seiten nicht mehr mit dem vorangestellten „mail.“ zu finden bzw. zu erreichen sind, denn das macht meiner Meinung nach keinen Sinn. Hat jemand die gleichen Erfahrungen?
    Die DNS- und Umleitungs-Einträge wurden nicht aktiv, manuell angelegt, sondern wurden durch das System erstellt.
    Vielen Dank im Voraus

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    30.696
    Partner-ID
    10107

    Standard

    Zitat Zitat von Alok Beitrag anzeigen
    Zum Problem: bei einigen meiner Contao 4 Installationen ist mir aufgefallen, dass die Seiten auch über die Subdomain „mail.“ zu erreichen ist, also https://mail.domain.se
    Trage einfach die korrekte Domain im Website Root ein, dann kann das nicht mehr passieren (egal wie der Web Server konfiguriert ist).
    » sponsor me via GitHub or PayPal or Revolut

  3. #3
    Contao-Urgestein Avatar von tab
    Registriert seit
    22.10.2013.
    Beiträge
    9.772
    Contao-Projekt unterstützen

    Support Contao

    Standard

    Zum einen könntest du einfach die Hauptdomain eintragen im Startpunkt der Website. Dann dürfte die Seite mit anderen (Sub-)Domains nicht mehr anzeigbar sein. Zum anderen kommt die von dir angesprochene Umleitung nur zum Einsatz, wenn mod_rewrite nicht verfügbar ist. Das ist m.E. schlecht und jedenfalls nicht mehr zeitgemäß für ein Webhosting.

  4. #4
    Administratorin Avatar von lucina
    Registriert seit
    19.06.2009.
    Ort
    Kiel (DE)
    Beiträge
    7.136
    Partner-ID
    152
    User beschenken
    Wunschliste
    Contao-Projekt unterstützen

    Support Contao

    Standard

    Ich wäre ja noch nicht einmal sicher, ob ich für reine Mail-(Sub-)Domains überhaupt einen A- resp. AAAA-Record setzen würde. Kannst du das nicht entfernen (lassen)?

  5. #5
    Contao-Nutzer
    Registriert seit
    14.10.2010.
    Beiträge
    129

    Standard

    @Spooky und @tab: Danke, das hatte ich tatsächlich vernachlässigt. Habe jetzt unter URL-Einstellungen > Domainname "www.domainXXX.se" eingetragen. Leider bekomme ich aber eine 404 , wenn ich die Adresse ohne www eingebe. Da stehe ich noch irgendwo auf dem Schlauch

    @lucina: der Eintrag hat mich ja auch verwundert, wurde aber von mir so nie eingetragen. Ich kann den löschen, wäre mir aber nicht im Klaren, ob das Löschen irgendwelche anderen negativen Folgen nach sich zieht. Deswegen habe ich es noch nicht gemacht

  6. #6
    Contao-Urgestein Avatar von Kahmoon
    Registriert seit
    22.06.2009.
    Ort
    München
    Beiträge
    5.148

    Standard

    Zitat Zitat von Alok Beitrag anzeigen
    @Spooky und @tab: Danke, das hatte ich tatsächlich vernachlässigt. Habe jetzt unter URL-Einstellungen > Domainname "www.domainXXX.se" eingetragen. Leider bekomme ich aber eine 404 , wenn ich die Adresse ohne www eingebe. Da stehe ich noch irgendwo auf dem Schlauch
    Genau darum gehts ja bei dieser Einstellung ;-). Du hast dort www eingetragen damit mail. oder weisswurst.deinedomain.de nicht mehr geht. Jetzt musst du nur noch eine Weiterleitung von nicht www zu www in der .htaccess im /web machen.

    Code:
        RewriteCond %{HTTP_HOST} ^domain\.de$
        RewriteRule (.*) https://www.domain.de/$1 [R=301,L]

  7. #7
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    30.696
    Partner-ID
    10107

    Standard

    Zitat Zitat von Alok Beitrag anzeigen
    @Spooky und @tab: Danke, das hatte ich tatsächlich vernachlässigt. Habe jetzt unter URL-Einstellungen > Domainname "www.domainXXX.se" eingetragen. Leider bekomme ich aber eine 404 , wenn ich die Adresse ohne www eingebe. Da stehe ich noch irgendwo auf dem Schlauch
    Da musst du noch Server-Seitig weiterleiten lassen (Hosting-Einstellungen oder .htaccess).
    » sponsor me via GitHub or PayPal or Revolut

  8. #8
    Contao-Nutzer
    Registriert seit
    14.10.2010.
    Beiträge
    129

    Standard

    in der htaccess steht bisher
    Code:
    RewriteCond %{HTTP_HOST} ^domain\.se$ [OR]
    RewriteCond %{HTTP_HOST} ^www\.domain\.se$
    RewriteRule ^/?$ "https\:\/\/www\.domain\.se\/" [R=301,L]
    Ist das nicht richtig?

  9. #9
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    30.696
    Partner-ID
    10107

    Standard

    Durch deine Domain-Verheimlichung lässt sich das nicht gesichert sagen - denn das was du da gepostet hast, würde zu einem unendlichen Redirect führen.
    » sponsor me via GitHub or PayPal or Revolut

  10. #10
    Contao-Nutzer
    Registriert seit
    14.10.2010.
    Beiträge
    129

    Standard

    so sieht es jetzt aus in Contao
    screen_20220926_165328.png

    beim Hoster
    screen_20220926_164859.png

    in der htaccess
    Code:
    RewriteCond %{HTTP_HOST} ^domain\.se$ [OR]
    RewriteCond %{HTTP_HOST} ^www\.domain\.se$
    RewriteRule ^/?$ "https\:\/\/www\.domain\.se\/" [R=301,L]
    damit erreiche ich www.domain.se aber nicht domain.se
    Geändert von Alok (29.09.2022 um 17:07 Uhr)

  11. #11
    Contao-Urgestein Avatar von Kahmoon
    Registriert seit
    22.06.2009.
    Ort
    München
    Beiträge
    5.148

    Standard

    Die mittlere Zeile brauchts nicht. In die .htaccess im Verzeichnis /web muss
    Code:
    RewriteCond %{HTTP_HOST} ^plusweb\.se$
    RewriteRule (.*) https://www.plusweb.se/$1 [R=301,L]

  12. #12
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    30.696
    Partner-ID
    10107

    Standard

    Du hättest also direkt in der Hosting-Konfiguration einen Redirect eingerichtet. Da müsstest du beim Hoster fragen, warum das nicht greift.
    » sponsor me via GitHub or PayPal or Revolut

  13. #13
    Community-Moderatorin & Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    5.899
    Partner-ID
    7421
    Contao-Projekt unterstützen

    Support Contao

    Standard

    In welchem Verzeichnis liegt die .htaccess?
    Wurde die .htaccess vom Hoster erstellt als Du den Eintrag beim Hoster gemacht hast oder hast Du zusätzlich eine .htaccess erstellt?
    Ich habe Dir mit meinen Hinweisen geholfen und Du möchtest Dich bedanken?
    Unterstütze bitte das Contao-Projekt (Button Links)
    Weitere Spendenmöglichkeiten
    ------------------------------------------------------------------------------------------------------
    Contao-Dokumentation: Contao-Handbuch und Contao-Entwickler-Doku
    Contao-Online-Video-Kurse: Contao Academy
    Funktionalität erweitern: Contao-Erweiterungen

    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.




  14. #14
    Contao-Nutzer
    Registriert seit
    14.10.2010.
    Beiträge
    129

    Standard

    @Kahmoon: habe den Eintrag entsprechend geändert. Beim Hoster steht jetzt in den Umleitungen, ohne dass ich etwas selbst geändert habe, im Bereich "Verzeichnis" /(.*)
    screen_20220926_172155.png

    @mlweb: die htaccess liegt in /web. Ich selbst habe keine htaccess erstellt

    hier die komplette htaccess
    Code:
    <IfModule mod_rewrite.c>
        RewriteEngine On
    
        <IfModule mod_headers.c>
            # Assets in /assets and /bundles either contain a hash in their filename
            # or are called with a ?version suffix, therefore cache them for 1 year.
            RewriteRule ^(assets|bundles)/ - [ENV=CONTAO_ASSETS:true]
            Header set Cache-Control "max-age=31536000" env=CONTAO_ASSETS
    
            # Allow CORS on the Contao TinyMCE skin.
            RewriteRule ^assets/tinymce4/js/skins/contao/fonts/ - [ENV=CONTAO_TINYMCE_SKIN:true]
            Header set Access-Control-Allow-Origin "*" env=CONTAO_TINYMCE_SKIN
        </IfModule>
    
        # Determine the RewriteBase automatically and set it as environment variable.
        # If you are using Apache aliases to do mass virtual hosting or installed the
        # project in a subdirectory, the base path will be prepended to allow proper
        # resolution of the index.php file and to redirect to the correct URI. It will
        # work in environments without path prefix as well, providing a safe, one-size
        # fits all solution. But as you do not need it in this case, you can comment
        # the following 2 lines to eliminate the overhead.
        RewriteCond %{REQUEST_URI}::$1 ^(/.+)/(.*)::\2$
        RewriteRule ^(.*) - [E=BASE:%1]
    
        # Sets the HTTP_AUTHORIZATION header removed by Apache
        RewriteCond %{HTTP:Authorization} .
        RewriteRule ^ - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
        # Redirect to URI without front controller to prevent duplicate content
        # (with and without `/index.php`). Only do this redirect on the initial
        # rewrite by Apache and not on subsequent cycles. Otherwise we would get an
        # endless redirect loop (request -> rewrite to front controller ->
        # redirect -> request -> ...).
        # So in case you get a "too many redirects" error or you always get redirected
        # to the start page because your Apache does not expose the REDIRECT_STATUS
        # environment variable, you have 2 choices:
        # - disable this feature by commenting the following 2 lines or
        # - use Apache >= 2.3.9 and replace all L flags by END flags and remove the
        #   following RewriteCond (best solution)
        RewriteCond %{ENV:REDIRECT_STATUS} ^$
        RewriteRule ^index\.php(?:/(.*)|$) %{ENV:BASE}/$1 [R=301,L]
    
        # If the requested filename exists, simply serve it.
        # We only want to let Apache serve files and not directories.
        RewriteCond %{REQUEST_FILENAME} -f
        RewriteRule ^ - [L]
    
        # Rewrite all other queries to the front controller.
        RewriteRule ^ %{ENV:BASE}/index.php [L]
    </IfModule>
    
    <IfModule !mod_rewrite.c>
        <IfModule mod_alias.c>
            # When mod_rewrite is not available, we instruct a temporary redirect of
            # the start page to the front controller explicitly so that the website
            # and the generated links can still be used.
            RedirectMatch 302 ^/$ /index.php/
            # RedirectTemp cannot be used instead
        </IfModule>
    </IfModule>
    #RewriteCond %{HTTP_HOST} ^plusweb\.plusweb\.se$
    #RewriteRule ^/?$ "http\:\/\/plusweb\.se\/plusweb\/\^\/\$" [R=301,L]
    
    <IfModule mod_rewrite.c>
    # BEGIN Force http to https
    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^(.*) https://%{HTTP_HOST}/$1 [R=301,L]
    # END Force http to https
    </IfModule>
    #RewriteCond %{HTTP_HOST} ^plusweb\.se$ [OR]
    #RewriteCond %{HTTP_HOST} ^www\.plusweb\.se$
    #RewriteRule ^/?$ "https\:\/\/www\.plusweb\.se\/" [R=301,L]
    RewriteCond %{HTTP_HOST} ^plusweb\.se$
    RewriteRule (.*) https://www.plusweb.se/$1 [R=301,L]

  15. #15
    Contao-Urgestein Avatar von tab
    Registriert seit
    22.10.2013.
    Beiträge
    9.772
    Contao-Projekt unterstützen

    Support Contao

    Standard

    Also ich würde mal tippen, dass die Regeln ganz unten gar nicht mehr abgearbeitet werden, weil vorher schon die letzte Anweisung steht, nach der Weiterleitung zur index.php.
    Sollten solche Dinge wie http->https und domain.se->www.domain.se direkt oben nach "RewriteEngine On" stehen? Bzw http->https macht doch schon Contao selbst.

  16. #16
    Contao-Nutzer
    Registriert seit
    14.10.2010.
    Beiträge
    129

    Standard

    @tab: habe die htaccess entsprechend geändert, und nun funktioniert es. Habe die untersten Zeilen nach oben gesetzt und auch die "http to https"-Zeilen auskommentiert. Hier nochmal die geänderte htaccess. Soll ich die auskommentierten Zeilen löschen?
    Code:
    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteCond %{HTTP_HOST} ^plusweb\.se$
        RewriteRule (.*) https://www.plusweb.se/$1 [R=301,L]
    
        <IfModule mod_headers.c>
            # Assets in /assets and /bundles either contain a hash in their filename
            # or are called with a ?version suffix, therefore cache them for 1 year.
            RewriteRule ^(assets|bundles)/ - [ENV=CONTAO_ASSETS:true]
            Header set Cache-Control "max-age=31536000" env=CONTAO_ASSETS
    
            # Allow CORS on the Contao TinyMCE skin.
            RewriteRule ^assets/tinymce4/js/skins/contao/fonts/ - [ENV=CONTAO_TINYMCE_SKIN:true]
            Header set Access-Control-Allow-Origin "*" env=CONTAO_TINYMCE_SKIN
        </IfModule>
    
        # Determine the RewriteBase automatically and set it as environment variable.
        # If you are using Apache aliases to do mass virtual hosting or installed the
        # project in a subdirectory, the base path will be prepended to allow proper
        # resolution of the index.php file and to redirect to the correct URI. It will
        # work in environments without path prefix as well, providing a safe, one-size
        # fits all solution. But as you do not need it in this case, you can comment
        # the following 2 lines to eliminate the overhead.
        RewriteCond %{REQUEST_URI}::$1 ^(/.+)/(.*)::\2$
        RewriteRule ^(.*) - [E=BASE:%1]
    
        # Sets the HTTP_AUTHORIZATION header removed by Apache
        RewriteCond %{HTTP:Authorization} .
        RewriteRule ^ - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
        # Redirect to URI without front controller to prevent duplicate content
        # (with and without `/index.php`). Only do this redirect on the initial
        # rewrite by Apache and not on subsequent cycles. Otherwise we would get an
        # endless redirect loop (request -> rewrite to front controller ->
        # redirect -> request -> ...).
        # So in case you get a "too many redirects" error or you always get redirected
        # to the start page because your Apache does not expose the REDIRECT_STATUS
        # environment variable, you have 2 choices:
        # - disable this feature by commenting the following 2 lines or
        # - use Apache >= 2.3.9 and replace all L flags by END flags and remove the
        #   following RewriteCond (best solution)
        RewriteCond %{ENV:REDIRECT_STATUS} ^$
        RewriteRule ^index\.php(?:/(.*)|$) %{ENV:BASE}/$1 [R=301,L]
    
        # If the requested filename exists, simply serve it.
        # We only want to let Apache serve files and not directories.
        RewriteCond %{REQUEST_FILENAME} -f
        RewriteRule ^ - [L]
    
        # Rewrite all other queries to the front controller.
        RewriteRule ^ %{ENV:BASE}/index.php [L]
    </IfModule>
    
    <IfModule !mod_rewrite.c>
        <IfModule mod_alias.c>
            # When mod_rewrite is not available, we instruct a temporary redirect of
            # the start page to the front controller explicitly so that the website
            # and the generated links can still be used.
            RedirectMatch 302 ^/$ /index.php/
            # RedirectTemp cannot be used instead
        </IfModule>
    </IfModule>
    #RewriteCond %{HTTP_HOST} ^plusweb\.plusweb\.se$
    #RewriteRule ^/?$ "http\:\/\/plusweb\.se\/plusweb\/\^\/\$" [R=301,L]
    
    #<IfModule mod_rewrite.c>
    # BEGIN Force http to https
       # RewriteEngine On
       # RewriteCond %{HTTPS} !=on
       # RewriteRule ^(.*) https://%{HTTP_HOST}/$1 [R=301,L]
    # END Force http to https
    #</IfModule>
    #RewriteCond %{HTTP_HOST} ^plusweb\.se$ [OR]
    #RewriteCond %{HTTP_HOST} ^www\.plusweb\.se$
    #RewriteRule ^/?$ "https\:\/\/www\.plusweb\.se\/" [R=301,L]

  17. #17
    Contao-Urgestein Avatar von tab
    Registriert seit
    22.10.2013.
    Beiträge
    9.772
    Contao-Projekt unterstützen

    Support Contao

    Standard

    Zitat Zitat von Alok Beitrag anzeigen
    @tab: habe die htaccess entsprechend geändert, und nun funktioniert es. Habe die untersten Zeilen nach oben gesetzt und auch die "http to https"-Zeilen auskommentiert. Hier nochmal die geänderte htaccess. Soll ich die auskommentierten Zeilen löschen?
    Ich würde die unten auskommentierten Zeilen löschen um die Datei "sauber" zu halten. Aber notwendig ist das natürlich nicht.

  18. #18
    Contao-Nutzer
    Registriert seit
    14.10.2010.
    Beiträge
    129

    Standard

    Vielen Dank für alle Tipps!

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •