Results 1 to 5 of 5

Thread: Page not found

  1. #1
    New user
    Join Date

    Default Page not found

    I'm sure there a very simple answer to this, but I can't seem to find it:

    I can only see front-end pages when I'm logged in to Contao, and select Front end preview...

    Otherwise - and also after some time even though I'm logged in - I get to see "Page not found".

    The Articles are set as Published.

    What else do I heed to do to make the site permanently visible?


  2. #2
    Experienced user
    Join Date

    Default Re: Page not found


    The first thing you should check is make sure that none of your pages have "protect page" checked. This is in the site structure in a group labeled "Access Protection".

    I believe how it works is if you have a parent page checked, the child pages are protected as well -- but not 100% sure. If true, you could have one page accidentally checked (and all it's children would then also be inaccessible).

    This would explain why it works for a while if you are logged in. As a back-end user you may have access, but after a while your session will expire and you'll be automatically logged out. That could be when it stops working for you.

  3. #3
    Experienced user
    Join Date

    Default Re: Page not found

    In fact; you should also check that your pages are published (which is not inherited by subpages, unlike protection). Because the published status of your articles does not influence the "page not found" message.

    Finally you should check that you've created at least one root page (when creating a page you can choose "Root page" as a pagetype). If you have only one, make sure it has the correct language and you must also check "fallback language" for at least one root page. This way people browsing with a different language setting will land on the fallback instead of on the error page.

    So, you checklist;
    1. Make sure there is at least one root page. (all other page types must be within a root page)[/*:m:27u8tv03]
    2. Make sure at least one root page is the fallback language[/*:m:27u8tv03]
    3. Under each root page at least one page must be published[/*:m:27u8tv03]
    4. At least one of the item 3 pages must also not be protected (or must be made visible to guests only). It may also not reside within an ancestor page that IS protected.[/*:m:27u8tv03]

    One last thing. I'm not sure what happens if there is no layout defined yet, I assume you have one. I usually create a "default" layout. This layout is automatically applied to all pages.

  4. #4
    New user
    Join Date

    Default Re: Page not found

    I have exactly the same problem now with Contao 2.10.4
    My problem is that I cant see my front page. Only if I take a Frontend-show, and toggle the drop down menu to show the invisible site. So my site cant be shown, except if I am looged in.
    I have checked all of the above things, but they seem to be as they should.
    Did you come up with any solutions, or where did this thread end?

  5. #5
    Join Date
    New York, NY USA

    Default Re: Page not found


    Thanks so much, you post ended a week long effort!

    I did not know to check the Language fallback under the root page within "Site Structure". This appears to have fixed my issue of the site not being viewable to outside of the English language.

    One would think this should be a default I would think.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts