Results 1 to 11 of 11

Thread: Installation problem - Contao 3

  1. #1
    New user
    Join Date
    02-05-13.
    Posts
    6

    Default Installation problem - Contao 3

    Hi, I need a help - I'm not able to install Contao 3 on my server...
    I have several web pages with Contao 2.x.x, and there were no problems.
    With Contao check, everything seems ok, I can install version 2 completely. But when I install Contao 3.0.3 (3.0.1 and 3.0.2), download to server is ok, then I change installation password, enter the database connection and then it falls down:
    Code:
    Warning: Invalid argument supplied for foreach() in /www/doc/www.mydomain.eu/www/system/modules/core/library/Contao/Controller.php on line 114 
    #0 /www/doc/www.mydomain.eu/www/system/modules/core/library/Contao/Controller.php(114): __error(2, 'Invalid argumen...', '/www/doc/www.kl...', 114, Array)
    #1 /www/doc/www.mydomain.eu/www/system/modules/newsletter/dca/tl_newsletter.php(203): Contao\Controller::getTemplateGroup('mail_')
    #2 /www/doc/www.mydomain.eu/www/system/modules/core/library/Contao/Controller.php(2394): include('/www/doc/www.kl...')
    #3 /www/doc/www.mydomain.eu/www/system/modules/core/library/Contao/DcaExtractor.php(280): Contao\Controller->loadDataContainer('tl_newsletter')
    #4 /www/doc/www.mydomain.eu/www/system/modules/core/library/Contao/DcaExtractor.php(109): Contao\DcaExtractor->createExtract()
    #5 /www/doc/www.mydomain.eu/www/system/modules/core/library/Contao/DcaExtractor.php(459): Contao\DcaExtractor->__construct('tl_newsletter')
    #6 /www/doc/www.mydomain.eu/www/system/modules/core/library/Contao/Database/Installer.php(258): Contao\DcaExtractor::createAllExtracts()
    #7 /www/doc/www.mydomain.eu/www/system/modules/core/library/Contao/Database/Installer.php(106): Contao\Database\Installer->getFromDca()
    #8 /www/doc/www.mydomain.eu/www/system/modules/core/library/Contao/Database/Installer.php(38): Contao\Database\Installer->compileCommands()
    #9 /www/doc/www.mydomain.eu/www/contao/install.php(227): Contao\Database\Installer->generateSqlForm()
    #10 /www/doc/www.mydomain.eu/www/contao/install.php(936): InstallTool->run()
    #11 {main}
    
    
    Warning: Cannot modify header information - headers already sent by (output started at /www/doc/www.mydomain.eu/www/system/helper/functions.php:69) in /www/doc/www.mydomain.eu/www/system/modules/core/library/Contao/Template.php on line 277 
    #0 [internal function]: __error(2, 'Cannot modify h...', '/www/doc/www.kl...', 277, Array)
    #1 /www/doc/www.mydomain.eu/www/system/modules/core/library/Contao/Template.php(277): header('Vary: User-Agen...', false)
    #2 /www/doc/www.mydomain.eu/www/system/modules/core/classes/BackendTemplate.php(156): Contao\Template->output()
    #3 /www/doc/www.mydomain.eu/www/contao/install.php(747): Contao\BackendTemplate->output()
    #4 /www/doc/www.mydomain.eu/www/contao/install.php(250): InstallTool->outputAndExit()
    #5 /www/doc/www.mydomain.eu/www/contao/install.php(936): InstallTool->run()
    #6 {main}
    
    
    Warning: Cannot modify header information - headers already sent by (output started at /www/doc/www.mydomain.eu/www/system/helper/functions.php:69) in /www/doc/www.mydomain.eu/www/system/modules/core/library/Contao/Template.php on line 278 
    #0 [internal function]: __error(2, 'Cannot modify h...', '/www/doc/www.kl...', 278, Array)
    #1 /www/doc/www.mydomain.eu/www/system/modules/core/library/Contao/Template.php(278): header('Content-Type: t...')
    #2 /www/doc/www.mydomain.eu/www/system/modules/core/classes/BackendTemplate.php(156): Contao\Template->output()
    #3 /www/doc/www.mydomain.eu/www/contao/install.php(747): Contao\BackendTemplate->output()
    #4 /www/doc/www.mydomain.eu/www/contao/install.php(250): InstallTool->outputAndExit()
    #5 /www/doc/www.mydomain.eu/www/contao/install.php(936): InstallTool->run()
    #6 {main}
    Behind those errors continues "installation page", but without graphic. Database seems connected. But every button goes to mydomain.eu/contao/contao/install.php instead of mydomain.eu/contao/install.php, so error – page not found…

    Can you anybody help? Thanks Jakub

  2. #2
    New user
    Join Date
    02-05-13.
    Posts
    6

    Default Re: Installation problem - Contao 3

    Now I can install version 3.0.4 OK - first problem solved

    But after login there are no CSS and every link goes to mydomain.eu/contao/contao/.. instead of mydomain.eu/contao/..., so error again – page not found…

    Thanx for your help...

  3. #3
    New user
    Join Date
    02-19-13.
    Posts
    14

    Default Re: Installation problem - Contao 3

    Add in system\config\localconfig after the last line
    ### INSTALL SCRIPT STOP ###
    these two lines:
    unset($_SERVER['HTTP_X_FORWARDED_FOR']);
    unset($_SERVER['HTTP_X_FORWARDED_HOST']);

  4. #4
    New user
    Join Date
    02-05-13.
    Posts
    6

    Default Installation OK, backend error

    Hi, I can install all versions Contao 3.x.x OK, but after login to backend there are no CSS and every link goes to mydomain.eu/contao/contao/.. instead of mydomain.eu/contao/..., so error again – page not found…
    I tried different languages, and Klaus tip, but still the same...

  5. #5
    Community-Moderator xchs's Avatar
    Join Date
    06-20-09.
    Posts
    1,284

    Default Re: Installation problem - Contao 3

    Delete "system/config/pathconfig.php" and run the Contao install tool again. This will set all the path variables automatically.
    Contao Community Moderator
    → Support options

  6. #6
    New user
    Join Date
    02-05-13.
    Posts
    6

    Default Re: Installation problem - Contao 3

    Thanx xchs, but that isn't solution.
    In that file is
    Code:
    <?php // Relative path to the installation return '';
    any when I delete it - nothing changes.

    Here is screenshot - the URLs still goes to contao/contao
    Than you for your time!
    Jakub

  7. #7
    Community-Moderator xchs's Avatar
    Join Date
    06-20-09.
    Posts
    1,284

    Default Re: Installation problem - Contao 3

    Did you run the Contao install tool afterwards? Also, did you set or change the RewriteBase in your ".htaccess"?
    Contao Community Moderator
    → Support options

  8. #8
    New user
    Join Date
    02-05-13.
    Posts
    6

    Default Re: Installation problem - Contao 3

    Install tool generates exactly the same config file. And I didn't even touch .htaccess
    I install Contao thru "CHECK utility". Now I tried install 2.11.11 and it's OK.
    I had some (different) problem with czech language pack, so I tried different languages, bud no solution.

  9. #9
    Community-Moderator xchs's Avatar
    Join Date
    06-20-09.
    Posts
    1,284

    Default Re: Installation problem - Contao 3

    Hmm, strange. You already wrote (in the OP) that when running the Contao check everything seems to be fine, but did you perform also the last step, i.e. "Validate an existing Contao installation"? Any corrupt or missing files there?

    Please also check the WebsitePath in your "system/config/localconfig.php". There should be an entry like this
    Code:
    $GLOBALS['TL_CONFIG']['websitePath'] = '';
    (if you set up your Contao installation in the vhosts "root" directory)
    Contao Community Moderator
    → Support options

  10. #10
    New user
    Join Date
    02-05-13.
    Posts
    6

    Default Re: Installation problem - Contao 3

    It's absolutly strange! :-)
    Check tool validation of installation is OK.
    Code you wrote wasn't there, so I tried to add it, but no change.
    I installed contao to directory "www", which is made by provider for websites - there are 3 more direcories, but they aren't accessible from the web (it's "tmp" and "log" ... directory).
    I tried to install contao to different hosting, and everything is OK, but I can't find the problem.
    And now - the fancy! - When I login, its still the same picture (no CSS, no icons, bad URLs). Only one URL at the top is OK: "user jklimes". When I click on it, I can change my personal data and everything is OK! From here I can do everything, work normaly, and it works. Only one URL is bad: "home".
    So I am happy that I can work, bud it's a little bit clumsy...

  11. #11
    Community-Moderator xchs's Avatar
    Join Date
    06-20-09.
    Posts
    1,284

    Default Re: Installation problem - Contao 3

    Quote Originally Posted by jklimes
    Code you wrote wasn't there
    Hmm, there should be already an entry $GLOBALS['TL_CONFIG']['websitePath'] = ... in your "localconfig.php"!
    Maybe a problem with write permissions? Try to enable the option "Display error messages" in the back end module "Settings" > "Security settings". If Contao is allowed to edit the local configuration file, then there should be an additional entry now:
    Code:
    $GLOBALS['TL_CONFIG']['displayErrors'] = true;
    Is that the case with you?
    Contao Community Moderator
    → Support options

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •