Results 1 to 4 of 4

Thread: Contao 3.5 - Problem with Composer on Gandi.net shared hosting

  1. #1
    User
    Join Date
    04-01-10.
    Posts
    229

    Default Contao 3.5 - Problem with Composer on Gandi.net shared hosting

    Hi the community,

    On one Contao installation, I got a pb with Composer.

    1st installation :
    http://legrandmenage.fr

    Contao 3.5.6 - PHP 5.4.45-0+deb7uG
    Contao's check message : "You cannot use Composer package manager" / "The PHP APC extension is installed".

    2nd installation
    http://lesnouvelleshybrides.com
    Contao 3.5.12 - PHP 5.6.30-0+deb8u1
    Contao's check : "You can use use Composer package manager" / "The PHP APC extension is not installed".

    As both installation are in production, I'd like to understand where is the problem before doing anything…
    Why can't Composer work on the first installation ? Because of PHP version , Contao's version or both ?

    Thanks for your hep.

  2. #2
    User Spooky's Avatar
    Join Date
    01-03-13.
    Posts
    336

    Default

    The problem is already explained in the Contao Check:

    PHP APC extension

    The PHP APC extension is installed.

    Using the PHP APC extension with Composer can lead to unexpected "cannot redeclare class" errors.

    You (or your hoster) must disable the PHP APC extension.


    Btw. you are using an old version of the Contao Check. You should use the latest master version which can be downloaded from contao.org.
    Last edited by Spooky; 04/26/2017 at 17:26.

  3. #3
    User
    Join Date
    04-01-10.
    Posts
    229

    Default

    Hi Spooky,

    I understood.

    But, as I have 2 versions of Contao on 2 versions of PHP, I'm trying to understand if this could be a bug in 3.5.6 fixed in 3.5.12 or if this could be the difference between the 2 versions of PHP…

  4. #4
    User Spooky's Avatar
    Join Date
    01-03-13.
    Posts
    336

    Default

    It has nothing to do with Contao or the PHP version. Those are two completely different hosting environments and thus two completely different configurations, according to the Check.

    legrandmenage.fr is running on a Debian 7 Server with PHP 5.4.45-0+deb7u5
    lesnouvelleshybrides.com is running on a Debian 8 Server with PHP 5.6.30-0+deb8u1

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •