Results 1 to 1 of 1

Thread: [solved] /contao/install 404 not found on Ubuntu 20.04 local installation

  1. #1
    User
    Join Date
    04-01-10.
    Posts
    278

    Default [solved] /contao/install 404 not found on Ubuntu 20.04 local installation

    Hello,
    I'm trying to install a local dev environnement on my laptop under Ubuntu 20.04. I've installed lamp from Ubuntu official repos.from

    1. I tried to transfer a Contao 4.4 prod website from a shared host.
    As explained in the doc, I copied /files, /templates, composer.json and composer.lock to my local vhost and added /web/contao-manager.phar.php.
    For the installation to work, I had to chmod -R 775.

    At the end, when I click to Update the database, /myvhost/contao/install returns a 404 not found page.

    2. I tried 3 times then I tried a fresh installation.
    Same 404 error. When I look in the vhost directory, all 1st level directories (except /web) and files are locked with owner: www-data: create and suppress and group: www-data: files access. And the /app directory is missing.

    Where is the problem ? In my Apache2 conf ?

    Or in my vhost conf file ?
    Code:
    <VirtualHost *:80>
            #nom de domaine
        ServerName terea.test 
            #on accepte aussi le www
        ServerAlias www.terea.test 
            #logs d'erreur
        ErrorLog /var/log/apache2/error.terea.test.log 
            #logs de connexion
        CustomLog /var/log/apache2/access.terea.test.log  common
            #Définition de la racine des sources php
        DocumentRoot "/var/vhosts/terea.test/web/"
        <directory "/var/vhosts/terea.test/web/">
            Options -Indexes +FollowSymLinks +MultiViews
            AllowOverride All
            Require all granted
        </Directory>
    </VirtualHost>
    Thanks for your help.
    Last edited by charled; 07/16/2022 at 08:09.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •