Seite 4 von 7 ErsteErste ... 23456 ... LetzteLetzte
Ergebnis 121 bis 160 von 273

Thema: [con4gis_maps] Offizieller Support-Thread

  1. #121
    Contao-Nutzer Avatar von tamague
    Registriert seit
    19.05.2010.
    Ort
    Klagenfurt
    Beiträge
    197

    Standard

    Hallo Matthias,
    nachdem ich nichts fgefunden habe , habe ich icon4gis entfernt und nochmal con4gis map , nachdem es keine Veränderung gab zusätzlich con4giscore installiert .
    Ich habe in var logs unter anderem folgende Meldungen nach den Anlegen einer neuen Karte ... etc gefunden :
    [2018-04-13 23:28:46] security.INFO: Attempting SimplePreAuthentication. {"key":"frontend","authenticator":"Contao\\CoreBun dle\\Security\\ContaoAuthenticator"} []
    [2018-04-13 23:28:46] request.ERROR: Uncaught PHP Exception Symfony\Component\HttpKernel\Exception\NotFoundHtt pException: "Page not found: http://idev40/con4gis/baseLayerService/null" at /Applications/MAMP/htdocs/idev40/vendor/contao/core-bundle/src/EventListener/ExceptionConverterListener.php line 112 {"exception":"[object] (Symfony\\Component\\HttpKernel\\Exception\\NotFou ndHttpException(code: 0): Page not found: http://idev40/con4gis/baseLayerService/null at /Applications/MAMP/htdocs/idev40/vendor/contao/core-bundle/src/EventListener/ExceptionConverterListener.php:112, Contao\\CoreBundle\\Exception\\PageNotFoundExcepti on(code: 0): Page not found: http://idev40/con4gis/baseLayerService/null at /Applications/MAMP/htdocs/idev40/vendor/contao/core-bundle/src/Resources/contao/controllers/FrontendIndex.php:66)"} []
    [2018-04-13 23:51:45] request.INFO: Matched route "contao_catch_all". {"route":"contao_catch_all","route_parameters":{"_ scope":"frontend","_token_check":true,"_controller ":"Contao\\CoreBundle\\Controller\\FrontendControl ler::indexAction","_url_fragment":"con4gis/baseLayerService/null","_route":"contao_catch_all"},"request_uri":" http://idev40/con4gis/baseLayerService/null","method":"HEAD"} []
    [2018-04-13 23:51:45] security.INFO: Attempting SimplePreAuthentication. {"key":"frontend","authenticator":"Contao\\CoreBun dle\\Security\\ContaoAuthenticator"} []
    [2018-04-13 23:51:45] request.INFO: Matched route "contao_catch_all". {"route":"contao_catch_all","route_parameters":{"_ scope":"frontend","_token_check":true,"_controller ":"Contao\\CoreBundle\\Controller\\FrontendControl ler::indexAction","_url_fragment":"con4gis/baseLayerService/null","_route":"contao_catch_all"},"request_uri":" http://idev40/con4gis/baseLayerService/null","method":"GET"} []
    [2018-04-13 23:51:45] security.INFO: Attempting SimplePreAuthentication. {"key":"frontend","authenticator":"Contao\\CoreBun dle\\Security\\ContaoAuthenticator"} []
    [2018-04-13 23:51:45] request.ERROR: Uncaught PHP Exception Symfony\Component\HttpKernel\Exception\NotFoundHtt pException: "Page not found: http://idev40/con4gis/baseLayerService/null" at /Applications/MAMP/htdocs/idev40/vendor/contao/core-bundle/src/EventListener/ExceptionConverterListener.php line 112 {"exception":"[object] (Symfony\\Component\\HttpKernel\\Exception\\NotFou ndHttpException(code: 0): Page not found: http://idev40/con4gis/baseLayerService/null at /Applications/MAMP/htdocs/idev40/vendor/contao/core-bundle/src/EventListener/ExceptionConverterListener.php:112, Contao\\CoreBundle\\Exception\\PageNotFoundExcepti on(code: 0): Page not found: http://idev40/con4gis/baseLayerService/null at /Applications/MAMP/htdocs/idev40/vendor/contao/core-bundle/src/Resources/contao/controllers/FrontendIndex.php:66)"} []

  2. #122
    Contao-Nutzer Avatar von tamague
    Registriert seit
    19.05.2010.
    Ort
    Klagenfurt
    Beiträge
    197

    Standard Problem gefunden

    ..habe alle js script templates im layout mal testweise deaktiviert ... uns siehe da die Karte wird wieder angezeigt ... sobald ich entweder js_caroufredsel oder js_mmenu aktiviere wird die Karte des con4gis maps nicht mehr angezeigt ....

  3. #123
    Contao-Urgestein Avatar von folkfreund
    Registriert seit
    09.04.2010.
    Ort
    Dortmund
    Beiträge
    1.892

    Standard

    Dann kannst du es jetzt ja noch weiter eingrenzen...

    Ich tippe auf js_mmenu, da das die HTML-Struktur verändert um das Overlaymenü einzubauen. Leider kann ich dir aber nicht sagen, was dagegen zu tun ist.
    Da es mit dk_mmenu ja auch Lizenz-unklarheiten gab, könntest du versuchen, es durch mobilde_menu (per Composer codefog/contao-mobile_menu) zu ersetzen. Ob da mit die Probleme weg sind, kann ich dir aber nicht versprechen.
    www.folkfreun.de - Treffpunkt für Folkmusiker, Folktänzer, Veranstalter und alle Freunde von trad. Folkmusik

  4. #124
    Contao-Nutzer Avatar von tamague
    Registriert seit
    19.05.2010.
    Ort
    Klagenfurt
    Beiträge
    197

    Standard

    ja danke....ich werd eine andere Lösung verwenden... zum Glück gibt es ja nur nicht eine"glücklich machende Variante "

  5. #125
    Contao-Nutzer
    Registriert seit
    02.02.2014.
    Beiträge
    5

    Standard Direktlink ohne Funktion

    Hallo, ich benötige für eine 3.9.5 eine Möglichkeit auf Kartenstrukturen (.kml) einen Link zu setzen. Die Funktion Direktlink funktioniert leider nicht. Habe es mit und ohne Doppelklick im Kartenprofil probiert. Kann mir jemand helfen.

    Danke.

  6. #126
    Contao-Nutzer
    Registriert seit
    29.11.2016.
    Beiträge
    43

    Standard Anpassen des Tooltip für eine Mitgliederkarte/Tabelle

    Hallo,

    nachdem ich mich durch dieses wahrhaft gigantische Modul con4gis_maps gekämpft habe, habe ich nun eine schöne Karte mit den Standorten aus der Mitgliedertabelle.

    Als Lokationsstil verwende ich einen einfachen Punkt. Den Label habe ich weggelassen, damit die Karte übersichtlich bleibt.

    Nun möchte ich natürlich, dass bei Klick/Überfahren mit der Maus die Firma/Anschrift im Tooltip angezeigt wird. Leider habe ich nirgends eine Beschreibung gefunden wie ich an diesen Tooltip komme, bzw. wie ich die Einträge verändern kann. Aktuell erscheint immer der Vorname des Mitglieds

    Könnt ihr mir mal auf die Sprünge helfen?

    LG seagull



    Update gelöst: Unter /system/modules/con4gis_maps3/config sind in der config.php beispielhaft die Felder voreingetragen. Diese kann man nach Bedarf anpassen.
    Geändert von seagull (31.07.2018 um 15:02 Uhr)

  7. #127
    Contao-Nutzer
    Registriert seit
    16.03.2012.
    Beiträge
    2

    Standard Keine Karte / Baselayer

    Hallo zusammen,

    letztes Jahr gab es bei @Schneetiger und @Govili schon mal das Problem das alle Elemente außer der Karte dargestellt werden. Gab es da eine Lösung?
    Ich habe die Erweiterung heute mal in einem lokalen Testsystem installiert und es läuft alles super. Danach habe ich das Ganze online gestellt und die Karte wird nicht angezeigt.
    Was auch etwas seltsam ist, ist das wenn ich online im Backend in der Kartenstruktur auf die Buttons zum Festlegen der Geo-Koordinaten klicke die Contao Meldung "Es ist ein Fehler aufgetreten" erscheint.

    Das Ganze läuft unter Contao 3.5.35, con4gis_core 1.9.3.5 und con4gis_maps3 3.9.6.6. Lokal und online läuft jeweils PHP 7.1

    Die Konsole gibt folgende Meldungen aus:
    ?
    Code:
    GET ../system/modules/con4gis_core/api/index.php/baseLayerService/2 400 ()
    send @ d7a958025ba2.js:2
    ajax @ d7a958025ba2.js:2
    loadBaseLayers @ c4g-maps-proxy.js:913
    initialize @ c4g-maps-proxy.js:71
    c4g.maps.MapController @ c4g-maps.js:379
    (anonymous) @ kontakt.html:285
    j @ d7a958025ba2.js:2
    fireWith @ d7a958025ba2.js:2
    ready @ d7a958025ba2.js:2
    J @ d7a958025ba2.js:2
    
    An error occured while trying to load the baselayers...
    (anonymous) @ c4g-maps-proxy.js:927
    j @ d7a958025ba2.js:2
    fireWith @ d7a958025ba2.js:2
    x @ d7a958025ba2.js:2
    b @ d7a958025ba2.js:2
    XMLHttpRequest.send (async)
    send @ d7a958025ba2.js:2
    ajax @ d7a958025ba2.js:2
    loadBaseLayers @ c4g-maps-proxy.js:913
    initialize @ c4g-maps-proxy.js:71
    c4g.maps.MapController @ c4g-maps.js:379
    (anonymous) @ kontakt.html:285
    j @ d7a958025ba2.js:2
    fireWith @ d7a958025ba2.js:2
    ready @ d7a958025ba2.js:2
    J @ d7a958025ba2.js:2
    
    Spinner is already hidden.
    hide @ c4g-maps-misc-spinner.js:72
    (anonymous) @ c4g-maps-proxy.js:928
    j @ d7a958025ba2.js:2
    fireWith @ d7a958025ba2.js:2
    x @ d7a958025ba2.js:2
    b @ d7a958025ba2.js:2
    XMLHttpRequest.send (async)
    send @ d7a958025ba2.js:2
    ajax @ d7a958025ba2.js:2
    loadBaseLayers @ c4g-maps-proxy.js:913
    initialize @ c4g-maps-proxy.js:71
    c4g.maps.MapController @ c4g-maps.js:379
    (anonymous) @ kontakt.html:285
    j @ d7a958025ba2.js:2
    fireWith @ d7a958025ba2.js:2
    ready @ d7a958025ba2.js:2
    J @ d7a958025ba2.js:2
    
    GET ../system/modules/con4gis_core/api/index.php/layerService/1 400 ()
    send @ d7a958025ba2.js:2
    ajax @ d7a958025ba2.js:2
    loadLayers @ c4g-maps-proxy.js:1656
    initialize @ c4g-maps-proxy.js:72
    c4g.maps.MapController @ c4g-maps.js:379
    (anonymous) @ kontakt.html:285
    j @ d7a958025ba2.js:2
    fireWith @ d7a958025ba2.js:2
    ready @ d7a958025ba2.js:2
    J @ d7a958025ba2.js:2
    
    An error occured while trying to load the layers...
    (anonymous)	@	c4g-maps-proxy.js:1677
    j	@	d7a958025ba2.js:2
    fireWith	@	d7a958025ba2.js:2
    x	@	d7a958025ba2.js:2
    b	@	d7a958025ba2.js:2
    XMLHttpRequest.send (async)		
    send	@	d7a958025ba2.js:2
    ajax	@	d7a958025ba2.js:2
    loadLayers	@	c4g-maps-proxy.js:1656
    initialize	@	c4g-maps-proxy.js:72
    c4g.maps.MapController	@	c4g-maps.js:379
    (anonymous)	@	kontakt.html:285
    j	@	d7a958025ba2.js:2
    fireWith	@	d7a958025ba2.js:2
    ready	@	d7a958025ba2.js:2
    J	@	d7a958025ba2.js:2
    Es wäre super wenn ihr mir da auf die Sprünge helfen könntet.

    Danke und einen schönen Abend,

    Exe

  8. #128
    Contao-Nutzer
    Registriert seit
    30.03.2010.
    Ort
    Berlin
    Beiträge
    219

    Frage Migrationsscript dlh_googlemaps > con4gis_maps

    Hallo zusammen,

    endlich habe ich mich aufgemacht, mein altes dlh_googlemaps gegen con4gis_maps austauschen zu wollen. Das hat kaum vier Jahre gedauert. Und ich bin wirklich begeistert, wie sich con4gis_maps entwickelt hat; klasse.

    Da ich so ein paar Marker migrieren möchte, habe ich mir die Datenbank jeweils einmal angesehen. Bei dlh_googlemaps habe ich rund 44 Einträge pro Marker in der DB, bei con4gis_maps scheinen es 47 zu sein. Da ich mich nicht so richtig an die DB-Migration der Daten traue aber meine Motivation zur manuellen Erfassung auch noch gering ist, kurz die Frage in die Runde: Hat das schon mal jemand migriert und eventuell ein Script gemacht? Bzw. geht das überhaupt, oder sollte ich lieber manuell neu erfassen. Auf den ersten Blick sieht es machbar aus, aber da ja Daten fehlen werden...

    Viele Grüße
    Jens_
    Lieblingsurlaubsstadt am Meer
    http://www.kolberg-cafe.de

  9. #129
    Contao-Nutzer Avatar von gecki
    Registriert seit
    01.04.2012.
    Ort
    Berlin
    Beiträge
    32

    Standard Marker anzeigen

    Moin,

    ich bin gerade dabei Marker zu erstellen (erstellt sind sie) und auf meiner Karte anzeigen zu lassen. Aber es wird einfach nix angezeigt. Bin langsam am verzweifeln.

    Ich habe eine Karte angelegt, ein Lokationsstil, ein Karteprofil und eine Stuktur (siehe Anhang).

    Bildschirmfoto 2018-09-20 um 11.27.44.png
    Bildschirmfoto 2018-09-20 um 11.28.00.png
    Bildschirmfoto 2018-09-20 um 11.28.14.png
    Bildschirmfoto 2018-09-20 um 11.28.26.png
    Bildschirmfoto 2018-09-20 um 11.29.00.png

    Aber es kommt einfach nix....

    Hat wer ne Idee wo ich was übersehen haben könnte?

    Vielen Dank
    gecki

  10. #130
    Alter Contao-Hase Avatar von Franko
    Registriert seit
    22.06.2009.
    Beiträge
    1.250
    Partner-ID
    6122

    Standard

    Kann ich mit der Erweiterung für Contao 4.4.x auch Mitglieder Koordinaten setzen/lassen und anzeigen?
    Carpe diem ...

  11. #131
    Contao-Nutzer Avatar von Joern
    Registriert seit
    14.09.2018.
    Beiträge
    104

    Standard

    Zitat Zitat von gecki Beitrag anzeigen
    ich bin gerade dabei Marker zu erstellen (erstellt sind sie) und auf meiner Karte anzeigen zu lassen. Aber es wird einfach nix angezeigt. Bin langsam am verzweifeln.

    Ich habe eine Karte angelegt, ein Lokationsstil, ein Karteprofil und eine Stuktur (siehe Anhang).
    ...
    Aber es kommt einfach nix....
    Moin, ich bin auch dabei, mich in con4gis_maps einzuarbeiten. Die Möglichkeiten sind beeindruckend, aber die ersten Schritte fallen mir noch schwer.
    Ich habe mich an die Anleitung https://maps.con4gis.org/anreisekarte gehalten. Die Karte wird auch angezeigt, aber kein Marker.

    In der Google Chrome Console erhalte ich folgenden Fehler:
    Code:
    jquery.min.js:4 GET https://example.com/con4gis/layerService/3 500 (Internal Server Error)
    An error occured while trying to load the layers...
    Im Cantao 4.24 Logfile erhalte ich folgenden Eintrag:
    Code:
    [2018-09-19 13:18:03] app.CRITICAL: An exception occurred. {"exception":"[object] (Symfony\\Component\\DependencyInjection\\Exception\\ServiceNotFoundException(code: 0): You have requested a non-existent service \"doctrine.orm.entity_manager\". at /var/www/contao/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/Container.php:348)"} []
    Im Browser sieht das so aus, als ob es ewig laden würde, wenn man rechts das Sideboard einblendet:
    con4gis_maps_1.PNG

    An Erweiterungen habe ich terminal42/contao-changelanguage (Version 3.1.9) und con4gis/maps (Version v5.0.0) installiert.

    Vielleicht handelt es sich hier um ein ähnliches Problem?
    Ich bin momentan ratlos und weiß nicht weiter.

    Jörn
    Geändert von Joern (20.09.2018 um 12:02 Uhr)

  12. #132
    Contao-Nutzer Avatar von Joern
    Registriert seit
    14.09.2018.
    Beiträge
    104

    Standard gelöst durch Update auf con4gis/maps Version 5.0.1

    Zitat Zitat von Joern Beitrag anzeigen
    An Erweiterungen habe ich terminal42/contao-changelanguage (Version 3.1.9) und con4gis/maps (Version v5.0.0) installiert.
    Hallo,
    das Update von con4gis/maps auf Version 5.0.1 hat das Problem behoben. Jetzt läuft es einwandfrei. Und die in der Zwischenzeit im BE erstellten Einträge tauchen jetzt alle in der Karte auf.
    Vielen Dank an die Küstenschmiede für das schnelle Update und für diese tolle Extension.
    Jörn

  13. #133
    Contao-Fan Avatar von Gassi
    Registriert seit
    18.11.2009.
    Ort
    Konstanz
    Beiträge
    360

    Standard Kann man auch nach Adressen suchen lassen?

    Hallo,
    ich habe die Con4gis Map Erweiterung erfolgreich zum laufen bekommen. Jedoch stellt sich bei mir noch die Frage: Kann man denn Einzelne Standorte auch einfach wie bei z.B. der Googlemaps-Erweiterung über eine Adresse suchen lassen? Ich finde es rech umständlich immer über die Karte den Ort rauszusuchen....

    Hab ich was übersehen - zudem läuft der Routenplaner nicht - da erscheint in dem Fenster leider nie der ausgewählte Standort. Es erscheint immer ein error das der Ort nicht definiert ist.

    Vielen Dank
    Gruss Gassi

  14. #134
    Contao-Nutzer Avatar von Joern
    Registriert seit
    14.09.2018.
    Beiträge
    104

    Standard Mehrsprachige Einträge in den Kartenelementen

    Ich bin dabei, mit con4gis Karten mit Einträgen zu erstellen, die ich auf einer mehrsprachigen Webseite einsetzen möchte. Im Starboard wechseln die con4gis eigenen Texte auch passend zwischen Deutsch und Englisch.

    Um nicht alle Kartenstrukturen redundant einmal in Deutsch und ein weiteres mal in Englisch anlegen und pflegen zu müssen, hatte ich die Idee, dort bei den Einträgen dann mittels Abfrage zwischen den Texten für Deutsch und Englisch zu wechseln:
    Code:
    {{ifnlng::de}}English{{ifnlng}}{{iflng::de}}Deutsch{{iflng}}
    Allerdings erscheint dann immer der Eintrag "English" im Starboard, egal ob ich die Seite auf Deutsch oder Englisch anschaue.

    Meine Idee war es, die Einträge unter "Bezeichnung im Starboard", "Tooltip" sowie "Direktverlinkung" mit der Abfrage der Sprache zu versehen. Wobei ich dann bei der Direktverlinkung nicht mehr so bequem die Seiten innherhalb von Contao auswählen kann.

    Aktuell siehe ich nur die Möglichkeit, die Kartenstrukturelemente redundant anzulegen, einen Baum für Deutsch und einen weiteren für Englisch.

    Gibt es hier eine einfachere Möglichkeit, die den Pflegeaufwand reduziert?

  15. #135
    Contao-Nutzer
    Registriert seit
    15.02.2014.
    Beiträge
    165

    Standard Wie wird das Routing gestartet?

    Hallo!
    Nachdem ich gestern erstmals mit der Erweiterung 'CON4GIS 5.0' in Berührung gekommen bin, da Google-Maps ja seit Juli eine Kreditkarte wünscht, habe ich nun die ersten Schritte damit unternommen und bin schon mal so weit, dass die Karte auf der Website anbgezeigt wird. Das 'Tool' ist übrigens Klasse!

    Was ich allerdings nicht schaffe ist, dass Routing nach Eingaben von Start & Endpunkt zu starten. Der 'Router - Pfeil' in der linken oberen Ecke ist zu sehen und auch die Positionen kann ich eingeben (schön wäre es, wenn die Lokation als Ziel bereits vorbelegt wäre).
    Ich finde allerdings nirgends eine Schaltfläche wie zB 'Starten' oder ähnliches. Was muss ich noch wo einstellen oder anhaken?

    Schöne Grüße
    Bernhard

  16. #136
    Contao-Nutzer Avatar von krischanski
    Registriert seit
    11.04.2013.
    Ort
    Berlin
    Beiträge
    27

    Standard Umstellung auf PHP 7

    Bisher läuft meine Website auf PHP 5.6, das mein Hoster aber vernünftigerweise demnächst abstellt. Bei der Umstellung auf PHP 7 kommt es jedoch auf Seiten mit eingebundenen Karten zu einer Fehlermeldung und folgendem Eintrag im error.log, mit dem ich leider gar nichts anfangen kann:

    PHP Fatal error: Uncaught exception 'Error' with message 'Function name must be a string' thrown in /.../system/modules/con4gis_maps/C4GMaps.php on line 301
    #0 /.../system/modules/con4gis_maps/C4GMaps.php(709): C4GMaps::addLocations(Object(Module_c4g_maps), Object(Contao\Database\Mysqli), '2', Array, Array, Array, 0)
    #1 /.../system/modules/con4gis_maps/Module_c4g_maps.php(57): C4GMaps:repareMapData(Object(Module_c4g_maps), Object(Contao\Database\Mysqli))
    #2 /.../system/modules/core/modules/Module.php(287): Module_c4g_maps->compile()
    #3 /.../system/modules/con4gis_maps/Module_c4g_maps.php(49): Contao\Module->generate()
    #4 /.../system/modules/core/library/Contao/Controller.php(321): Module_c4g_maps->generate()
    #5 /.../system/modules/core/pages/PageRegular.php(133): Contao\Controller::getFrontendModule(Object(Contao \ModuleModel), 'main')
    #6 /.../system/modules/core/controllers/FrontendIndex.php(285): Contao\PageRegular->generate(Object(Contao\PageModel), true)
    #7 /.../index.php(20): Contao\FrontendIndex->run()
    #8 {main}

    Hat jemand eine Idee, was ich da tun kann? Eine Umstellung auf con4gis_maps3 hilft leider auch nicht, weil da bereits die Seite für die Datenbank-Aktualisierung weiß bleibt.
    Achso: ich verwende Contao 3.5.36, con4gis_maps 1.1.3 und con4gis_core 1.2.0.

  17. #137
    Contao-Nutzer
    Registriert seit
    30.03.2010.
    Ort
    Berlin
    Beiträge
    219

    Standard SQLi

    Hallo krischanski,

    eventuell hast Du noch nicht auf SQLi für die DB-Connection umgestellt? contao/install.php prüfen, ob dort als DB-Verbindung SQLi steht. Das war bei mir auch das Problem.

    Grüße
    Jens_
    Lieblingsurlaubsstadt am Meer
    http://www.kolberg-cafe.de

  18. #138
    Contao-Nutzer Avatar von krischanski
    Registriert seit
    11.04.2013.
    Ort
    Berlin
    Beiträge
    27

    Standard

    Zitat Zitat von Jens_ Beitrag anzeigen
    eventuell hast Du noch nicht auf SQLi für die DB-Connection umgestellt?
    Dochdoch, darauf habe ich geachtet. Und der Rest der Website funktioniert ja auch, nur die Seiten mit den Karten nicht.

  19. #139
    Contao-Nutzer Avatar von krischanski
    Registriert seit
    11.04.2013.
    Ort
    Berlin
    Beiträge
    27

    Standard

    Moment ... ich ahne was ... in Zeile 301 von C4GMaps.php geht es ja um SQL-Condition-Hooks ... da hab ich doch ...

  20. #140
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    14.344
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von krischanski Beitrag anzeigen
    Eine Umstellung auf con4gis_maps3 hilft leider auch nicht, weil da bereits die Seite für die Datenbank-Aktualisierung weiß bleibt.
    Hast Du in diesem Fall auch mal in der Logdatei unter system/logs nachgeschaut, ob es hierzu Fehlerprotokollierungen gibt?
    Contao Community Administrator

    [Unterstützungsmöglichkeiten]

  21. #141
    Contao-Nutzer Avatar von krischanski
    Registriert seit
    11.04.2013.
    Ort
    Berlin
    Beiträge
    27

    Standard

    Zitat Zitat von xchs Beitrag anzeigen
    Hast Du in diesem Fall auch mal in der Logdatei unter system/logs nachgeschaut, ob es hierzu Fehlerprotokollierungen gibt?
    Nee, hab ich leider nicht ...

    Aber ich hab die SQL-Condition-Funktion meines kleinen Ergänzungsmoduls (auf den Seiten mit den Monats-Terminlisten sollen in der Karte auch nur die Marker der Termine des ausgewählten Monats auftauchen) mal eben deaktiviert, dann kommt bei Umstellung auf PHP 7 der o.g. Fehler nicht mehr. Dafür kommt wieder der Javascript-Fehler "aGraphicTitle not defined", mit dem ich mich vorher schon herumgeärgert habe und der erst verschwunden war, als ich in der Kartenstruktur Label und Tooltip von "nicht anzeigen" auf "zeige einen Eintrag" umgestellt hatte.

  22. #142
    Contao-Nutzer Avatar von krischanski
    Registriert seit
    11.04.2013.
    Ort
    Berlin
    Beiträge
    27

    Standard

    Der Fehler beim Versuch, die 3er Version zu installieren, lautet

    PHP Fatal error: Cannot redeclare class tl_content_c4g_maps in /.../system/modules/con4gis_maps3/dca/tl_content.php on line 143
    PHP Fatal error: Cannot redeclare class tl_module_c4g_maps in /.../system/modules/con4gis_maps3/dca/tl_module.php on line 155

    Ich muss also doch vorher die alte Version löschen, das hatte ich anders verstanden. Das probier ich dann heute abend nochmal aus. Vielen Dank schonmal für die bisherigen Tipps.

  23. #143
    Contao-Nutzer
    Registriert seit
    15.02.2014.
    Beiträge
    165

    Standard

    Darf ich nochmal auf meine Anfrage vom 29.9. hinweisen:
    Zitat Zitat von bteppan Beitrag anzeigen
    Hallo!
    Nachdem ich gestern erstmals mit der Erweiterung 'CON4GIS 5.0' in Berührung gekommen bin, da Google-Maps ja seit Juli eine Kreditkarte wünscht, habe ich nun die ersten Schritte damit unternommen und bin schon mal so weit, dass die Karte auf der Website anbgezeigt wird. Das 'Tool' ist übrigens Klasse!

    Was ich allerdings nicht schaffe ist, dass Routing nach Eingaben von Start & Endpunkt zu starten. Der 'Router - Pfeil' in der linken oberen Ecke ist zu sehen und auch die Positionen kann ich eingeben (schön wäre es, wenn die Lokation als Ziel bereits vorbelegt wäre).
    Ich finde allerdings nirgends eine Schaltfläche wie zB 'Starten' oder ähnliches. Was muss ich noch wo einstellen oder anhaken?

    Schöne Grüße
    Bernhard
    Ich habe leider noch keine Lösung für das Problem gefunden obwohl ich alles so erstellt habe, wie ich es aus der Anleitung auf der Herstellerwebsite halbwegs entnehmen konnte.
    Zwischenzeitlich habe ich den 'Router-Pfeil' in der linken oberen Ecke wieder entfernt und möchte einfach nur auf die in der Mitte der Karte erstellt 'Lokation' klicken, dann den 'Startpunkt' eingeben und das Routing starten. Nur tut sich da leider nix ... (http://prototyp.sewe5.at/kontakt.html)
    Kann mir vielleicht jemand einen Tipp geben?
    Danke

  24. #144
    Alter Contao-Hase Avatar von Messa
    Registriert seit
    19.01.2011.
    Ort
    Vorarlberg, Österreich
    Beiträge
    1.417

    Standard

    Hallo.

    Ich baue gerade die erste Karte mit eurer Erweiterung auf.
    Klappt soweit gut. Das einzige was bei mir nicht funktioniert ist der Versatz des Icons.
    Egal as ich eintrage, das Icon bewegt sich nicht.

    Bildschirmfoto 2018-10-10 um 10.23.43.png

    Muss ich sonst noch etwas einstellen?
    Das Icon wird auf der Karte dargestellt.

    Conteo: 3.5.36
    con4gis_core: 1.9.3
    con4gis_maps3: 3.9.6

    Liebe Grüße
    Matthias
    Geändert von Messa (10.10.2018 um 09:40 Uhr)
    Full Service Agentur - Grafikdesign, Screendesign, Webdesign, Webentwicklung, SEO, Weiterbildung, persönliches Coaching
    http://www.matthiasgmeiner.com

  25. #145
    Contao-Nutzer Avatar von Dr. Jo
    Registriert seit
    11.08.2009.
    Ort
    Riehen (CH)
    Beiträge
    169

    Standard SSL für OSM

    Moin,

    ich habe festgestellt, dass die Zugriffe auf die OSM-Karten (Contao 3.5.xx, con4gis_maps3 3.9.6) noch auf http://-Adressen verweisen, und habe das einfach einmal in der Datei /system/modules/con4gis_maps3/assets/js/c4g-maps-config.js auf https:// umgebogen, ab Zeile 17:

    HTML-Code:
    /**
       * osmSourceDefinitions
       */
      c4g.maps.config.osm = $.extend(c4g.maps.config.osm, {
    
        CycleMap: {
          attributions: [
            new ol.Attribution({
              html: 'Style by <a target="_blank" href="https://www.opencyclemap.org/">OpenCycleMap</a>'
            }),
            ol.source.OSM.ATTRIBUTION
          ],
          minZoom: 0,
          maxZoom: 19,
          url: 'https://{a-c}.tile.opencyclemap.org/cycle/{z}/{x}/{y}.png'
        },
    Damit verhindert man dann, dass die Browser sich wegen Mixed Content beschweren. Vielleicht kann man das ja bei Gelegenheit einmal fest einbauen.

    Grüße aus dem Süden!

  26. #146
    Contao-Fan
    Registriert seit
    28.01.2010.
    Beiträge
    303

    Standard Zoomfaktor

    ...nach vielen Stunden der Verzweiflung stelle ich nun meine Frage hier:
    Wie kann ich die Darstellung bzw den Zoomfaktor der Karte einstellen?
    Ich brauche nicht wie anzeigt eine Weltkarte sondern einen Karteausschnitt der gewünschten Region.
    Geändert von Truller500 (07.11.2018 um 19:19 Uhr)

  27. #147
    Contao-Nutzer Avatar von Joern
    Registriert seit
    14.09.2018.
    Beiträge
    104

    Standard

    Zitat Zitat von Truller500 Beitrag anzeigen
    ...nach vielen Stunden der Verzweiflung stelle ich nun meine Frage hier:
    Wie kann ich die Darstellung bzw den Zoomfaktor der Karte einstellen?
    Ich brauche nicht wie anzeigt eine Weltkarte sondern einen Karteausschnitt der gewünschten Region.
    Bei der Karte gibt es die Einträge Geo X-Koordinate sowie Geo Y-Koordinate, hiermit wird der Mittelpunkt der anzuzeigenden Karte festgelegt. Direkt danach folgt der Eintrag Zoom-Level, hiermit wird bestimmt, wie weit in die Karte hineingezoomt wird. Je höher die Zahl, desto weiter wird hineingezoomt. Ich nutze hier Zoom-Level von 6 oder 7 für die Darstellung eines einzelnen Landes. Einfach mal verschiedene Werte ausprobieren. Der Wertebereich geht von 0 bis 19.

  28. #148
    Contao-Fan
    Registriert seit
    28.01.2010.
    Beiträge
    303

    Standard

    Danke, aber ich komme damit leider nicht weiter.
    Bei der Karte gibt es die Einträge Geo X-Koordinate sowie Geo Y-Koordinate, hiermit wird der Mittelpunkt der anzuzeigenden Karte festgelegt.
    Beim welchen Baukastenpunkt? Kartenstrukturen? Dort folgt direkt danach der Eintrag "Lokalisationsstil"...

  29. #149
    Contao-Nutzer Avatar von Joern
    Registriert seit
    14.09.2018.
    Beiträge
    104

    Standard

    Zitat Zitat von Truller500 Beitrag anzeigen
    Danke, aber ich komme damit leider nicht weiter.

    Beim welchen Baukastenpunkt? Kartenstrukturen? Dort folgt direkt danach der Eintrag "Lokalisationsstil"...
    Im Backend unter Maps: Kartenstrukturen ein Kartenstrukturelement anlegen. Beim Kartenstrukturelement unter Karte den Punkt Als Karte verwenden anwählen. Dann werden die von mir oben beschriebenen Punkte eingeblendet und können konfiguriert werden.

    Die Dokumentation für con4gis ist leider etwas versteckt zu finden, ich habe da anfangs auch ziemlich zu kämpfen gehabt und ein paar speziellere Details auch noch nicht so ganz verstanden.
    Unter https://docs.con4gis.org/con4gis-maps ist einiges beschrieben. Mir hat es für den Einstieg geholfen, das Beispiel mit der Anfahrtskarte unter https://maps.con4gis.org/anreisekarte selbst nachzubauen und darauf aufbauend zu experimentieren.

  30. #150
    Contao-Fan
    Registriert seit
    28.01.2010.
    Beiträge
    303

    Standard

    ...vielen Dank für die Tipps.
    Die ersten Versuche sind leider kläglich gescheitert... keine Regung der abgebildeten Karte.
    Werde es morgen weiter versuchen...

  31. #151
    Contao-Nutzer Avatar von Joern
    Registriert seit
    14.09.2018.
    Beiträge
    104

    Standard

    Zitat Zitat von Truller500 Beitrag anzeigen
    ...vielen Dank für die Tipps.
    Die ersten Versuche sind leider kläglich gescheitert... keine Regung der abgebildeten Karte.
    Werde es morgen weiter versuchen...
    Welche Contao-Version und welche Version von con4gis-Maps?

  32. #152
    Contao-Fan
    Registriert seit
    28.01.2010.
    Beiträge
    303

    Standard

    Contao 3.5.36
    con4gis_maps 1.1.3

  33. #153
    Contao-Nutzer Avatar von Joern
    Registriert seit
    14.09.2018.
    Beiträge
    104

    Standard

    Zitat Zitat von Truller500 Beitrag anzeigen
    Contao 3.5.36
    con4gis_maps 1.1.3
    Zu dieser alten Version kann ich nichts sagen, ich nutze Contao 4.4.26 sowie 4.6.6 mit con4gis-Maps 5.0.5. Für Contao 3.5 ist con4gis_maps3 in der Version 3.9.6 aktuell. Ich empfehle, auf die aktuelle Version upzudaten.
    Geändert von Joern (08.11.2018 um 10:41 Uhr)

  34. #154
    Contao-Nutzer
    Registriert seit
    31.08.2010.
    Beiträge
    42

    Standard

    Hallo seagull, …

    Zitat Zitat von seagull Beitrag anzeigen
    Hallo,

    nachdem ich mich durch dieses wahrhaft gigantische Modul con4gis_maps gekämpft habe, habe ich nun eine schöne Karte mit den Standorten aus der Mitgliedertabelle.
    Welche Defintion muss denn in der
    Code:
    /contao/system/modules/con4gis_maps/config/config.php
    vorgenommen werden, damit die Werte aus der Tabelle tl_member als Punkte (c4g_loc_geox und c4g_loc_geoy Werte liegen in der tl_member vor)
    angezeigt werden können.
    Mit den versuchten Einstellungen wird nichts angezeigt
    Code:
    $GLOBALS['con4gis_maps_extension']['sourcetable']['tl_member'] =
    	array('ptable'        => 'tl_member',
            'geox'          => 'c4g_loc_geox',
            'geoy'          => 'c4g_loc_geoy',
            'label'         => 'c4g_loc_label',
            'locstyle'      => 'c4g_locstyle',
            'tooltip'       => 'title',
            'popup'         => 'lastname',
          'sqlwhere'      => 'disable = 0',
      		'alias_getparam'=> 'member'
    	);
    Bin für jeden Tipp dankbar.
    Geändert von xmoto (22.12.2018 um 00:27 Uhr)

  35. #155
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    161
    Partner-ID
    7247

    Standard

    Moin xmoto,

    damit die Mitglieder in der Karte dargestellt werden, musst Du das Kartenstrukturelement "Aus anderer Tabelle" unterhalb Deiner Karte einfügen und dort als Quelltabelle "Mitglieder" auswählen. Die Mitglieder sind ja bereits vordefiniert.

    con4gis-Maps liefert in der config.php ein paar der Konfigurationen mit. Du kannst $GLOBALS['con4gis_maps_extension']['sourcetable'] aber auch an anderer Stelle erweitern. In Contao 3 reicht es aus, wenn Du Dir ein ein eigenes Extension-Verzeichnis anlegst (unter system/modules) und dort nur das config Verzeichnis mit der config.php anlegst.
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  36. #156
    Contao-Nutzer
    Registriert seit
    12.03.2012.
    Ort
    Dresden
    Beiträge
    184

    Standard Zwei Karten auf einer Seite

    Hallo,
    unter Contao3.5 habe ich immer zwei Anfahrtskarten nebeneinander engebunden.
    Nach dem Update auf Contao4 überschreibt augenscheinlich die zweite Karte nun immer die erste.

    Ich nutze jeweils das Inhaltselement con4gis maps mit unterschiedlichen Kartenstrukturelementen, aber der gleichen Basiskarte. Habe alles nach Anleitung eingerichtet.
    Wo könnte der Fehler liegen?

    Danke und viele Grüße
    Silvia

  37. #157
    Contao-Nutzer Avatar von CoastFace
    Registriert seit
    07.12.2011.
    Ort
    Jever
    Beiträge
    161
    Partner-ID
    7247

    Standard

    Hallo Silvia,

    dass hier ist der Forum-Thread, bitte weitere Anfragen zu den Karten an entsprechender Stelle posten oder wende Dich gerne direkt an das con4gis Team. Technisch hat sich zwischen der con4gis-Maps3 Extension und dem jetzigen Maps Bundle einiges getan. Wir müssen das prüfen. Zwei Karten auf einer Seite, kommt auch bei uns nicht so oft vor

    Hier ist der Maps Thread: https://community.contao.org/de/show...Support-Thread

    Beste Grüße
    Matthias
    „Das meiste ist noch nicht getan – wunderbare Zukunft“ (Auch ein Zitat vom großen Meister Unbekannt)

  38. #158
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    14.344
    User beschenken
    Wunschliste

    Standard

    //Moderation: Beiträge in den entsprechenden Erweiterungsthread verschoben.
    Contao Community Administrator

    [Unterstützungsmöglichkeiten]

  39. #159
    Contao-Nutzer
    Registriert seit
    22.10.2018.
    Beiträge
    13

    Standard

    Du ahnst nicht, wie lange ich nach so einer Antwort gesucht habe! Vielen vielen Dank!

    Bei meiner Version versteckte sich der Teufel unter /system/modules/con4gis_maps/html/js in der C4GMaps.js.

    Und ich würde es hier auch noch einmal anstoßen: Ich würde mich freuen wenn dies in zukünftigen Versionen fest eingepflegt wird.


    Zitat Zitat von Dr. Jo Beitrag anzeigen
    Moin,

    ich habe festgestellt, dass die Zugriffe auf die OSM-Karten (Contao 3.5.xx, con4gis_maps3 3.9.6) noch auf http://-Adressen verweisen, und habe das einfach einmal in der Datei /system/modules/con4gis_maps3/assets/js/c4g-maps-config.js auf https:// umgebogen, ab Zeile 17:

    HTML-Code:
    /**
       * osmSourceDefinitions
       */
      c4g.maps.config.osm = $.extend(c4g.maps.config.osm, {
    
        CycleMap: {
          attributions: [
            new ol.Attribution({
              html: 'Style by <a target="_blank" href="https://www.opencyclemap.org/">OpenCycleMap</a>'
            }),
            ol.source.OSM.ATTRIBUTION
          ],
          minZoom: 0,
          maxZoom: 19,
          url: 'https://{a-c}.tile.opencyclemap.org/cycle/{z}/{x}/{y}.png'
        },
    Damit verhindert man dann, dass die Browser sich wegen Mixed Content beschweren. Vielleicht kann man das ja bei Gelegenheit einmal fest einbauen.

    Grüße aus dem Süden!

  40. #160
    Contao-Nutzer Avatar von Joern
    Registriert seit
    14.09.2018.
    Beiträge
    104

    Standard con4gis-Maps Version 6 ist verfügbar, Karte wird nach Update nicht mehr angezeigt

    Seit kurzem ist Version 6 von con4gis-Maps verfügbar: https://packagist.org/packages/con4gis/maps

    Nach einem Update unter Contao 4.8.1 auf die neue Version 6 von con4gis-Maps wird bei mir die auf der Webseite eingebundene Karte nicht mehr angezeigt. Es gibt keinen Log-Eintrag (im Contao Backend) beim Aufruf der Webseite, der auf eventuelle Fehler hindeutet.

    Gibt es beim Update von con4gis-Maps Version 5.1.6 auf Version 6.0.4 etwas speziell zu beachten?

    Jörn

Seite 4 von 7 ErsteErste ... 23456 ... LetzteLetzte

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 2 (Registrierte Benutzer: 0, Gäste: 2)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •