Results 1 to 15 of 15

Thread: error after update 4.5.4 [SOLVED]

  1. #1
    User
    Join Date
    10-12-13.
    Posts
    103

    Default error after update 4.5.4 [SOLVED]

    Hello!
    Does anybody know where is the problem?
    [23-Feb-2018 10:15:02 UTC] PHP Fatal error: Class 'Backend' not found in /home/myusername/public_html/vendor/contao/core-bundle/src/Resources/contao/classes/Ajax.php on line 26
    I have successfully installed 4.5.4, but when I tried to (via ssh) update composer $ composer update get error below!
    Thank all for any help!
    Best regards,
    Goran
    Last edited by essecosi; 02/23/2018 at 17:25. Reason: SOLVED

  2. #2
    User Spooky's Avatar
    Join Date
    01-03-13.
    Posts
    336

    Default

    Quote Originally Posted by essecosi View Post
    I have successfully installed 4.5.4, but when I tried to (via ssh) update composer $ composer update get error below!
    Which error?

  3. #3
    User
    Join Date
    10-12-13.
    Posts
    103

    Default

    [23-Feb-2018 10:15:02 UTC] PHP Fatal error: Class 'Backend' not found in /home/myusername/public_html/vendor/contao/core-bundle/src/Resources/contao/classes/Ajax.php on line 26

  4. #4
    User Spooky's Avatar
    Join Date
    01-03-13.
    Posts
    336

    Default

    Execute a composer update and post the output.

  5. #5
    User
    Join Date
    10-12-13.
    Posts
    103

    Default

    here is:
    Attached Images Attached Images

  6. #6
    User Spooky's Avatar
    Join Date
    01-03-13.
    Posts
    336

    Default

    Do not post a screenshot. Run the command again with
    Code:
    composer update -vvv
    and copy & paste the complete output here with [code] tags.

  7. #7
    User
    Join Date
    10-12-13.
    Posts
    103

    Default

    screen shot
    Attached Images Attached Images

  8. #8
    User Spooky's Avatar
    Join Date
    01-03-13.
    Posts
    336

    Default

    You seem to be using a globally installed composer, what is the output of
    Code:
    composer -V

  9. #9
    User
    Join Date
    10-12-13.
    Posts
    103

    Default

    :-(
    Attached Images Attached Images

  10. #10
    User Spooky's Avatar
    Join Date
    01-03-13.
    Posts
    336

    Default

    Don't use the globally installed version of composer. As a general rule: never use the globally installed version of composer, if you have no control over it. Download the composer.phar manually via
    Code:
    wget https://getcomposer.org/download/1.6.3/composer.phar
    and then execute a composer update via
    Code:
    php composer.phar update -o
    Important: replace "php" with the path to the correct PHP CLI - it needs to be the same version as the PHP version your web server uses for your Contao Installation.

  11. #11
    User
    Join Date
    10-12-13.
    Posts
    103

    Default

    I have updated it, but still some errors
    Attached Images Attached Images
    • File Type: jpg 1.jpg (76.5 KB, 2 views)
    • File Type: jpg 2.jpg (88.1 KB, 1 views)

  12. #12
    User Spooky's Avatar
    Join Date
    01-03-13.
    Posts
    336

    Default

    What is the output of
    Code:
    php -v
    ?

  13. #13
    User
    Join Date
    10-12-13.
    Posts
    103

    Default

    7.1
    Attached Images Attached Images
    • File Type: png 3.png (4.2 KB, 2 views)

  14. #14
    User
    Join Date
    10-12-13.
    Posts
    103

    Default

    I have clean install from ssh and now it's ok! :-)
    thank you for big help!!!

  15. #15
    User
    Join Date
    10-12-13.
    Posts
    103

    Default

    Quote Originally Posted by essecosi View Post
    I have clean install from ssh and now it's ok! :-)
    thank you for big help!!!
    more about install 4.5.x
    https://community.contao.org/en/show...-beta15-SOLVED

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •